#opendaylight-meeting: MD-SAL interest call

Meeting started by colindixon at 16:03:34 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:03:38)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_interest_call/ if we call the meeting “MD-SAL interest call” every time the meeting minutes end up at that link (colindixon, 16:04:33)

  2. status update (colindixon, 16:05:40)
    1. around SchemaContext scalability, the yangtools part is done, but there may be some bugs in the netconf part which are being resolve and should be merged soon (colindixon, 16:06:55)
    2. the DataObject to JSON/XML conversion is waiting on the biding codecs coming in, there’s one remaining patch that needs to be merged (colindixon, 16:09:42)
    3. otherwise, in the MD-SAL most things are testing and hunting down bugs (colindixon, 16:11:31)
    4. https://git.opendaylight.org/gerrit/#/c/9068/ this gerrit fixes the swagger RESTCONF explorer to allow posts to work (colindixon, 16:15:36)
    5. it also makes post broken out in terms of the different models that can be posted to the same URI (colindixon, 16:17:27)
    6. there is some discussion about this with carol sanders and colindixon voting for the broken up version (colindixon, 16:19:55)
    7. kent watsen says that the current RESTCONF draft (and REST semantics) for POST would make him think this is illegal (colindixon, 16:21:47)
    8. loosely, POST means “create” and PUT means “replace” (for the entire document located at this URI) (colindixon, 16:25:24)
    9. a lot of discussion about how this could work better or not (some of them are that swagger might not be the right tool in the end) (colindixon, 16:35:40)
    10. ramkumar and andrew kinard say that they find this stuff is incredibly useful because mapping YANG to REST calls is incredibly difficult otherwise (colindixon, 16:37:00)
    11. in particular they also vote for the breakout by the different things that can be posted (colindixon, 16:38:35)
    12. everyone agrees that we should be consistent between POST and PUT (which we are not) (colindixon, 16:40:15)
    13. after (probably way too much) discussion, we basically say we’d like to fix the defect without having to change the swagger layout and we can deal with changing the layout later (colindixon, 16:46:36)

  3. questions (colindixon, 16:46:45)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=1514 bug around getting warnings/errors when building pretty much anything today, I’m not sure what the resolution is (colindixon, 16:49:59)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=1512 bug around builders for unions which wind up in src/main/java (it turns out that this is because you need to actually write code for that to work right) (colindixon, 16:51:57)
    3. the solution to that is likely to add a comment or something else in that fie to make it clear what’s going on (colindixon, 16:53:15)
    4. ACTION: colindixon to amend that bug to suggest the fix (colindixon, 16:53:47)


Meeting ended at 16:53:53 UTC (full logs).

Action items

  1. colindixon to amend that bug to suggest the fix


Action items, by person

  1. colindixon
    1. colindixon to amend that bug to suggest the fix


People present (lines said)

  1. colindixon (25)
  2. odl_meetbot (4)


Generated by MeetBot 0.1.4.