#opendaylight-meeting: MD-SAL Status Call - July 15th, 2014

Meeting started by devinavery at 16:14:58 UTC (full logs).

Meeting summary

  1. Status Sync (devinavery, 16:15:18)
    1. Toaster example updated with example async programming (devinavery, 16:15:40)
    2. upcoming: Simplify WriteTransaction by changing signature - deprecating old method adding new one (devinavery, 16:16:29)
    3. Colin asks if using "asyncCommit" instead of "Ready" would make more sense to others. (devinavery, 16:16:47)
    4. Robert explains that "ready" means that the transaction is "ready to submit" (devinavery, 16:17:05)
    5. another suggestion is to use "submit". Looking for opinions on this call. (devinavery, 16:17:39)
    6. Does "submit" generally apply to transactions? (devinavery, 16:19:46)
    7. Robert: Transactions which are "Ready" is well known in transaction processing, so it really depends where we get our vocabulary from (devinavery, 16:20:41)
    8. ACTION: Tom P to send an e-mail to controller dev to get opinion on submit vs ready. Keep open for 24 hours (devinavery, 16:22:01)
    9. Question about MD-SAL Clustering - colindixon is providing a quick update (devinavery, 16:23:34)
    10. https://git.opendaylight.org/gerrit/#/q/status:open+topic:akka-raft,n,z akka raft related commits (colindixon, 16:24:10)
    11. https://git.opendaylight.org/gerrit/#/q/status:open+topic:clustering,n,z clustering related commits (colindixon, 16:24:26)

  2. general questions (devinavery, 16:28:40)
    1. Can you provide some pointers on the possible query languages being developers for MD-SAL? (devinavery, 16:29:10)
    2. https://www.youtube.com/watch?v=UihFZpi8E-s youtube video of xsql query stuff from Sharon (colindixon, 16:29:26)
    3. There is a NO-SQL type language being developed. See notes from previous calls. (devinavery, 16:29:41)
    4. Also an effort ongoing with an intern to get xpath working with MD-SAL - colindixion, devinavery regXboi, jan medev are working on that (devinavery, 16:30:48)
    5. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:XSQL this the wiki page which walks through the XSQL (nosql-style) query language and how you can play with it (colindixon, 16:32:05)
    6. Question about consolidating data models - is anyone working on this? (devinavery, 16:32:45)
    7. Tony - the model colindixon mentioned is used by the topology exporter. (devinavery, 16:34:02)
    8. Colindixon: in general there is a desire to move towards having only one inventory/topology. Ask to Tony - do you know if it is on the roadmap? (devinavery, 16:34:33)
    9. Tony there are some on going discussions. Heavily depends on the community (devinavery, 16:34:55)
    10. Colin: topology stores hosts, inventory is the root for flows. So you have to translate from topology to inventory and back and forth because of the varying models. (devinavery, 16:36:01)
    11. topology does not not actually have hosts (at least not at the moment) it stores the links betwee switches (colindixon, 16:36:48)
    12. Tony: we would need someone to focus on a migration strategy and so far there is no one actively working it. (devinavery, 16:37:23)
    13. Jan: The open flow call discussed these models and we need to kick off the conversation about the common models. We need to start the discussions within open daylight and then move on to IETF. (devinavery, 16:38:18)
    14. colindixon: suggestion we need some group of people (really light way) who can review and track models going into the code and can provide some comments on yangs to help standardizing them (devinavery, 16:39:36)
    15. colindixon: that group could provide suggestions when models are similar etc. (devinavery, 16:40:26)
    16. : devinavery: question: should the MD-SAL call start the modeling discussions? (devinavery, 16:40:44)
    17. colindixon: we should at least open a bug to merge the two models together. (devinavery, 16:41:18)
    18. ACTION: colindixon will open a bug for a feature enhancement to merge the inventory and topology models so we can at least track it (colindixon, 16:41:46)
    19. Next MD-SAL call - we can revisit this discussion about a body of people to review the yang models as they come in. Not proposing a a rigid review body... need to brain storm (devinavery, 16:43:27)
    20. Question from Colin: If I have a DataObject, is there an easy way to convert that to JSON or XLM without going through restconf (devinavery, 16:44:05)
    21. Answer: you would need to replicate what resting does under the hood, which is not exposed in a friendly API right now. Question from Colin - should we open an enhancement? (devinavery, 16:44:36)
    22. https://bugs.opendaylight.org/show_bug.cgi?id=1360 this is the bug to track (colindixon, 16:45:24)
    23. Enhancement 1360 is open and tracking this. Colindixon is willing to start working if he can (devinavery, 16:45:27)
    24. ACTION: robert varga to add some feedback on 1360 (colindixon, 16:48:25)


Meeting ended at 16:49:19 UTC (full logs).

Action items

  1. Tom P to send an e-mail to controller dev to get opinion on submit vs ready. Keep open for 24 hours
  2. colindixon will open a bug for a feature enhancement to merge the inventory and topology models so we can at least track it
  3. robert varga to add some feedback on 1360


Action items, by person

  1. colindixon
    1. colindixon will open a bug for a feature enhancement to merge the inventory and topology models so we can at least track it
  2. UNASSIGNED
    1. Tom P to send an e-mail to controller dev to get opinion on submit vs ready. Keep open for 24 hours
    2. robert varga to add some feedback on 1360


People present (lines said)

  1. devinavery (32)
  2. colindixon (11)
  3. tbachman (4)
  4. odl_meetbot (3)
  5. dbainbri (1)
  6. harman_ (1)


Generated by MeetBot 0.1.4.