#opendaylight-meeting: MD-SAL Weekly Meeting

Meeting started by edwarnicke___ at 16:02:00 UTC (full logs).

Meeting summary

  1. Akka Framework discussion and demo (edwarnicke___, 16:02:41)
  2. Prototyping Akka in ODL (edwarnicke___, 16:04:15)
    1. Mathieu Lemay presenting (edwarnicke___, 16:06:27)
    2. Concerns raised: "Why Datastore?" and "Scala in codebase?" (edwarnicke___, 16:08:49)
    3. talking about fixing the runtime - werk done with Giovanni and Jamie and about how to port it to Karaf (jmedved, 16:09:25)
    4. Current status - fixing the runtime (Mix and Match, Karaf Runtime Port, Releases and Features, Need for common underlay (AD-SAL and MD-SAL) (edwarnicke___, 16:09:28)

  3. Why DataStore? (edwarnicke___, 16:10:09)
    1. Datastore prototype useful to test Akka's clustering store in ODL (edwarnicke___, 16:12:22)
    2. Would like to be able to have partial features running within different controller cluster nodes and have proper messaging (edwarnicke___, 16:12:49)
    3. Many options for datastore (inside/outside the controller etc) (edwarnicke___, 16:13:48)
    4. purpose is to drive more efficient message handling in ODL (edwarnicke___, 16:13:56)

  4. Scala in the codebase? (edwarnicke___, 16:14:52)
    1. How should we handle scala in ODL? (edwarnicke___, 16:15:37)
    2. put the scala code into their own repos, or put them into ODL repos? (jmedved, 16:15:57)
    3. ewarncike echoes conrerns avbobut scala: 1 yet another language, 2. support scala also means you have to support the scala compiler, which is a bigger issue (jmedved, 16:16:53)
    4. mlemay talked to chris wright about this as well (jmedved, 16:17:15)
    5. ewarncike is personally excited about scala, but there are concerns (jmedved, 16:17:35)
    6. mlemay : there is already impedance for new comers to grok the codebase, and scala just adds to it. akka support the java environment, so why not use it? (jmedved, 16:18:13)
    7. ewarnicke says that there are tradeoffs, e.g. are the some core pieces to which we limit ourselves? mlemay says that why want to discuss it now; there are different ways to wrap it up or hide it (jmedved, 16:19:20)
    8. mlemay says there are different ways to address akka - one is to make it fully separate and not in core ODL, which is the direction in which we seem to be going now; mlemay wants to make sure the issue is addressed the rigth way (jmedved, 16:21:27)
    9. david bainbridge voices conerns about supporting scala - there is not much expertise out there (jmedved, 16:21:57)
    10. question is akka linked to scala? mlemay: akka is written in scala, so introducing akka will introduce scala into ODL one way or another (jmedved, 16:24:24)
    11. dbainbridge we need one implementation behind java libraries (jmedved, 16:24:55)
    12. ashish chirputkar: how idfferent is this from having an external componet such as a DB which is written in a different language? (jmedved, 16:25:32)
    13. rvarga: having swappable data store is good, and we do not have to have a swappable data store within a distribution (jmedved, 16:27:46)
    14. different distributions can use different data stores (jmedved, 16:28:04)

  5. Controller Runtime (edwarnicke___, 16:29:37)
    1. mlemay: prototype implementation well underway, should be done within a day or two (jmedved, 16:29:42)
    2. mix and match from felix, virgo, gemini and different OSGI versions (edwarnicke___, 16:29:54)
    3. mlemay: current runtime a “mix and match” to meed needs & requirements in ODL (jmedved, 16:30:10)
    4. mlemay: runtime being ported to Karaf with help of Jamie Goodyear (jmedved, 16:30:51)
    5. projects will follow the same pattern (jmedved, 16:31:51)
    6. what you get: nicer console, noicer loggin, admin & security features, blueprints, etc (jmedved, 16:32:15)
    7. karaf gerrit should be coming shortly from mlemay :) (edwarnicke___, 16:32:49)
    8. Karat ditro will be in the distributions folder, it will be pusehd as a set of patches (jmedved, 16:32:52)
    9. ewarnicke: more to karaf not a radical shift, it’s just a better OSGI container (jmedved, 16:34:43)
    10. other projects in production that may be using Karaf? jboss, opennms, apache service mix, other companies (jmedved, 16:35:54)
    11. rovarga brings out a point that migrating will not be easy. a barebones distro should be build into which apps can be moved into (jmedved, 16:37:21)
    12. dbainbridge are we expecting projects APIs changes? (jmedved, 16:38:48)
    13. ewarnicke: for example, if somebody has a cli based on current container, it needs to be ported; then features need to be introduced into project; this has impact on versioning, bundles can have their own version, features follow release versioning (jmedved, 16:40:27)
    14. will this help unifying the sals? (jmedved, 16:40:42)
    15. karaf is just a container, nothing to do with the SALs (jmedved, 16:40:57)
    16. madhu happy to move ovsdb onto feature, multiple oriject running in veritualization ed twhere certain bundles are filtered out a feature w/o breaking things? (jmedved, 16:41:52)
    17. jamie: generally design a feature as subfeatures, a bundle can be part of multiple features (jmedved, 16:42:52)
    18. ACTION: can we make sure the release management for karaf distribution and existing distribution are compatible (Madhu, 16:47:16)
    19. rovarga: for migraton start with a new base edition which gives us a playground for experimenting with new things (jmedved, 16:50:29)
    20. concern about forking too much, too many editions, must have one edition that everybody can use (jmedved, 16:52:55)
    21. erwarnicke: project must have space to sort this out; (jmedved, 16:53:23)


Meeting ended at 20:00:31 UTC (full logs).

Action items

  1. can we make sure the release management for karaf distribution and existing distribution are compatible


People present (lines said)

  1. jmedved (35)
  2. edwarnicke___ (16)
  3. odl_meetbot (3)
  4. icbts (3)
  5. dbainbri (2)
  6. tykeal (1)
  7. Madhu (1)


Generated by MeetBot 0.1.4.