#opendaylight-meeting: MDSAL call

Meeting started by alagalah at 16:07:39 UTC (full logs).

Meeting summary

    1. https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call#Agenda (alagalah, 16:07:53)

  1. Status update (as per Agenda) (alagalah, 16:08:20)
    1. edwarnicke is chairing meeting on webex (alagalah, 16:08:49)
    2. rovarga_ says that there was a renaming of the binding independent instance identifier to a yang instance identifier (tbachman, 16:09:19)
    3. edwarnicke to share code to describe what rovarga_ just mentioned (alagalah, 16:09:58)
    4. https://git.opendaylight.org/gerrit/#/c/9427/ (rovarga_, 16:10:03)
    5. https://git.opendaylight.org/gerrit/#/c/9427/ gerrit for the instance identifier change (tbachman, 16:10:19)
    6. edwarnicke says that most people are using the binding aware versions, rather than the binding indepndent versions (tbachman, 16:11:45)
    7. edwarnicke explains that binding aware version is java class specific, but binding independent allows you to describe restconf etc (alagalah, 16:12:24)
    8. This change has to do with renaming the case that most don’t use (binding independent case) and the more popular case be just “binding” (discussed on last week’s call). (tbachman, 16:13:59)
    9. rovarga_ says that the change is already in to both yangtools and the controller (tbachman, 16:15:35)
    10. https://gist.github.com/anonymous/790487c28a4dbf8b7dc3 (flaviof, 16:17:47)
    11. xsql is broken by this change, but that’s because it’s not part of the default build (tbachman, 16:17:51)
    12. colindixon points out that setting up integration jobs for the projects they depend on (tbachman, 16:19:27)
    13. edwarnicke says that this was part of the M3 criteria (tbachman, 16:19:40)
    14. https://wiki.opendaylight.org/view/GettingStarted:Jenkins_Integration_Job_Setup (LuisGomez, 16:20:23)
    15. edwarnicke submitted a patch yesterday that wired up the restconf subsystem to the config subsystem (tbachman, 16:20:47)
    16. https://git.opendaylight.org/gerrit/#/c/9443/ should fix XSQL (rovarga_, 16:23:13)
    17. https://git.opendaylight.org/gerrit/#/c/9322/ (flaviof, 16:25:31)
    18. flaviof asks a question about using the createparent flag in the databroker (tbachman, 16:25:58)
    19. edwarnicke asks if it is more work to use an API like this, or to test for the existence directly (tbachman, 16:26:27)
    20. edwarnicke recommends for flaviof to push a patch implementing what he’d like to see for an API (tbachman, 16:27:55)
    21. ttkacik recommends implementing this as a utility function on top of the API (tbachman, 16:28:18)
    22. https://lists.opendaylight.org/pipermail/yangtools-dev/2014-July/000334.html (colindixon, 16:29:32)

  2. yangtools (tbachman, 16:29:42)
    1. https://lists.opendaylight.org/pipermail/yangtools-dev/2014-July/000334.html (tbachman, 16:29:57)
    2. colindixon says that if you have a singleton list it gets converted to an element, and not a list (tbachman, 16:30:18)
    3. colindixon asks if this is intentional, or if this is a bug (tbachman, 16:30:30)
    4. ttkacik says that this is a bug, but needs to look into the API that specifies this behavior. It could be a regression introduced by restconf (tbachman, 16:31:00)
    5. ACTION: colindixon will open a bug on this for tracking purposes (tbachman, 16:31:34)
    6. colindixon asks if there is an RFC for this (tbachman, 16:31:56)
    7. http://tools.ietf.org/html/draft-bierman-netconf-restconf-02 is the current spec we implement (rovarga_, 16:32:43)

  3. bug 1418 (tbachman, 16:33:31)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=1418 bug for notifications on data change (tbachman, 16:33:52)
    2. rgowrishankar filed this bug last week, and found that this worked in older versions of ODL (tbachman, 16:34:14)
    3. rovarga_ says that ttkacik is looking into this (tbachman, 16:34:59)
    4. ttkacik says that 1418 that data change notifications are empty if leafs are augmentations (tbachman, 16:35:26)
    5. ttkacik says that there may be a fix for this by Friday (tbachman, 16:35:36)
    6. rgowrishankar says that he’s working off an older version of ODL for now (tbachman, 16:36:02)
    7. rgowrishankar says that there were QName issues when going back to this version (tbachman, 16:37:35)
    8. edwarnicke mentions that there are weekly releases (tbachman, 16:37:50)
    9. https://nexus.opendaylight.org/content/repositories/opendaylight.weekly/ (edwarnicke, 16:38:14)
    10. maven clean install -nsu (edwarnicke, 16:40:17)
    11. edwarnicke says to also be careful with mvn, as it may pull in versions of things that are more recent than what you want (tbachman, 16:40:18)
    12. edwarnicke recommends using -nsu (no snapshot updates) (tbachman, 16:41:01)
    13. colindixon says that the weekly releases still have the problem where other bundles pull in newer dependencies than are needed (tbachman, 16:43:19)
    14. and that tracking down all these dependencies and fixing them isn’t scalable (tbachman, 16:43:46)
    15. dbainbri asks if there is a way to parameterize this? (tbachman, 16:45:07)
    16. edwarnicke says that this would not save you in cases where you have pointers up to the parent project (tbachman, 16:45:39)

  4. name generation from yang (tbachman, 16:48:27)
    1. colindixon provides an example where you have a container with a list (tbachman, 16:49:22)
    2. even though it’s a list in yang, it’s instead a single item (using TTP code as an example) (tbachman, 16:49:56)
    3. colindixon asks if this was done intentionally (tbachman, 16:50:36)
    4. ttkacik says this is covered in the yang specification. The keyword after a list is the name of one item. (tbachman, 16:51:03)
    5. rovarga_ says that yang is XML-centric, and the way you represent lists in XML is lay out the individual items. There’s no container for the list itself. (tbachman, 16:53:44)
    6. kwatsen says that there is a best practice in using a container (tbachman, 16:54:40)
    7. colindixon says that we really could use a style-guide for YANG (tbachman, 16:55:29)
    8. kwatsen says that a style guide is being created (tbachman, 16:57:12)
    9. kwatsen says that there are also “yang doctors”, somewhat “on call”, to help with yang modeling (tbachman, 17:03:01)


Meeting ended at 17:03:54 UTC (full logs).

Action items

  1. colindixon will open a bug on this for tracking purposes


Action items, by person

  1. colindixon
    1. colindixon will open a bug on this for tracking purposes


People present (lines said)

  1. tbachman (59)
  2. alagalah (12)
  3. edwarnicke (9)
  4. flaviof (7)
  5. odl_meetbot (4)
  6. marcbe-sel (4)
  7. colindixon (3)
  8. rovarga_ (3)
  9. LuisGomez (1)
  10. rgowrishankar (1)


Generated by MeetBot 0.1.4.