#opendaylight-meeting: OpenDaylight TSC Meeting 2014-05-08

Meeting started by phrobb at 17:00:05 UTC (full logs).

Meeting summary

  1. TSC members please #info in (phrobb, 17:01:45)
    1. Rob Dolin proxy for Rajeev Nagar (Microsoft) (RobDolin, 17:02:30)
    2. Chris Wright (cdub, 17:02:56)
    3. Chris O'Shea proxy for Chris Price (Ericsson) (ChrisOShea, 17:03:04)
    4. Kent Watsen (Kent, 17:04:16)
    5. dmm (dmm, 17:04:37)

  2. Agenda Bashing (phrobb, 17:07:43)
    1. https://wiki.opendaylight.org/view/TSC:Main#Agenda_Summary (agenda) (dmm, 17:07:47)
    2. Ed Warnicke (edwarnicke, 17:08:06)
    3. regXboi for IBM ( I *do* hold the proxy today) (regXboi, 17:08:06)

  3. Event Updates (phrobb, 17:08:51)
    1. http://www.opendaylight.org/events/2014-05-12/openstack-summit-atlanta (phrobb, 17:09:17)
    2. dmm mentions that TSC members will be at OpenStack next week and hopes for running the call next week from the summit (regXboi, 17:09:46)
    3. Kent Watsen (kwatsen, 17:09:47)

  4. At-Large TSC member election update (phrobb, 17:10:05)
    1. board meeting was held last night and the "option 1" proposal was discussed (removing the "unless otherwise represented" language for platinum members). (regXboi, 17:11:23)
    2. board approved with the stipulation that this clause only applies to the forthcoming election (regXboi, 17:11:38)
    3. so by-laws return to the original form for the next election (regXboi, 17:11:59)

  5. Committer Promotions (phrobb, 17:13:17)
    1. https://wiki.opendaylight.org/view/Group_Policy:Main (Group Policy) (dmm, 17:13:39)
    2. proposal: keith burns and rob adams to committer for group based policy (regXboi, 17:13:54)
    3. https://lists.opendaylight.org/pipermail/tsc/2014-May/001172.html (relevant list thread) (cdub, 17:17:40)
    4. luis asks, can a committer voluntarily drop committer responsbility (cdub, 17:22:11)
    5. we don't have charter mechanism for that, while could be useful, it's offtopic (cdub, 17:23:07)
    6. VOTE: Voted on ""Shall we promote Kieth Burns and Rob Adams to Committer of Group Based Policy Project?" Results are, 1: 4, 0: 2 (phrobb, 17:23:49)
    7. AGREED: Keith Burns and Rob Adams are now Committers on the Group Based Policy Project (phrobb, 17:24:50)
    8. Ryan Moats (IBM) suggests this should be a special case and not a precedent (RobDolin, 17:24:56)

  6. Creation Reviews (phrobb, 17:25:23)
  7. Creation-Review: ODL-SDNi App (phrobb, 17:26:22)
    1. https://wiki.opendaylight.org/view/Project_Proposals:ODL-SDNi_App (SDNi Project Proposal) (RobDolin, 17:27:45)
    2. https://wiki.opendaylight.org/view/File:SDNiAppProposal1.ppt <-- slides (cdub, 17:27:51)
    3. question about whether this is hardcoded or user defined (regXboi, 17:30:12)
    4. Q:  regXboi asks "since this isn't clustering, are you assuming you are federating controllers in some way?" (phrobb, 17:33:58)
    5. Q in particular what does this project add above existing clustering capabilities? (phrobb, 17:34:49)
    6. A We are trying to establish a federation of controllers - different controllers from different domains (phrobb, 17:35:25)
    7. Q: Concern this is federation based on BGP - issues with securing the data flowing between the domains (phrobb, 17:43:11)
    8. Q what is the plan to secure the trust-path? (phrobb, 17:43:33)
    9. A: This is a known issue with BGP, with solutions being worked on (phrobb, 17:45:10)
    10. I think sacurity of this is being handled in the sidr IETF working group (rovarga, 17:46:41)
    11. there are dependencies on existing ODL-BGPCEP project and those are being taken into account in the release plan (phrobb, 17:46:47)
    12. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects - place to list yourself and your release plan (by Monday 5/12) if you want to join Helium (edwarnicke, 17:47:13)
    13. Q: Is this the first proposal that has described cross-domain federation? (phrobb, 17:48:10)
    14. A: yes and for opendaylight, things are bottom up (regXboi, 17:48:36)
    15. A: This is the first federation type of proposal, everything before has been more clustering focused… (phrobb, 17:49:00)
    16. With a clustering datastore working, similar functionality is exists but having a more federation-view is also a valid methodology. (phrobb, 17:50:37)
    17. Is there any provision for different controllers having similar/compatible functionality? (phrobb, 17:51:08)
    18. Current plan is to share the data provided in this presentation. More information can be shared in the future (phrobb, 17:53:21)
    19. VOTE: Voted on "Shall SDNi be moved to Incubation?" Results are, +1: 6 (phrobb, 17:54:59)
    20. AGREED: ODL-SDNi is moved to Incubation (phrobb, 17:55:38)

  8. Creation Review - South Bound Plugin To The OpenContrail Platform (phrobb, 17:56:09)
    1. I have to upload the slides to the wiki first (kwatsen, 17:58:50)
    2. https://wiki.opendaylight.org/view/Project_Proposals:Southbound_plugin_to_the_OpenContrail_platform (Southbound plugin to the OpenContrail platform Proposal) (RobDolin, 17:59:17)
    3. LuisGomez notes that the proposal seems to propose a completely vertically integrated approach with calls going from the Neutron plugin to their SB plugin and then to OpenContrail, he asks if there are any plans for more integration in the future. (colindixon, 18:04:12)
    4. answer is that they may integrate more in the future, but for now the veritcal integration is the plan for the first release efforts (colindixon, 18:04:44)
    5. Question raised on added value expected from including OpenContrail plugin within OpenDaylight? (phrobb, 18:10:23)
    6. A: there have been customers wanting to manage OpenContrail-manged networks along with other types of networks all from OpenDaylight (phrobb, 18:11:39)
    7. Q: Given that Board has a Vendor-Neutral policy, can the TSC decide on this name? (phrobb, 18:13:16)
    8. A: dmm states that we will be only voting on the project. The name of the project is still TBD until the Board decides on OpenDaylight's "Vendor Neutral" policy (phrobb, 18:14:13)
    9. VOTE: Voted on ""Shall the TSC give conditional approval the Southbound Plugin to the OpenContrail platform" to Incubation.. two conditions 1) the name to be used for the project not decided, and 2) a successful code scan?" Results are, 0: 1, +1: 6 (RobDolin, 18:19:16)
    10. AGREED: Conditional approval of project proposal (RobDolin, 18:20:25)

  9. Hydrogen Stable Release (phrobb, 18:20:32)
    1. https://wiki.opendaylight.org/view/CrossProject:Stable_Release (phrobb, 18:21:14)
    2. https://lists.opendaylight.org/pipermail/tsc/2014-May/001156.html <-- mail thread (cdub, 18:21:38)
    3. discussion ongoing on list. Proposal made to not Cherrypick all changes to master. Instead pick a point in time and copy master to stable-branch then pull non-bug-fix patches from the stable copy. Discussion is ongoing (phrobb, 18:24:22)
    4. cdub suggests maybe getting the specific projects that are having the problem of cherrypickig bug-fixes from master to do the mass-copy. Other projects that have not had that much delta or cross-project-dependencies can just cherrypick the bug-fixes. (phrobb, 18:27:59)

  10. Developer Best Practices (phrobb, 18:36:21)
    1. https://wiki.opendaylight.org/view/Developer_Best_Practices (regXboi, 18:36:32)
    2. request is for TSC to advocate/strongly-encourage all projects in OpenDaylight to comply with 2 recommendations: 1) Build Time Testing, and 2) Comments documenting the code (phrobb, 18:41:46)
    3. comments made that this is "Motherhood and Apple pie", *but* we should probably look at a stylecheck rule that documentation is done with to succeed a build cycle (phrobb, 18:43:41)
    4. On commenting - not having comments is the exception not the norm… ie it must be explained why the comment is not there. (phrobb, 18:45:17)
    5. https://pad.opendaylight.org/p/DevelopmentBestPractices <-- here's what i wrote down as things to consider (cdub, 18:52:53)
    6. devinavery to continue this discussion on the list (phrobb, 18:52:57)
    7. ACTION: devinavery will send a mail out to start this discussion about code best practices (colindixon, 18:53:36)

  11. ovsdb.neutron in SP edition (phrobb, 18:53:41)
    1. madhu asks TSC " given the interest from the users, should we add ovsdb integration project to the SP edition?" (phrobb, 18:54:39)
    2. dmm notes that this request is also to add ovsdb to Hydrogen SP release (phrobb, 18:56:44)
    3. dmm suggests that we take this discussion to the List to further explore ovsdb inclusion into stable hydrogen release of the SP edition (phrobb, 19:00:18)


Meeting ended at 19:00:33 UTC (full logs).

Action items

  1. devinavery will send a mail out to start this discussion about code best practices


Action items, by person

  1. devinavery
    1. devinavery will send a mail out to start this discussion about code best practices


People present (lines said)

  1. phrobb (54)
  2. cdub (40)
  3. regXboi (29)
  4. odl_meetbot (26)
  5. edwarnicke (23)
  6. Madhu (20)
  7. RobDolin (13)
  8. dmm (10)
  9. colindixon (10)
  10. rovarga (7)
  11. kwatsen (6)
  12. ChrisOShea (5)
  13. alagalah (5)
  14. ChrsPriceAB (3)
  15. dkehnx (3)
  16. networkstatic (2)
  17. tbachman (2)
  18. readams (2)
  19. devinavery (1)
  20. Kent (1)
  21. raghu67_ (1)


Generated by MeetBot 0.1.4.