#opendaylight-meeting: Release daily sync

Meeting started by gzhao at 14:30:35 UTC (full logs).

Meeting summary

    1. edwarnicke (edwarnicke, 14:32:13)
    2. colindixon for TTP (colindixon, 14:33:05)
    3. regXboi for general uselessness (regXboi, 14:33:19)
    4. tbachman for groupbasedpolicy (colindixon, 14:33:19)
    5. gzhao release (gzhao, 14:33:21)
    6. phrobb (phrobb, 14:33:27)
    7. abhijitkumbhare OpenFlowPlugin (abhijitkumbhare, 14:33:43)
    8. lori for lispflowmapping (lori, 14:35:20)

  1. blocking issue (gzhao, 14:40:25)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-September/001638.html there has been a request for defense4all to not have to be in karaf, the TSC is voting on this mail thread, so far only one +1 (colindixon, 14:42:25)
    2. LuisGomez for integration (LuisGomez, 14:43:56)
    3. list of projects in red for RC1: Defense4all, SDNi, pluginoc, PCMM, SFC, SNMP4SDN, VTN (gzhao, 14:44:05)
    4. radhika for sdni (radhika, 14:45:20)
    5. edwarnicke says that SFC will hit code freeze by RC1 (and I’m assuming because he didn’t say so, it’s still not code-frozen yet) (colindixon, 14:47:21)
    6. Thomas packetcable (xsited, 14:48:05)
    7. https://git.opendaylight.org/gerrit/#/c/11094 (radhika, 14:48:21)
    8. SDNi Karaf change submitted pending review (gzhao, 14:49:53)
    9. pcmm code not forzen xsited is trying best to catch up (gzhao, 14:51:57)
    10. hideyukie said yesterday that VTN would be code frozen on monday (we will hope that is still true) (colindixon, 14:52:00)
    11. sfc, pcmm, snmp, vtn are in the “danger zone” for RC1 b/c of code freeze (colindixon, 14:54:04)
    12. sdni and plugin2oc are in the “danger zone” for RC1 b/c of karaf (colindixon, 14:54:43)
    13. we believe (hope) that defense4all will be removed from the “danger zone” for RC1 by TSC exception (colindixon, 14:55:09)
    14. working an issue for defense4all... they appear to have release versions from Hydrogen, not SNAPSHOT for Helium, and that must be corrected (edwarnicke, 14:55:54)
    15. missing representatives from RC1"danger zone" projects: Defense4All, pluginoc, SNMP4sdn, VTN (gzhao, 14:56:13)

  2. call for blocking issues from projects (colindixon, 14:57:14)
    1. rovarga asks who should he talk to about changing the branch from which a projects code is pulled for auto-releases (colindixon, 14:58:32)
    2. the answer (at least for now) is that edwarnicke is the keeper of the magic of the auto-release and can change what branch it pulls from in projects (colindixon, 14:59:26)
    3. (from above on getting projects into karaf) LuisGomez sys the sdni karaf patch to integration is pending for review by integration committers (colindixon, 15:00:31)
    4. (from above on getting projects into karaf) LuisGomez sys the plugin2oc karaf patch to integration is pending review by by the project (colindixon, 15:01:06)
    5. PriyankaChopra for plugin2oc (PriyankaChopra, 15:02:56)
    6. phrobb asks if all projects in the “danger zone” for RC1 acked that they would be dropped if they didn’t get out my Monday at 5pm pacific (colindixon, 15:09:40)
    7. gzhao says that all 7 projects responded to that statement (colindixon, 15:09:57)
    8. Vina Ermagan for lispflowmapping (vina_, 15:17:12)
    9. ACTION: gzhao to forward the direct responses acking the RC1 requirements and consequences to the release list so that we have them publicly logged (colindixon, 15:18:00)
    10. rafat for sdni along with Radhika (colindixon, 15:23:21)

  3. documentation (colindixon, 15:23:51)
    1. edwarnicke asks where the “how to” information is on creating documentation (colindixon, 15:24:05)
    2. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Tools mlemay says this is it but it is stil “very shady” (colindixon, 15:24:34)
    3. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines this is a flow chart of what kind of documentation you should be making (colindixon, 15:25:10)
    4. https://wiki.opendaylight.org/view/OpenDaylight_Controller:How_To:_Site_Deploy (colindixon, 15:42:41)
    5. sdni (rafat, 15:48:55)
    6. https://git.opendaylight.org/gerrit/#/c/11111 (colindixon, 16:00:30)
    7. https://git.opendaylight.org/gerrit/#/c/11094/ is the link where you gave the comment..This one is verified an awaiting merge (rafat, 16:03:36)
    8. https://git.opendaylight.org/gerrit/#/c/11111 is the new link where I tried updating the link... (rafat, 16:03:58)
    9. https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-verify/org.opendaylight.plugin2oc$features-plugin2oc/43/testReport/installFeature(org.opendaylight.yangtools.featuretest.SingleFeatureTest)[repoUrl_%20file__opt_jenkins-plugin2oc_jobs_plugin2oc-verify_workspace_features-plugin2oc_target_classes_features.xml,%20Feature_%20odl-plugin2oc%200/1]/installFea (edwarnicke, 16:05:48)
    10. https://git.opendaylight.org/gerrit/#/c/11046/ (rafat, 16:13:19)
    11. https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/ (rafat, 16:13:49)
    12. https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/org.opendaylight.sdninterfaceapp$features-sdninterfaceapp/10/testReport/ (CASP3R, 16:17:20)
    13. https://git.opendaylight.org/gerrit/#/c/11094/ does not.. (rafat, 16:45:01)
    14. https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/ (rafat, 16:51:01)
    15. https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/325/ looks like its for a patch of yours https://git.opendaylight.org/gerrit/#/c/11111/ may I cancel https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/325/ (edwarnicke, 16:52:06)
    16. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Docs_Decision_Matrix is the closest thing to a process (mlemay, 17:31:27)
    17. https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/16-SbSzdBzTXEk8lD6Q09zl-Ip8jBU3B8_BBqRPXGimg/edit#gid=0 <— this is the tracking spreadsheet the documentation project has been using. It contains the contacts… but is very sparse on actual work getting/being done… sadly because not much has yet been done to date. (phrobb, 17:32:55)
    18. https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-verify/51/console (PriyankaChopra, 18:26:02)
    19. https://www.irccloud.com/pastebin/lPBu01jt (edwarnicke, 19:25:05)
    20. https://git.opendaylight.org/gerrit/gitweb?p=plugin2oc.git;a=blob;f=neutron/src/main/java/org/opendaylight/plugin2oc/neutron/Activator.java;h=f81d01615fca1ae083d1e1f80dc6ed8fc852b29c;hb=752b9accae0d57597df6ff21448371d88363d314 (tbachman, 19:25:08)
    21. https://www.irccloud.com/pastebin/bY0iXhMK (edwarnicke, 19:47:19)
    22. https://www.irccloud.com/pastebin/S2EyosNM (edwarnicke, 19:50:24)
    23. https://www.irccloud.com/pastebin/ET4Q2tYe (edwarnicke, 19:51:34)
    24. https://www.irccloud.com/pastebin/lsXHiUZD (edwarnicke, 20:28:35)
    25. https://git.opendaylight.org/gerrit/11119 (tbachman, 20:40:13)


Meeting ended at 20:58:43 UTC (full logs).

Action items

  1. gzhao to forward the direct responses acking the RC1 requirements and consequences to the release list so that we have them publicly logged


Action items, by person

  1. gzhao
    1. gzhao to forward the direct responses acking the RC1 requirements and consequences to the release list so that we have them publicly logged


People present (lines said)

  1. edwarnicke (376)
  2. colindixon (141)
  3. tbachman (130)
  4. regXboi (126)
  5. rafat (100)
  6. gzhao (98)
  7. PriyankaChopra (93)
  8. mlemay (44)
  9. radhika (15)
  10. odl_meetbot (12)
  11. rovarga (12)
  12. CASP3R (9)
  13. tykeal (8)
  14. phrobb (7)
  15. abhijitkumbhare (7)
  16. xsited (4)
  17. ChristineH (4)
  18. LuisGomez (3)
  19. CASP3R_ (2)
  20. rovarga_ (2)
  21. lori (1)
  22. regXboi_on_phone (1)
  23. posterity (1)
  24. vina_ (1)


Generated by MeetBot 0.1.4.