#opendaylight-meeting: release daily sync

Meeting started by colindixon at 14:31:55 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 14:32:03)
    1. abhijitkumbhare OF plugin (abhijitkumbhare, 14:32:14)
    2. tbachman for groupbasedpolicy (tbachman, 14:32:17)
    3. edwarnicke (edwarnicke, 14:32:21)
    4. colindixon for TTP (and braaaaiiinnnns) (colindixon, 14:32:21)
    5. gzhao (gzhao, 14:32:40)
    6. oflibMichal for openflowjava (oflibMichal, 14:32:42)
    7. regXboi (for general gad-fly-ness) (regXboi, 14:32:44)
    8. thomas packetcable (xsited1, 14:34:56)
    9. ttkacik yangtools & mdsal (ttkacik, 14:35:14)
    10. Hideyuki Tai for VTN (hideyuki, 14:35:36)

  2. auto-release (colindixon, 14:37:46)
    1. https://lists.opendaylight.org/pipermail/release/2014-September/000403.html we’ll use gzhao’s agenda from yesterday as a skeleton (colindixon, 14:38:32)
    2. edwarnicke reports that snmp4sdn and defense4all both should be good for auto-release at this point, but RC1 cutting hit two issues: one in plugin2oc and one in dlux (colindixon, 14:40:08)
    3. edwarnicke believes he’s fixed both the plugin2oc and dlux issues and will have a fully RC1 kicked off in the next 30 minutes (colindixon, 14:42:12)
    4. AsafOron for D4A (gzhao, 14:42:53)

  3. project status and blocking issues (colindixon, 14:44:38)
    1. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 <= spreadsheet to track project feature testing (gzhao, 14:45:47)
    2. https://lists.opendaylight.org/pipermail/release/2014-September/000418.html sent this e-mail asking people to track their feature testing with the above spreadsheet (colindixon, 14:46:20)
    3. groupbasedpolicy was working as of late last night, but there was a new bug that’s causing the Proof of Concept to fail (tbachman, 14:47:24)
    4. if you don’t report testing, expect gently prodding and then cranky e-mails from gzhao, edwarnicke, and others (colindixon, 14:48:00)
    5. https://git.opendaylight.org/gerrit/#/c/11067/ the TTP project merged this bug fix yesterday prior to RC1 (colindixon, 14:49:50)

  4. blocking issues (colindixon, 14:55:09)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=1907 bug for NPE when running groupbasedpolicy POC (tbachman, 14:57:17)
    2. colindixon notes that testing and docs *need* to happen for each project (colindixon, 14:57:49)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2014/tws/opendaylight-meeting-tws.2014-09-15-17.04.html the meeting minutes from yesterday’s TWS call go through a basic idea about how to do docs (colindixon, 14:58:55)
    4. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_RC0 shows how to test RCs (they’re written for RC0, but the idea is the same except you’ll want to get the newer RC) (colindixon, 15:00:39)
    5. ACTION: colindixon to add instructions/links on how to get more recent builds to the RC testing instructions (colindixon, 15:01:08)
    6. https://lists.opendaylight.org/pipermail/release/2014-September/000418.html this e-mail from gzhao describes how to report testing results (colindixon, 15:02:08)
    7. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 testing results should be reported on this spreadsheet (colindixon, 15:02:24)
    8. please also note we will have nightly builds, and testing the nightlies is also mega goodness (edwarnicke, 15:02:56)
    9. https://www.irccloud.com/pastebin/PrJ8SvG8 (edwarnicke, 15:07:00)
    10. ACTION: colindixon to inform the TSC that defense4all built successfully in the RC1 (colindixon, 15:08:09)
    11. ACTION: gzhao to harass projects about reporting documentation status or at least what kind of docs they’re going to produce (colindixon, 15:08:51)
    12. https://docs.google.com/spreadsheets/d/16-SbSzdBzTXEk8lD6Q09zl-Ip8jBU3B8_BBqRPXGimg/edit#gid=0 we will use this spreadsheet to track doc status for each project (colindixon, 15:09:09)

  5. other topics and issues (colindixon, 15:10:44)


Meeting ended at 15:15:37 UTC (full logs).

Action items

  1. colindixon to add instructions/links on how to get more recent builds to the RC testing instructions
  2. colindixon to inform the TSC that defense4all built successfully in the RC1
  3. gzhao to harass projects about reporting documentation status or at least what kind of docs they’re going to produce


Action items, by person

  1. colindixon
    1. colindixon to add instructions/links on how to get more recent builds to the RC testing instructions
    2. colindixon to inform the TSC that defense4all built successfully in the RC1
  2. gzhao
    1. gzhao to harass projects about reporting documentation status or at least what kind of docs they’re going to produce


People present (lines said)

  1. colindixon (80)
  2. edwarnicke (70)
  3. tbachman (38)
  4. gzhao (23)
  5. regXboi (16)
  6. AsafOron (9)
  7. odl_meetbot (8)
  8. gershon (5)
  9. Madhu (4)
  10. abhijitkumbhare (3)
  11. hideyuki (2)
  12. oflibMichal (1)
  13. phrobb (1)
  14. xsited1 (1)
  15. ttkacik (1)
  16. alagalah (1)
  17. dave_tucker (1)


Generated by MeetBot 0.1.4.