#opendaylight-meeting: release daily sync

Meeting started by colindixon at 14:31:14 UTC (full logs).

Meeting summary

  1. roll call (colindixon, 14:31:19)
    1. tbachman for groupbasedpolicy (tbachman, 14:31:28)
    2. colindixon for TTP (and ponies!) (colindixon, 14:31:30)
    3. abhijitkumbhare for OF plugin (abhijitkumbhare, 14:32:01)
    4. oflibMichal (oflibMichal, 14:32:03)
    5. Hideyuki Tai for VTN (hideyuki_, 14:32:19)
    6. Vijay for SNBI (vjanandr, 14:32:54)
    7. thomas packetcable (xsited1, 14:33:58)
    8. Phil Robb (phrobb, 14:34:25)
    9. edwarnicke (edwarnicke, 14:35:21)
    10. LuisGomez (LuisGomez, 14:35:33)

  2. RC1 (and auto-release) (colindixon, 14:36:58)
    1. goldavberg for lispflowmapping (goldavberg_phone, 14:37:19)
    2. http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC1/ we have RC1 artifacts (colindixon, 14:37:26)
    3. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_.28Your_Project.2FFeatures_in.29_RCs this contains instructions on how to test your stuff in RC1 (and all other RCs) (colindixon, 14:38:10)
    4. I will pass system test for RC1 today, just need to adjust 1 job (LuisGomez, 14:38:58)
    5. edwarnicke notes that we’ve had several successful runs of the RC1 auto release (nightlies) and that the current one hit a snag (colindixon, 14:40:21)
    6. edwarnicke has already found the source of the snag and fixed it (colindixon, 14:41:41)
    7. https://jenkins.opendaylight.org/integration/view/CSIT%20Jobs/job/integration-master-csit-karaf-compatible-all/ (LuisGomez, 14:41:59)
    8. tbachman notes that for him, to get REST in RC1 to work, he had to load the restconf bundle feature before running the compatible-with-all feature (colindixon, 14:45:23)
    9. the problem seems to have resolved itself for LuisGomez, but edwarnicke also thinks he knows how to fix it if it’s still persisting for tbachman (colindixon, 14:46:16)
    10. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 this is where to report your the testing you do in RC1 (colindixon, 14:46:46)
    11. ^^^^^^ go test and report (colindixon, 14:47:06)
    12. also, you should test nightlies if you can, more testing is more better. instructions on where to find nightlies are on the testing wiki page linked above (colindixon, 14:48:41)
    13. tbachman asks what column F (“Test compatible with feature”) is supposed to be reporting (colindixon, 14:50:01)
    14. colindixon notes that the explanation on the sheet is: “Please input the feature IDs that you tested compatible with the testing feature” (colindixon, 14:51:00)
    15. column B is for the feature being tested, it and it’s dependencies should be the only things loaded when you do the “single feature” test which you’ll report with “Yes” in column D (colindixon, 14:55:33)
    16. column F is for reporting what other features you loaded to test when doing your “feature compatibility test”, which when run, you report with “Yes” in column E (colindixon, 14:56:21)
    17. note that column F should likely be “odl-integration-compatibility-with-all” (for projects which don’t have any expected compatibility issues), or “odl-integration-compatibility-with-<project-from-column-B>” (for projects that do have known compatibility issues) (colindixon, 14:57:41)
    18. ACTION: colindixon to add explanation about the testing report spreadsheet to the testing part of the karaf step by step wiki page (colindixon, 14:58:16)

  3. project status reports (colindixon, 14:58:53)
    1. VTN project has started testing RC1, and has not detected any isues of VTN features so far. (hideyuki_, 14:59:04)
    2. hideyuki_ notes that VTN project has detected some bugs in controller and openflowplugin. Bug 1491, 1759, and 1866. (colindixon, 14:59:12)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=1759#c7 (hideyuki_, 14:59:19)
    4. each project should check their current status and report if project is till green/red/yellow (gzhao, 15:00:28)
    5. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068 <= current project status (gzhao, 15:00:50)
    6. groupbasedpolicy has tested both odl-groupbasedpolicy-ofoverlay and odl-integration-compatible-with-groupbasedpolicy, and both passed (tbachman, 15:02:03)

  4. documentation (colindixon, 15:07:25)
    1. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1408765403 this shows what information we currently have projects about the kinds of documentation projects intend to produce (colindixon, 15:07:54)
    2. it’s still incomplete despite gzhao’s pushing to get the missing info with in M5 (colindixon, 15:08:18)
    3. https://git.opendaylight.org/gerrit/#/c/11258/ the l2switch project has pushed documentation, which might be a good place to go look for an example (colindixon, 15:09:25)
    4. https://git.opendaylight.org/gerrit/#/q/project:docs,n,z others have pushed docs as well (lispflowmapping and yangtools) (colindixon, 15:10:29)
    5. ACTION: colindixon, regXboi, or mlemay to review some of the pushed docs and try to find a good example to put forward as an exemplar (colindixon, 15:12:16)
    6. please, please, please start your docs if you can (colindixon, 15:12:28)

  5. blocking issues (colindixon, 15:12:34)
    1. https://lists.opendaylight.org/pipermail/release/2014-September/000433.html dana reported some issues here (colindixon, 15:14:57)
    2. it appears that they aren’t blocking, but should be tackled (colindixon, 15:15:54)
    3. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068 (gzhao, 15:18:01)
    4. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068 gzhao would like to have yellow projects report in if the move to green (colindixon, 15:19:04)
    5. ACTION: gzhao to send a mail to projects still in yellow explaining that their goal should be to get to green, and that reducing the scope of their deliverables (and documenting that) to do so is fine (colindixon, 15:24:25)


Meeting ended at 15:26:31 UTC (full logs).

Action items

  1. colindixon to add explanation about the testing report spreadsheet to the testing part of the karaf step by step wiki page
  2. colindixon, regXboi, or mlemay to review some of the pushed docs and try to find a good example to put forward as an exemplar
  3. gzhao to send a mail to projects still in yellow explaining that their goal should be to get to green, and that reducing the scope of their deliverables (and documenting that) to do so is fine


Action items, by person

  1. colindixon
    1. colindixon to add explanation about the testing report spreadsheet to the testing part of the karaf step by step wiki page
    2. colindixon, regXboi, or mlemay to review some of the pushed docs and try to find a good example to put forward as an exemplar
  2. gzhao
    1. gzhao to send a mail to projects still in yellow explaining that their goal should be to get to green, and that reducing the scope of their deliverables (and documenting that) to do so is fine


People present (lines said)

  1. colindixon (92)
  2. tbachman (54)
  3. edwarnicke (44)
  4. gzhao (26)
  5. hideyuki_ (23)
  6. LuisGomez (17)
  7. odl_meetbot (5)
  8. abhijitkumbhare (5)
  9. vjanandr (3)
  10. oflibMichal (1)
  11. goldavberg_phone (1)
  12. phrobb (1)
  13. xsited1 (1)


Generated by MeetBot 0.1.4.