#opendaylight-meeting: release daily sync

Meeting started by gzhao at 14:30:34 UTC (full logs).

Meeting summary

  1. roll call (gzhao, 14:30:54)
    1. gzhao for release (gzhao, 14:31:15)
    2. Phil Robb (phrobb, 14:31:48)
    3. colindixon for TTP (colindixon, 14:32:13)
    4. Hideyuki for VTN (hideyuki_, 14:33:37)
    5. regXboi for general mischief and gadfly-ness (regXboi, 14:34:00)
    6. thomas packetcable (xsited1, 14:34:12)
    7. abhijitkumbhare for OpenFlow plugin (on another meeting same time) (abhijitkumbhare, 14:36:02)

  2. autorelease (gzhao, 14:36:40)
    1. paulq for sfc (paulq_, 14:37:07)
    2. https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ (colindixon, 14:37:24)
    3. https://www.irccloud.com/pastebin/8oj2sfr5 (gzhao, 14:37:54)
    4. alagalah for GBP (alagalah, 14:38:40)
    5. edwarnicke (edwarnicke, 14:38:43)
    6. oflibMichal (oflibMichal, 14:38:49)
    7. https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ the last two auto-releases (58 and 59) have failed at BGPCEP (colindixon, 14:39:00)
    8. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Download_the_RC the nightly build (RC1-3) did build successfully and can be downloaded here (colindixon, 14:40:29)
    9. https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/59/console complains it can't find artifact org.opendaylight.controller:sal-dom-xsql:bundle:1.1-Helium-RC1-v201409191037 (edwarnicke, 14:43:12)
    10. https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ws/.m2repo/org/opendaylight/controller/sal-dom-xsql/1.1-Helium-RC1-v201409191037/ and yet here is that artifact in the m2repo for the workspace (edwarnicke, 14:43:48)
    11. rovarga notes that it appears as though xsql’s javadoc build is failing which is why bcpcep can’t find the jar and so fixing that should fix the auto-release (colindixon, 14:49:38)
    12. tbachman for groupbasedpolicy (tbachman, 14:51:12)
    13. ACTION: edwarnicke to work on resolving the auto-release issue with the new information from the bgpcep team (colindixon, 14:53:01)

  3. RC2 release (colindixon, 14:53:30)
    1. we’re planning to cut RC2 artifacts on Monday 9/22 at 5p pacific (that’s midnight UTC between 9/22 and 9/23) (colindixon, 14:54:03)
    2. the TSC has said that those artifacts will be the Helium release artifacts unless there are any show-stopping issues (colindixon, 14:54:35)
    3. edwarnicke understands that the RC2 artifacts scheduled to be cut Monday Sept 22 at 5pm PST will be used as release artifacts unless a show stopper is uncovered (edwarnicke, 14:58:01)
    4. ACTION: gzhao to send a mail to release saying that RC2 artifacts are going to be release artifacts including instructions to update the testing doc (colindixon, 14:58:59)
    5. colindixon acks that he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs (colindixon, 15:02:42)
    6. regXboi acks (not sure why - i'm only here for mischief :) ) (regXboi, 15:02:43)
    7. gzhao acks (gzhao, 15:02:50)
    8. +1 / ack (oflibMichal, 15:03:07)
    9. ACK (phrobb, 15:03:12)
    10. tbachman acks that he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs (tbachman_, 15:03:56)
    11. Hideyuki acks that he understands RC2 artifact will be release artifacts barring show stoping bugs (hideyuk__, 15:05:00)

  4. project status reports/issues (colindixon, 15:05:22)
    1. groupbasedpolicy is seeing two NPEs (tbachman_, 15:05:41)
    2. https://lists.opendaylight.org/pipermail/vtn-dev/2014-September/000608.html hideyuk__ says VTN project is working on system test failures (colindixon, 15:08:14)
    3. ACTION: colindixon to work with gzhao to start making a list of known helium blocking bugs (colindixon, 15:09:07)
    4. ACTION: colindixon to work with gzhao to hunt down projects make them fill out the testing spreadsheet (colindixon, 15:09:26)
    5. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 this is the helium testing spreadsheet (colindixon, 15:10:00)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=1984 one of the NPE bugs reported by GPB (colindixon, 15:11:15)
    7. documentation is still a project in red (but that is known and unlikely to change) (colindixon, 15:11:41)
    8. pcmm, integration and ovsdb are currently yellow (colindixon, 15:12:14)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=1985 the other NPE bug reported by GBP (colindixon, 15:12:40)
    10. ACTION: gzhao to follow up with Madhu and xsited directly about ovsdb and pcmm to figure out if they can be moved to green (colindixon, 15:14:20)
    11. Madhu notes that ovsdb is having issues with flow programming (blocking issues), hence being yellow (colindixon, 15:16:42)
    12. tbachman notes that GBP is having issues with flow programming (blocking issue) (tbachman, 15:17:00)
    13. Madhu notes that these issues may not turn out to be bugs outside of OVSDB (colindixon, 15:20:06)

  5. blocking issues (colindixon, 15:22:41)
    1. tbachman and Madhu seem to be debugging potentially-related issues around flow programming and will keep people abreast of the issues (colindixon, 15:23:30)
    2. Madhu acks he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs (gzhao, 15:23:50)
    3. we have a break in auot-release which edwarnicke is hunting down (colindixon, 15:24:34)
    4. it appears as though snmp4sdn is having issues with karaf and may or may not be code-frozen (colindixon, 15:30:36)
    5. ChristineH notes that the the part of the code which isn’t frozen is because of bug testing (colindixon, 15:34:08)
    6. ACTION: ChristineH to file a bug around the issues they are facing, she will e-mail gzhao with that info (colindixon, 15:36:31)


Meeting ended at 15:37:39 UTC (full logs).

Action items

  1. edwarnicke to work on resolving the auto-release issue with the new information from the bgpcep team
  2. gzhao to send a mail to release saying that RC2 artifacts are going to be release artifacts including instructions to update the testing doc
  3. colindixon to work with gzhao to start making a list of known helium blocking bugs
  4. colindixon to work with gzhao to hunt down projects make them fill out the testing spreadsheet
  5. gzhao to follow up with Madhu and xsited directly about ovsdb and pcmm to figure out if they can be moved to green
  6. ChristineH to file a bug around the issues they are facing, she will e-mail gzhao with that info


Action items, by person

  1. ChristineH
    1. ChristineH to file a bug around the issues they are facing, she will e-mail gzhao with that info
  2. colindixon
    1. colindixon to work with gzhao to start making a list of known helium blocking bugs
    2. colindixon to work with gzhao to hunt down projects make them fill out the testing spreadsheet
  3. edwarnicke
    1. edwarnicke to work on resolving the auto-release issue with the new information from the bgpcep team
  4. gzhao
    1. gzhao to send a mail to release saying that RC2 artifacts are going to be release artifacts including instructions to update the testing doc
    2. colindixon to work with gzhao to start making a list of known helium blocking bugs
    3. colindixon to work with gzhao to hunt down projects make them fill out the testing spreadsheet
    4. gzhao to follow up with Madhu and xsited directly about ovsdb and pcmm to figure out if they can be moved to green
    5. ChristineH to file a bug around the issues they are facing, she will e-mail gzhao with that info
  5. Madhu
    1. gzhao to follow up with Madhu and xsited directly about ovsdb and pcmm to figure out if they can be moved to green


People present (lines said)

  1. colindixon (108)
  2. gzhao (54)
  3. tbachman (41)
  4. edwarnicke (39)
  5. Madhu (28)
  6. odl_meetbot (11)
  7. rovarga (8)
  8. regXboi (7)
  9. ChristineH (7)
  10. tbachman_ (5)
  11. abhijitkumbhare (4)
  12. hideyuk__ (3)
  13. phrobb (2)
  14. oflibMichal (2)
  15. alagalah (2)
  16. paulq_ (1)
  17. xsited1 (1)
  18. gzhao_ (1)
  19. hideyuki_ (1)


Generated by MeetBot 0.1.4.