#opendaylight-meeting: release daily sync

Meeting started by gzhao at 14:30:22 UTC (full logs).

Meeting summary

  1. roll call (gzhao, 14:30:40)
    1. Phil Robb (phrobb, 14:30:43)
    2. tbachman for groupbasedpolicy (tbachman, 14:30:50)
    3. LuisGomez for integration (LuisGomez, 14:31:12)
    4. oflibMichal for openflowjava (oflibMichal, 14:31:19)
    5. gzhao for release (gzhao, 14:31:21)
    6. abhijitkumbhare for openflowplugin (abhijitkumbhare, 14:31:35)
    7. thomas packetcable (xsited1, 14:31:39)
    8. colindixon for TTP (and caffeine) (colindixon, 14:32:21)
    9. PriyankaChopra for plugin2oc (PriyankaChopra, 14:32:51)
    10. goldavberg for lispflowmapping (goldavberg_, 14:32:59)
    11. gershon defense4all (gershon, 14:33:30)
    12. edwarnicke (edwarnicke, 14:35:26)

  2. auto-release (gzhao, 14:35:48)
    1. https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ auto-release #77 just worked a few minutes back (colindixon, 14:36:57)
    2. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_.28Your_Project.2FFeatures_in.29_RCs <- included last night nightly (edwarnicke, 14:37:06)

  3. blocking issues (gzhao, 14:38:25)
    1. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163 (gzhao, 14:38:44)
    2. groupbasedpolicy is working with openflowjava team to resolve a blocking bug on group mod programming (tbachman, 14:38:52)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=2023 <= bug for openflowjava bug affecting groupbasedpolicy (tbachman, 14:39:11)
    4. root cause of 1997 identified. I have tested a 'machete' fix and gone from reliable failure to reliable success... michal_rehak is working on a proper fix and expects it to be done in an hour or so (edwarnicke, 14:39:30)
    5. we also have a new bug filed, where our application doesn’t always seem to start (tbachman, 14:39:55)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=2019 <= Bug for groupbasedpolicy application not starting every time (tbachman, 14:40:09)
    7. ACTION: colindixon to verify that bug 1991 is fixed ASAP (colindixon, 14:40:52)
    8. there are still 26 bugs on http://goo.gl/AhRSfF (tbachman, 14:43:38)
    9. http://goo.gl/AhRSfF <= helpful lnk created by colindixon for looking up showstopper bugs (tbachman, 14:44:00)
    10. alagalah for GBP (alagalah, 14:46:58)
    11. Hideyuki for VTN (hideyuki_, 14:47:30)
    12. edwarnicke says “to be precise, RC2 will be cut tonight with release versions or Helium to a staging repo. The TSC is expected to decide whether to bless those to the release repo on Thursday if we don't find showstoppers in subsquent testing.” (colindixon, 14:51:27)
    13. edwarnicke follows up with “My point is... the train *is* leaving tonight.. the only question is if there will be subsequent trains" (colindixon, 14:51:38)
    14. alagalah asks what “showstopper” is defined to be (colindixon, 14:52:18)
    15. colindixon responds “showstopper is not explicitly defined, but casually I’ve been thinking that it’s that a project says they can’t be used in the state that they exist in RC2" (colindixon, 14:52:33)
    16. edwarnicke points out that autorelease builds from *master* (or in a few cases, project specified alternate branch) for final RC (tbachman, 14:53:31)
    17. https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ autorelease builds... please watch, if your stuff breaks, please fix (edwarnicke, 14:54:24)
    18. gzhao asks if we will delay the RC2 build if there are show stoppers (colindixon, 14:55:15)
    19. phrobb responds that there’s probably no reason to tag it for release if theyre are known, non-fixed showstoppers still there, but all projects should be running hard to fix show stoppers by 5p pacific (colindixon, 14:55:48)
    20. colindixon also notes, per edwarnicke’s comment above, that RC2 is just going to go in a staging zone, so that decision can be made after the fact, thus delaying the build seems inadvisable, we’ll just run it again later (colindixon, 14:56:33)
    21. ACTION: everyone go look at the bug list and find your project and deal with them here: http://goo.gl/AhRSfF (colindixon, 15:02:28)
    22. ACTION: “deal with them” means (i) fix them and change their status to resolved, (ii) change their status because they’ve already been fixed, (iii) change the target milestone to Lithium, and/or (iv) revise their severity down from critical or blocker (colindixon, 15:03:42)

  4. testing status (colindixon, 15:03:47)
    1. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 the testing spreadsheet (colindixon, 15:04:19)
    2. gzhao generously says we have half of our top-level-features tested, it looks like 11/27 this second (colindixon, 15:06:44)
    3. edwarnicke says he has a lot of things he can fill in this second (colindixon, 15:07:32)
    4. ACTION: test your projects!!!!! TEST THEM NOW!!!!! (and report it on the testing spreadsheet) (colindixon, 15:08:01)
    5. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_.28Your_Project.2FFeatures_in.29_RCs that page contains info on how to get RCs to test with, how to run them, and where to report the results (colindixon, 15:08:47)

  5. blocking issues (counting down to midnight UTC) (colindixon, 15:13:04)
    1. colindixon asks are there projects which are concerned they will still have blocking issues in a bit over 9 hours? (tbachman, 15:15:21)
    2. snmp reported still hasn't resolved the two blocking issues they have (tbachman, 15:15:34)
    3. 1997 root cause has been idenfied, fix on the way (edwarnicke, 15:17:19)
    4. groupbasedpolicy is blocking on 2019 and 2023 (tbachman, 15:19:17)
    5. it sounds like defense4all has a few patches they need to get in, but are ready to go (colindixon, 15:21:46)
    6. ACTION: gzhao to follow up with aaa to see about bugs 2009 and 2011 (colindixon, 15:22:10)
    7. gershon says that defense4all has fixed all the show-stopping bugs they are aware of, but are waiting on auto-release to verify (colindixon, 15:25:54)
    8. dlenrow says that that AAA has people working on bugs 2009 and 2011 (colindixon, 15:27:11)

  6. final call for issues (colindixon, 15:29:21)
    1. regXboi notest that edwarnicke’s windows patch to change JVM settings in karaf on windows appears to be incorrect (colindixon, 15:31:59)
    2. when encounter blocking issues: please use #opendaylight-release #opendaylight-meeting or gzhao (gzhao, 15:33:07)


Meeting ended at 15:35:44 UTC (full logs).

Action items

  1. colindixon to verify that bug 1991 is fixed ASAP
  2. everyone go look at the bug list and find your project and deal with them here: http://goo.gl/AhRSfF
  3. “deal with them” means (i) fix them and change their status to resolved, (ii) change their status because they’ve already been fixed, (iii) change the target milestone to Lithium, and/or (iv) revise their severity down from critical or blocker
  4. test your projects!!!!! TEST THEM NOW!!!!! (and report it on the testing spreadsheet)
  5. gzhao to follow up with aaa to see about bugs 2009 and 2011


Action items, by person

  1. colindixon
    1. colindixon to verify that bug 1991 is fixed ASAP
  2. gzhao
    1. gzhao to follow up with aaa to see about bugs 2009 and 2011
  3. UNASSIGNED
    1. everyone go look at the bug list and find your project and deal with them here: http://goo.gl/AhRSfF
    2. “deal with them” means (i) fix them and change their status to resolved, (ii) change their status because they’ve already been fixed, (iii) change the target milestone to Lithium, and/or (iv) revise their severity down from critical or blocker
    3. test your projects!!!!! TEST THEM NOW!!!!! (and report it on the testing spreadsheet)


People present (lines said)

  1. colindixon (80)
  2. edwarnicke (69)
  3. gzhao (64)
  4. tbachman (58)
  5. regXboi (32)
  6. alagalah (20)
  7. odl_meetbot (10)
  8. gershon (10)
  9. abhijitkumbhare (8)
  10. phrobb (6)
  11. dlenrow (3)
  12. zxiiro (2)
  13. LuisGomez (2)
  14. goldavberg_ (1)
  15. oflibMichal (1)
  16. PriyankaChopra (1)
  17. xsited1 (1)
  18. hideyuki_ (1)


Generated by MeetBot 0.1.4.