#opendaylight-meeting: TSC

Meeting started by phrobb at 16:58:31 UTC (full logs).

Meeting summary

    1. dmm (dmm, 16:58:38)

  1. TSC Members please #info in (phrobb, 16:59:01)
    1. Lenrow (dlenrow, 16:59:09)
    2. Kent Watsen (kwatsen, 16:59:31)
    3. edwarnicke (edwarnicke, 17:00:19)
    4. charis price (ChrisPriceAB, 17:01:05)
    5. regXboi (regXboi, 17:03:28)

  2. upcoming events (colindixon, 17:03:57)
    1. there’s the OpenFlow World Congress in Dusseldorf which there’s a call for papers open (colindixon, 17:04:30)
    2. there’s also a hackfest there which we’re organizing (colindixon, 17:04:44)
    3. this is a big event for us, please reach out to ChrisPriceAB as he’s coordinating our efforts there (colindixon, 17:05:08)
    4. https://wiki.opendaylight.org/view/TSC:Main the agenda for this whole meeting (colindixon, 17:05:33)
    5. http://www.opendaylight.org/events/2014-10-14/opendaylight-mini-summit-sdn-openflow-world-congress ODL minisummit at OFWC (colindixon, 17:05:59)
    6. http://www.opendaylight.org/events/2014-10-13/opendaylight-d%C3%BCsseldorf-hackfest hackfest (colindixon, 17:06:07)
    7. http://www.opendaylight.org/events/2014-09-29/opendaylight-developer-design-forum developer design forum (colindixon, 17:06:26)

  3. committer additions to openflowplugin (colindixon, 17:07:03)
    1. two people (Anil Vishnoi and Ed Warnicke) are up (colindixon, 17:07:38)
    2. RobDolin proxy for Rajeev Nagar (MSFT) (RobDolin, 17:08:02)
    3. 5 of 6 committers have voted in favor of this (colindixon, 17:08:04)
    4. https://lists.opendaylight.org/pipermail/tsc/2014-July/001451.html this thread showing the voting (colindixon, 17:08:30)
    5. VOTE: Voted on "Shall Anil Vishnoi be promoted to committer on the OpenFlow Plugin Project?" Results are, +1: 7 (phrobb, 17:09:26)
    6. VOTE: Voted on "Shall Ed Warnicke be promoted to committer on the OpenFlow Plugin Project?" Results are, 0: 1, +1: 6 (phrobb, 17:10:08)
    7. AGREED: Anil Vishnoi is promoted to committer on OpenFlow Plugin project (phrobb, 17:11:04)
    8. AGREED: Ed Warnicke is promoted to Committer on OpenFlow Plugin project (phrobb, 17:11:23)

  4. Chris O’Shea to committer on integration (colindixon, 17:11:39)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-July/001454.html evidence of 8 of 10 committers voting yes (colindixon, 17:11:58)
    2. he’s done a lot of work on providing mock interfaces in the project which has be helpful (colindixon, 17:12:30)
    3. VOTE: Voted on "Shall Chris O’Shea be promoted to committer on the Integration Project?" Results are, +1: 6 (phrobb, 17:12:37)
    4. AGREED: Chris O’Shea is promoted to committer on the Integration Project. (phrobb, 17:12:47)

  5. board vote on modifications to TSC charter (and at large election updates) (colindixon, 17:13:05)
  6. stable hydrogen release progress (colindixon, 17:13:35)
    1. pretty much everybody has +1'd (regXboi, 17:14:50)
    2. there are a few gaps and we may need to remove the folks who haven't (regXboi, 17:15:06)
    3. in future hydrogen/stable (regXboi, 17:15:20)
    4. looking (regXboi, 17:15:24)
    5. https://docs.google.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0 (regXboi, 17:15:51)
    6. Defense4All and Affinity are gaps (regXboi, 17:16:09)
    7. edwarnicke sent email to Defense4All and they are not planning to participate in Hydrogen release (colindixon, 17:17:28)
    8. Chris Wright (cdub, 17:19:24)
    9. colindixon asks if we can interpret this as n-2 yes votes and 2 don’t care votes and just ship it (colindixon, 17:19:53)
    10. dmm says, as cdub suggests, sending something out the door that has “stable” on it with something like that seems bad (colindixon, 17:21:16)
    11. regXboi says there are two options: (1) drop those projects and ship without them [edwarnicke is working on the mechanics to do that], (2) ship the release with them as is (colindixon, 17:22:40)
    12. edwarnicke would like it known that doing the mechanics is should not be interpretted as a particular position one way or another (edwarnicke, 17:23:56)
    13. dmm asks what does it mean that all the documentation, release info, etc. lists these two projects as part of hydrogen, but they’re not in the stable hydrogen release (colindixon, 17:24:13)
    14. ACTION: dlenrow to figure out if he can unstick affinity for the stable release over the next week (colindixon, 17:26:15)
    15. regXboi and colindixon point out that we should probably make it explicit that participating in a simultaneous release means meaningfully participating in the stable releases (colindixon, 17:28:43)
    16. cdub clarifies that we don’t need projects to fix bugs (they might not have any) but they do need to provide testing feedback that they haven’t regressed (colindixon, 17:30:21)
    17. yes, I +1 that (regXboi, 17:30:33)
    18. second cdub's points (edwarnicke, 17:30:43)
    19. currently, we know that Defense4All does not intend to participate in the hydrogen stable release, by next week we will know yes or no for Affinity (or we will declare that they are not) (colindixon, 17:32:39)
    20. question: do we need to look at projects having CI jenkins jobs so these questions become moot in the future? (regXboi, 17:33:09)
    21. colindixon asks what are we going to do next week with the information we have next week? drop them if they’re not participating? or include them as is if they’re not participating? (colindixon, 17:37:03)
    22. CASP3R says he’s tested Defense4All and they pass (colindixon, 17:37:55)
    23. Nils Swart says he'll reach out to DMM to clarify Affinity status (dlenrow, 17:38:37)
    24. CASP3R says Affinity has no tests (colindixon, 17:38:53)
    25. cdub points out that we should probably ask the project to plus-one based on CASP3R's feedback rather than doing it for them (colindixon, 17:39:54)
    26. this topic is now closed pending feedback (by next week) from D4A and Affinity (colindixon, 17:40:58)
    27. dmm points out that we need to start being really clear what we’re going to expect from people in the Lithium release and future ones and what support we will provide (colindixon, 17:41:51)

  7. board vote/tsc at large elections (colindixon, 17:42:15)
    1. the board passed the proposed modifications (colindixon, 17:44:13)
    2. phrobb says he’s going to send out a request for nominations (colindixon, 17:45:18)
    3. edwarnicke asks if we can’t establish how the nominations and elections are going to work and document it somewhere so that people know what to expect (colindixon, 17:45:41)
    4. the passed things include a waiver for current TSC members to have to step down if somebody from their company wins an at-large seat for one year starting yesterday (July 23, 2014) (colindixon, 17:47:00)
    5. ACTION: phrobb to create a wiki page documenting how the process will happen (colindixon, 17:48:53)

  8. future releases and project lifecycle (colindixon, 17:51:07)
    1. mlemay is presenting slides, they will be attached to the meeting minutes later (colindixon, 17:51:55)
    2. mlemay says that while Karaf features help, they are still too fine-grained to work with when it comes to documenting things, expose as installable to users, etc. (colindixon, 17:52:54)
    3. projects are too coarse-grained (colindixon, 17:53:07)
    4. the proposal is to use “components” as the unit in between the two (colindixon, 17:53:53)
    5. https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations this link contains some information about what is being thought about components and how to use them (colindixon, 17:57:11)
    6. edwarnicke says he thinks this is good, but that he wants to avoid forcing projects to do it in this release (colindixon, 17:59:06)


Meeting ended at 18:00:44 UTC (full logs).

Action items

  1. dlenrow to figure out if he can unstick affinity for the stable release over the next week
  2. phrobb to create a wiki page documenting how the process will happen


Action items, by person

  1. dlenrow
    1. dlenrow to figure out if he can unstick affinity for the stable release over the next week
  2. phrobb
    1. phrobb to create a wiki page documenting how the process will happen


People present (lines said)

  1. colindixon (79)
  2. regXboi (21)
  3. phrobb (18)
  4. edwarnicke (18)
  5. odl_meetbot (18)
  6. alagalah (18)
  7. kwatsen (12)
  8. cdub (11)
  9. dlenrow (6)
  10. dmm (6)
  11. CASP3R (6)
  12. RobDolin (5)
  13. ChrisPriceAB (4)
  14. marcbe-sel (2)
  15. networkstatic (1)
  16. LuisGomez (1)
  17. abhijitkumbhare (1)
  18. drizzt_ (1)


Generated by MeetBot 0.1.4.