#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:52 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:01:00)
    1. dmm (dmm_, 17:01:05)
    2. regXboi (regXboi, 17:01:11)
    3. edwarnicke (edwarnicke, 17:02:23)
    4. Kent Watsen (kwatsen, 17:02:33)
    5. Dave Lenrow (dlenrow, 17:02:44)
    6. Ivan Wood for Microsoft (IvanWood, 17:03:25)
    7. https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda the agenda in it’s usual place (colindixon, 17:03:28)
    8. Chris Wright (cdub, 17:03:59)
    9. Chris Price joined (ChrisPriceAB, 17:04:06)
    10. dmm_ will be out next week, colindixon will fill in for administrative issues of running the meeting next week (colindixon, 17:04:31)

  2. event updates (colindixon, 17:04:54)
    1. http://spectrometer.opendaylight.org/ spectrometer gives stats on opendaylight commits and stuff (colindixon, 17:05:21)
    2. http://www.opendaylight.org/events/2014-08-25/opendaylight-meetup-and-evening-reception-vmworld opendaylight meetup at vmworld, limited space, please RSVP (colindixon, 17:05:41)

  3. documentation (colindixon, 17:06:27)
    1. ACTION: LuisGomez to send e-mail about who is taking over for Paul Zimmerman in terms of docs (colindixon, 17:06:40)

  4. board update (colindixon, 17:06:58)
    1. dmm_ informed them about where we are (or are not) with hydrogen stable (colindixon, 17:07:23)
    2. dmm_ gave them the request for infrastructure, release manager and community manager (colindixon, 17:07:58)
    3. there wasn’t any pushback on that, but they asked for further details about the positions and infrastructure (colindixon, 17:08:42)
    4. if you have information, please reach out to dmm_ via e-mail (colindixon, 17:09:10)

  5. at large tsc elections (colindixon, 17:09:25)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-August/001504.html the e-mail vote to approve the process failed to carry in the time that was proscribed (colindixon, 17:11:14)
    2. cdub was the one person who objected on the list and his only objection was that he wanted nomination happen on an open list (colindixon, 17:13:23)
    3. colindixon asks why this matters. if we only allow self-nomination the fact that it’s public or private shouldn’t matter. (colindixon, 17:15:22)
    4. https://wiki.opendaylight.org/view/TSC:Committer-At-Large_Election_Process this is the process we’re talking about (colindixon, 17:16:00)
    5. cdub says he just wants to separate whether the nominations are public or private from how the nominations are done, e.g., self nomination only (colindixon, 17:17:18)
    6. there is a proposal to remove “or send a separate email with their self-nomination to the committer email list.“ from bullet point 3 of the nomination phase of the above process (colindixon, 17:19:22)
    7. ACTION: kwatsen will edit the election process wiki to remove the or clause of bullet point 3 of the nomination phase and will edit for clarity about term limits and how many tsc members there will be, then send mail to the TSC (colindixon, 17:20:38)
    8. ACTION: after the edits to the process, dmm_ will try to resuscitate the TSC e-mail vote on the process so that we can try to get it resolved for next week (colindixon, 17:21:44)

  6. Helium API Freeze clarity (colindixon, 17:22:16)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-August/001506.html (colindixon, 17:22:33)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium:Suggestions_for_Post_API_Freeze_Exception_Handling (colindixon, 17:22:41)
    3. both above links point to a paragraph that describes what the developers agree on as a working definition of API freeze (colindixon, 17:24:49)
    4. the second link tries to provide some clarity around what happens if you for whatever reason *have* to break API freeze (colindixon, 17:26:42)
    5. the high-level idea is to make it possible for people to change an API as long as everyone that is using that API agrees to it (colindixon, 17:29:12)
    6. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Lessons_from_Hydrogen.2FHelium_that_Should_be_Applied (colindixon, 17:32:22)
    7. the goal is to provide as concrete a process as possible to do that in a way people can understand with well-know expectations (colindixon, 17:34:14)
    8. process is: (1) file a bug, (2) send an e-mail, (3) if there is agreement, record that [more details on the wiki] (colindixon, 17:36:25)
    9. one key point of note is agreement must be unanimous or escalated to the TSC before it’s approved (colindixon, 17:43:36)
    10. regXboi asks about who the IMPACTED PROJECT is when the APIs are also exposed to the outside world, e.g., via REST (colindixon, 17:48:14)
    11. colindixon restates it as, we have an implicit assumption that the only promises from API freeze are internal to OpenDaylight, and we might want to make this explicit (colindixon, 17:52:05)
    12. ACTION: regXboi to modify the He, Li and template Simultaneous releases plan wiki pages to make the statement that the M4 API freeze applies to internal cross project APIs only (regXboi, 17:53:21)
    13. dmm_ says he’d like to wait for a week to formally approve this process (ChrisPriceAB agrees with that) (colindixon, 17:56:43)
    14. there some discussion about the tractability of finding all impacted projects and what happens if we fail to do that (colindixon, 18:00:01)
    15. colindixon and dmm_ point out that to get there people will have had to not follow the process and even then it will be limited in scope to code not yet merged (which is hopefully small) (colindixon, 18:00:45)
    16. VOTE: Voted on "should we adopt this as the process to deal with breaking API freeze?" Results are, 1: 7 (colindixon, 18:03:34)
    17. AGREED: it carries and the process for breaking API freeze is described on the wiki page above (colindixon, 18:03:57)
    18. note that vasya10 is not a TSC member and so his vote was not needed for it cary (colindixon, 18:04:39)
    19. colindixon takes that AI to be able to end the meeting (colindixon, 18:06:26)
    20. ACTION: dmm_ will e-amil release, tsc, and discuss to let folks know about the change (colindixon, 18:06:51)


Meeting ended at 18:06:54 UTC (full logs).

Action items

  1. LuisGomez to send e-mail about who is taking over for Paul Zimmerman in terms of docs
  2. kwatsen will edit the election process wiki to remove the or clause of bullet point 3 of the nomination phase and will edit for clarity about term limits and how many tsc members there will be, then send mail to the TSC
  3. after the edits to the process, dmm_ will try to resuscitate the TSC e-mail vote on the process so that we can try to get it resolved for next week
  4. regXboi to modify the He, Li and template Simultaneous releases plan wiki pages to make the statement that the M4 API freeze applies to internal cross project APIs only
  5. dmm_ will e-amil release, tsc, and discuss to let folks know about the change


Action items, by person

  1. dmm_
    1. after the edits to the process, dmm_ will try to resuscitate the TSC e-mail vote on the process so that we can try to get it resolved for next week
    2. dmm_ will e-amil release, tsc, and discuss to let folks know about the change
  2. kwatsen
    1. kwatsen will edit the election process wiki to remove the or clause of bullet point 3 of the nomination phase and will edit for clarity about term limits and how many tsc members there will be, then send mail to the TSC
  3. regXboi
    1. regXboi to modify the He, Li and template Simultaneous releases plan wiki pages to make the statement that the M4 API freeze applies to internal cross project APIs only


People present (lines said)

  1. colindixon (56)
  2. odl_meetbot (13)
  3. edwarnicke (9)
  4. cdub (6)
  5. regXboi (5)
  6. dmm_ (5)
  7. ChrisPriceAB (4)
  8. kwatsen (3)
  9. vasya10 (2)
  10. dlenrow (2)
  11. IvanWood (2)


Generated by MeetBot 0.1.4.