#opendaylight-meeting: tsc

Meeting started by colindixon at 16:59:58 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:04)
    1. regXboi here (regXboi, 17:00:41)
    2. colindixon standing in for dmm (colindixon, 17:00:56)
    3. Ivan Wood for Microsoft (IvanWood, 17:01:31)
    4. Chris Price in attendance (ChrisPriceAB, 17:01:38)
    5. Chris Wright (cdub, 17:02:06)
    6. kwatsen (kwatsen, 17:03:50)
    7. ad-hoc discussion on how a project may change a "project contact" when there is a need to change (ChrisPriceAB, 17:04:09)
    8. edwarnicke (edwarnicke, 17:04:16)
    9. The project comitters shall select a new project contact and inform the TSC of the change (ChrisPriceAB, 17:05:00)
    10. ACTION: phrobb to document the process to identify project contacts (phrobb, 17:05:51)

  2. event updates (colindixon, 17:06:42)
    1. best place is to visit the events page on opendaylight.org (ChrisPriceAB, 17:08:21)
    2. http://www.opendaylight.org/news/events (phrobb, 17:10:01)
    3. lenrow (dlenrow, 17:10:25)
    4. http://www.opendaylight.org/news/events for opendaylight events (ChrisPriceAB, 17:10:36)

  3. hydrogen stable (ChrisPriceAB, 17:10:53)
    1. Expect to get hydrogen Karaf built by next week, if this is not done we may need to make a priority call next TSC. (ChrisPriceAB, 17:11:23)
    2. note that this topic is actually “integration/testing” and “karaf” not hydrogen stable (colindixon, 17:12:06)
    3. mlemay says we should be able to have a base distro with dlux, controller, openflowplugin etc. by next week, only major missing piece so far is OVSDB (colindixon, 17:13:30)
    4. Madhu_ says that the major issue is that NB APIs aren’t working, mlemay says it’s not working because of a CORS filter issue, but that should be easy enough to fix (colindixon, 17:14:47)
    5. colindixon asks about the dependancy on other projects being on Karaf, given the core projects are working (ChrisPriceAB, 17:15:56)
    6. Madhu_ indicates we are not dependant on other projects however installation for those features/projects will be more cumbersome. (ChrisPriceAB, 17:17:05)

  4. documentation (ChrisPriceAB, 17:18:01)
    1. mlemay states most people are OK with the toolchain, have started migrating we expect an improvement on Hydrogen (ChrisPriceAB, 17:19:11)
    2. mlemay indicates there is a dependancy on Karaf and dlux where he has ben focusing his effort (ChrisPriceAB, 17:19:33)
    3. OVSDB is also karaf ready, we just need to put it in integration. Which i will work with mlemay (Madhu_, 17:19:54)
    4. colindixon asks how the feednack has been from the broader project community (ChrisPriceAB, 17:20:04)
    5. mlemay indicates there is a lack of clear guidelines from the project on what is expected. (ChrisPriceAB, 17:20:44)
    6. colindixon indicates there should be a discussion on the TSC's expectation on the level of documentation produced by projects, mlemay agrees a set of document artifacts is something that should be clarified. (ChrisPriceAB, 17:22:01)
    7. LuisGomez indicates we have been awaiting completion of Karaf to define the release vehicles. The release vehicle is then necessary for defining the release documentation and as such documentation id delayed by Karaf delays. (ChrisPriceAB, 17:25:02)
    8. general deiscussion on how to include documentation as a gating factor for projects to ensure there is sufficient focus on this durign the project. (ChrisPriceAB, 17:25:47)
    9. phrobb says that the docs team has templates and guidelines ready as of yesterday’s meeting and we shoudl figure out if we can give them a TWS (or other) slot soon so they can spread that knowledge (colindixon, 17:26:30)
    10. edwarnicke indicates documentation may be a good candidate for the simultaneous release process at M4 or a suitable release gate (ChrisPriceAB, 17:26:37)
    11. specific Milestone (e.g. M4) is part of it, but overall context is using release plan to codify how we want docs to be gating to a release, and it's appropriate for Lithium (retro-active for Hydrogen is not community-friendly since it's potential big shift in expectations) (cdub, 17:30:15)
    12. ACTION: Madhu_ to reach out to mlemay, phrobb, etc. to set up a docs topic for the TWS (colindixon, 17:30:36)

  5. elections (ChrisPriceAB, 17:31:05)
    1. phrobb will begin the two week election nomination process today. (ChrisPriceAB, 17:31:53)
    2. as described and agreed previously by the TSC. (ChrisPriceAB, 17:32:08)
    3. colindixon suggests automating committer email list (e.g. from gerrit) (cdub, 17:32:18)
    4. phrobb will work on automation however it is not in place today. (ChrisPriceAB, 17:33:12)
    5. phrobb is actually working on that automation w/ odl infra folks (cdub, 17:33:12)

  6. stable hydrogen release (ChrisPriceAB, 17:33:22)
    1. colindixon asks who is running stable hydrogen releases. (ChrisPriceAB, 17:33:37)
    2. denial from both edwarnicke and regXbio (ChrisPriceAB, 17:33:55)
    3. curet state of stable Hydrogen. Defense for All and Affinity were not able to participate effectively. Affinity has been removed from the release distribution and we have pushed the necessary changes. No stable release has been built yet with these changes in place. (ChrisPriceAB, 17:37:43)
    4. there seems to be an issue with the autobuild script where Affinity is being built for hydrogen stable. These are not being included in the distribution and it is not clear if this is a sufficient solution. (ChrisPriceAB, 17:38:39)
    5. edwarnicke asks if this is necessary to be addressed as Helium is due in 6 weeks. (ChrisPriceAB, 17:39:03)
    6. Madhu_ asks if anyone is waiting for the stable release. (ChrisPriceAB, 17:39:17)
    7. colindixon indicates there are receivers for the release awaiting bugfixes. (ChrisPriceAB, 17:39:48)
    8. to be clear, I don’t actually know of a person that is expecting it, but I do see people sending mail to the mailing list saying that they are using the hydrogen release regularly (colindixon, 17:40:53)
    9. regXboi asks “how long do we expect stable hydrogen to live?" (colindixon, 17:44:13)
    10. colindixon asks if we can push the artifacts this week and discuss next week the testing and releasing of those artifacts. (ChrisPriceAB, 17:45:53)
    11. dlenrow indicates the ongoing support of stable release for incubation projects should be considered in the context of all projects being at incubation. (regXboi, 17:47:14)
    12. regXboi has pushed the button (regXboi, 17:47:21)
    13. colindixon asks if non-automated testing would be too much to ask of projects (ChrisPriceAB, 17:49:24)
    14. not red - green (regXboi, 17:49:36)
    15. edwarnicke indicates he (and by inference others) do not have time to perform the manual effort of verification. (ChrisPriceAB, 17:50:01)
    16. abhijitkumbhare indicates he also does not have time in OF-Plugin (ChrisPriceAB, 17:50:24)
    17. edwarnicke Did try to be precise about limiting inference ;) May have failed ;) (edwarnicke, 17:50:31)
    18. dlenrow proposes we ask on the lists for receivers of the release. (ChrisPriceAB, 17:51:05)
    19. ACTION: dlenrow will initiate communications on the topic of indefinitely postponing the hydrogen stable release in lieu of delivering helium. (ChrisPriceAB, 17:52:36)
    20. LuisGomez asks how much offline testing actually takes place for controller and openflowplugin (colindixon, 17:53:48)
    21. ChrisPriceAB proposes a formal TSC vote be taken on this during next weeks call to provide dlenrow time to vet the community and TSC members to discuss with own projects. (ChrisPriceAB, 17:55:00)
    22. edwarnicke responds saying that there are people he runs around to ask them to bless releases, but he would have to spend cycles just to do that nevermind test (colindixon, 17:55:29)
    23. colindixon proposes we communicate in a neutral fashion on users of stable hydrogen (ChrisPriceAB, 17:56:48)
    24. colindixon approves dlenrow to act on his previous action point in a neutral fashion, he shall run the proposed text by colin, phil and dmayer. (ChrisPriceAB, 17:59:44)
    25. AGREED: TSC commissions Dave Lenrow to send a note to the ODL community to gauging priority of resources within project to dedicate efforts at this time to Helium, or to also push to release the first Hydrogen Stable release concurrent to Helium development now (phrobb, 18:00:39)
    26. ACTION: colindixon needs to raise the topic of release support at a future TSC meeting (ChrisPriceAB, 18:03:01)
    27. cdub proposes a quikc discussion on odlforge (ChrisPriceAB, 18:03:38)
    28. http://ci.openstack.org/stackforge.html this is template example for odl forge (this is openstack) (cdub, 18:06:03)
    29. https://github.com/odlforge example of new space for forge work related to odl (cdub, 18:06:43)
    30. ACTION: colindixon to add odlforge to next week's agenda (cdub, 18:07:37)
    31. cdub will stay online for a non TSC call on odlforge (ChrisPriceAB, 18:08:14)
    32. TSC members can now consider the meeting over, but those who are interested in information about odlforge can stay (colindixon, 18:08:21)


Meeting ended at 18:08:51 UTC (full logs).

Action items

  1. phrobb to document the process to identify project contacts
  2. Madhu_ to reach out to mlemay, phrobb, etc. to set up a docs topic for the TWS
  3. dlenrow will initiate communications on the topic of indefinitely postponing the hydrogen stable release in lieu of delivering helium.
  4. colindixon needs to raise the topic of release support at a future TSC meeting
  5. colindixon to add odlforge to next week's agenda


Action items, by person

  1. colindixon
    1. colindixon needs to raise the topic of release support at a future TSC meeting
    2. colindixon to add odlforge to next week's agenda
  2. dlenrow
    1. dlenrow will initiate communications on the topic of indefinitely postponing the hydrogen stable release in lieu of delivering helium.
  3. Madhu_
    1. Madhu_ to reach out to mlemay, phrobb, etc. to set up a docs topic for the TWS
  4. mlemay
    1. Madhu_ to reach out to mlemay, phrobb, etc. to set up a docs topic for the TWS
  5. phrobb
    1. phrobb to document the process to identify project contacts
    2. Madhu_ to reach out to mlemay, phrobb, etc. to set up a docs topic for the TWS


People present (lines said)

  1. ChrisPriceAB (58)
  2. cdub (25)
  3. colindixon (24)
  4. edwarnicke (11)
  5. tbachman (9)
  6. regXboi (7)
  7. odl_meetbot (6)
  8. phrobb (4)
  9. kwatsen (3)
  10. Madhu_ (3)
  11. dfarrell07 (2)
  12. abhijitkumbhare (2)
  13. IvanWood (2)
  14. dlenrow (1)
  15. rexpugh (1)
  16. LuisGomez (1)
  17. mlemay (1)


Generated by MeetBot 0.1.4.