#opendaylight-meeting: tsc

Meeting started by phrobb1 at 16:56:51 UTC (full logs).

Meeting summary

    1. dmm (dmm, 16:56:59)
    2. regXboi (partial so far) (regXboi, 16:57:07)
    3. Lenrow (dlenrow, 16:57:36)
    4. Chris Price in attendance. (ChrisPriceAB, 16:57:38)

  1. TSC members please #info in (phrobb1, 16:59:21)
    1. Chris Price (ChrisPriceAB, 16:59:33)
    2. George Zhao for release (gzhao, 16:59:40)
    3. lenrow (dlenrow, 17:00:17)
    4. regXboi now fully there (regXboi, 17:01:40)
    5. EdM_ (edwarnicke, 17:03:05)
    6. edwarnicke (edwarnicke, 17:03:12)
    7. Ivan Wood (IvanWood, 17:03:14)

  2. Agenda Bashing (regXboi, 17:03:29)
    1. regXboi will be finding a proxy for next week as I will be on vacation (regXboi, 17:04:07)
    2. recording started (regXboi, 17:05:00)

  3. Updates (regXboi, 17:05:04)
    1. http://www.opendaylight.org/news/events upcoming events (regXboi, 17:05:19)
    2. Chris Wright (cdub, 17:05:31)
    3. TSC trying to orginaize a face-to-face meeting around the design summit (tbachman, 17:07:51)
    4. suggestion of a three hour meeting (cdub asks about a three hour tour) (regXboi, 17:08:52)
    5. ACTION: phrobb1 to kick off something on the TSC list to discuss possibility of TSC face-to-face during the design summit (tbachman, 17:09:44)
    6. ACTION: phrobb1 to send call for topics for upcoming design summit to mailing list later today (8/28) (regXboi, 17:09:54)
    7. edwarnicke asks about unconference time being available (regXboi, 17:10:45)
    8. format for the summit might have a few sessions on topics of interest in the morning and close, with smaller breakout sessions (tbachman, 17:11:50)
    9. phrobb1 says that the sessions on topics will be on *design* (tbachman, 17:13:00)
    10. CASP3R_ says there is about a 90% pass rate on the integration tests (tbachman, 17:14:39)

  4. At large elections (tbachman, 17:14:56)
    1. election closes tonight (tbachman, 17:15:02)
    2. voting begins on Sept 1st, ands on Sept 15th (tbachman, 17:15:42)
    3. cutoff for nominations is 5pm PST today (tbachman, 17:15:55)
    4. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068 (gz__, 17:16:24)
    5. correction: voting beings on 9/1 and *ends* on 9/15 (regXboi, 17:16:36)

  5. Update on Helium Release Status (regXboi, 17:16:50)
    1. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068 current status (regXboi, 17:17:15)
    2. Defense4All has not reported status since M4 (regXboi, 17:20:04)
    3. definition of Code Freeze created during Pre-M5 Developer Meeting == Code Freeze means that no new features/functionality are to be allowed into the Helium code base. Only errors/bugs identified in the bugzilla system should be allowed.  The exceptions to this include new tests, and documentation.  Packaging, ie Karaf packaging must be completed by M5.  Errors/bugs found post M5 are still bugs and they may be cr (phrobb1, 17:21:56)
    4. mlemay_away has created a Karaf tracking spreadsheet (phrobb1, 17:23:52)
    5. https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/12MWfLYNG_YO8pnUt5CrFD2xL1vHUXcmnUNrH-m6EdC0/edit#gid=0 (phrobb1, 17:23:58)
    6. https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/16-SbSzdBzTXEk8lD6Q09zl-Ip8jBU3B8_BBqRPXGimg/edit#gid=0 <— Link to Documentation Tracking SS for Helium. Each project should provide info (phrobb1, 17:29:11)
    7. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines <— Link to Documentation decision matrix for "what should each project document and where to put it" (phrobb1, 17:30:24)
    8. George asks: should M5 date change from 9/1 to 9/2 as 9/1 is a U.S.A. holiday (phrobb1, 17:31:09)
    9. VOTE: Voted on "shall the TSC change M5 date to Tuesday 9/2/2014?" Results are, 0: 1, +1: 6 (phrobb1, 17:33:19)
    10. edwarnicke notes that mlemay_away has done much for the project at large to the detriment of his "reservation" project and it would be bad if "reservation" was removed from the release for being late to code freeze. (phrobb1, 17:34:57)
    11. Madhu asks: with the long weekend and the need to finish karaf work for many projects, slipping to 9/5/2014 for M5 would be a better date for the project (phrobb1, 17:36:11)
    12. VOTE: Voted on "shall the TSC change M5 to 9/4/214?" Results are, 0: 1, +1: 6 (phrobb1, 17:38:39)
    13. note: on that vote it is 9/4/2014 (regXboi, 17:39:00)
    14. AGREED: M5 will be changed to Thursday 9/4/2014 (phrobb1, 17:39:07)

  6. karaf (tbachman, 17:40:28)
    1. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide wiki page describing how projects can “karaf” their project (tbachman, 17:42:26)

  7. back to the Helium Release Status (phrobb1, 17:47:24)
  8. M5 redux (tbachman, 17:47:31)
    1. gzhao asked the TSC whether we should have projects in red status to report more frequently (e.g. daily) (tbachman, 17:47:56)
    2. question: for projects that are red, should the tsc require projects in "red" status to report frequently (such as daily)? (phrobb1, 17:48:14)
    3. ACTION: gzhao to ask projects to report daily nicely (phrobb1, 17:48:52)
    4. gzhao asks what communication options/channels there are for projects that can’t be reached (tbachman, 17:49:14)

  9. infrastructure (tbachman, 17:50:31)
    1. There are a lot of projects that are placing requests on infra the closer we get to the release. phrobb1 says we should try as a group to minize fires with roadmaps, and coming up with a method to ensure we have fair and consistent priorities for things that the infrastructure team works on, and to minimize thrashing of those resources. (tbachman, 17:52:08)
    2. One recommendation is to have an infra-specific discussion at the design summit for the projects (tbachman, 17:52:54)
    3. there are some near-term needs, and the LF need some direction no priorities (tbachman, 17:55:05)
    4. there needs to be an infrastrure discussion at the design summit to address "just in time" issues post Helium (regXboi, 17:55:36)
    5. which requires better proactive resource planning (regXboi, 17:55:58)
    6. regXboi wanders away for another meeting (regXboi, 17:56:36)
    7. ACTION: edwarnicke to create a list of infra priorities or delegate this task (tbachman, 17:58:31)


Meeting ended at 17:59:43 UTC (full logs).

Action items

  1. phrobb1 to kick off something on the TSC list to discuss possibility of TSC face-to-face during the design summit
  2. phrobb1 to send call for topics for upcoming design summit to mailing list later today (8/28)
  3. gzhao to ask projects to report daily nicely
  4. edwarnicke to create a list of infra priorities or delegate this task


Action items, by person

  1. edwarnicke
    1. edwarnicke to create a list of infra priorities or delegate this task
  2. gzhao
    1. gzhao to ask projects to report daily nicely
  3. phrobb1
    1. phrobb1 to kick off something on the TSC list to discuss possibility of TSC face-to-face during the design summit
    2. phrobb1 to send call for topics for upcoming design summit to mailing list later today (8/28)


People present (lines said)

  1. tbachman (37)
  2. regXboi (32)
  3. phrobb1 (21)
  4. odl_meetbot (17)
  5. ChrisPriceAB (8)
  6. dmm (6)
  7. dlenrow (5)
  8. edwarnicke (5)
  9. cdub (4)
  10. IvanWood (3)
  11. rexpugh (2)
  12. gz__ (2)
  13. gzhao (1)
  14. CASP3R_ (1)
  15. Madhu (0)


Generated by MeetBot 0.1.4.