#opendaylight-meeting: tsc

Meeting started by phrobb at 17:01:44 UTC (full logs).

Meeting summary

    1. dmm (dmm, 17:01:51)
    2. edwarnicke (running 2 min late on audio) (edwarnicke, 17:02:18)
    3. kwatsen (kwatsen, 17:02:39)
    4. (EdM, 17:03:02)
    5. Chris Price (ChrisPriceAB, 17:03:51)
    6. Ivan Wood (IvanWood, 17:03:58)
    7. Lenrow (dlenrow, 17:05:10)

  1. agenda bashing (colindixon, 17:05:59)
    1. https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda the agenda in it’s usual place (colindixon, 17:06:17)
    2. dmm says that there is are some post-helium hot issues at the bottom there (colindixon, 17:06:43)

  2. events updates (colindixon, 17:06:47)
    1. the good price for hotels for the developer design forum ends tomorrow, so book now (colindixon, 17:07:12)
    2. the thread on discussion topics has been active, please add your topics and volunteer to lead them (colindixon, 17:07:33)
    3. sdn and openflow world congress is coming up in dusseldorf (sp?) in mid october (colindixon, 17:07:52)

  3. at large elections (colindixon, 17:08:20)
    1. nominations complete, we’re now taking votes (committers should have e-mails) on the 4 candidates for the 2 seats (colindixon, 17:08:43)
    2. voting closes on 9/15 and as soon as that closes, phrobb, Neela, and dmm will review the results and announce the winners (hopefully in short order) (colindixon, 17:09:06)

  4. board seat elections (colindixon, 17:09:23)
    1. this proeess will be launched as soon as the TSC at-large election ends (colindixon, 17:09:39)

  5. TSC chair election (colindixon, 17:09:49)
    1. dmm would like to do it sooner rather than later, phrobb says we could do it the first TSC meeting after the at-large elections (colindixon, 17:10:19)
    2. edwarnicke asks for it to be pushed after the helium release, there is some resistance from phrobb and dmm since they think it should be pretty fast (colindixon, 17:11:10)

  6. integration and testing (colindixon, 17:11:30)
    1. we’re still trying to pull the karaf distribution in integration and get it tested (colindixon, 17:12:03)
    2. gzhao and others say that the full karaf distributions should be ready next week (colindixon, 17:12:28)
    3. edwarnicke asks if we can get *some* testing started now given that many projects are there (colindixon, 17:12:48)
    4. there is some discussion around what test cases we have and how we’re going to get the integration tests we have *now* running and get the patches in the queue merged (colindixon, 17:19:43)
    5. there is a meeting around auto-release with gzhao, edwarnicke and Giovanni tomorrow morning to start generating release candidates (colindixon, 17:21:43)
    6. Luis think RC0 should be delayed for a week (gzhao, 17:22:17)
    7. edwarnicke says we should just try to hit it, there is some discussion without an obvious answer as to how behind or not we’ll be (colindixon, 17:25:48)

  7. simultaneous release readout (colindixon, 17:25:59)
    1. defense4all is listed as black, but gzhao has had communication with them and they are trying to get things done today (colindixon, 17:27:05)
    2. most projects (11/21) have karaf done and in integration, others are in some state of in-progress (either awaiting review or code in progress) (colindixon, 17:29:00)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Status the spreadsheet is embedded here (colindixon, 17:32:31)

  8. defense4all committer promotions (colindixon, 17:35:24)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-September/001576.html (dmm, 17:35:47)
    2. edwarnicke asks if there’s a history of commits from the to-be-added committers (colindixon, 17:39:49)
    3. https://wiki.opendaylight.org/view/TSC:Committer-promotion-process wiki describing committer promotion process (dfarrell07, 17:40:08)
    4. the response is that there are commits in their private git repo, but not publicly visible (colindixon, 17:40:50)
    5. there is some pushback until there is a public history, dmm asks if this would negatively impact the project (colindixon, 17:43:17)
    6. the answer is that there would be no effect (colindixon, 17:43:33)
    7. the decision is to wait on this promotion until the commit history is there to better judge things (colindixon, 17:45:21)

  9. karaf updates (colindixon, 17:46:37)
    1. edwarnicke says we’re coming together slowly, but surely with a few projects lagging (colindixon, 17:47:01)

  10. adding project infrastructure (colindixon, 17:47:57)
    1. dmm says that the problem he’s been running into when going to the board is not around support to get new resources, but rather quantifying what resources we need (colindixon, 17:48:26)
    2. jmedved says he will get quantified resources to run the extensive set of OpenFlow tests later today (colindixon, 17:48:48)
    3. jmedved also asks for the TSC and/or the integration team to call for the community at large to try to bang on the controller to test and find bugs (colindixon, 17:51:17)
    4. LuisGomez says that the time to do this is probably when we get RC0 out (colindixon, 17:51:38)
    5. Neela speaks up to say if there is an issue that people see as going unmet, please reach out to him and phrobb (ideally after getting together with others who have similar issues to document it) (colindixon, 17:55:41)

  11. security response (colindixon, 17:57:07)
    1. cdub points out again that we don’t have a process/team/group, yet, but he has the start of that put together and will present it next week (colindixon, 17:57:52)
    2. https://lists.opendaylight.org/pipermail/odlparent-dev/2014-August/000000.html (cdub, 17:58:49)

  12. cdub as a committer on odlparent (colindixon, 17:59:07)
    1. above link shows that cdub likely should have been a committer on odlparent from the start (colindixon, 17:59:27)
    2. https://lists.opendaylight.org/pipermail/odlparent-dev/2014-August/000002.html this has the actual votes (colindixon, 17:59:46)
    3. AGREED: cdub will be made a committer on odlparent (colindixon, 18:00:53)

  13. helium milestones (colindixon, 18:01:24)
    1. phrobb notes that we have let M5 slip from 9/1 to 9/5 (colindixon, 18:01:56)
    2. we are currently not sure whether RC0 will slip or not, given that we’d have to turn it around in 2-4 days rather than a week (colindixon, 18:03:05)
    3. phrobb notes that no dates will change unless the TSC does anything and RC0 will be Tuesday (colindixon, 18:03:41)

  14. documentation (colindixon, 18:03:47)
    1. manny can’t make this time because of an ongoing conflict (colindixon, 18:04:00)
    2. phrobb says that manny is saying that documentation is *still* red despite added resources (colindixon, 18:04:21)
    3. people should do anything/everything they can to get documentation written and more resources there, coordinate with the core docs teams (colindixon, 18:04:47)


Meeting ended at 18:04:54 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. colindixon (56)
  2. edwarnicke (5)
  3. cdub (4)
  4. odl_meetbot (4)
  5. dfarrell07 (3)
  6. gzhao (2)
  7. phrobb (2)
  8. dmm (2)
  9. tykeal (2)
  10. IvanWood (1)
  11. dlenrow (1)
  12. ChrisPriceAB (1)
  13. tbachman (1)
  14. kwatsen (1)
  15. EdM (1)
  16. Madhu (0)


Generated by MeetBot 0.1.4.