#opendaylight-meeting: tsc

Meeting started by colindixon at 16:58:30 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 16:58:36)
    1. dmm (dmm, 16:58:44)
    2. colindixon (colindixon, 16:58:47)
    3. regXboi (regXboi, 16:59:06)
    4. Chris Price (ChrisPriceAB, 16:59:32)
    5. Ivan Wood (IvanWood, 17:01:02)
    6. edwarnicke (edwarnicke, 17:01:03)
    7. ACTION: colindixon to grep #info of TSC members joining to see histogram of when a meeting can start for next week (regXboi, 17:01:07)
    8. Kent Watsen (kwatsen_, 17:02:28)

  2. committer at large election results (colindixon, 17:04:01)
    1. https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda (regXboi, 17:04:12)
    2. dmm welcomes colindixon and edwarnicke as the new Committers-At-Large (phrobb, 17:04:28)
    3. https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda (regXboi, 17:04:31)
    4. cdub is here and did #info in (I just borked it) (colindixon, 17:05:12)

  3. event updates (regXboi, 17:05:26)
    1. design forum is coming up (colindixon, 17:05:40)
    2. http://www.opendaylight.org/events/2014-09-29/opendaylight-developer-design-forum (colindixon, 17:05:53)
    3. https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/10glP04x7AWi_baA_R8K7DGvd99CeOOXY5AZqC87vWlM/edit#gid=2032322710 (phrobb, 17:06:11)
    4. confirmed - phrobb's link is the design forum spreadsheet (regXboi, 17:06:41)
    5. many of these topics do not have an “owner” and it’s difficult to schedule a topic w/o an owner (colindixon, 17:07:29)
    6. phrobb asks the TSC to review the list and see if there are high-priority items w/o owners so he can prioritize his time to go find owners for those (colindixon, 17:08:01)
    7. https://docs.google.com/spreadsheets/d/19hVW0PIzKlu6oaG5QGg8BdD02IiAvSp4VhuUq1eUj6Y/edit#gid=0 (phrobb, 17:10:38)
    8. phrobb notes that his current plan is to have scheduled topics where we can, and then put other high-priority ideas (if we can’t schedule them) as unconference topics (colindixon, 17:11:09)
    9. above link is a proposed schedule (colindixon, 17:11:16)
    10. colindixon suggests doing a poll of TSC members to get a quick idea of what topics are important (colindixon, 17:12:29)
    11. phrobb asks people to register if you haven’t already, we are at ~150, but phrobb was expecting 200-300 (colindixon, 17:13:03)
    12. ChrisPriceAB asks about how we have rooms, phrobb responds that we have 9 rooms: 1 that will fit everyone, 2 that will fit ~100 people, 6 that fit 35 (colindixon, 17:14:00)
    13. the 6 that fit 35 can be merged into 2 that fit 105 each (colindixon, 17:14:12)
    14. regXboi asks if we’re going to replicate live streaming? phrobb says he’s going to bring all the gear, so it will have one good live stream and some iPads as before (colindixon, 17:14:44)

  4. integration (colindixon, 17:15:19)
    1. LuisGomez says that currently there are two issues: one with VTN and one with l2switch that are being worked on (colindixon, 17:16:11)
    2. otherwise, we’re working on running all tests we have on RC1 and prepping for RC2 (colindixon, 17:16:28)

  5. documentation (regXboi, 17:16:31)
    1. the only core document manny is concerned about is the user guide (colindixon, 17:17:08)
    2. lenrow (dlenrow, 17:17:18)
    3. they are not sure if they’re going to get the info they need from the people that have it, apparently those people are at Cisco, so manny is hunting them down (colindixon, 17:18:19)
    4. also, if any project has special things that need to happen before loading features from their project, let the docs people know (colindixon, 17:18:39)

  6. helium release update (regXboi, 17:18:43)
    1. RC1 is built and under test (regXboi, 17:19:26)
    2. we had all projects make RC1 and meet the requirements put down by the TSC (colindixon, 17:19:30)
    3. there was a break in auto-release overnight, but edwarnicke says it should be fixed at this point (colindixon, 17:20:51)
    4. there are four projects which have yet to express what (if any) docs they intend to provide (colindixon, 17:21:07)

  7. TSC chair elections (colindixon, 17:21:13)
    1. regXboi asks if there is a list of the responsibilities for the chair (colindixon, 17:23:24)
    2. the answer seems to be that there aren’t a list of them, but reach out to phrobb or dmm or anyone else to figure that out if you’re curious (colindixon, 17:24:19)
    3. dmm proposes: (1) open up call for nominations and leave it open for 2 weeks, (2) after that there will be a very simple roll-call vote with a run-off in the case of tie (colindixon, 17:24:37)
    4. the goals were to make it low-overhead, lightweight and fast (colindixon, 17:24:55)
    5. edwarnicke asks about using condorcet for the election. A: condorcet for the TSC chair is not needed. The only people that vote on this election is the members of the TSC. (phrobb, 17:26:23)
    6. ChrisPriceAB asks if there was going to be an opportunity for candidates to express their stances and/or introduce themselves (colindixon, 17:27:31)
    7. dmm says that seems reasonable, but asks if that would extend the time required past two weeks (colindixon, 17:28:42)
    8. http://www.opendaylight.org/project/tsc/charter (edwarnicke, 17:28:43)
    9. the consensus seems to be that it wouldn’t require that, people could put such position statements forward during the two week period (colindixon, 17:29:33)
    10. alagalah suggested that we have the run off in the case of no candidate getting a simple majority, we have the run off consist of the top n candidates for the smallest n such that they received a simple majority of votes in the first election (colindixon, 17:37:03)
    11. and presumably that would repeat if necessary (colindixon, 17:37:18)
    12. Q: who can nominate for the TSC Chair (phrobb, 17:37:39)
    13. consensus is that the nominations will be self-nominations only (phrobb, 17:38:00)
    14. closing this topic having decided (1) that it will be self-nomination, (2) that we will have a page describing the process including how to handle run-offs (colindixon, 17:39:45)
    15. dmm would like to start it as soon as possible, ideally in the next week (colindixon, 17:40:09)
    16. ACTION: phrobb will take an action to describe the TSC chair election process and outline the role of the TSC chair. (ChrisPriceAB, 17:40:21)

  8. discovery creation review (colindixon, 17:42:07)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Discovery proposal (colindixon, 17:42:21)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2014-August/000146.html announcing the proposal >2 weeks ago (colindixon, 17:42:41)
    3. Description: Supports the discovery, identification, and synchronization of network elements with the controller as well as provides a framework for link or connection reconciliation between the network elements. (colindixon, 17:45:55)
    4. Scope: This proposal does not include the algorithms to find new network elements, such as a ping sweep; It is assumed that finding is the responsibility of other modules. This proposal will interact with topology and inventory modules as network elements and links are discovered. (colindixon, 17:46:12)
    5. both the above were taking verbatim from the proposal pages (colindixon, 17:46:46)
    6. regXboi asks for a clear description of the problem trying to be solved? (colindixon, 17:51:03)
    7. colindixon: I always think i'm on mute when not talking. If I screw up don't hesitate to mute me. (dlenrow, 17:52:59)
    8. colindixon asks "is this something that needs to be a separate project or does it logically fit into an existing project? (phrobb, 17:55:13)
    9. phudgins is happy to take direction on where/how this functionality would go. (phrobb, 17:56:04)
    10. the response seems to be that it should be it’s own project from ChrisPriceAB and edwarnicke (colindixon, 17:56:59)
    11. dlenrow and edwarnicke note that putting more stuff into the controller is not a great idea (phrobb, 17:56:59)
    12. dmm notes that several TSC members don't understand this project well enough to vote (phrobb, 17:58:58)
    13. cdub notes that this is why incubate code instead of wiki pages (phrobb, 17:59:23)

  9. Helium Release date and time to cut final release candidate (phrobb, 18:00:04)
    1. we’ve been cutting RCs mondays at 5p pacific (colindixon, 18:00:18)
    2. we need a time and a date to cut the real release artifacts (colindixon, 18:00:42)
    3. regXboi suggests having a TSC meeting on Monday 9/29 to approve final release artifacts (phrobb, 18:03:14)
    4. edwarnicke says the issue is making sure they’re cut in time for the TSC to bless them on Thursday (colindixon, 18:03:17)
    5. edwarnicke asks "what input to the TSC decision will need to be available?" (phrobb, 18:03:52)
    6. regXboi asks for actual release artifacts and anything that any project thinks is big enough to be a show stopper (colindixon, 18:04:30)
    7. edwarnicke asks if we know when marketing is expecting us to produce downloadable things (colindixon, 18:05:04)
    8. Melissa and phil say that they usually put out press releases in the morning, but this release could go out on tuesday if that’s what we need (colindixon, 18:05:51)
    9. edwarnicke says that the other option we have is to cut RC2 artifacts as release artifacts on 9/22 (colindixon, 18:07:38)
    10. edwarnicke suggests cut artifacts on Tuesday (9/23) giving two days of test before the TSC meeting on 9/25. Or we can cut RC2 artifacts as release artifacts on 9/22 (phrobb, 18:08:14)
    11. dmm asks edwarnicke to create an email thread with the options availlable (next Wednesday, Tuesday or Monday (from RC2)… Also gzhao to work with Ed on understanding find/fix rate for defects (phrobb, 18:09:33)
    12. ACTION: edwarnicke and gzhao to send out an e-mail (to release and TSC) with the various options, e.g., those listed above (colindixon, 18:09:53)
    13. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Schedule <-- just a reminder of our current plan (cdub, 18:13:49)
    14. edwarnicke notes that doing Release artifacts on Monday (9/22) allow for 3 days of testing before the TSC meeting on 9/25. If no show-stoppers are present, we use that as the final, approve the bits on the TSC call on 9/25 and release to the public on Monday morning 9/29 (regXboi, 18:14:02)
    15. last link is because the undo hit the wrong thing (regXboi, 18:14:19)
    16. we are making the above our current plan of action barring any show stoppers (colindixon, 18:16:16)

  10. release reviews (colindixon, 18:16:35)
    1. phrobb says that the current plan is for two release review slots starting at 7:30a pacific (for two hours) on next Wednesday (9/24) and Thursday (9/25) (colindixon, 18:17:15)
    2. AGREED: Final Release artifacts will be cut on Monday 9/22. Release reviews will occur on Wednesday and Thursday (9/24, 9/25). TSC to vote on final release of artifacts during the TSC call on 9/25. Helium bits to go live the morning of 9/29 (phrobb, 18:17:30)
    3. phrobb and gzhao will send mails out with a schedule about that (colindixon, 18:17:31)


Meeting ended at 18:18:03 UTC (full logs).

Action items

  1. colindixon to grep #info of TSC members joining to see histogram of when a meeting can start for next week
  2. phrobb will take an action to describe the TSC chair election process and outline the role of the TSC chair.
  3. edwarnicke and gzhao to send out an e-mail (to release and TSC) with the various options, e.g., those listed above


Action items, by person

  1. colindixon
    1. colindixon to grep #info of TSC members joining to see histogram of when a meeting can start for next week
  2. edwarnicke
    1. edwarnicke and gzhao to send out an e-mail (to release and TSC) with the various options, e.g., those listed above
  3. phrobb
    1. phrobb will take an action to describe the TSC chair election process and outline the role of the TSC chair.


People present (lines said)

  1. colindixon (80)
  2. phrobb (20)
  3. regXboi (16)
  4. ChrisPriceAB (14)
  5. alagalah (8)
  6. odl_meetbot (7)
  7. cdub (6)
  8. tbachman (5)
  9. edwarnicke (4)
  10. dmm (3)
  11. xsited1 (3)
  12. dlenrow (2)
  13. kwatsen (1)
  14. kwatsen_ (1)
  15. IvanWood (1)


Generated by MeetBot 0.1.4.