#opendaylight-meeting: tsc

Meeting started by phrobb at 17:00:14 UTC (full logs).

Meeting summary

  1. roll call (colindixon, 17:00:48)
    1. colindixon (colindixon, 17:00:51)
    2. dmm (dmm, 17:00:53)
    3. (kwatsen, 17:00:58)
    4. Chris Price (ChrisPriceAB, 17:01:02)

  2. TSC members please #info in (phrobb, 17:01:02)
    1. Chris Price (ChrisPriceAB, 17:01:14)
    2. Kent Watsen (kwatsen, 17:01:14)
    3. Ivan Wood (IvanWood, 17:01:54)
    4. Ryan Moats (regXboi, 17:02:28)
    5. Chris Wright (cdub, 17:04:04)
    6. https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda (regXboi, 17:04:50)
    7. Lenrow (dlenrow, 17:05:48)

  3. Event Updates (regXboi, 17:05:50)
    1. http://events.linuxfoundation.org/events/opendaylight-developer-design-forum/program/schedule << link to dev forum schedule (phrobb, 17:06:14)
    2. phrobb reports that schedules for the summit event next week are still being massaged (regXboi, 17:06:18)
    3. phrobb also reports on TSC chair elections - self-nominations are open until the weekend (regXboi, 17:08:11)

  4. integration (colindixon, 17:08:18)
    1. LuisGomez reports that we are testing the release candidate and have been identifying blocking bugs and helping others find and solve them as well (colindixon, 17:08:53)
    2. LuisGomez reports on integration - they've identified one blocking issue for Helium which has been addressed and nothing more to report (regXboi, 17:09:07)
    3. regXboi, edwarnicke, and colindixon all would like to give a +10 to the integration team (colindixon, 17:09:38)

  5. documentation (colindixon, 17:09:41)
    1. manny_ is working with edwarnicke to work on what’s going into the core release notes, barring him being hit by a truck the core docs will be done by EoD tomorrow (colindixon, 17:10:33)
    2. regXboi reports that the helium review included pushing projects to provide content to the doc projects (regXboi, 17:11:15)

  6. helium release status (regXboi, 17:12:44)
    1. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163 (gzhao, 17:13:46)
    2. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit?pli=1#gid=670022163 the blocking issues for Helium (colindixon, 17:13:56)
    3. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1622731782 <= blocking issue from Bugzilla by Colin (gzhao, 17:18:09)
    4. https://wiki.opendaylight.org/view/Project_Proposals:Discovery << Discovery Project Proposal (phrobb, 17:18:10)
    5. ACTION: phudgins to put the contents of the e-mail clarification in the proposal (colindixon, 17:18:51)
    6. https://lists.opendaylight.org/pipermail/tsc/2014-September/001782.html Project Proposal for Discovery (tbachman, 17:18:55)
    7. colindixon says he does not understand why the topology and inventory models don’t provide the support described (colindixon, 17:21:22)
    8. phudgins says that this is really a generic method to “discover” a device, find a module to own it, and then push it into the right existing model(s) (colindixon, 17:22:32)
    9. ACTION: phudgins to to add the committers for HP to the wiki (colindixon, 17:24:28)
    10. rexpugh notes that the TSC should consider having a separate meeting to educate TSC and key committers on project scope and description so that evaluation and approval for proposals can be done more quickly in TSC meeting. (phrobb, 17:27:11)
    11. edwarnicke asks for the scope to be explicitly stated to say that this project does not want to do the discovery but to provide APIs that help people do that once it’s discovered (colindixon, 17:27:27)
    12. colindixon asks if this is a generic form of discovery, we should get it to work with legacy projects as well as new ones… hence having committment/committer from those groups would be needed (phrobb, 17:28:54)
    13. phudgins notes that he would be happy to include other interested projects/committers in the project (phrobb, 17:29:38)
    14. edwarnicke says that he’s allergic forcing committers on anyone else, and so would favor approving things with the intended changes made (to committers, to scope, etc.) (colindixon, 17:31:11)
    15. dlenrow notes that getting into incubation for past project reviews has been very easy. Sending this project off to provide more information multiple times seems against our past behavior (phrobb, 17:32:15)
    16. TSC members note that being liberal in acceptance to incubation is a core value, but also from past experience there are some topics (committers, scope understanding, potential relationship to across other ODL projects) is helpful to understand (phrobb, 17:34:16)

  7. project merge jobs breaking (colindixon, 17:38:14)
    1. regXboi and edwarnicke note that a misconfigured merge job which broke integration (colindixon, 17:38:38)
    2. regXboi has done a linear walk of all the jenkins he cold find (based on the helium release) to make sure that no other merge jobs are broken in a way that will break things over the weekend (colindixon, 17:40:06)
    3. this problem cost us a few days at a critical time and should be reviewed in the future (colindixon, 17:40:26)
    4. edwarnicke pleads for us to ask the board for a community support person that can comb through things and find bugs like this early (colindixon, 17:40:56)
    5. dmm and colindixon agree that we this role should be filled (colindixon, 17:41:53)

  8. release candidates (colindixon, 17:42:11)
    1. dmm notes that in the future we need to work on defining what release candidates are (colindixon, 17:43:09)
    2. regXboi asks if we ever agreed on release vehicles (colindixon, 17:43:38)
    3. colindixon notes that we did agree on karaf would be one of the release vehicles, but didn’t agree that it would be the only vehicle (colindixon, 17:44:11)

  9. Helium download tool (colindixon, 17:44:33)
    1. http://odl-project-explorer.herokuapp.com/download the download tool as it stands today (colindixon, 17:44:45)
    2. phrobb has asked him for the full list of flip cards (mlemay_away has said he imagines it will be per-project) (colindixon, 17:45:15)
    3. edwarnicke says that this worries him because everything we’ve discussed previously was that all features would be presented, not just a subset or just projects (colindixon, 17:46:26)
    4. edwarnicke also note that it doesn’t work to download, phrobb confirms that and says this is just for look and feel (colindixon, 17:47:24)
    5. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 (phrobb, 17:47:30)
    6. colindixon also says he thought it would be feature-based (colindixon, 17:48:25)
    7. phrobb asks if the list of features listed in the above sheet are the right things to show to users (colindixon, 17:48:42)
    8. edwarnicke says some of this is out of date and some may need to be modulated by asking projects what features they want to expose to users (colindixon, 17:49:10)
    9. colindixon suggests that we use this list as a starting point, reach out to projects if we think they should be exposing different features, also telling all projects what we’re planning on doing so they can adjust if they need (colindixon, 17:51:49)
    10. colindixon explicitly notes that to avoid the political issues, it seems we pretty much need to allow projects to surface whatever features they want (colindixon, 17:53:30)
    11. kwatsen asks why are we doing a web portal instead of an installer? (colindixon, 17:53:45)
    12. edwarnicke says the answer is that the people who wanted to do the work were willing to do that (colindixon, 17:54:08)
    13. phrobb asks if we want to surface internal features or just to drag them in through the other features (colindixon, 17:55:02)
    14. edwarnicke says he thinks it’s the latter, with the possible exception of clustering (colindixon, 17:55:28)
    15. cdub says he doesn’t quite see how we’re going to execute this before Monday (colindixon, 17:57:36)
    16. phrobb agrees with that (colindixon, 17:57:41)
    17. colindixon suggests that we ship the custom distribution downloader after the release and the first release is just the karaf zip file (colindixon, 17:58:10)
    18. phrobb asks what docs we need to produce to make that possible (colindixon, 17:58:23)
    19. edwarnicke suggests a 4 column table of: (i) human-readable component name, (ii) human-readable description, (iii) features command to load that component, (iv) compatibility notes (colindixon, 18:00:43)
    20. LuisGomez asks what information is in each project's installation guide given it's relation to name/desc/features, etc (phrobb, 18:00:54)
    21. we need somebody to make this table, it could be pulled from install guide if projects are filling it out right (colindixon, 18:01:20)
    22. i just want to make sure we do not work twice (LuisGomez, 18:01:24)

  10. release artifact approval (colindixon, 18:01:48)
    1. AGREED: will will review release artifacts at a special TSC meeting on Monday aftenoon (colindixon, 18:02:37)
    2. ACTION: colindixon will lead producing the documentation table (colindixon, 18:02:45)
    3. AGREED: we will meet at 12:15p pacific on Monday (colindixon, 18:04:46)
    4. AGREED: the TSC agrees that the karaf distribution (possibly modulated by the web downloader) will be *the* release vehicle for Helium (colindixon, 18:06:12)
    5. colindixon notes that for clarification, we would like the web downloader in the future, we are just using an alternative for quicker delivery by 9/29 (colindixon, 18:06:53)

  11. revisit of discovery (regXboi, 18:06:54)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Discovery (regXboi, 18:06:59)
    2. VOTE: Voted on "Shall the TSC accept the Discovery project into OpenDaylight as an Incubation Project?" Results are, +1: 8 (phrobb, 18:07:50)
    3. congrats to discovery and welcome aboard! (regXboi, 18:08:00)
    4. note kwatsen had a late +1 vote for the record (colindixon, 18:08:06)
    5. AGREED: Discovery Project is moved to Incubation (phrobb, 18:08:12)

  12. final topics (colindixon, 18:09:36)
    1. regXboi says we need to talk about EOLing hydrogen in the future (colindixon, 18:10:08)
    2. we need to establish whether and how projects have to cut stable release branches for helium (or to delay it), we can do that on Monday (colindixon, 18:10:40)


Meeting ended at 18:11:08 UTC (full logs).

Action items

  1. phudgins to put the contents of the e-mail clarification in the proposal
  2. phudgins to to add the committers for HP to the wiki
  3. colindixon will lead producing the documentation table


Action items, by person

  1. colindixon
    1. colindixon will lead producing the documentation table
  2. UNASSIGNED
    1. phudgins to put the contents of the e-mail clarification in the proposal
    2. phudgins to to add the committers for HP to the wiki


People present (lines said)

  1. colindixon (71)
  2. regXboi (24)
  3. phrobb (18)
  4. odl_meetbot (16)
  5. cdub (12)
  6. ChrisPriceAB (9)
  7. dlenrow (6)
  8. dbainbri (6)
  9. tbachman (6)
  10. kwatsen (6)
  11. edwarnicke (5)
  12. gzhao (4)
  13. alagalah (4)
  14. dmm (3)
  15. LuisGomez (2)
  16. IvanWood (2)
  17. rexpugh (1)


Generated by MeetBot 0.1.4.