#opendaylight-meeting: tsc

Meeting started by phrobb at 19:39:33 UTC (full logs).

Meeting summary

  1. Roll Call: TSC members please #info in (phrobb, 19:39:50)
    1. regXboi (regXboi, 19:40:31)
    2. TSC members in Conference Room Chris Price, Kent Watsen, Ed Warnicke, Dave Meyer, Colin Dixon, Jan Medved (phrobb, 19:40:39)
    3. Kent Watsen (kwatsen, 19:45:56)
    4. https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163 (phrobb, 19:46:12)
    5. Chris Price (ChrisPriceAB, 19:46:43)
    6. Lenrow (dlenrow, 19:52:58)
    7. colindixon (colindixon, 19:53:30)

  2. Helium Release Status (phrobb, 19:53:51)
    1. TSC members in the room are: dave lenrow, david meyer, colin dixon, chris prices, kent watsen, jan medved, ed warnicke, chris wright (colindixon, 19:54:29)
    2. there is a discussion of the current blocking issues (2098, 2091, 2103, 2106, 2108, and 2112) (colindixon, 19:56:14)
    3. 2106 - statistical bug (kwatsen, 19:56:33)
    4. 2108 is something edwarnicke saw once and has never been reporduced (colindixon, 19:57:10)
    5. colindixon says that he felt as though we had an almost ready-to-release version 5 days ago and it feels like we’ve regressed (colindixon, 19:57:11)
    6. 2098 - dangling/missing nodes (kwatsen, 19:57:17)
    7. 2112 is something which appears to have been a regression in GBP which they are currently bisecting (colindixon, 19:58:36)
    8. 2106 can hang controller, fix is almost in (kwatsen, 20:00:55)

  3. what our options are now (colindixon, 20:04:53)
    1. marketing people have said (publicly) that we will release code today (colindixon, 20:05:16)
    2. we are left between a rock (release code with know bugs without workarounds) and a hard place (not releasing as promised) (colindixon, 20:06:28)
    3. Ed details that it takes 8-10 hours to turn the crank, 4 hours just to build (kwatsen, 20:07:26)
    4. the discussion boils down to the fact that it takes ~4.5 hours to even produce a zip file and then several hours to test (colindixon, 20:07:31)
    5. the key points to make is that (i) we found last-minute show-stopping bugs, (ii) we are committed to shipping good, stable code, and (iii) as a consequence we will not be shipping code today (colindixon, 20:09:30)
    6. dmm says no chance to release today, only decision is what to tell Marketing (kwatsen, 20:09:41)
    7. add (iv) we will be meeting daily to take stock of where we are and ship at the earliest possible date (colindixon, 20:11:02)
    8. Chris Wright (just got into IRC, sorry) (cdub, 20:15:32)
    9. edwarnicke just got IRC too (edwarnicke, 20:15:44)
    10. Jan Medved (jmedved, 20:16:25)
    11. dmm (dmm, 20:16:43)
    12. VOTE: Voted on "shall Helium be released on 9/29 with the defects 2098, 2091, 2103, 2106, and 2112 known and as yes unverified as resolved?" Results are, -1: 9 (phrobb, 20:18:29)

  4. chair elections (brief aside) (colindixon, 20:22:04)
    1. kwatsen asks about whether we should also do a vice chair election at the same time as the TSC chair election (colindixon, 20:22:35)
    2. it’s pointed out that there is no occurrence of the term vice chair in the bylaws, or TSC charter (colindixon, 20:23:15)
    3. so there is no such vice chair to discuss (colindixon, 20:23:37)
    4. dlenrow asks if the chair comes with lots of travel and promoting and things that would be useful to share (colindixon, 20:24:19)
    5. dmm says there was at the beginning, but now Neela, Ambassadors, etc. make this not a requirement (colindixon, 20:24:35)
    6. kwatsen asks dmm, but you seemed to be very much in favor of vice chair a little bit back (colindixon, 20:25:38)
    7. dmm says there are two reasons for that: (i) he always seems to wind up traveling on Thursday mornings, and (ii) the chair should also be looking to mentor other members to provide redundant and diverse leadership (colindixon, 20:26:35)
    8. kwatsen says the only part that’s not visible to the whole TSC, but is visible to the chair is the board (colindixon, 20:26:59)
    9. those who sit on both (including dmm) say that isn’t really a big issue (colindixon, 20:27:23)

  5. dealing with the fallout of the helium (non) release (colindixon, 20:28:10)
    1. four points, 1) late discovery of showstopper bugs 2) As a tech community, we want to ship quality code, 3) this code is not ready to ship, 4) A new date for delivery is not yet known. (phrobb, 20:31:16)
    2. melissa asks other than the download page, where else do we need to send this (colindixon, 20:32:32)
    3. TSC to put this decision on discuss, tsc and release mailing lists (phrobb, 20:32:32)

  6. technical, infrastructure, and process debt (colindixon, 20:43:18)
    1. everyone agrees that we really need to help solve this problem (colindixon, 20:44:11)
    2. some of it will involve the board, but there has historically been push back because we don’t have precise asks (colindixon, 20:44:33)
    3. we have some precise asks now which hopefully the board can board can help us meet (colindixon, 20:45:09)
    4. there is also a discussion that we may be growing so fast that reacting to problems we precisely understand will have us always behind (colindixon, 20:46:16)
    5. as a consequence we *need* at least some parts be proactive (colindixon, 20:46:40)
    6. the consensus is that we need a full-time infrastructure team (and maybe it’s not us, maybe it’s the LF) to keep this stuff going and anticipate needs (colindixon, 20:47:36)
    7. kwatsen says he thinks part of the problem is not just infrastructure, but also the simultaneous release plan (colindixon, 20:50:47)
    8. kwatsen suggests that we might try to target core projects that are supposed to be able to be released at any time (colindixon, 20:52:38)
    9. cdub says the discussion about putting the lithium release is broken in his mind, it should be wrapped into helium release goals (colindixon, 20:53:49)
    10. regXboi says he thinks if you do that Lithium is going to take longer than 6 months (colindixon, 20:54:03)
    11. colindixon suggests we just reduce the scope to make it take 6 months (colindixon, 20:54:15)
    12. regXboi notes that he is very much disagrees and thinks that this won’t work (colindixon, 20:56:12)
    13. regXboi would *love* to be proven wrong (regXboi, 20:56:31)

  7. next meeting about the release (colindixon, 20:56:52)
    1. AGREED: the TSC will meet in salon 9 at 8a pacific tomorrow (colindixon, 20:57:04)


Meeting ended at 20:57:08 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. colindixon (45)
  2. odl_meetbot (16)
  3. regXboi (13)
  4. phrobb (12)
  5. kwatsen (12)
  6. ChrisPriceAB (5)
  7. gzhao (2)
  8. dmm (2)
  9. dlenrow (2)
  10. jmedved (2)
  11. edwarnicke (2)
  12. cdub (2)
  13. tbachman (1)
  14. kwat (0)


Generated by MeetBot 0.1.4.