#opendaylight-meeting: tsc

Meeting started by phrobb at 16:59:10 UTC (full logs).

Meeting summary

    1. dmm (dmm, 16:59:28)

  1. Roll Call - TSC members please #info in (phrobb, 16:59:28)
    1. regXboi is partially here (regXboi, 16:59:47)
    2. colindixon (colindixon, 17:00:10)
    3. alagalah (Keith) as proxy for Ed Warnicke (alagalah, 17:00:14)
    4. https://wiki.opendaylight.org/view/TSC:Main#Agenda agenda as usual (colindixon, 17:00:27)
    5. Chris Price (ChrisPriceAB, 17:00:36)
    6. regXboi now here fully (regXboi, 17:01:26)
    7. Ivan Wood (IvanWood, 17:01:30)
    8. Kent Watsen (kwatsen, 17:02:05)
    9. Lenrow (dlenrow, 17:03:20)
    10. jmedved (jmedved, 17:03:36)

  2. dmm’s thanks (colindixon, 17:05:02)
    1. dmm wants to say thank you to the community, TSC, linux foundation and everyone (colindixon, 17:05:16)

  3. Updates (phrobb, 17:07:51)
    1. phrobb Dusseldorf conf next week (alagalah, 17:08:29)
    2. hackfest in Octoboer on 10/29 (tbachman, 17:08:45)
    3. following week is openstack paris, with talks on ODL in the main conference and in the OpenSource ecosystem track (tbachman, 17:09:04)
    4. http://events.linuxfoundation.org/events/linuxcon-europe Cloud Open + LinuxCon conference coming up (tbachman, 17:09:46)
    5. http://www.opendaylight.org/events/2014-10-29/opendaylight-tokyo-hackfest Tokyo ODL Hackfest (alagalah, 17:10:23)
    6. Youcef Laribi (Youcef, 17:10:53)
    7. Welcome to new TSC Chair Youcef Laribi, the new representative from Citrix (tbachman, 17:11:07)

  4. Stable Helium Update (tbachman, 17:11:36)
    1. https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1307630876 (colindixon, 17:12:47)
    2. there are eight projects that are complete, with others waiting on dependencies (tbachman, 17:12:59)
    3. Most of the remaining projects are in steps 4, 5, or 6, with 8-9 of them that haven’t started yet (tbachman, 17:13:25)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:Cutting_Stability_Branches <= Link describing steps for cutting Helium Stability Branches (tbachman, 17:14:01)
    5. zxiiro says that the remaining projects that haven’t started are likely doing so because they think they can’t start yet b/c they are blocked on dependent projects (tbachman, 17:15:04)
    6. colindixon notes that the autorelease for stable/helium is about 1 month away, so we need to get the branches cut soon (tbachman, 17:15:40)
    7. LuisGomez asks why there are two projects in the spreadsheet with no contact (tbachman, 17:16:35)
    8. phrobb notes that opflex is an error because it wasn’t in helium (tbachman, 17:16:45)
    9. 8 projects completed, 7 projects in steps 4-6, 8 not started yet (tbachman, 17:18:29)
    10. ACTION: zxiiro to remove opflex from helium/stable spreadsheet and find "handler" for sdni project (tbachman, 17:18:48)

  5. System Integration and Testing (tbachman, 17:19:32)
    1. LuisGomez says there are two new workgroups in Integration: Project Engagement to get requirements for testing from the beginning and work closely with release management; and Performance Tools, to focus just on creating performance tools (tbachman, 17:20:26)
    2. LuisGomez said that someone has asked about Windows testing, as there are possibly issues with the Windows karaf distribution (tbachman, 17:20:52)
    3. LuisGomez asks if someone from Microsoft could find someone to help out with Windows integration testing (tbachman, 17:21:14)
    4. The base Karaf windows distribution is tested prior to our releases, so issues found may be ODL specific (icbts, 17:21:31)
    5. colindixon asks whether we can get a MAC and Windows machines/resources for the integration team for testing (tbachman, 17:21:53)
    6. ACTION: IvanWood will try to find out more information about the issues with Windows (tbachman, 17:22:44)
    7. colindixon asks if we’ve started testing on stable/helium yet (tbachman, 17:24:11)
    8. LuisGomez says this hasn’t happened yet (tbachman, 17:24:19)
    9. ACTION: IvanWood, LuisGomez, and phrobb to get together to build a plan for Windows testing in integration (test expertise, and actual hardware and OS platform). (phrobb, 17:24:42)

  6. Committer Promotions on OVSDB (tbachman, 17:25:56)
    1. shague and flaviof have been nominated by the OVSDB team as committers (tbachman, 17:26:43)
    2. colindixon asks if there’s a precedent for requiring a committer during the TSC call for committers (tbachman, 17:27:31)
    3. phrobb says he doesn’t think there’s such a precendent, but we have emails indicating +1’s from the OVSDB committers (tbachman, 17:27:58)
    4. https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-October/000749.html email thread on new committers for OVSDB (regXboi, 17:27:59)
    5. http://spectrometer.opendaylight.org/?user_id=shague&metric=commits same hague on spectrometer (colindixon, 17:28:35)
    6. http://spectrometer.opendaylight.org/?user_id=ffernandes fLavio on spectrometer (regXboi, 17:28:48)
    7. regXboi says that flaviof and shague are #3 and #6 on the contributors for OVSDB (tbachman, 17:30:37)
    8. VOTE: Voted on "Shall the TSC approve shague and flaviof as committers on the OVSDB project?" Results are, +1: 8 (phrobb, 17:32:14)
    9. flaviof and shague are promoted to committers on the OVSDB project (tbachman, 17:32:44)
    10. AGREED: shague and flaviof are now committers on the OVSDB project (phrobb, 17:32:46)

  7. Hydrogen End of Life (tbachman, 17:33:22)
    1. colindixon asks if we can just vote to end of life hydrogen today (tbachman, 17:33:57)
    2. dlenrow says that he has received little feedback about the need for sable hydrogen (tbachman, 17:34:27)
    3. IMHO you can't vote on EOL or EOS without defining the terms (alagalah, 17:34:27)
    4. regXboi says we should set some ground rules for End of Life and End of Support (tbachman, 17:34:56)
    5. regXboi would favor voting End of Support today, and focus on End of Life later (tbachman, 17:35:18)
    6. jmedved asks if we can define support, as that carries certain committments (tbachman, 17:36:13)
    7. colindixon says the proposal on the table is no more patches (tbachman, 17:36:22)
    8. regXboi says that in theory someone could file a defect against Hydrogen, and we as a community ought to consider cutting a new release to address the defect(s) (tbachman, 17:36:51)
    9. jmedved says that even if someone in the community pushes a patch, are we going to commit resources to that release (reviewing, testing, etc.) (tbachman, 17:37:30)
    10. rovarga says that whether or not to take patches should be up to the project (tbachman, 17:37:55)
    11. This means there are two issues: project life cycle, and support for the simultaneous release (tbachman, 17:38:26)
    12. proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases), projects may continue to update stable branches, and stable/hydrogen will still be available for download (regXboi, 17:42:21)
    13. proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download) (regXboi, 17:43:20)
    14. alagalah notes that there are no current bugs outstanding against hydrogen (regXboi, 17:44:49)
    15. VOTE: Voted on "proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download)?" Results are, +1: 9 (phrobb, 17:45:01)
    16. AGREED: EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download) (tbachman, 17:45:45)

  8. Longer TSC Meetings (tbachman, 17:46:00)
    1. phrobb says that at the end and beginning of cycles, there are usually a lot more topics (tbachman, 17:46:19)
    2. phrobb asks if we want to increase the meetings to 90 minutes or 2 hours over the next couple of months (tbachman, 17:46:37)
    3. regXboi proposes 3-4 weeks we increase, and then about 6 weeks before the Lithium release (tbachman, 17:47:42)
    4. kwatsen says that it seemed like we needed extra time towards the end of Helium (tbachman, 17:48:26)
    5. colindixon asks whether folks prefer 90 minutes or 2hrs? (tbachman, 17:48:45)
    6. regXboi prefers 2hrs for now (tbachman, 17:49:11)
    7. alagalah points out that if we schedule for 2 hrs we can go short, but if we schedule for 90 minutes then we have a harder time going longer (regXboi, 17:50:27)
    8. VOTE: Voted on "Shall the TSC increase their weekly meetings to 2 hours while discussion topics warrant it?" Results are, +1: 8 (phrobb, 17:51:24)
    9. AGREED: TSC meetings are now 2 hours (phrobb, 17:51:47)
    10. ACTION: phrobb to change the TSC meeting invites to 2 hours (phrobb, 17:52:13)

  9. debt reduction (regXboi, 17:52:22)
    1. https://wiki.opendaylight.org/view/File:Debt-reduction-ideas.TSC-meeting.2014.10.09.pptx slides with conrcrete suggestions/ides (colindixon, 17:52:31)
    2. colindixon says a couple of people have proposed that we delay starting the Lithium release to perform concrete, time-boxed work on addressing the various debt on OpenDaylight (tbachman, 17:53:42)
    3. regXboi points out that cdub has some strong opinions on stopping work for Tech Debt so asks if topic can be deferred until he can have input (alagalah, 17:54:37)
    4. colindixon notes that he doesn't want to delay the Lithiium Release schedule if we don't have concrete, time-boxed technical debt reduction items to deliver (phrobb, 17:56:09)
    5. regXboi notes that with increased TSC time, we might be able to do this without delaying Lithium start (tbachman, 17:56:41)
    6. there is a draft litium simultaneous release plan out (regXboi, 17:57:03)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan draft Lithium Release Plan (tbachman, 17:57:42)
    8. kwatsen says we should re-label this to indicate that this isn’t the plan of record (tbachman, 18:00:01)
    9. dlenrow notes we need to address the dates as well (tbachman, 18:00:13)
    10. alagalah says that the release plan doesn’t address project dependencies (tbachman, 18:01:13)
    11. colindixon says that Hydrogen did have a concept of different release stages to address this (tbachman, 18:01:58)
    12. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan update page with red warning (colindixon, 18:03:40)
    13. discussion ensues on the needs for several improvements oto the Lithium Release Plan (phrobb, 18:05:33)
    14. colindixon requests that folks add requests/ideas to the bottom of the Lithium Release Plan (tbachman, 18:06:07)

  10. Introduction of Dave Neary (tbachman, 18:06:37)
    1. dneary will be spending ~25% of his time working with phrobb, neelajaques, et. al. on how to grow a healthy a community (tbachman, 18:07:12)
    2. Dave is reachable at dneary@redhat.com, dneary on IRC (dneary, 18:07:30)


Meeting ended at 18:07:45 UTC (full logs).

Action items

  1. zxiiro to remove opflex from helium/stable spreadsheet and find "handler" for sdni project
  2. IvanWood will try to find out more information about the issues with Windows
  3. IvanWood, LuisGomez, and phrobb to get together to build a plan for Windows testing in integration (test expertise, and actual hardware and OS platform).
  4. phrobb to change the TSC meeting invites to 2 hours


Action items, by person

  1. IvanWood
    1. IvanWood will try to find out more information about the issues with Windows
    2. IvanWood, LuisGomez, and phrobb to get together to build a plan for Windows testing in integration (test expertise, and actual hardware and OS platform).
  2. phrobb
    1. IvanWood, LuisGomez, and phrobb to get together to build a plan for Windows testing in integration (test expertise, and actual hardware and OS platform).
    2. phrobb to change the TSC meeting invites to 2 hours
  3. zxiiro
    1. zxiiro to remove opflex from helium/stable spreadsheet and find "handler" for sdni project


People present (lines said)

  1. tbachman (93)
  2. alagalah (36)
  3. regXboi (34)
  4. ChrisPriceAB (32)
  5. odl_meetbot (27)
  6. colindixon (21)
  7. phrobb (18)
  8. dmm (13)
  9. dlenrow (12)
  10. dneary (8)
  11. rovarga (7)
  12. kwatsen (7)
  13. jmedved (4)
  14. Youcef (4)
  15. icbts (3)
  16. tykeal (3)
  17. IvanWood (2)
  18. zxiiro (1)


Generated by MeetBot 0.1.4.