#opendaylight-meeting: tsc

Meeting started by colindixon at 18:03:29 UTC (full logs).

Meeting summary

  1. roll call and agenda (colindixon, 18:03:35)
    1. colindixon (colindixon, 18:03:41)
    2. regXboi (irc for now) (regXboi, 18:03:43)
    3. Chris Wright (cdub, 18:03:44)
    4. mohnish (mohnish, 18:03:50)
    5. Kent Watsen (kwatsen, 18:03:52)
    6. Youcef Laribi (Youcef, 18:03:52)
    7. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place (colindixon, 18:03:57)
    8. abhijitkumbhare (for Chris Price) (abhijitkumbhare, 18:03:57)
    9. LuisGomez (LuisGomez, 18:04:21)
    10. edwarnicke (edwarnicke, 18:04:36)
    11. https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-11-13-17.59.html (colindixon, 18:05:12)
    12. ACTION: rovarga to email alagalah to do a TWS on this topic (colindixon, 18:06:32)
    13. ACTION: colindixon to get the release notes linked in to download (tbachman, 18:07:30)
    14. ACTION: phrobb will create a wiki page by next week’s TSC meeting where we can put projects and mentors (colindixon, 18:07:49)
    15. phrobb1 has identified the CAs that work for Oracle’s Java JDK on the Mac and we are working on getting a cert from one of them (colindixon, 18:08:45)

  2. board elections (tbachman, 18:10:13)
    1. phrobb1 says elections have concluded and email has been sent indicating LuisGomez and mlemay have been elected (tbachman, 18:10:39)
    2. colindixon asks if there are any more elections (tbachman, 18:11:09)
    3. phrobb1 says there are the Project Lead elections (tbachman, 18:11:19)
    4. usecase meeting will be tomorrow will follow up at next TSC on #action item (mlemay, 18:11:25)
    5. https://wiki.opendaylight.org/view/CondorcetElection4PTLs page describing how to run an e-election for your PTL (colindixon, 18:13:24)
    6. drizzt__ says the board of directors need to vote on who will be the chair of the BoD (tbachman, 18:14:30)
    7. phrobb1 says Monday is the conclusion of the Board of Directors chair (tbachman, 18:14:43)

  3. events (tbachman, 18:14:50)
    1. phrobb1 says that venues are tight for a January hack fest (tbachman, 18:15:16)
    2. https://lists.opendaylight.org/pipermail/discuss/2014-November/003872.html initial email discussing hack fests (tbachman, 18:19:07)

  4. system integration and test (colindixon, 18:20:38)
    1. the stable/helium branch is currently stalled because of (a lack of) version bumps (colindixon, 18:21:12)
    2. zxiiro is chasing down the projects to be able to resolve the remaining version bumps (tbachman, 18:21:40)
    3. Integration team is blocked waiting on version bumps, can't do testing on stable branch (dfarrell07, 18:22:31)
    4. cdub says we need a common person or people who have committer rights across projects, otherwise too much time spent chasing project committers (tbachman, 18:24:04)
    5. https://lists.opendaylight.org/pipermail/integration-dev/2014-November/002055.html start of email thread describing docker naming convention (tbachman, 18:26:38)
    6. https://lists.opendaylight.org/pipermail/tsc/2014-November/002140.html Docker naming proposal thread (dfarrell07, 18:27:40)
    7. AGREED: the TSC approves the Docker Naming Proposal linked in above (phrobb1, 18:28:24)

  5. lithium and stable helium updates (tbachman, 18:28:32)
    1. gzhao says that helium auto-release has same issue as integration project’s testing (blocked) (tbachman, 18:28:52)
    2. gzhao second’s cdub’s proposal for single person or persons with ability to implement version bump across projects (tbachman, 18:29:15)
    3. ACTION: colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion (tbachman, 18:31:24)
    4. ACTION: edwarnicke and gzhao to work on the Lithium auto-build (colindixon, 18:32:28)

  6. infrastructure (tbachman, 18:33:13)
    1. tykeal says they upgraded and moved gerrit to Rackspace environment last weekend (tbachman, 18:33:33)
    2. zxiiro upgraded sonar to the latest LTS version and has updated the sonar rules to be the non-deprecated ones (tbachman, 18:34:06)
    3. https://git.opendaylight.org/gerrit/Documentation/user-review-ui.html the guide for the new gerrit (colindixon, 18:34:50)
    4. ACTION: mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro (colindixon, 18:36:12)
    5. zxiiro says they’re ready to have more projects come in and start using Jenkins Job Builder (hopefully still somewhat simple projects) (tbachman, 18:37:09)
    6. edwarnicke asks if we’ve figured out what to do with the job retriggers (tbachman, 18:37:56)
    7. zxiiro says gerrit has a feature called a comment trigger, which may help (tbachman, 18:38:11)
    8. ACTION: zxiiro to work on how to (re)trigger builds in the unified jenkins silo (colindixon, 18:38:41)
    9. tykeal says comment trigger works by if you create a comment that has the text “retrigger” it will retrigger the job (colindixon, 18:39:14)

  7. Creation Review: CAPWAP (tbachman, 18:39:39)
    1. https://wiki.opendaylight.org/view/Project_Proposals:CAPWAP Project proposal page of CAPWAP (hideyuki, 18:41:55)

  8. commiter promotion for docs (tbachman, 18:44:29)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-November/002160.html the votes (colindixon, 18:44:50)
    2. VOTE: Voted on "Shall the TSC approve Sujatha Joseph and Colin Dixon as committers on the Documentation project?" Results are, +1: 9 (phrobb1, 18:47:53)

  9. Committer Promotions for Integration (tbachman, 18:48:40)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-November/002165.html Email for committer nomination for Integration (tbachman, 18:49:01)
    2. AGREED: sujatha and colindixon added as committers for documentation (last topic) (colindixon, 18:49:11)
    3. https://lists.opendaylight.org/pipermail/integration-dev/2014-November/002064.html (LuisGomez, 18:49:41)
    4. dfarrell07 commit history http://spectrometer.opendaylight.org/?company=redhat&release=all&project_type=all&metric=loc&user_id=dfarrell07 (dfarrell07, 18:49:52)
    5. https://git.opendaylight.org/gerrit/#/q/owner:%22Daniel+Farrell%22+project:integration,n,z another version of dfarrell07 commit history (dfarrell07, 18:50:09)
    6. http://spectrometer.opendaylight.org/?module=integration&metric=commits (CASP3R, 18:51:26)
    7. http://spectrometer.opendaylight.org/?module=integration&metric=loc Jamo is #5 dfarrell07 is #9 (colindixon, 18:52:08)
    8. https://lists.opendaylight.org/pipermail/opflex-dev/2014-November/000030.html OpFlex Committer LOC + Committer vote thread (alagalah, 18:52:41)
    9. VOTE: Voted on "Shall the TSC approve Daniel Farrell and Jamo Luhrsen as committers on the Integration project?" Results are, +1: 10 (phrobb1, 18:53:06)
    10. https://lists.opendaylight.org/pipermail/opflex-dev/2014-November/000030.html OpFlex Committer LOC + Committer vote thread (alagalah, 18:53:27)
    11. AGREED: adding dfarrell07 and Jamo Luhrsen to integration as committers (colindixon, 18:53:51)

  10. OpFlex Committer Promotion (tbachman, 18:54:28)
    1. http://spectrometer.opendaylight.org/?metric=loc&module=opflex they are #5 #6 (colindixon, 18:54:36)
    2. https://lists.opendaylight.org/pipermail/opflex-dev/2014-November/000030.html OpFlex committer email (tbachman, 18:54:39)
    3. VOTE: Voted on "Shall the TSC approve Mike Dvorkin and Amit Bose as committers on the OpFlex project?" Results are, +1: 9 (phrobb1, 18:56:36)
    4. AGREED: Mike Dvorkin and Amit Bose are approved committers on the OpFlex project (phrobb1, 18:56:57)

  11. Creation Review CAPWAP (revisited) (tbachman, 18:56:59)
    1. colindixon notes that there is only one listed committer and resource committed (tbachman, 18:58:06)
    2. abhijitkumbhare says that if they figure out the DTLS issue, please share it with OpenFlow{plugin,java} (colindixon, 18:58:32)
    3. Mahesh says there are other resources committed (Tiju John and Abi Varghese) (tbachman, 19:00:20)
    4. colindixon asks Mahesh to add them to the project proposal (tbachman, 19:00:32)
    5. ACTION: Mahesh to add the resources to the project proposal (tbachman, 19:00:47)
    6. edwarnicke says this seems like a southbound plugin for the protocol, and if there’s a link to the protocol available which can be added to the proposal (tbachman, 19:01:13)
    7. ACTION: Mahesh to add links from the project proposal to the RFCs and standards, also the slides (colindixon, 19:01:21)
    8. http://tools.ietf.org/html/rfc5415 (kwatsen, 19:01:31)
    9. http://tools.ietf.org/html/rfc5416 Control and Provisioning of Wireless Access Points (CAPWAP) ProtocolRFC (tbachman, 19:02:47)
    10. link for RFC5415 is Control And Provisioning of Wireless Access Points (CAPWAP) (tbachman, 19:03:20)
    11. rexpugh1 asks if this southbound plugin is going to integrate with the inventory data store (tbachman, 19:03:39)
    12. abhijitkumbhare asks if they will use the MD-SAL, and the answer is yes (colindixon, 19:05:03)
    13. the answer (to rexpugh1) is that it could be integrated, but hasn’t ben decided yet (colindixon, 19:05:32)
    14. ACTION: CAPWAP project team to codify what they presented into the wiki and reply to the original project proposal, and TSC to vote on mailing list (tbachman, 19:09:53)

  12. ODL Forge (tbachman, 19:11:00)
    1. https://pad.opendaylight.org/p/odlforge odlforge pad link (with disucssion points) (cdub, 19:11:45)
    2. use your ODL credentials to log in (colindixon, 19:12:10)
    3. tykeal says one idea is to create a new namespace for ODL forge (tbachman, 19:14:05)
    4. tykeal says the forge would stand up pretty much everything that exists for an ODL project (gerrit, jenkins, etc.) (tbachman, 19:14:45)
    5. tykeal says a separate nexus is a bit tricky, but under consideration (tbachman, 19:15:17)
    6. There’s a question of whether we’ll have a bugzilla for this or not (tbachman, 19:15:29)
    7. mailing lists should probably stay under opendaylight namespace (tbachman, 19:15:42)
    8. colindixon asks if we bought odlforge yet (tbachman, 19:16:49)
    9. ACTION: tykeal to investigate obtaining odlforge (tbachman, 19:17:16)
    10. https://lists.opendaylight.org/pipermail/tsc/2014-November/002178.html this e-mail lists what the current proposal is (colindixon, 19:21:48)
    11. phrobb1 asks how this weill affect costs (colindixon, 19:21:56)
    12. tykeal says that costs will go up because we’ll need systems, but it will likely go down overall as we reduce our one silo per project (colindixon, 19:23:21)
    13. tykeal also says that costs will fluctuate as we do more things in an elastic fashing, and we shoudl be aware of this (colindixon, 19:23:59)
    14. colindixon asks, given that we want ODL Forge is there any other way things can be done which would be a lot cheaper (colindixon, 19:24:22)
    15. tykeal seems to say no (colindixon, 19:24:29)
    16. VOTE: Voted on "Shall the TSC approve items 1 through 7 on the odlforge ehterpad?" Results are, +1: 9 (phrobb1, 19:28:11)
    17. tykeal has discovered that we can preserve git history on moving, however the coments on changes gerrit would be lost (colindixon, 19:28:13)
    18. AGREED: items 1 through 7 on odlforge etherpad is approved by the TSC (phrobb1, 19:28:41)
    19. drizzt__ asks what about trademarks and other things, do we enforce it on the front end? (colindixon, 19:29:57)
    20. colindixon says he’d rather not involve lawyers on the front-end if it can be avoided, so we encourage people to pick names carefully to avoid future pain, but not enforce it (colindixon, 19:31:20)
    21. phrobb1 asks a similar question about doing incoming code IPR, should we do it or not (colindixon, 19:31:40)
    22. edwarnicke and cdub say that we should do a similar thing and advise against doing bad things, but not enforce it unless it becomes an issue (colindixon, 19:32:16)
    23. http://ci.openstack.org/stackforge.html example of gerrit based automated project proposal/creation (cdub, 19:33:28)
    24. colindixon asks what we’re goign to do about “a) TBD - mechanism of request (email?, webform?, bugzilla bug?)” (colindixon, 19:33:29)
    25. tykeal says his bias is to go with a helpdesk ticket or mailing list request to get this info (tbachman, 19:33:53)
    26. We still need something in there that indicates that this is a valid project (tbachman, 19:34:05)
    27. colindixon says that if the TSC has to be involved in this process then it will slow things down (tbachman, 19:34:36)
    28. tykeal recommends cc’ing the TSC mailing list just to make them aware (tbachman, 19:34:49)
    29. colindixon asks if we could use project proposals for this? Or a separate mailing list? (tbachman, 19:35:11)
    30. cdub recommends using the dev list with a topic (tbachman, 19:35:56)
    31. cdub proposes to use odlforge-dev list with a topic of [proposal] for requests, this seems like a good idea (colindixon, 19:36:38)
    32. https://lists.opendaylight.org/pipermail/tsc/2014-November/002179.html the new 8–11 (colindixon, 19:47:55)
    33. VOTE: Voted on "Shall the TSC approve items 8 through 11 on the odlforge as archived in the above mailing list archive?" Results are, +1: 1 (colindixon, 19:49:11)
    34. ignore the above vote (colindixon, 19:49:16)
    35. VOTE: Voted on ""Shall the TSC approve items 8 through 11 on the odlforge proposal as documented in https://lists.opendaylight.org/pipermail/tsc/2014-November/002179.html?" Results are, +1: 7 (regXboi, 19:49:45)
    36. AGREED: the TSC approves items 8 through 11 on the odlforge proposal as documented in https://lists.opendaylight.org/pipermail/tsc/2014-November/002179.html (regXboi, 19:50:05)


Meeting ended at 19:50:49 UTC (full logs).

Action items

  1. rovarga to email alagalah to do a TWS on this topic
  2. colindixon to get the release notes linked in to download
  3. phrobb will create a wiki page by next week’s TSC meeting where we can put projects and mentors
  4. colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
  5. edwarnicke and gzhao to work on the Lithium auto-build
  6. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
  7. zxiiro to work on how to (re)trigger builds in the unified jenkins silo
  8. Mahesh to add the resources to the project proposal
  9. Mahesh to add links from the project proposal to the RFCs and standards, also the slides
  10. CAPWAP project team to codify what they presented into the wiki and reply to the original project proposal, and TSC to vote on mailing list
  11. tykeal to investigate obtaining odlforge


Action items, by person

  1. alagalah
    1. rovarga to email alagalah to do a TWS on this topic
  2. colindixon
    1. colindixon to get the release notes linked in to download
    2. colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
  3. edwarnicke
    1. edwarnicke and gzhao to work on the Lithium auto-build
  4. gzhao
    1. edwarnicke and gzhao to work on the Lithium auto-build
  5. mlemay
    1. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
  6. tykeal
    1. tykeal to investigate obtaining odlforge
  7. zxiiro
    1. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
    2. zxiiro to work on how to (re)trigger builds in the unified jenkins silo
  8. UNASSIGNED
    1. phrobb will create a wiki page by next week’s TSC meeting where we can put projects and mentors
    2. Mahesh to add the resources to the project proposal
    3. Mahesh to add links from the project proposal to the RFCs and standards, also the slides
    4. CAPWAP project team to codify what they presented into the wiki and reply to the original project proposal, and TSC to vote on mailing list


People present (lines said)

  1. tbachman (127)
  2. colindixon (69)
  3. odl_meetbot (31)
  4. cdub (18)
  5. edwarnicke (17)
  6. phrobb1 (16)
  7. dfarrell07 (15)
  8. alagalah (15)
  9. regXboi (12)
  10. abhijitkumbhare (10)
  11. rexpugh1 (8)
  12. kwatsen (8)
  13. mohnish (7)
  14. dneary (6)
  15. LuisGomez (6)
  16. Youcef (6)
  17. tykeal (6)
  18. mlemay (4)
  19. drizzt__ (4)
  20. gzhao (2)
  21. hideyuki (1)
  22. zxiiro (1)
  23. CASP3R (1)


Generated by MeetBot 0.1.4.