#opendaylight-meeting: TSC 08-21-2014

Meeting started by regXboi at 17:01:28 UTC (full logs).

Meeting summary

    1. dmm (dmm, 17:01:38)
    2. regXboi (regXboi, 17:01:44)
    3. kwatsen (kwatsen, 17:01:44)
    4. uchau - proxy for HP (uchau, 17:01:48)
    5. Ivan Wood for Microsoft (IvanWood, 17:01:51)
    6. Chris Price joined (ChrisPriceAB, 17:02:41)

  1. Agenda Bashing (tbachman, 17:03:28)
    1. edwarnicke (edwarnicke, 17:03:43)

  2. creation reviews (regXboi, 17:04:26)
    1. In the queue: Discovery (first possible review date: 09.04.2014) (regXboi, 17:04:34)
    2. No project reviews this week. (ChrisPriceAB, 17:04:37)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2014-August/000146.html (regXboi, 17:04:42)
    4. https://wiki.opendaylight.org/view/Project_Proposals:Discovery (regXboi, 17:04:47)

  3. committer promotions (regXboi, 17:04:54)
    1. Maxime Millette-Coulombe and Harman Singh to committer on dlux (regXboi, 17:05:54)
    2. https://lists.opendaylight.org/pipermail/tsc/2014-August/001554.html (regXboi, 17:06:21)
    3. need committer +1s email - some discussion (regXboi, 17:06:31)
    4. not having committers to dlux is posing a problem for getting Helium out the door (tbachman, 17:06:49)
    5. edwarnicke asks if it’s possible to have a majority of committers for the project (tbachman, 17:07:31)
    6. ACTION: will punt to next week (unforuntaely) (regXboi, 17:08:45)

  4. Release Readout (regXboi, 17:08:54)
    1. ACTION: postponed (regXboi, 17:09:27)

  5. at-large elections update (regXboi, 17:09:33)
    1. only one persone has nominated (regXboi, 17:09:40)
    2. request from dmm to get more nominees (regXboi, 17:09:52)
    3. - https://lists.opendaylight.org/pipermail/dlux-dev/2014-August/000075.html 3rd commiter of 4 chimes in (edwarnicke, 17:10:19)

  6. committer promotions (redux) (regXboi, 17:11:30)
    1. Maxime Millette-Coulombe and Harman Singh to committer on dlux (Madhu standing in for Endre) (regXboi, 17:11:50)
    2. repeat link (regXboi, 17:12:11)
    3. https://lists.opendaylight.org/pipermail/tsc/2014-August/001554.html (regXboi, 17:12:19)
    4. - https://lists.opendaylight.org/pipermail/dlux-dev/2014-August/000075.html 3rd commiter of 4 chimes in (tbachman, 17:12:32)
    5. above is repeat link of email (regXboi, 17:12:41)
    6. 1 (kwatsen, 17:15:41)
    7. VOTE: Voted on "Maxime Millette-Coulombe and Harman Singh to committer on dlux?" Results are, 1: 5 (regXboi, 17:15:57)
    8. AGREED: Maxime Millette-Coulombe and Harman Singh to committer on dlux (regXboi, 17:16:12)

  7. TSC role(s) and Project Scoping (regXboi, 17:16:21)
    1. OVSBB and HP openflow code (regXboi, 17:16:30)
    2. dmm says there is a role for project scoping, if only for the reason of only having 1 solution per problem. (tbachman, 17:17:31)
    3. https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-August/000648.html (regXboi, 17:17:31)
    4. dmm asks if this is in the critical path for helium and suggests that the OVSDB and OFplugin folks sort this out themselves and come back to the TSC with a proposed solution for the 8/28 meeting (regXboi, 17:18:35)
    5. and the TSC will review and exercise its oversite responsibility at that meeting (regXboi, 17:19:03)
    6. Madhu and networkstatic ask how this request has turned into scope creep? (regXboi, 17:20:53)
    7. ChrisPriceAB replies that OFPlugin has been working with HP about the plugin and so the original request has friction (regXboi, 17:23:00)
    8. regXboi comments that he feels the OVSDB project has a history of creeping out of the agreed project scope. (ChrisPriceAB, 17:25:39)
    9. dmm recommends taking this off of the TSC meeting, and thinks the teams should sit down and talk through the differences, n account of lack of not all parties being present and lack of time on the TSC (tbachman, 17:27:26)
    10. ACTION: dmm will find a time for all parties to get together to discuss, and will moderate (tbachman, 17:27:57)

  8. ODL Forge (tbachman, 17:30:06)
    1. out of order because related to previous topic (regXboi, 17:30:28)
    2. Information needed to start ODL Forge has been provided to LF (tbachman, 17:31:08)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-08-14-16.59.html for minutes of last week's call (regXboi, 17:31:49)
    4. edwarnicke says that the TSC hasn’t approved ODL Forge (tbachman, 17:32:12)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2014/odlforge/opendaylight-meeting-odlforge.2014-08-14-18.10.html (regXboi, 17:33:51)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2014/odlforge/opendaylight-meeting-odlforge.2014-08-14-18.10.html (CASP3R, 17:33:52)
    7. link is odlforge meeting minutes (regXboi, 17:34:15)
    8. edwarnicke asks if this is how the TSC wants to spend their energy at the moment (tbachman, 17:34:19)
    9. dmm wonders if we aren't ready for this discussion (regXboi, 17:34:53)
    10. edwarnicke points out there are open questions that need to be brought to the TSC (tbachman, 17:35:44)
    11. kwatsen asks what the motivation is for ODL forge (tbachman, 17:36:05)
    12. ACTION: without Chris Wright, we have to push this to next week (regXboi, 17:36:38)

  9. Karaf Updates (regXboi, 17:36:43)
    1. edwarnicke is sharing hot wiki page (regXboi, 17:37:08)
    2. https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#Structure_of_Karaf_so_far (edwarnicke, 17:37:23)
    3. ACTION: edwarnicke to update https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#Structure_of_Karaf_so_far to be usable by the larger community (regXboi, 17:37:55)
    4. edwarnicke discusses how to have a test that checks karaf features file (regXboi, 17:42:36)
    5. there is a limitation in pax-exam 4.1 that limits it to 50 instances (tbachman, 17:43:43)
    6. which causes issues with respect to recursive testing in integration (regXboi, 17:44:05)
    7. questions from Madhu (deferred until after the wiki page) (regXboi, 17:45:52)
    8. https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#The_things.2C_where_they_are.2C_and_why link to explain reasons behind decisions in karaf (tbachman, 17:46:36)
    9. kwatsen expresses concern about introducing karaf this late (tbachman, 17:48:18)
    10. edwarnicke says this page is germane to the mechanics of making feature.xml files available to integration and "unit test" are table stakes (regXboi, 17:50:45)
    11. Madhu says that the AD-SAL was removed from the distribution, breaking OVSDB (tbachman, 17:51:24)
    12. https://git.opendaylight.org/gerrit/#/c/9861/9/opendaylight/distribution/opendaylight-karaf/pom.xml gerrit where AD-SAL was removed (tbachman, 17:52:05)
    13. Requests are made that when changes/actions are done that impact projects those causing the impact need to communicate the impact prior to causing the impact (phrobb, 17:56:16)
    14. long discussion (regXboi, 18:01:15)
    15. kwatsen asks what all the projects have to do and by when, and when will this be communicated clearly (tbachman, 18:01:17)
    16. ACTION: edwarnicke will communicate the changes needed for projects to support karaf (tbachman, 18:01:50)
    17. kwatsen asks if all the projects need to get on top of this within the next week (tbachman, 18:02:01)
    18. edwarnicke says yes ASAP (regXboi, 18:02:17)
    19. kwatsen says that some projects may not be able to get on top of this in the next week, so we may need an exception path (regXboi, 18:03:17)
    20. dmm notes that this looks like its in critical path and edwarnicke agrees (regXboi, 18:04:20)
    21. edwarnicke asks that George Zhao be the "project herder" (regXboi, 18:07:22)


Meeting ended at 18:08:19 UTC (full logs).

Action items

  1. will punt to next week (unforuntaely)
  2. postponed
  3. dmm will find a time for all parties to get together to discuss, and will moderate
  4. without Chris Wright, we have to push this to next week
  5. edwarnicke to update https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#Structure_of_Karaf_so_far to be usable by the larger community
  6. edwarnicke will communicate the changes needed for projects to support karaf


Action items, by person

  1. dmm
    1. dmm will find a time for all parties to get together to discuss, and will moderate
  2. edwarnicke
    1. edwarnicke to update https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#Structure_of_Karaf_so_far to be usable by the larger community
    2. edwarnicke will communicate the changes needed for projects to support karaf
  3. UNASSIGNED
    1. will punt to next week (unforuntaely)
    2. postponed
    3. without Chris Wright, we have to push this to next week


People present (lines said)

  1. regXboi (98)
  2. tbachman (64)
  3. odl_meetbot (34)
  4. ChrisPriceAB (10)
  5. edwarnicke (6)
  6. dmm (5)
  7. alagalah (5)
  8. Madhu (4)
  9. IvanWood (4)
  10. uchau (3)
  11. kwatsen (3)
  12. phrobb (3)
  13. mlemay (3)
  14. CASP3R (2)
  15. dbainbri (1)


Generated by MeetBot 0.1.4.