#opendaylight-meeting: TSC 11/6/2014

Meeting started by regXboi at 17:59:50 UTC (full logs).

Meeting summary

  1. agenda bashing (tbachman, 18:00:12)
  2. roll call and agenda bashing (regXboi, 18:00:37)
    1. Chris Price (ChrisPriceAB, 18:00:47)
    2. regXboi (regXboi, 18:00:51)
    3. colindixon (colindixon, 18:01:00)
    4. Ivan Wood (IvanWood, 18:01:07)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-10-30-16.59.html last weeks TSC minutes to review action items (colindixon, 18:01:16)
    6. Luis Gomez (LuisGomez, 18:01:43)
    7. https://wiki.opendaylight.org/view/TSC:Main#Agenda this weeks agenda (regXboi, 18:01:48)
    8. mohnish anumala (mohnish, 18:02:42)
    9. colindixon claims to have covered his action items :) (regXboi, 18:03:47)
    10. colindixon did all his action items (alagalah, 18:03:49)
    11. edwarnicke claims that auto-release on master is still stuck ... so (regXboi, 18:04:14)
    12. ACTION: gzhao and edwarnicke to continue to work on getting Lithium auto-build to work (colindixon, 18:04:14)
    13. dlenrow (dlenrow, 18:04:53)
    14. edwarnicke (edwarnicke, 18:05:59)
    15. jmedved (jmedved, 18:06:36)

  3. updates (regXboi, 18:06:52)
    1. we only have 25 of our ~150 committers registered as members of the nonprofit and thus eleigible to vote (colindixon, 18:07:31)
    2. it would be good of others could join the nonprofit so that they can vote (colindixon, 18:07:48)
    3. the voting started on Tuesday and closes on 11/18, if you get your membership in, you will be allowed to vote (colindixon, 18:08:14)
    4. https://wiki.opendaylight.org/view/Committer_Board_Members:2014_Election the board elections wiki page (colindixon, 18:08:49)
    5. phrobb will do his best to get people in to vote if they sign up by 11/18, but the sooner you do it the better (colindixon, 18:09:12)

  4. events (tbachman, 18:09:24)
    1. a lot of folks are at OpenStack in Paris (as is phrobb) (regXboi, 18:10:04)
    2. phrobb says neutron devs are working hard on improving the stability and modularization of their component (tbachman, 18:11:11)
    3. colindixon asks if we should have a pre-Lithium hackfest (tbachman, 18:15:45)
    4. regXboi recommends that it be virtual, given the global participation in the project (tbachman, 18:15:57)
    5. ACTION: phrobb to start email thread on dates/times/activities for hackfest and integration-togetherness (phrobb, 18:16:23)
    6. edwarnicke recommends doing something between the M1 and M2 time frame (tbachman, 18:16:37)
    7. mlemay recommends having it sooner rather than later, focused more around the users rather than internal devs of ODL (tbachman, 18:17:10)

  5. update: system integration/testing (regXboi, 18:17:51)
    1. LuisGomez says he has no updates this week (regXboi, 18:18:30)
    2. mohnish question what solutions ODL is aimed at? (I think) (regXboi, 18:20:27)
    3. mlemay and colindixon says that the common one is OpenStack, but having others as well would be helpful (tbachman, 18:20:49)
    4. colindixon says that Margaret (sp?) from AT&T showed up at the dev summit and had some input from their perspective (tbachman, 18:21:19)
    5. colindixon says this is an area we should look to improve for Lithium, so if folks will start cataloging this kind of information it would be very helpful (tbachman, 18:22:14)
    6. phrobb knows that Dave Neary is also working on collecting these… collaboration opportunity (phrobb, 18:24:06)
    7. ACTION: dlenrow, mohnish and mlemay to work on gathering and acrhiving use cases (tbachman, 18:24:19)

  6. infrastructure (tbachman, 18:24:33)
    1. tykeal says that they’ve finished building the images for RackSpace silos, and is preparing to migrate the gerrit instance tonight (will send email) (tbachman, 18:25:10)
    2. OVSDB migration to rackspace is imminent. (phrobb, 18:25:41)
    3. zxiiro emailed instructions on how to get started with Jenkins Job Builder to a handful of projects (tbachman, 18:26:34)
    4. ACTION: colindixon to try Jenkins Job Builder with TTP (tbachman, 18:27:17)

  7. creation reviews and committer promotions (regXboi, 18:29:22)
    1. none so (regXboi, 18:29:28)

  8. stable/helium release (regXboi, 18:29:33)
    1. https://lists.opendaylight.org/pipermail/release/2014-November/000856.html email with link to stable/helium build (tbachman, 18:30:48)
    2. https://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.1-Helium-SR1/ the current RC (colindixon, 18:31:00)
    3. edwarnicke asks if we’ve given the projects adequate time to do their testing (tbachman, 18:31:28)
    4. colindixon says that given that the build happened this morning, are we willing to bless the build without hearing back from the projects (tbachman, 18:32:07)
    5. https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/200/ the build that produced those artifcats (colindixon, 18:32:12)
    6. colindixon looks for a time for a special meeting (regXboi, 18:34:19)
    7. VOTE: Voted on "shall the tsc have a meeting/vote at 9:30am PST on Monday Nov 10th to bless the Helium stable release?" Results are, +1: 7, -1: 1 (regXboi, 18:36:39)
    8. AGREED: the tsc will meet/vote at 9:30am PST on 11/10 for Helium SR1 (regXboi, 18:37:36)
    9. ACTION: phrobb to send out an invite for 9:30a pacific on 11/10 to bless Helium SR1 (or not) (colindixon, 18:37:58)
    10. alagalah asks how to get the source for every single helium project (regXboi, 18:38:32)
    11. ACTION: zxiiro and alagalah to produce instructions on how to get the source for the various releases for Helium (colindixon, 18:38:54)
    12. colindixon says if you want to merge a patch to stable/helium, put it on the spreadsheet tracked by gzhao (tbachman, 18:40:48)

  9. lithium release plan (regXboi, 18:43:07)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:DRAFT_Lithium_Release_Plan_ckd draft lithium release plan (regXboi, 18:43:25)
    2. ACTION: mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro (tbachman, 18:43:58)
    3. previous action is part of previous topic (regXboi, 18:44:15)
    4. colindixon moved the deadlines based on M1 to Thursdays, so that we have Friday to process results and give advice to projects, and have the weekend as free time to pursue any items (tbachman, 18:45:40)
    5. a change was made that APIs must be deprecated in a release before they can be removed in a following release (tbachman, 18:48:26)
    6. Added that sonar reporting will be used as consideration for committer promotions (tbachman, 18:49:05)
    7. https://lists.opendaylight.org/pipermail/integration-dev/2014-November/002001.html email from LuisGomez describing integration checklist proposal (tbachman, 18:50:29)
    8. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Project_Integration_Requirements link from draft RP (regXboi, 18:50:45)
    9. ACTION: LuisGomez to change Karafe Distribution bullet one to say "a release vehicle" instead of "the release vehicle" (phrobb, 18:53:24)
    10. edwarnicke asks if integration should be *all* the features, or just user-facing features? (tbachman, 18:53:37)
    11. regXboi notes that action is already done - that may be a record :) (regXboi, 18:53:52)
    12. colindixon says we can strongly encourage people to do better things with their feature repos, but requiring them to do that at this point is probably not going to happen (tbachman, 18:54:35)
    13. regXboi feels we can encourage but can’t require it (tbachman, 18:54:48)
    14. regXboi wishes to correct that - I said we can document in Li and encoruage in Li, but we can't require until Be or B (regXboi, 18:55:27)
    15. mlemay says we need some good high-level features that users can have to install, if we don’t consider these to be the -all features (tbachman, 19:01:56)
    16. colindixon says all features that are intended to be included in the release should have their encompassing features repo listed in integration (tbachman, 19:02:30)
    17. the editing of the integration wiki page conitinues (regXboi, 19:11:13)
    18. LuisGomez covers items that are new for the Lithium release, including things like optionally trigger System Test (ST) upon code commit, project merge and project integration jobs will run System Test (ST) on project recommended karaf features, project release test job will run System Test (ST) on project recommended karaf features, and ntegration project will provide "extra" longer tests, scalability/performance, platfo (tbachman, 19:15:18)
    19. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Project_Integration_Requirements#Requirements Propsed requirements on projects from the Integration group (tbachman, 19:16:41)
    20. TSC asks if the additional jenkins jobs will slow down merges (tbachman, 19:17:14)
    21. edwarnicke says implementing all of this will have the effect of delaying the pushing of artifacts (tbachman, 19:18:16)
    22. rovarga says we may want to have a layered system test (tbachman, 19:19:16)
    23. Refer to webex recording for discussion on Lithium release plan and Integration Project Lithium requirements (tbachman, 19:28:13)
    24. I'd suggest that folks may be finding this section hard to scribe, so would suggest listening to recording from point ~1hr 10min. (alagalah, 19:28:16)
    25. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template System Test Template from Integration Project (tbachman, 19:31:40)
    26. VOTE: Voted on "shall the tsc allow integration 2 weeks after each milestone?" Results are, 0: 2, +1: 7 (phrobb, 19:44:48)
    27. AGREED: Integration Team has 2 weeks offset after each milestone for their deliverables (phrobb, 19:45:37)

  10. Documentation requirements (tbachman, 19:45:39)
    1. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Lithium_Project_Documentation_Requirements Draft of proposed documentation requirements for Lithium release (tbachman, 19:45:41)
    2. regXboi says they’re looking to move the ascii doc files to the projects (tbachman, 19:46:06)
    3. it’s noted that release notes (which are listed in the main release plan) will also be required in AsciiDoc format (according this draft) so they can be published in the formal documenation on release (colindixon, 19:47:01)
    4. ACTION: colindixon to include release notes in the documentation requiremets as well even though they are already in the main release plan (colindixon, 19:47:29)

  11. API change/deprecated/removed rules (tbachman, 19:59:09)
    1. we intend to vote on the release plan during th special session on Monday at 9:30a pacific (colindixon, 20:12:03)

  12. cookies (regXboi, 20:12:08)


Meeting ended at 20:12:09 UTC (full logs).

Action items

  1. gzhao and edwarnicke to continue to work on getting Lithium auto-build to work
  2. phrobb to start email thread on dates/times/activities for hackfest and integration-togetherness
  3. dlenrow, mohnish and mlemay to work on gathering and acrhiving use cases
  4. colindixon to try Jenkins Job Builder with TTP
  5. phrobb to send out an invite for 9:30a pacific on 11/10 to bless Helium SR1 (or not)
  6. zxiiro and alagalah to produce instructions on how to get the source for the various releases for Helium
  7. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
  8. LuisGomez to change Karafe Distribution bullet one to say "a release vehicle" instead of "the release vehicle"
  9. colindixon to include release notes in the documentation requiremets as well even though they are already in the main release plan


Action items, by person

  1. alagalah
    1. zxiiro and alagalah to produce instructions on how to get the source for the various releases for Helium
  2. colindixon
    1. colindixon to try Jenkins Job Builder with TTP
    2. colindixon to include release notes in the documentation requiremets as well even though they are already in the main release plan
  3. dlenrow
    1. dlenrow, mohnish and mlemay to work on gathering and acrhiving use cases
  4. edwarnicke
    1. gzhao and edwarnicke to continue to work on getting Lithium auto-build to work
  5. LuisGomez
    1. LuisGomez to change Karafe Distribution bullet one to say "a release vehicle" instead of "the release vehicle"
  6. mlemay
    1. dlenrow, mohnish and mlemay to work on gathering and acrhiving use cases
    2. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
  7. mohnish
    1. dlenrow, mohnish and mlemay to work on gathering and acrhiving use cases
  8. phrobb
    1. phrobb to start email thread on dates/times/activities for hackfest and integration-togetherness
    2. phrobb to send out an invite for 9:30a pacific on 11/10 to bless Helium SR1 (or not)


People present (lines said)

  1. tbachman (106)
  2. regXboi (82)
  3. colindixon (38)
  4. ChrisPriceAB (34)
  5. odl_meetbot (27)
  6. alagalah (16)
  7. phrobb (12)
  8. abhijitkumbhare (7)
  9. dlenrow (6)
  10. LuisGomez (6)
  11. mohnish (6)
  12. edwarnicke (5)
  13. mlemay (5)
  14. mestery (5)
  15. jmedved (4)
  16. tykeal (4)
  17. flaviof (2)
  18. IvanWood (2)
  19. rovarga (1)
  20. tbachman_ (1)


Generated by MeetBot 0.1.4.