#opendaylight-meeting: TSC_2014-07-03

Meeting started by phrobb at 16:59:26 UTC (full logs).

Meeting summary

  1. TSC members please #info in (phrobb, 16:59:51)
    1. regXboi (regXboi, 17:00:25)
    2. edwarnicke (edwarnicke, 17:00:34)
    3. dmm (proxy from regXboi) (regXboi, 17:00:40)
    4. dmm (Dave Meyer) is present (phrobb, 17:00:48)
    5. Chris Price joined (ChrisPriceAB, 17:01:52)
    6. RobDolin proxy for Rajeev Nagar (MSFT) (RobDolin, 17:03:01)

  2. Creation Review for TCP-MD5 (phrobb, 17:06:04)
    1. https://wiki.opendaylight.org/view/Project_Proposals:TCP-MD5 (phrobb, 17:06:59)

  3. TCP-MD5 creation review (edwarnicke, 17:07:20)
    1. https://wiki.opendaylight.org/view/Project_Proposals:TCP-MD5 - repeated to get it under the right section (edwarnicke, 17:07:36)
    2. Lenrow (dlenrow, 17:08:19)
    3. Chris Wright (cdub, 17:08:27)
    4. rovarga_ says that BGP-PCEP needs (or just suggests?) TCP with the MD5 signature option (colindixon, 17:09:06)
    5. question from dmm: why does this need to be its own project? (regXboi, 17:10:01)
    6. as a conseuqnece, they’re targetting an implementation for Linux 64-bit (in C) along with JNI bindings so that people can use it (colindixon, 17:10:28)
    7. answer from rovarga: in working with opendaylight a project is a repository and so this is to give this code its own repository and its own version (regXboi, 17:11:25)
    8. rovarga_ notes that if it is a separate project it can have a separate set of committers so the people and expertise needed is different than BGP/PCEP (phrobb, 17:11:45)
    9. continued answer: making it its own project would allow for a separate set of committers than bgp or pcep (regXboi, 17:11:47)
    10. question from abhijitkumbhare: is it a good idea to have projects for common utility (regXboi, 17:12:19)
    11. abhijitkumbhare asks "should there be a utility project for this type of generally applicable functionality? (phrobb, 17:12:48)
    12. answer from colindixon: there are actually two questions: one is where should code live and two who is able to own code in the sense of reviews? (regXboi, 17:13:03)
    13. and while splitting a code base off is an answer for the first, but may not be an answer for the second (regXboi, 17:13:28)
    14. dmm says this is part of what he wanted to get at. what are the other implications of createing projects like this, e.g., that the PTL of this project could ultimately end up on the TSC (colindixon, 17:15:01)
    15. colindixon points out that this is *only* if the project become core (colindixon, 17:15:18)
    16. regXboi says that something that might help in this kind of discussions would be to have contracts between projects that explain their relationships (colindixon, 17:16:02)
    17. regXboi notes a reason for a separate project is also to have projects agree and document their "contracts" between each other… Where "contracts" mean a well-defined and slowly evolving touch points between projects so that new project can easily see how to connect and also for new alternatives to existing implementations… (phrobb, 17:16:15)
    18. so if creating a new project will enable that type of modularity, then it could be worthwhile, otherwise, maybe not (phrobb, 17:16:52)
    19. ChrisPriceAB notes that projects starting in incubation on their own allows small teams do what they need to to get started without putting at risk a larger project (phrobb, 17:18:01)
    20. dmm asks that "long ago", there have been talks about MD5 being deprecated, is this being done as a minimal implementation just using MD5 or is it more flexible to use other types of hashes (phrobb, 17:19:25)
    21. Answer: the existing code is really modeled after unix so there is jus a channel that talks to the underlying TCP layer. For service providers it was a must to be deployable (phrobb, 17:20:27)
    22. http://www.kb.cert.org/vuls/id/836068 “Software developers, Certification Authorities, website owners, and users should avoid using the MD5 algorithm in any capacity. As previous research has demonstrated, it should be considered cryptographically broken and unsuitable for further use.” (colindixon, 17:20:45)
    23. windows nor mac support these interfaces so this is limited to linux (phrobb, 17:20:57)
    24. Q: will the project commit to support windows/mac if underlying libs/function available... (phrobb, 17:21:50)
    25. answer is that "no" project does not have plan to support windows/mac if lib available (phrobb, 17:22:39)
    26. edwarnicke noting that if someone comes with patches to support other platforms the code would be welcome. (phrobb, 17:23:17)
    27. question and discussion ensue on cross-platform project requirements on existing projects and how cross platform support is to be handled (phrobb, 17:25:28)
    28. rovarga_ notes that the core problems are that the build environment is linux centric. having help building on other platforms rovarga_ is willing to work to support multi platform, but that help is manditory for this project (phrobb, 17:27:10)
    29. We raised issue not related to MD5 about whether we require multi-platform commitment for incubation approval. Might need separate session. (dlenrow, 17:28:12)
    30. rovarga_ answers Madhu by saying the code is there in BGP-PCEP now and so it will ship with Helium if there is no action and so the answer is *yes* (colindixon, 17:29:52)
    31. rovarga_ (in response to dbainbri) is that this feature is disabled by default on all platforms, needs to be activated by config system which will cleanly fail if it’s on the wrong platform (colindixon, 17:31:14)
    32. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects - "Please also note that projects that may be splitting into logical parts may have those logical parts join the Simultaneous Release at any point prior to M3 provided their Release Plans are apportioned between the projects they split into." in response (edwarnicke, 17:31:41)
    33. VOTE: Voted on "shall the TCP-MD5 project be moved to incubation?" Results are, 0: 1, +1: 4 (phrobb, 17:34:26)
    34. actual vote was 5 +1 as dmm was unable to register (regXboi, 17:34:57)
    35. RobDolin voted abstaining as did ChrisPriceAB (phrobb, 17:35:17)
    36. AGREED: TCP-MD5 project is moved to incubation (phrobb, 17:35:33)

  4. XSQL demo (colindixon, 17:36:03)
    1. Sharon starts a demo of using XSQL to query the MD-SAL (colindixon, 17:36:30)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:XSQL (phrobb, 17:38:36)
    3. https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call#July_1st.2C_2014 this was also presented at the July 1st MD-SAL weekly meeting and you can find minutes and (hopefully soon) a recording of a longer demo there (colindixon, 17:38:52)
    4. demo shows that you can query virtual tables (read dynamically from the MD-SAL) with columns and the ability to do SQL-like things (colindixon, 17:41:08)
    5. demo shows that you can access with a jdbc interface (edwarnicke, 17:43:02)
    6. Q: dmm asks "what do you want to have happen with this?" (phrobb, 17:44:16)
    7. answer, The goal is to make things easier. this should be usable by anything that wants to extract data from ODL (phrobb, 17:44:53)
    8. Q: there is nothing hardcoded here correct? (phrobb, 17:46:28)
    9. answer, no everything is dynamically built (phrobb, 17:46:44)
    10. Q on access to data based on ACL? (phrobb, 17:50:02)
    11. answer, currently in ODL there is no authentication (phrobb, 17:51:01)
    12. this discussion should go to TWS as more questions and discussion needed (phrobb, 17:51:29)
    13. the real answer is that the MD-SAL data store as of today doesn’t allow for authentication (colindixon, 17:51:38)
    14. colindixon running with this (regXboi, 17:52:21)
    15. almost everybody has signed off on the artifacts cut on Tuesday night (regXboi, 17:52:43)
    16. https://docs.google.com/a/colindixon.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0 (edwarnicke, 17:53:42)
    17. ACTION: either colindixon or edwarnicke to send email to release mailing list to firm up status (regXboi, 17:54:46)
    18. ACTION: dlenrow to contact Affinity team to get clear understanding on their participation in stable release to hydrogen (phrobb, 17:55:53)
    19. https://wiki.opendaylight.org/view/Special:WhatLinksHere/Template:Project_Facts please use this (colindixon, 17:56:20)
    20. https://wiki.opendaylight.org/view/Template:Project_Facts the right link (colindixon, 17:56:32)
    21. all projects please use this!!! (regXboi, 17:56:44)
    22. TSC members mull the fact box template proposal over and be ready to discuss/close at next meeting (phrobb, 17:58:38)
    23. https://wiki.opendaylight.org/view/Table_Type_Patterns:Main this is an example of how to use the template (colindixon, 17:58:41)


Meeting ended at 17:59:00 UTC (full logs).

Action items

  1. either colindixon or edwarnicke to send email to release mailing list to firm up status
  2. dlenrow to contact Affinity team to get clear understanding on their participation in stable release to hydrogen


Action items, by person

  1. colindixon
    1. either colindixon or edwarnicke to send email to release mailing list to firm up status
  2. dlenrow
    1. dlenrow to contact Affinity team to get clear understanding on their participation in stable release to hydrogen
  3. edwarnicke
    1. either colindixon or edwarnicke to send email to release mailing list to firm up status


People present (lines said)

  1. phrobb (41)
  2. colindixon (35)
  3. regXboi (31)
  4. edwarnicke (10)
  5. odl_meetbot (10)
  6. cdub (9)
  7. Madhu (9)
  8. ChrisPriceAB (7)
  9. dlenrow (4)
  10. RobDolin (4)
  11. tbachman (3)
  12. dbainbri (1)
  13. rovarga_ (1)
  14. regxboi (0)
  15. robdolin (0)


Generated by MeetBot 0.1.4.