#opendaylight-meeting: TSC 7-17
Meeting started by regXboi at 17:00:28 UTC
(full logs).
Meeting summary
- 
  - dmm (dmm,
    17:00:33)
- regXboi (regXboi,
    17:00:43)
- Chris Wright (cdub_,
    17:00:49)
- Chris Price (ChrisPriceAB,
    17:01:25)
- Jan Medved (jmedved,
    17:02:14)
- Kent Watsen (kwatsen,
    17:02:29)
- Rob Dolin proxy for Rajeev Nagar (MSFT)
    (RobDolin,
    17:02:33)
- note: jmedved has ed's proxy this week
    (regXboi,
    17:02:40)
- uchau - proxy for HP (uchau,
    17:03:33)
- no audio recording this week (regXboi,
    17:04:46)
 
 
- agenda bashing (colindixon, 17:04:51)
  - https://wiki.opendaylight.org/view/TSC:Main
    the agenda can be found here (as usual) (colindixon,
    17:05:26)
- phrobb arrives (there will actually be a
    recording) (colindixon,
    17:05:51)
- just missing first 5+ minutes :( (regXboi,
    17:06:03)
 
 
- system testing and integration (colindixon, 17:06:38)
  - LuisGomez says that he Mathieu (karaf
    pacakging) and Paul Zimmerman (documentation) are working together
    to communicate to projects what they’re going to need from projects
    to get testing and documentation working (colindixon,
    17:07:48)
- skipping Doc topic for today (regXboi,
    17:09:01)
- expect an e-mail from phrobb about this meeting
    to the release mailing lists; all primary contacts for projects
    participating in the helium release should be on that list
    today (colindixon,
    17:09:06)
 
 
- Committer Promitions (regXboi, 17:09:14)
  - Michal Rehak to committer to
    OpenFlowJavaLibrary (regXboi,
    17:09:33)
- https://lists.opendaylight.org/pipermail/tsc/2014-July/001359.html
    (hideyuki,
    17:11:40)
- https://lists.opendaylight.org/pipermail/tsc/2014-July/001359.html
    the mail showing the internal vote (thanks to hideyuki) (colindixon,
    17:12:21)
- VOTE: Voted on "shall
    Michal Rehak be promoted to committer on the OpenFlowJava Project?"
    Results are, +1: 8 (regXboi,
    17:13:36)
- AGREED: Michal Rehak
    has been promoted to committer (phrobb,
    17:13:51)
- congrats (just as further supporing
    information, Micahal has 150 of 254 commits on that project)
    (colindixon,
    17:13:55)
 
 
- hydrogen statble release (colindixon, 17:14:33)
  - Ryan, need to re-spin stable hydrogen.
    (ChrisPriceAB,
    17:15:32)
- regXboi says we need to respin the release and
    he’s having some trouble getting it done (with the auto-release
    jobs) and also to make sure that we have confirmation from all
    projects (colindixon,
    17:15:46)
- Dave m proposed (ChrisPriceAB,
    17:16:32)
- cdub_ and dmm suggest that we don’t wait a
    whole week, maybe provide provisional support based on the current
    project +1s (colindixon,
    17:16:32)
- https://docs.google.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0
    is the google's doc (regXboi,
    17:17:00)
- dmm asks if we’re having trouble because the
    baton has been passed around or if it’s technical issues?
    (colindixon,
    17:18:29)
- Q:  is the problem in getting the stable
    release done due to passing around the lead-responsibility, or are
    there real issues with the release?  A:  some problems in shifting
    leadership, some possibly on infrastructure (auto release scripts),
    and some on a good process to get feedback from projects
    promptly. (phrobb,
    17:19:34)
- colindixon says one key problem which we don’t
    have a good way to get a response to a question from *all* projects
    in an efficient manner (colindixon,
    17:21:10)
- phrobb says that basically, the common pattern
    for that is that we get a response from ~60% in a timeline fashion
    and the remaining 40% takes 7-10 days to get responses from everyone
    by manually pinging people repeatedly (colindixon,
    17:22:02)
- cdub suggests...if you don't comply we keep
    note and record on the "regular release" part of ability to be
    promoted _and_ i propose that we focus future releases on not
    releasing incubated code (cdub_,
    17:22:43)
- plan for stable/H is to see if the current spin
    works - once we have a spin, to publicize it to folks and to cat
    herd projects to +1 the google docs (regXboi,
    17:24:48)
- plan(2) is to then use TSC mailing list for
    approval once all projects +1 the google doc (regXboi,
    17:25:08)
- or a majority (regXboi,
    17:25:14)
 
 
- karaf update (regXboi, 17:25:28)
  - ACTION: cdub_ to
    propose his suggestion (about using failure to respond as a gate to
    moving out of incubation) to the TSC list and maybe have a vote on
    it in the future (colindixon,
    17:25:51)
- LuisGomez says he is very, very much in favor
    of using features to help testing (colindixon,
    17:26:33)
- dmm asks if we should set a drop dead date so
    that we can put some fire underneath people to make a
    decision (colindixon,
    17:27:20)
- phrobb says mail today will send out and invite
    for two meetings (to accomodate all time zones) around this stuff
    which will be on 7/23 (colindixon,
    17:28:59)
- we will provide a readout of that to the TSC on
    7/24 (colindixon,
    17:29:20)
- we will also give projects a week to react to
    that by the 7/30 M4 meeting which should give us a project-level
    readout on how we’re doing with karaf things (colindixon,
    17:30:03)
- then the TSC could provide an informed go/no-go
    decsion on the 7/31 meeting (colindixon,
    17:30:36)
- ACTION: phrobb will
    send a mail with this timeline to TSC and release (colindixon,
    17:32:15)
 
 
- events in dusseldorf (colindixon, 17:34:58)
  - http://www.layer123.com/sdn
    (cdub_,
    17:35:38)
- http://www.opendaylight.org/events/2014-10-13/opendaylight-d%C3%BCsseldorf-hackfest
    (abhijitkumbhare,
    17:35:48)
- http://www.opendaylight.org/events/2014-10-13/opendaylight-d%C3%BCsseldorf-hackfest
    (abhijitkumbhare,
    17:35:56)
- minisummit:
    http://www.opendaylight.org/events/2014-10-14/opendaylight-mini-summit-sdn-openflow-world-congress
    (ChrisPriceAB,
    17:36:06)
- if you want to help out get in touch with him
    or Todd or Katy (sp?) (colindixon,
    17:36:42)
- ChrisPriceAB would like to use this to gett
    OpenDaylight better booted up in Europe (colindixon,
    17:36:56)
- https://lists.opendaylight.org/pipermail/tsc/2014-July/001387.html
    CFP is open email (cdub_,
    17:36:58)
 
 
- new bylaws (colindixon, 17:37:10)
  - As the bylaws have now been approved we will
    soon be ready to hold at large elections across the OpenDaylight
    community. (ChrisPriceAB,
    17:38:28)
- Phil Robb will call for these over the regular
    mailing lists. (ChrisPriceAB,
    17:38:46)
- the TSC had no objections to final by-laws sent
    by phrobb.  The Board is now voting on approval of the amended
    by-laws and TSC charter and to implement the Waiver for one year.
    The Board vote will end next Wednesday 7/23 and at that point, if
    approved the waiver will begin to be in affect (phrobb,
    17:39:05)
- Learship in time and content! (ChrisPriceAB,
    17:39:16)
 
Meeting ended at 17:39:35 UTC
(full logs).
Action items
  - cdub_ to propose his suggestion (about using failure to respond as a gate to moving out of incubation) to the TSC list and maybe have a vote on it in the future
- phrobb will send a mail with this timeline to TSC and release
Action items, by person
  -  cdub_ 
    - cdub_ to propose his suggestion (about using failure to respond as a gate to moving out of incubation) to the TSC list and maybe have a vote on it in the future
 
-  phrobb 
    - phrobb will send a mail with this timeline to TSC and release
 
People present (lines said)
  - colindixon (39)
- regXboi (25)
- ChrisPriceAB (19)
- cdub_ (18)
- odl_meetbot (10)
- phrobb (6)
- dmm (5)
- jmedved (3)
- tbachman (3)
- RobDolin (3)
- kwatsen (2)
- abhijitkumbhare (2)
- uchau (2)
- hideyuki (2)
Generated by MeetBot 0.1.4.