#opendaylight-meeting: TSC Meeting 2014-06-12

Meeting started by phrobb at 16:59:56 UTC (full logs).

Meeting summary

    1. lenrow (lenrow, 17:01:08)

  1. TSC members please #info in (phrobb, 17:01:18)
    1. Dave Meyer is Here (phrobb, 17:01:41)
    2. Chris Wright (cdub, 17:01:49)
    3. Chris Price joined the call (ChrisPriceAB, 17:04:47)
    4. Ed Warnicke (edwarnicke, 17:05:27)
    5. Kent Watsen (kwatsen, 17:05:41)

  2. TSC charter update (colindixon, 17:06:30)
  3. Bylaw and charter edits for TSC At-Large Elections (phrobb, 17:06:32)
    1. Rob Dolin proxy for Rajeev Nagar (Microsoft) (RobDolin, 17:06:43)
    2. https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda meeting agenda (colindixon, 17:09:40)
    3. http://en.wikipedia.org/wiki/Veil_of_ignorance edwarnicke explains this term and advocates for decisions w.r.t. to at large TSC seats to be made with this in mind (colindixon, 17:11:26)
    4. the wording change for the TSC charter is to allow for the platinum-designate to the TSC to not step down when an At-Large committer is elected from the same company. (phrobb, 17:12:29)
    5. Mohammad Banikazemi attending the TSC meeting for Ryan Moats (banix, 17:13:06)
    6. the wording allows the Board, by supermajority, can vote to remove the mandate that the platinum designate step down for the particular election. Also the Board's choice to do this needs to be *before* the election begins so that they make that decision in a "veil-of-ignorance" with regard to the outcome of the election (phrobb, 17:15:25)
    7. the other issue to be considered is what happens to a platinum designate if/when we have core project leaders joining the Board (phrobb, 17:18:09)
    8. irc://irc.freenode.net:6667/#notinfo not the Board… sorry, I meant when a Core Project Lead joins the TSC (phrobb, 17:19:14)
    9. Q: Should we clarify if/when a TSC member is representing their company vs their own views to the project?… Rob, did I capture this accurately? (phrobb, 17:21:46)
    10. The group is not yet ready to put forth specific text for the charter and bylaws (phrobb, 17:25:10)
    11. It was noted that the 60 day deadline has passed so expediency is needed (phrobb, 17:25:52)

  4. TSC Call cadence (phrobb, 17:26:00)
    1. choices, reduce call length to 1 hour, and/or reduce call frequency to biweekly (phrobb, 17:26:45)
    2. Chris W, Rob, and Ed all are fans of reducing call time from 2h to 1h (RobDolin, 17:27:27)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan (phrobb, 17:32:35)
    4. ACTION: phrobb to kick off discusion on discuss list for Lithium release planning (phrobb, 17:34:40)

  5. Helium Release Vehicles (phrobb, 17:35:07)
    1. discussion ensues on "what should be the balance between focus-on-stability vs new features"? (phrobb, 17:37:16)
    2. It is noted that without adequate stability, a rich feature set is undeployable (phrobb, 17:39:04)
    3. discussion ensues on process-oriented technical requirements to ensure stabilty, scalability, etc. (phrobb, 17:42:11)
    4. further discussion on requirements vs implementation as a method to steering the projects to improve stability (phrobb, 17:47:01)
    5. concern is raised that requirements without committment and resources to work on filling the requirements will not succeed (phrobb, 17:50:32)
    6. ACTION: A request to all TSC members and community members to voice their thoughts on needs of the community for stability and performance improvements needed for the project (phrobb, 17:51:57)
    7. please bring your thoughts for these improvements to the TSC meetings (phrobb, 17:52:54)
    8. differing views on responsibility of TSC to improve process for stability of the code produced vs setting the timeline for future releases (phrobb, 17:54:43)


Meeting ended at 17:59:08 UTC (full logs).

Action items

  1. phrobb to kick off discusion on discuss list for Lithium release planning
  2. A request to all TSC members and community members to voice their thoughts on needs of the community for stability and performance improvements needed for the project


Action items, by person

  1. phrobb
    1. phrobb to kick off discusion on discuss list for Lithium release planning


People present (lines said)

  1. phrobb (34)
  2. cdub (13)
  3. colindixon (12)
  4. Madhu (5)
  5. RobDolin (5)
  6. odl_meetbot (4)
  7. edwarnicke (3)
  8. banix (3)
  9. lenrow (2)
  10. tbachman (2)
  11. ChrisPriceAB (1)
  12. kwatsen (1)


Generated by MeetBot 0.1.4.