#opendaylight-meeting: TSC Meeting 4/24/2014

Meeting started by phrobb at 16:58:43 UTC (full logs).

Meeting summary

  1. TSC Members please #info in as you join (phrobb, 16:59:03)
    1. dmm (dmm, 16:59:15)
    2. regXboi (for vijoy today) (regXboi, 16:59:29)
    3. dbainbri (dbainbri, 16:59:33)
    4. Chris Wright here (cdub, 17:02:17)
    5. Ed Warnicke (edwarnicke___, 17:02:48)
    6. RobDolin for Rajeev Nagar (Microsoft) (RobDolin, 17:05:51)
    7. regXboi thanks tykeal for #startvote/#vote (publically this time) :) (regXboi, 17:06:52)
    8. Thanks also Andy / tykeal for helping get the Docs project set-up (RobDolin, 17:06:56)

  2. Release Manager (phrobb, 17:07:05)
    1. successful first call with Huawei - plan for BOF meet up in Atlanta at OpenStack (regXboi, 17:08:55)

  3. Helium Release Plan (phrobb, 17:09:07)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan (edwarnicke___, 17:09:29)
    2. Chris Price joining (ChrsPriceAB, 17:09:47)
    3. Ed Warnicke (Cisco) has heard comments that the volume on discuss is so high that people don't pay attention to it (RobDolin, 17:11:35)

  4. Lithium Release Plan (phrobb, 17:15:26)
    1. Phil: There may be an opportunity for an OpenDaylight Summit in early June at the Hyatt Santa Clara (CA, USA) (RobDolin, 17:16:50)
    2. Ed Warnicke suggests that may work well for design for 4th release (RobDolin, 17:17:44)

  5. TSC Charter Text re: Elections (RobDolin, 17:19:01)
    1. https://lists.opendaylight.org/pipermail/tsc/2014-April/001089.html (edwarnicke___, 17:19:57)
    2. Phil Robb explaining options proposed in email: (RobDolin, 17:25:02)
    3. Option 1 - Remove the "If Otherwise Not Represented" clause from the (RobDolin, 17:25:17)
    4. Option 2 - Allow existing TSC members to run for re-election (RobDolin, 17:25:26)
    5. Option 3 - Do nothing; Leave everything the same and let the voting fall (RobDolin, 17:25:41)
    6. Ryan Moats (IBM) suggests that Option 2 may create a conflict of interest between representing company and representing committers at-large (RobDolin, 17:29:43)
    7. regXboi does not like option 2 because if elected from the committer base but bumped my employer's TSC rep, the elected person is in an uncomfortable position of needing to represent the community but having some need to represent the employer (phrobb, 17:31:09)
    8. Dave Lenrow (HP) suggests there is a one-time offset because we don't have core project PTLs or elected at-large committers (RobDolin, 17:31:29)
    9. Lots of projects being brought by non-Platinum members (RobDolin, 17:41:08)
    10. ACTION: phrobb to build a new list of committers and their company affiliation (phrobb, 17:43:11)
    11. David Meyer askes if ready for a vote (RobDolin, 17:43:13)
    12. David Meyer suggests an option of including a sunset clause (RobDolin, 17:43:33)
    13. Ryan Moats (IBM) suggests we can also send multiple suggestions (RobDolin, 17:43:51)
    14. Ed Warnicke (Cisco) suggests the proposal has not be available for very long (RobDolin, 17:45:08)
    15. Ryan Moats agrees with Ed that we should let this percolate on the mailing list for another week (RobDolin, 17:46:23)
    16. ACTION: regXboi to put out a mail to continue discussion on the discuss list (phrobb, 17:47:09)
    17. ACTION: all should read community feedback on proposal(s) (RobDolin, 17:47:39)

  6. Automated Release (RobDolin, 17:48:52)
  7. Root Parent Project Creation Review (RobDolin, 17:52:31)
    1. https://wiki.opendaylight.org/view/Project_Proposals:ODL_Root_Parent (cdub, 17:52:38)
    2. ACTION: Root Parent team to #link in minutes (RobDolin, 17:56:05)
    3. regXboi raises concern that the project needs to document how to fully enable/educate projects how to do automated documentation building in this new structure (phrobb, 17:59:39)
    4. further details to be worked out w/in technical community (cdub, 18:01:30)
    5. David Meyer explains this is creation of the project, not which solution will be used (RobDolin, 18:02:08)
    6. Mathieu Lemay asks why we need a seprate project for this (RobDolin, 18:05:26)
    7. Raghurama explains this is importance for release dependencies order (RobDolin, 18:05:52)
    8. Mlemay and madhu ask if we need a new project for this work or could it be hosted within an existing project? (phrobb, 18:08:17)
    9. https://wiki.opendaylight.org/view/File:Versioning-Updated.ppt <- PPT that was presented (RobDolin, 18:09:07)
    10. ragbhat asks "is there a concern in creating a project out of this work"? (phrobb, 18:10:51)
    11. Chris Wright (Red Hat) volunteers to help with this project (RobDolin, 18:13:36)
    12. the question on the table is to create the root parent project (regXboi, 18:14:27)
    13. David Meyer clarifies "0" = Abstain (RobDolin, 18:15:23)
    14. Vote results are 5 +1, 0 -1, 1 0 (phrobb, 18:16:37)
    15. AGREED: root parent project to incubation (regXboi, 18:17:19)
    16. AGREED: Rott Parent Project is moved to incubation (phrobb, 18:17:20)

  8. Stable Release (RobDolin, 18:18:42)
    1. Chris Wright reports the process has started (RobDolin, 18:18:57)
    2. Chris also reports there has not been meaningful discussion about date for converging (RobDolin, 18:19:17)
    3. no date has been picked for the first release. At least two projects have not yet created a branch (phrobb, 18:19:31)
    4. regXboi asks if we are far enough along to switch the dependencies onto the stable branch to see what breaks. (phrobb, 18:20:14)
    5. cdub notes that the controller and yangtools projects need to have the patches/bug-fixes on the stable branch… that is still a work in progress with some Jenkins stability slowing things down (phrobb, 18:22:38)

  9. Can integration projects contain distributions other than Release Vehicles? (phrobb, 18:24:46)
    1. edwarnicke___ notes that it is implied that distributions in the integration project are 1 to 1 mapped to release vehicles… Does that have to be? (phrobb, 18:26:13)
    2. Madhu asks, since inclusion in the Integration project implies testing by integration team, is that what is recommended here? (phrobb, 18:27:04)
    3. edwarnicke___ notes that the integration team would need to define any bounds/scope on distributions other than release vehicles (phrobb, 18:27:57)
    4. regXboi pulls pin on grenade….. notes one of biggest headaches is non-determinacy of OSGi… putting more into that structure (with Karafe) will require fixing of the determinism (phrobb, 18:29:55)
    5. mlemay notes that this is an issue and needs to be worked… even thanks regXboi for the grenade (phrobb, 18:31:00)
    6. This topic came up due to Karafe migration work proposed by mlemay. The question was "how to do this the best way"… if a distribution within the Integration project were available, that would be the best place.... (phrobb, 18:36:18)
    7. but currently the only thing associated with the Integration project are "release vehicles" (phrobb, 18:36:57)
    8. regXboi notes that having a side conversation on "what automated release" means might be worthwhile for clarity (phrobb, 18:38:05)
    9. Seeking TSC clarity that "things in the Integration Project are not necessarily a Release Vehicle" (phrobb, 18:38:47)
    10. It is noted that automated release will generate weekly, non-release artifacts… however this question is about having a different set of artifacts built within integration that is not part of any expected release vehicle (phrobb, 18:41:57)
    11. regXboi asks "should this question go to the "discuss" list (phrobb, 18:42:33)
    12. Given that it doesn't seem that the Karafe activity won't be blocked in the short term, we should put this to the Discuss list for community comment (phrobb, 18:44:49)

  10. Other Topics (phrobb, 18:46:08)
    1. regXboi notes he has a few additional topics… (phrobb, 18:46:42)
    2. This will go to mailing list but the topic is on tomcat and more java/OSGi bundle loading determinism. (phrobb, 18:50:09)
    3. ACTION: regXboi to start discussion on tomcat and bundle loading determinism (phrobb, 18:50:33)


Meeting ended at 18:50:40 UTC (full logs).

Action items

  1. phrobb to build a new list of committers and their company affiliation
  2. regXboi to put out a mail to continue discussion on the discuss list
  3. all should read community feedback on proposal(s)
  4. Root Parent team to #link in minutes
  5. regXboi to start discussion on tomcat and bundle loading determinism


Action items, by person

  1. phrobb
    1. phrobb to build a new list of committers and their company affiliation
  2. regXboi
    1. regXboi to put out a mail to continue discussion on the discuss list
    2. regXboi to start discussion on tomcat and bundle loading determinism
  3. UNASSIGNED
    1. all should read community feedback on proposal(s)
    2. Root Parent team to #link in minutes


People present (lines said)

  1. regXboi (45)
  2. phrobb (43)
  3. RobDolin (43)
  4. cdub (27)
  5. edwarnicke___ (25)
  6. alagalah (14)
  7. dmm (11)
  8. odl_meetbot (8)
  9. tbachman (6)
  10. Madhu (4)
  11. icbts (3)
  12. mlemay (3)
  13. ChrsPriceAB (2)
  14. colindixon (2)
  15. dbainbri (2)
  16. edwarnicke__ (0)


Generated by MeetBot 0.1.4.