#opendaylight-meeting: TSC Meeting 5-29-2014
Meeting started by phrobb at 17:00:59 UTC
(full logs).
Meeting summary
- 
  - Madhu Venugopal (Madhu,
    17:01:09)
 
 
- TSC Members please #info into the meeting (phrobb, 17:01:58)
  - regXboi still getting to webex (regXboi,
    17:02:10)
- HELP:  (kwatsen,
    17:03:14)
- Ed Warnicke (edwarnicke,
    17:03:15)
- Lenrow Present (lenrow,
    17:03:25)
- Madhu Venugopal (Madhu,
    17:03:31)
- Kent Watsen (kwatsen,
    17:04:46)
- Chris Price is here (phrobb,
    17:05:00)
- Rob Dolin proxy for Rajeev Nagar (MSFT)
    (RobDolin,
    17:06:02)
 
 
- Agenda bashing (phrobb, 17:06:23)
  - https://wiki.opendaylight.org/view/TSC:Main
    (phrobb,
    17:06:37)
- edwarnicke thanks auric and GiovanniMeo putting
    in weekly automated releases (regXboi,
    17:08:36)
- Madhu points out this will be topic of next TWS
    call (regXboi,
    17:08:50)
 
 
- Event Updates (regXboi, 17:09:08)
  - Chris Price would like to join the
    committee (ChrsPriceAB,
    17:09:13)
- phrobb asking for volunteers for program
    committies for upcoming events (regXboi,
    17:09:30)
- TWS agenda for next week :
    https://wiki.opendaylight.org/view/Tech_Work_Stream:Main
    (Madhu,
    17:09:36)
 
 
- SFC to join Helium Simultaneous Release (regXboi, 17:09:45)
  - paulq apologizes for not realizing that there
    is a separate item for joining Helium Simultaneous Release
    (regXboi,
    17:10:35)
- phrobb asks if there are questions from the
    TSC (regXboi,
    17:10:47)
- Madhu has a question about whether it is
    possible for a new project joining now to join helium (regXboi,
    17:11:44)
- ChirsPriceAB thinks that the TSC reserved the
    right to evaluate new projects on a case by case basis (regXboi,
    17:12:34)
- phrobb concurs with that memory (regXboi,
    17:12:44)
- RobDolin states this was written into the
    helium plan (regXboi,
    17:13:10)
- Lenrow asks what are the dependencies of this
    module (regXboi,
    17:13:28)
- ChrisPriceAB thinks there are dependencies
    going NB, but there are not dependencies going SB (regXboi,
    17:13:51)
- https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-04-17-16.56.html
    <— has reference to what was discussed for projects (tbachman,
    17:14:03)
- Lenrow asks if this means there are no changes
    driven SB (regXboi,
    17:14:07)
- ChrisPriceAB states there may be changes driven
    SB, but these need to be done in a backward compatible way
    (regXboi,
    17:14:33)
- Madhu says his question is answered
    (regXboi,
    17:14:59)
- more discussion of case by case (regXboi,
    17:16:28)
- kwatsen says while he his is ok with this, the
    release plan should be updated with information on how projects join
    a release (regXboi,
    17:17:07)
- rmoats +1 (regXboi,
    17:17:12)
- that should have been regXboi +1 to kwatsen's
    statement (regXboi,
    17:18:04)
- question on whether we can close the door or
    not now (regXboi,
    17:18:19)
- that q was from ChrisPriceAB (regXboi,
    17:18:42)
- s/join a release/declare intent/  (on my
    statement captured by Ryan) (kwatsen,
    17:19:07)
- concern from RobDolin that closing the door
    would be exclusive (regXboi,
    17:19:24)
- Madhu has concern with needing to gate to
    ensure quality of release (regXboi,
    17:20:21)
- RobDolin understands the needs for a long tail
    but says the conversation at that point should be along the lines of
    the questions Lenrow asked earlier in the conversation (regXboi,
    17:20:55)
- phrobb asks if a vote is needed (regXboi,
    17:21:50)
- regXboi asks if anybody has a reason not to let
    SFC into Helium (regXboi,
    17:22:10)
- AGREED: with no
    objections the TSC allows SFC into the Helium release (regXboi,
    17:23:16)
 
 
- TSC Charter Modifications (regXboi, 17:23:25)
  - https://lists.opendaylight.org/pipermail/tsc/2014-May/001254.html
    (phrobb,
    17:23:45)
- phrobb begins to explain the changes to the by
    laws and the TSC charter (regXboi,
    17:25:53)
- these changes stemmed from the initial attempt
    to run an election of at-large committers (regXboi,
    17:26:14)
- the TSC recommended that platinum members
    continue to be represented even if an at-large representative from
    the same platinum member company is elected (regXboi,
    17:27:43)
- the board wanted to add language to remove the
    restriction at a particular point of time by the super majority of a
    board (regXboi,
    17:28:27)
- so the process would be to first approve these
    changes to the bylaws and charter (regXboi,
    17:29:02)
- and then the board would follow on by voting to
    remove the platinum member restriction for the purposes of this
    election (regXboi,
    17:29:40)
- Madhu asks if the at-large committers could
    potentially be from the same company (RobDolin,
    17:30:29)
- Proposed amendments are attached to an email
    sent by probb@linuxfoundation.org on Mon, 5/19 around 3pm (USA
    Pacific time) (RobDolin,
    17:32:41)
- dbainbri asked why this a concern (regXboi,
    17:39:50)
- phrobb represents the original concern which
    was the at-large election didn't work (regXboi,
    17:41:16)
- dbainbri asks why the restriction is not an
    issue anymore (regXboi,
    17:41:43)
- phrobb explains more of the background
    (apologies, I can't keep up with the discussion) (regXboi,
    17:42:07)
- phrobb explains that the waiver language was to
    avoid requiring changing the bylaws multiple times (regXboi,
    17:43:51)
- kwatsen was concerned about how the original
    issues were rpesented (regXboi,
    17:45:55)
- robdolin tries to explain how the original
    issues were voting (regXboi,
    17:46:14)
- that was David Lenrow, not RobDolin, I
    think (tbachman,
    17:46:41)
- phrobb points out that the language is set up
    to allow for the restriction to be removed on a case by case
    basis (regXboi,
    17:47:23)
- kwatsen claims that is not the case - the
    language for an existing member stepping down has been
    removed (regXboi,
    17:47:59)
- phrobb agrees that the step down language needs
    to be reinstated (regXboi,
    17:48:56)
- RobDolin suggests that if we are not agreeing
    on language, we should break this out to a subcommittee (regXboi,
    17:49:47)
- edwarnicke agrees this would be useful
    (regXboi,
    17:50:00)
- madhu asks where language about preventing
    at-large committers from the same platinum company (regXboi,
    17:52:40)
- phrobb refers to section 4, buillet 3
    (regXboi,
    17:52:56)
- Phil Robb points-out that there is another
    section that suggests at-large seats must be from unaffiliated
    companies (RobDolin,
    17:53:01)
- bullet 3 (regXboi,
    17:53:04)
- edwarnicke points out that bullet 3 can be read
    to apply to the original election (regXboi,
    17:53:39)
- dbainbri asked about affiliation (regXboi,
    17:54:44)
- phrobb answer there is language (regXboi adds
    in that the language is in the by-laws) (regXboi,
    17:55:22)
- Ed Warnicke suggests that we consider scoping
    the question to the languaging of previously agreed intent as a
    separate question from other questions being raised. (edwarnicke,
    17:57:57)
- regXboi laughs hystericaly (edwarnicke,
    17:59:08)
- Subcommittee volunteers: Ed, Kent, Phil,
    Rob (RobDolin,
    18:00:08)
- ACTION: edwarnicke
    RobDolin kwatsen phrobb to make a small committee to craft language
    edits in bylaws and tsc charter to bring back to tsc for further
    discussion at next week's tsc meeting (phrobb,
    18:00:32)
- Chris Price suggests we need to determine when
    the right of Platinum member to appoint expires (RobDolin,
    18:00:47)
- Rob Dolin needs to drop off today's TSC ConCall
    and passes MSFT proxy to Ivan Wood (RobDolin,
    18:02:39)
- Ivan Wood (IvanWood,
    18:03:14)
- Vice Chair discussion will be deferred until
    dmm is back (regXboi,
    18:03:34)
- kwatsen wants to split the two issues because
    while elections can close quickly, the VC discussion is still
    ongoing (regXboi,
    18:04:34)
- phrobb says the language can be split if
    needed (regXboi,
    18:04:53)
- edwarnicke distinctly remembers that the VC
    discussion is still open (regXboi,
    18:05:13)
- phrobb says the VC language was also for review
    and to further discussion (regXboi,
    18:05:32)
 
 
- OpenDaylight Security Analysis (regXboi, 18:06:30)
  - https://wiki.opendaylight.org/view/CrossProject:OpenDaylight_Security_Analysis
    (regXboi,
    18:06:37)
- kwatsen asks w.r.t. load time signature
    checking, where will the private key be located?  what about 3P
    off-line projects looking to integrate (regXboi,
    18:09:58)
- Madhu answers that signing can be done with
    various private keys and checked with public keys, with support for
    importing additional public keys for checking (regXboi,
    18:10:55)
- edwarnicke states that he put some effort into
    figuring how to sign bundles that go into nexus and that's hard to
    do in a reasonable way. (regXboi,
    18:12:03)
- Madhu asks to explain (regXboi,
    18:12:10)
- edwarnicke points out that the jenkins build
    system has to sign the artifacts and that is non trivial
    (regXboi,
    18:12:32)
- getting artifacts signed in jenkins in a secure
    and reliable way is non-trivial in an open source project and
    automated release processes (phrobb,
    18:13:14)
- the problem is not with the mechanics of
    signing but with the opensource mechanics of signing (regXboi,
    18:13:15)
- Madhu wants to sign the release bundles only
    before they are pushed into nexus (regXboi,
    18:14:03)
- (I think that is) (regXboi,
    18:14:12)
- regXboi notes that significant overhead may be
    added to the build/debug process with the addition signed
    bundles (phrobb,
    18:18:17)
- regXboi notes "security is goodness", we need
    to manage the mechanics as to not add significant overhead or
    complexity to the developer community who doesn't know how this
    works (phrobb,
    18:20:18)
- Madhu notes that SNAPSHOT creation would be
    done in with security turned off.  Bundle creation for end user
    consumption would include security/signing to give end user peace of
    mind in what they are running. (phrobb,
    18:22:11)
- ken beck takes both sides of the
    discussion (regXboi,
    18:22:32)
- , security also introduces bugs/errors adding
    complexity to the debug environment. This needs to be recognized as
    well. (phrobb,
    18:23:02)
- discussion of karaf's remote management
    environment (regXboi,
    18:24:54)
- madhu makes a point that some of these are
    available today (regXboi,
    18:25:09)
- edwarnicke (personal statement) says that we
    aren't to karaf yet (regXboi,
    18:25:28)
- madhu says we may need to enable the features
    in a non karaf enviro (regXboi,
    18:25:49)
- edwarnicke also wants it noted he likes karaf
    and is (personal statement) supportive :) (edwarnicke,
    18:26:13)
- +1s that :) (Madhu,
    18:26:28)
- https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Plan
    - OFplugin has TLS support on its roadmap (edwarnicke,
    18:28:03)
- https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Candidate_RELEASE_Plan_2014
    - as does OFjava (edwarnicke,
    18:28:55)
- regXboi wants to thank the team for their
    effort - this is all *goodness* and the only question (in my mind)
    is how to get from here to there! (regXboi,
    18:40:38)
 
 
- helium simultaneous release logistics (regXboi, 18:40:59)
  - https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Simultaneous_Release_Developer_Meetings
    (phrobb,
    18:41:33)
- https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Simultaneous_Release_Developer_Meetings
    (regXboi,
    18:41:33)
- https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Per_project_Simultaneous_Release_Contact
    (regXboi,
    18:41:43)
- https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Cross_Project_Milestone_and_Release_Candidate_Reporting
    (regXboi,
    18:41:54)
- discussion between Madhu and edwarnicke about
    getting this to work (regXboi,
    18:48:18)
- edwarnicke points to people implementing
    controller integration jobs (regXboi,
    18:48:39)
- these are integration jobs that trigger a build
    in a project every time there is a merge in another project you
    depend on (LuisGomez,
    18:50:40)
- https://wiki.opendaylight.org/view/GettingStarted:Jenkins_Integration_Job_Setup
    (regXboi,
    18:50:40)
- this is very useful to find other projects
    issues (LuisGomez,
    18:51:36)
 
Meeting ended at 18:53:56 UTC
(full logs).
Action items
  - edwarnicke RobDolin kwatsen phrobb to make a small committee to craft language edits in bylaws and tsc charter to bring back to tsc for further discussion at next week's tsc meeting
Action items, by person
  -  edwarnicke 
    - edwarnicke RobDolin kwatsen phrobb to make a small committee to craft language edits in bylaws and tsc charter to bring back to tsc for further discussion at next week's tsc meeting
 
-  kwatsen 
    - edwarnicke RobDolin kwatsen phrobb to make a small committee to craft language edits in bylaws and tsc charter to bring back to tsc for further discussion at next week's tsc meeting
 
-  phrobb 
    - edwarnicke RobDolin kwatsen phrobb to make a small committee to craft language edits in bylaws and tsc charter to bring back to tsc for further discussion at next week's tsc meeting
 
-  RobDolin 
    - edwarnicke RobDolin kwatsen phrobb to make a small committee to craft language edits in bylaws and tsc charter to bring back to tsc for further discussion at next week's tsc meeting
 
People present (lines said)
  - regXboi (102)
- phrobb (18)
- edwarnicke (16)
- RobDolin (12)
- odl_meetbot (10)
- Madhu (5)
- tbachman (4)
- kwatsen (4)
- dbainbri (3)
- lenrow (2)
- alagalah_ (2)
- LuisGomez (2)
- ChrsPriceAB (2)
- ashaikh (1)
- IvanWood (1)
- ChrisPriceAB (0)
Generated by MeetBot 0.1.4.