#opendaylight-meeting: TSC_Mtg_2014-06-19

Meeting started by phrobb at 17:00:28 UTC (full logs).

Meeting summary

    1. Ivan Wood (IvanWood, 17:00:35)
    2. Ed Warnicke (edwarnicke, 17:00:39)
    3. dmm (dmm, 17:00:40)
    4. Kent Watsen (kwatsen, 17:00:43)
    5. Ryan Moats (regXboi) (regXboi, 17:00:47)
    6. Chris Price (ChrisPriceAB, 17:01:25)

  1. security response team reboot (regXboi, 17:02:26)
    1. Lenrow present (lenrow, 17:03:07)
    2. eawarnicke: there was no clear memory of the previous security response team (regXboi, 17:03:11)
    3. so we need a reboot (regXboi, 17:03:26)
    4. GiovanniMeo (GiovanniMeo, 17:03:37)
    5. request that folks that want to volunteer for the security response team should send email to phrobb (regXboi, 17:04:56)
    6. ACTION: cdub gets the job of mocking up a security response page for ODL (regXboi, 17:06:55)
    7. ACTION: along with edwarnicke and phrobb (phrobb, 17:07:09)

  2. stable hydrogen release mechanics/logistics (regXboi, 17:07:37)
    1. http://www.apache.org/security/committers.html - how apache does it, many thanks to icbts (edwarnicke, 17:07:54)
    2. GiovanniMeo is going through dry runs of the release mechanics, when it passes, it will be a switch flip to cut the real artifacts (regXboi, 17:09:04)
    3. request from edwarnicke to understand the mechanics because today, only a project could cut its own artifacts (regXboi, 17:09:34)
    4. GiovanniMeo the new release mechanics cuts artifacts into a staging area and from there they will be promoted into the separate areas (regXboi, 17:11:21)
    5. edwarnicke points out that since this is a change to the previous process of a project being the only thing that could publish artifacts, the TSC should be involved (regXboi, 17:13:11)
    6. ACTION: GiovanniMeo agrees to send email to TSC when he's ready to go (regXboi, 17:13:36)
    7. edwarnicke now asks about how do we get to dates of the actual artifact cut... (regXboi, 17:13:56)
    8. regXboi notes email to all stable Hydrogen as next Tuesday as the date for release… but it hasn't gone out to a public list such as the "Discuss" list (phrobb, 17:15:45)
    9. also suggested to put the notice out on the dev lists of projects involved (phrobb, 17:16:14)
    10. ACTION: edwarnicke has the action item of sending the proposal of 6/24 as the stable-hydrogen date to -dev, discuss and tsc lists (regXboi, 17:16:15)
    11. ACTION: edwarnicke takes the action to do both (phrobb, 17:16:27)
    12. question for luis on how long they will need for testing - that needs to be hashed out off line (regXboi, 17:16:54)

  3. tsc charter update/modifications (regXboi, 17:17:22)
    1. CURRENT="If not otherwise represented, each Platinum member may designate a TSC member. This is expected to be a temporary measure and will be re-evaluated by the Board every year. Note that if a non-designated TSC member associated with a given Platinum member appears, the designated TSC member must step down immediately." (kwatsen, 17:18:04)
    2. http://www.opendaylight.org/project/tsc/charter (kwatsen, 17:18:18)
    3. PROP#1=CURRENT+", unless waived by a Super Majority vote of the Board prior to the precipitating event and for a specified amount of time, after which the designated TSC member must step down, unless the waiver is renewed." (kwatsen, 17:18:44)
    4. PROP#2=PROP#1+"In the case of elections, the commencement of the election is considered to be the precipitating event. In the case of a project being promoted to core, the proposal from its committers to be promoted is considered the precipitating event." (kwatsen, 17:19:30)
    5. question: what is a super majority? (regXboi, 17:20:13)
    6. answer: the current by-laws state that a super majority is 2/3rds (regXboi, 17:20:33)
    7. discussion of what is a "precipitating event" (regXboi, 17:22:39)
    8. http://www.opendaylight.org/project/bylaws defines super majority in 4.10(b) (colindixon, 17:22:59)
    9. ACTION: kwatsen to provide prop#1 and prop#2 as full text for review (regXboi, 17:25:25)
    10. point that a renewal will pierce the "veil of ignorance" (regXboi, 17:26:05)

  4. committer promotions: dave tucker to ovsdb (regXboi, 17:26:18)
    1. Dave Tucker to be committer of OVSDB : https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-June/000481.html (Madhu, 17:27:52)
    2. https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-June/000481.html for Dave Tucker to be committer of OVSDB (regXboi, 17:28:28)
    3. VOTE: Voted on "shall the TSC accept Dave Tucker as committer on ovsdb?" Results are, +1: 6 (phrobb, 17:28:57)
    4. AGREED: Dave Tucker as committer on ovsdb (regXboi, 17:29:53)

  5. committer promotions: devin avery, tom pantelis, moiz raja to committer on controller (regXboi, 17:30:21)
    1. https://lists.opendaylight.org/pipermail/controller-dev/2014-June/005084.html proposal for these promotions (regXboi, 17:31:19)
    2. edwarnicke waxes poetic for a while :-) (colindixon, 17:32:10)
    3. VOTE: Voted on "shall the TSC accept Devin Avery as committers to the Controller project?" Results are, +1: 7 (phrobb, 17:32:58)
    4. AGREED: Devin Avery to committer on controller (regXboi, 17:33:06)
    5. Congratulations to Devin Avery! (edwarnicke, 17:33:29)
    6. irc://irc.freenode.net:6667/#startvote shall the TSC accept Tom Pantelis as committers to the Controller project? -1, 0, +1 (phrobb, 17:33:48)
    7. VOTE: Voted on "shall the TSC accept Tom Pantelis as committers to the Controller project?" Results are, +1: 7 (regXboi, 17:34:28)
    8. AGREED: Tom Pantelis as committers to the Controller project (regXboi, 17:34:38)
    9. Congratulations Tom Pantelis! :) (edwarnicke, 17:34:43)
    10. VOTE: Voted on "shall the TSC accept Moiz Raja as committer on the Controller Project?" Results are, +1: 6 (regXboi, 17:35:25)
    11. AGREED: Moiz Raja as committer on the Controller Project (regXboi, 17:35:45)
    12. Congratulations to Moiz Raja! :) (edwarnicke, 17:35:53)

  6. TSC management approach/style (regXboi, 17:36:14)
    1. https://lists.opendaylight.org/pipermail/discuss/2014-June/002832.html the first mail in the related thread on discuss (colindixon, 17:37:38)
    2. lenrow (dave lenrow) comments that lots of people have pointed out that the TSC has generally taken a hands off approach to technical/architectural issues and some would like to see that be less hands off (colindixon, 17:39:47)
    3. https://lists.opendaylight.org/pipermail/tsc/2014-June/001304.html this appears to be the right email https://lists.opendaylight.org/pipermail/tsc/2014-June/001304.html (colindixon, 17:41:16)
    4. dmm: this needs to be discussed further on the list (regXboi, 17:42:04)
    5. lenrow asks if we want to consider having release requirements which can be used as a way to have a lever to lead/control technical and architectural issues (colindixon, 17:42:48)
    6. kwatsen points that best practices are within scope and so having a wiki page would be good (regXboi, 17:43:12)
    7. dmm there is an end user advisory council is being worked on now (regXboi, 17:43:40)
    8. dmm the projects are already use cases (regXboi, 17:43:52)
    9. not all of the projects are use cases, but some of them are (dmm, 17:45:07)
    10. a significant shift will occur in the TSC operation as we promote technical leads and committers into the council. I'm not sure a requirement spec will solve anything. (ChrisPriceAB, 17:45:51)
    11. regXboi notes that this topic has optics. For a mature community where the tsc is PTL of core projects, then the TSC for the next release can clearly articulate what is the target. regXboi asks how much of this is because the project is still imature? (phrobb, 17:46:26)
    12. controller has responded to use cases brought to it from other project (example: GBP requirements on scale and performance for clustering) (edwarnicke, 17:46:30)
    13. additionally I do agree the integration project should set (with guidance of the TSC) delivery quality metrics to be achieved to be considered releasable. (ChrisPriceAB, 17:46:51)
    14. edwarnicke notes that the controller project have responded to GBP and OVSDB project requests on controller. (phrobb, 17:47:55)
    15. openflowplugin has been working closely with ovsdb on meeting their requirements (edwarnicke, 17:48:16)

  7. Meeting our commitments to the community re:Helium (phrobb, 17:50:02)
  8. meeting community commitments in Helium (colindixon, 17:50:02)
    1. edwarnicke one example is that we could ask the community for ways we could improve the release process, e.g., milestones, and figure out what we could do better rather than copying and pasting (colindixon, 17:51:30)
    2. edwarnicke asks are there more questions we should be asking the community re the plan for Lithium? Is a larger gap between release and M0 needed? If so, what would be done then, etc (phrobb, 17:51:46)
    3. edwarnicke’s core comment is that we should ask “what could we have done better?” and could we work through them because it’s unlikely we got it all right on the first try (colindixon, 17:53:46)
    4. foresight for planning is needed for the dev community. We (the TSC) hasn't yet analyzed the milestones, their length, etc, for the best release cycle (phrobb, 17:54:15)
    5. ACTION: regXboi will send a mail to the list starting the discussion about how we might change the release process to better serve the community (starting with lithium) (colindixon, 17:54:49)

  9. Things we could add to the creation review template to allow for smoother on boarding of projects (colindixon, 17:55:07)
    1. edwarnicke (and regXboi and tykeal) have held a lot of people’s hands as they got projects up and running, and tykeal suggested that there could be correct information in the creation review template that would ease things, e.g., initial committer lists should include their ODL user name (colindixon, 17:56:29)
    2. first target simultaneous release project might be something to add. current assption is "next release" which may not be true. (ChrisPriceAB, 17:56:33)
    3. The initial committers of projects sometimes don't have an account on the system and/or their emails did not match accounts in the build system (phrobb, 17:56:35)
    4. the ask is that committers for projects document their account and email on the project proposal page (phrobb, 17:57:05)
    5. dmm asks are there more items that can make the onboarding process go smoothly (phrobb, 17:57:56)
    6. regXboi suggests that we ask new opboarding committers and projects what went well, what didn't so that we can continue to refine the onboarding process (phrobb, 17:58:41)
    7. ACTION: regXboi to update the project proposal page with the account and email data for committers (phrobb, 17:59:16)

  10. Lithium Release Logistics (phrobb, 18:02:50)
    1. ACTION: regXboi will propose release vehicles for lithium to the discuss list (colindixon_, 18:03:57)
    2. regXboi notes that there are commitments of the TSC for planning the Lithium release that need to be done (phrobb, 18:04:03)
    3. edwarnicke points out one good thing to keep in mind is that in hydrogen and helium we found a good, happy place for every project (colindixon_, 18:05:00)
    4. regarding initial question on test time for stable release, it will be < 1 hour (it is all automated) (LuisGomez, 18:06:23)


Meeting ended at 18:06:29 UTC (full logs).

Action items

  1. cdub gets the job of mocking up a security response page for ODL
  2. along with edwarnicke and phrobb
  3. GiovanniMeo agrees to send email to TSC when he's ready to go
  4. edwarnicke has the action item of sending the proposal of 6/24 as the stable-hydrogen date to -dev, discuss and tsc lists
  5. edwarnicke takes the action to do both
  6. kwatsen to provide prop#1 and prop#2 as full text for review
  7. regXboi will send a mail to the list starting the discussion about how we might change the release process to better serve the community (starting with lithium)
  8. regXboi to update the project proposal page with the account and email data for committers
  9. regXboi will propose release vehicles for lithium to the discuss list


Action items, by person

  1. edwarnicke
    1. along with edwarnicke and phrobb
    2. edwarnicke has the action item of sending the proposal of 6/24 as the stable-hydrogen date to -dev, discuss and tsc lists
    3. edwarnicke takes the action to do both
  2. GiovanniMeo
    1. GiovanniMeo agrees to send email to TSC when he's ready to go
  3. kwatsen
    1. kwatsen to provide prop#1 and prop#2 as full text for review
  4. phrobb
    1. along with edwarnicke and phrobb
  5. regXboi
    1. regXboi will send a mail to the list starting the discussion about how we might change the release process to better serve the community (starting with lithium)
    2. regXboi to update the project proposal page with the account and email data for committers
    3. regXboi will propose release vehicles for lithium to the discuss list


People present (lines said)

  1. regXboi (57)
  2. phrobb (29)
  3. colindixon (22)
  4. odl_meetbot (21)
  5. edwarnicke (15)
  6. ChrisPriceAB (13)
  7. kwatsen (10)
  8. lenrow (7)
  9. dmm (7)
  10. alagalah (7)
  11. IvanWood (7)
  12. colindixon_ (7)
  13. rexpugh-HP (2)
  14. rovarga (1)
  15. icbts (1)
  16. tbachman (1)
  17. LuisGomez (1)
  18. Madhu (1)
  19. GiovanniMeo (1)


Generated by MeetBot 0.1.4.