#opendaylight-meeting: TSC Weekly Meeting

Meeting started by phrobb at 17:01:29 UTC (full logs).

Meeting summary

    1. regXboi (regXboi, 17:01:44)
    2. Ed Warnicke (edwarnicke, 17:01:47)
    3. Kent Watsen (kwatsen, 17:02:03)
    4. dmm is on phone, not on IRC (regXboi, 17:02:12)
    5. David Bainbridge (dbainbri, 17:02:19)
    6. now recording (regXboi, 17:02:36)
    7. https://meetings.webex.com/collabs/meetings/join?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB - webex (edwarnicke, 17:02:38)

  1. agenda bashing (regXboi, 17:02:43)
    1. light meeting - aiming to end after 60 minutes today (regXboi, 17:03:24)
    2. chris wright (cdub, 17:03:55)
    3. TSC Charter Update pushed to next week: no update (regXboi, 17:04:06)
    4. question about programming languages? answer: kept to more general architectural discussions (regXboi, 17:06:19)

  2. network management using hierarchical domains patent (regXboi, 17:06:35)
    1. http://www.google.com/patents/US8078707 (regXboi, 17:06:44)
    2. kwatsen is declaring potential IPR here (regXboi, 17:07:45)
    3. proposal is for the LF's counsel to look at this to see how it impacts the project (regXboi, 17:08:21)
    4. edwarnicke discusses the difference between ietf and ODL and how this declaration is a really *good* thing (regXboi, 17:08:59)
    5. Rob Dolin proxy for Rajeev Nagar (Microsoft) (RobDolin, 17:09:02)
    6. ACTION: phrobb to discuss patent and it's impact on ODL development (phrobb, 17:09:05)
    7. lenrow asks what to do about proceeding (regXboi, 17:10:48)
    8. dmm's personal opinion is to keep on keeping on (regXboi, 17:11:04)
    9. regXboi +1's that (regXboi, 17:11:22)
    10. edwarnicke +1 (edwarnicke, 17:11:33)
    11. lenrow +1 (regXboi, 17:11:48)

  3. OF-1.3 AD-SAL plugin (regXboi, 17:12:34)
    1. https://lists.opendaylight.org/pipermail/discuss/2014-June/002801.html (regXboi, 17:12:40)
    2. the question from dmm is what type of oversight should the TSC provide (regXboi, 17:13:51)
    3. regXboi notes that this is open source and if someone wants to write and AD-SAL support for OF1.3, then it will happen (phrobb, 17:16:11)
    4. adsal of1.3 grew out of sdn hub desire to make odl accessible to application developers (e.g. base for hackfest activities) (cdub, 17:20:26)
    5. edwarnicke would like to have a focused effort on MD-SAL painpoints to make them better (phrobb, 17:23:13)
    6. dbainbri points out that while there are things that let the resources flow where they may, but other things where there needs to be direction (regXboi, 17:23:54)
    7. dbainbri says SAL is something where there needs to be direction (regXboi, 17:24:37)
    8. mlemay gives a +1 (regXboi, 17:25:50)
    9. relevant TSC Charter: "the TSC is responsible for simultaneous release dates, release quality standards, technical best practices (including the Development Process), monitoring technical progress, mediating technical conflicts between Committers and project leads, and organizing inter-project collaboration." (cdub, 17:26:58)
    10. dmm suggests that we need to find consensus what the long term direction for core functions are and if people want to work on that, they will, but if others want to pursue a different path, they can (phrobb, 17:28:02)
    11. dmm and regXboi note that currently the ADSAL and MDSAL are better at different tasks (phrobb, 17:34:14)
    12. Madhu notes that ADSAL is easier to use for app-type devs and the MDSAL is richer and more appealing to core ODL developers (phrobb, 17:37:18)
    13. lenrow wants to understand what actual remedies are "in scope" for TSC strong steering? i.e. when should the TSC mandate... (regXboi, 17:38:24)
    14. Lenrow asks for a TSC topic of "what guidance the TSC can or cannot give to the community" (phrobb, 17:38:35)
    15. thomas kee describing his experience with doing a PoC in AD-SAL and then moving to MD-SAL (regXboi, 17:40:50)
    16. ACTION: continue this discussion on the mailing list for another week because no consensus has emerged. (regXboi, 17:41:26)
    17. dmm notes that there is no clear consensus on this topic, so more discussion on the list is needed (phrobb, 17:41:57)
    18. dbainbri asks can we get to consensus with just more discussion on the list? How can we drive to closure? (phrobb, 17:42:42)
    19. :-) (phrobb, 17:43:20)
    20. all recognize that MDSAL is very complex for new app devs wanting to build something for ODL (phrobb, 17:48:10)
    21. cdub notes that we have incubated code and that is what we are releasing and we should consider the release process and what we (the TSC) recommend what goes into them (phrobb, 17:50:29)
    22. dmm suggests getting people together for release-guidelines (possibly for post Helium or later) to explore what those guidelines would be (phrobb, 17:56:36)


Meeting ended at 17:58:50 UTC (full logs).

Action items

  1. phrobb to discuss patent and it's impact on ODL development
  2. continue this discussion on the mailing list for another week because no consensus has emerged.


Action items, by person

  1. phrobb
    1. phrobb to discuss patent and it's impact on ODL development


People present (lines said)

  1. regXboi (41)
  2. phrobb (21)
  3. cdub (20)
  4. lenrow (10)
  5. edwarnicke (9)
  6. odl_meetbot (7)
  7. dbainbri (7)
  8. Madhu (6)
  9. tbachman (4)
  10. kwatsen (2)
  11. mlemay_ (1)
  12. RobDolin (1)
  13. robdolin (0)


Generated by MeetBot 0.1.4.