#opendaylight-meeting: TWS

Meeting started by phrobb at 17:04:06 UTC (full logs).

Meeting summary

    1. https://wiki.opendaylight.org/view/CrossProject:Helium_Release_Vehicle_Brainstorming:Pure_Karaf (phrobb, 17:11:01)
    2. https://lists.opendaylight.org/pipermail/discuss/2014-July/003142.html (phrobb, 17:13:15)
    3. the two links are the Karaf Brainstorming and the email from Luis G. on Testing needs for Karaf Release of ODL (phrobb, 17:13:54)
    4. https://wiki.opendaylight.org/view/CrossProject:Helium_Release_Vehicle_Brainstorming:Pure_Karaf#Testing_Strategy (icbts, 17:14:38)
    5. do we have PAX-EXAM templates?… Yes we do (phrobb, 17:14:48)
    6. even for small projects will mlemay help them one by one, or some other way?… mlemay is expecting to do it one by one (phrobb, 17:32:08)
    7. ACTION: mlemay and phrobb to contact each project for offering help in getting karaf set up for them… mlemay to provide a skeleton feature patch and pax-exam setup for each project (phrobb, 17:33:39)
    8. Q; to come up with a feature template, we need to know the dependencies? Bundle-level dependency vs feature-level dependency. For karaf, we need to understand the feature dependencies. (phrobb, 17:35:45)
    9. Need to get tooling to help with cross-project dependencies beyond what we have now (phrobb, 17:36:20)
    10. one of the hardest parts thus far has been to understand and document all of the dependencies… there are 35 to 40 features defined within the controller currently (phrobb, 17:37:21)
    11. Q; What will the interface look like when the user cherrypicks the features they want?… A: there are a few ways to do it; there is online/offline, there is a dlux interface (for features within controller), define a config profile, etc. (phrobb, 17:41:53)
    12. , two distinctions: What is installed, vs what is available to be installed (phrobb, 17:42:42)
    13. having a stablility-based repo would also be very advantageous… stable, unstable, experimental, etc… (phrobb, 17:43:18)
    14. mlemay notes having a stability lifecycle for each feature would b every helpful (phrobb, 17:44:03)
    15. Conflicting feature testing… for ones already known, the projects can define. Integration testing with putting everything together will find [many] more conflicting issues. (phrobb, 17:45:09)
    16. conflict mgmt will be managed by adding metadata to each feature to call out learned conflicts (phrobb, 17:46:02)
    17. luis proposes a weekly update on Karaf progress (phrobb, 17:46:54)
    18. Brent asks that we have a weekly Karaf sync at the TWS meeting (phrobb, 17:48:27)
    19. there has been a change in how OF1.0 and OF1.3 are specified in the run.sh file. For Helium, OF1.3 is the default. If you want OF1.0, then you must specify of1.0 on the run.sh CLI (phrobb, 17:53:19)


Meeting ended at 18:03:07 UTC (full logs).

Action items

  1. mlemay and phrobb to contact each project for offering help in getting karaf set up for them… mlemay to provide a skeleton feature patch and pax-exam setup for each project


Action items, by person

  1. phrobb
    1. mlemay and phrobb to contact each project for offering help in getting karaf set up for them… mlemay to provide a skeleton feature patch and pax-exam setup for each project


People present (lines said)

  1. phrobb (28)
  2. odl_meetbot (5)
  3. icbts (3)
  4. colindixon (0)


Generated by MeetBot 0.1.4.