#opendaylight-meeting: TWS Call

Meeting started by regXboi at 17:01:58 UTC (full logs).

Meeting summary

  1. Karaf in OpenDaylight & Hands-On demo on developing ODL components for Karaf Runtime - Mathieu Lemay (Madhu, 17:03:06)
    1. we are working in the background to get mlemay's slides onto the wiki and the #link into the meeting minutes (regXboi, 17:04:48)
    2. regXboi thanks networkstatic for running with that item (regXboi, 17:05:04)
    3. will cover Karaf, the ODL karak distribution, and hands-on demo & tips (tbachman, 17:06:14)
    4. s/karak/karaf/ (tbachman, 17:06:25)
    5. recap that Karaf is a bunch of “goodies and utiliities around an OSGi container” (tbachman, 17:07:23)
    6. karaf being a set of tools (console, logging, deployer, provisioning, admin, blueprint) on top of OSGi (regXboi, 17:07:32)
    7. karaf allows for bundles to be grouped into functional units (regXboi, 17:08:56)
    8. It is a replacement for the distribution folders currently being used in all the projects (tbachman, 17:09:31)
    9. as an alternative to a param pom (regXboi, 17:09:37)
    10. s/param/parent/ (regXboi, 17:09:45)
    11. question is the code snippet part of a specific file or is it an example (regXboi, 17:11:03)
    12. answer: this is just an example to illustrate versioning and dependencies between features (regXboi, 17:11:25)
    13. Features have their own versioning (tbachman, 17:11:41)
    14. and how bundles are pulled together into a feature (regXboi, 17:11:48)
    15. http://karaf.apache.org/manual/latest/users-guide/provisioning.html documentation on features (icbts, 17:11:57)
    16. question: so where is this feature file from? (regXboi, 17:12:00)
    17. mlemay answers his preference to build it manually... (regXboi, 17:12:24)
    18. question: how to use karaf in a specific case (ovsdb I think) (regXboi, 17:13:49)
    19. Mathieu Lemay Karaf presentation https://wiki.opendaylight.org/images/7/7e/Karaf-Discussion-TWS-June2-2014-Lemay.pdf (networkstatic, 17:14:08)
    20. https://wiki.opendaylight.org/images/7/7e/Karaf-Discussion-TWS-June2-2014-Lemay.pdf slies that mlemay is using (colindixon, 17:14:28)
    21. http://karaf.apache.org/manual/cave/latest/overview.html Cave overview for OBR (icbts, 17:15:33)
    22. API vs Impl versioning (icbts, 17:15:55)
    23. feature dependencies vs bundle dependencies (icbts, 17:16:22)
    24. can a bundle depend on a feature? answer: not clear how to do bundle-to-bundle dependencies (regXboi, 17:16:51)
    25. followup Q. If one wanted to do an OVSDB feature, it could depend on other features and bundles and when the OVSDB feature is installed, then all get installed (regXboi, 17:19:18)
    26. feature dependencies option 1. the feature file (xml) you can "deploy" to deploy folder at runtime to take effect (networkstatic, 17:19:45)
    27. feature dependencies option 2. you prepackage your feature file as part of ODL (Karaf) distribution by placing it into Karaf system folder under your package. this way you can add your feature for featuresBoot. this way it will be started automatically when ODL / Karaf starts (networkstatic, 17:19:45)
    28. feature dependencies option 3. you load your feature file from Karaf console or via Client command from Maven repo or File (networkstatic, 17:19:45)
    29. HELP: (regXboi, 17:23:21)
    30. HELP: question (regXboi, 17:23:30)
    31. OBR doesn't provide automatic Feature dependency resolution. it is bundle by bundle. (Madhu, 17:26:09)
    32. https://bugs.opendaylight.org/enter_bug.cgi?product=controller (networkstatic, 17:29:34)
    33. the management features SSH console & JMX is also available in the non-karaf version using the gogo and JXM access. (Madhu, 17:31:19)
    34. but Karaf comes prepackaged with all these. (Madhu, 17:31:31)
    35. question: how to change users/groups/roles on the fly (regXboi, 17:33:24)
    36. answer is that it either comes from the shell or via JAAS infra (regXboi, 17:33:47)
    37. . colindixon : its deafening when networkstatic and regXboi talks ;) (Madhu, 17:35:58)
    38. edwarnicke question: projects find the ability to try things out via a distribution directory. what is the correct way to maintain that ability within karaf? (regXboi, 17:39:39)
    39. answer: define a feature with a dependency on the base distro (regXboi, 17:40:03)
    40. answer: alternatively, one can depend on a lightweight distribution (regXboi, 17:41:01)
    41. more followup Qs and As on this, but nothing that appears to change the base statement (regXboi, 17:42:20)
    42. networkstatic suggestsion making videos showing how to migrate to karaf (colindixon, 17:44:42)
    43. ACTION: mlemay says he’d love to (colindixon, 17:44:51)

  2. discussion of tenants (regXboi, 17:44:52)
    1. dlenrow giving presentation on strawman proposal for tenants (tbachman, 17:45:39)
    2. https://git.opendaylight.org/gerrit/#/c/6756/ Ed's Karaf commit for openflowjava (networkstatic, 17:45:56)
    3. Base Assumptions: ODL should present a tenant-aware NBI, and ODL should provide NVaaS (tbachman, 17:47:12)
    4. NVaas: Network Virtualization as a Service (tbachman, 17:47:30)
    5. cdub asks about difference between proposal and Neutron API (tbachman, 17:48:15)
    6. Question: how is NVaaS different from neutron? (regXboi, 17:48:23)
    7. colindixon notes that Neutron might be a good starting point for this. (tbachman, 17:48:29)
    8. point of this presentation is to set down some ideas of what a tenant means (regXboi, 17:49:08)
    9. push back that neutron is IT centric view... (regXboi, 17:49:27)
    10. edwarnicke notes that tenant means different things to different people (tbachman, 17:49:35)
    11. https://wiki.opendaylight.org/view/File:TWS-ODL-tenancy-2014-06-02.pptx the slides being used (colindixon, 17:50:02)
    12. Tenancy in this context is an overlay (tbachman, 17:50:51)
    13. regXboi raises the question as to how this will play into the current “tenancy” and network virtualization solutions at the bottom, e.g., OpenDOVE, VTN, OVSDB (colindixon, 17:56:27)
    14. Madhu asks if we can use a different word than overlay (tbachman, 17:56:55)
    15. the answer w.r.t. existing tenant-oriented things is that this is more to try to have a unified construct to talk about tenants beyond virtual networks (Neutron) (colindixon, 17:58:18)
    16. colindixon notes that the way that this is different from existing tenant notions is that those are about virtual networks, (tbachman, 18:00:23)
    17. colindixon notes that we need a way of talking about tenancy from other perspectives, such as in the context of AAA (tbachman, 18:01:08)
    18. and (for above) in the _helium_ timeframe (cdub, 18:01:35)


Meeting ended at 18:10:37 UTC (full logs).

Action items

  1. mlemay says he’d love to


Action items, by person

  1. mlemay
    1. mlemay says he’d love to


People present (lines said)

  1. regXboi (64)
  2. networkstatic (40)
  3. tbachman (30)
  4. colindixon (20)
  5. readams (19)
  6. Madhu (14)
  7. icbts (8)
  8. cdub (8)
  9. odl_meetbot (7)
  10. edwarnicke (3)
  11. mlemay (1)
  12. imcharly (1)


Generated by MeetBot 0.1.4.