#opendaylight-meeting: TWS call

Meeting started by Madhu at 17:02:31 UTC (full logs).

Meeting summary

  1. discussion on stable/hydrogen release (Madhu, 17:08:17)
    1. the auto-release code is used for weekly releases as well as the hydrogen stable release (colindixon, 17:08:43)
    2. https://docs.google.com/a/colindixon.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0 this is the google doc tracking the hydrogen stable release (colindixon, 17:09:48)
    3. discussion on https://lists.opendaylight.org/pipermail/release/2014-July/000089.html (Madhu, 17:09:54)
    4. the current autorelease provides a way for staging it (Madhu, 17:12:13)
    5. the auto-release project pushes artifacts to a staging nexus which nobody directly relies on, so it can be blown away, doesn’t break anything, and doesn’t require project permissions for every project to run (this is all good) (colindixon, 17:12:26)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=1402 (GiovanniMeo, 17:12:33)
    7. https://github.com/giovannimeo/autorelease currently, this is the autorelease code which is hosed in GiovanniMeo’s github rather than inside ODL because there’s not a logical home for it at the moment (colindixon, 17:14:43)
    8. Git Bundle : http://git-scm.com/docs/git-bundle (Madhu, 17:18:42)
    9. the odlautorelease job doesn't push the tags to all the projects participating in that auto release (Madhu, 17:20:30)
    10. the tag is not pushed because the user running the odlautorelease may not have the privileges (Madhu, 17:20:51)
    11. - there is one other issue here (edwarnicke, 17:21:39)
    12. - when we do *releases* the *release* tag probably shouldn't be pulled to the git repo until its *actually* the release (edwarnicke, 17:22:05)
    13. git bundle, listed above, makes it possible to ship the entire git repository as a single file and this can be pushed into the nexus—this allows us to get around the fact that we can’t push tags into projects, but still record the exact state of the repo that produced and autorelease (colindixon, 17:26:13)
    14. mlemay asks about the build order (edwarnicke, 17:28:42)
    15. the build order is currently hard-coded in the odlautorelease. (Madhu, 17:28:46)
    16. GiovanniMeo build order is manual (edwarnicke, 17:28:55)
    17. hideyuki : does odlautorelease automatically update versions for each project from 0.1.0.1-SNAPSHOT to 0.1.0-2-SNAPSHOT? (Madhu, 17:31:42)
    18. hideyuki : does odlautorelease automatically update versions for each project from 0.1.0-1-SNAPSHOT to 0.1.0-2-SNAPSHOT? (hideyuki, 17:32:45)
    19. GiovanniMeo's answer : for master this version bump is done automatically by maven-version plugin. while the stable/hydrogen branch needs some work and can be patched by a minor fix. (Madhu, 17:34:37)
    20. regXboi really wants this to become it's own project with a release team to provide extra hands and eyes ... (regXboi, 17:35:21)
    21. GiovanniMeo suggests to keep it as a system script and handled by LF (tykeal) :-) (Madhu, 17:35:45)
    22. Madhu asks when are we actually going to release the hydrogen stable release? We’ve been slipping for weeks and things seem to be stalled. (colindixon, 17:37:09)
    23. we are looking for +1 from projects in : https://docs.google.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0 (Madhu, 17:37:26)

  2. Helium documentation (Madhu, 17:46:14)
    1. ACTION: colindixon to work with ed warnicke to document best practices around notifying projects of required responses (and possibly some other things that will help smooth releases). Some suggestions are specifying exactly what primary contacts need to pay attention to and the expected response time. Also suggestions around words in subject lines that will attract attention. (colindixon, 17:47:36)
    2. Mathieu Lemay talks about how to get documentation back on track (colindixon, 17:52:01)
    3. we need atleast 1 responsible person from each project to signup for project docs. (Madhu, 17:52:30)
    4. Mathieu will send out a small guide and go over that in the Docs meeting to happen on Wednesday 07/23 (Madhu, 17:52:54)


Meeting ended at 18:02:26 UTC (full logs).

Action items

  1. colindixon to work with ed warnicke to document best practices around notifying projects of required responses (and possibly some other things that will help smooth releases). Some suggestions are specifying exactly what primary contacts need to pay attention to and the expected response time. Also suggestions around words in subject lines that will attract attention.


Action items, by person

  1. colindixon
    1. colindixon to work with ed warnicke to document best practices around notifying projects of required responses (and possibly some other things that will help smooth releases). Some suggestions are specifying exactly what primary contacts need to pay attention to and the expected response time. Also suggestions around words in subject lines that will attract attention.


People present (lines said)

  1. colindixon (23)
  2. Madhu (22)
  3. edwarnicke (16)
  4. cdub (14)
  5. GiovanniMeo (12)
  6. odl_meetbot (6)
  7. abhijitkumbhare (6)
  8. regXboi (4)
  9. hideyuki (4)
  10. dbainbri (2)
  11. phrobb (0)


Generated by MeetBot 0.1.4.