#opendaylight-meeting: Weekly MD-SAL Call

Meeting started by colindixon at 16:06:30 UTC (full logs).

Meeting summary

  1. status update (colindixon, 16:07:30)
    1. all the data store improvements are checked in from rovarga_ (colindixon, 16:12:47)
    2. Moiz says that work continous on PoC on Akka clustered data store, they would like to present again next week (colindixon, 16:14:21)
    3. jquery for MD-SAL is ongoing with colindixon and Neel_B (colindixon, 16:14:42)
    4. looking through bugs that have been merged, this includes 1120, 724, (others in the minutes) (colindixon, 16:20:22)
    5. a discussion of what should happen to get a patch merged goes on, the consensus is that you need to add a committer as a reviewer to get their attention, currently that is edwarnicke, ttkacik, and rovarga_ (it seems) (colindixon, 16:22:21)
    6. edwarnicke says to whack him upside the head if there’s a patch that seems to be atrophying (colindixon, 16:25:17)
    7. flaviof asks is drafts are better than “DO NOT MERGE” patches, but edwarnicke and colindixon note that drafts are not visible except to people who are directly added as reviewers, so they’re different (colindixon, 16:26:24)
    8. ACTION: edwarnicke to start a thread on the mailing list about how to get your patches in (or delegate it) (colindixon, 16:28:25)

  2. big things coming up (colindixon, 16:29:27)
    1. people (rovarga_ and ttkacik) are removing more xtend from things and people are reviewing them (colindixon, 16:30:38)

  3. conversation about use of Akka (colindixon, 16:36:34)
    1. Madhu asks if Akka is a must (as was stated on the mailing list) or merely a good choice (colindixon, 16:36:47)
    2. people say that it’s just a really good fit/choice for the cluster/persistence (colindixon, 16:37:08)

  4. bug scrub (colindixon, 16:38:27)
    1. see bug lists for results (we went through ones for md-sal, netconf, and yangtools) (colindixon, 16:43:07)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=1125 - just added this into the pile. Its a nice small good example of how to dig into something and chase it down. (edwarnicke, 16:45:05)
    3. https://bugs.opendaylight.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&bug_status=VERIFIED&component=General&component=mdsal&component=netconf&product=controller&product=yangtools&query_format=advanced&resolution=---&order=bug_id%20DESC&query_based_on= the bug list (I think) (colindixon, 16:47:04)

  5. wrap-up (colindixon, 16:50:19)
    1. devinavery notes the bug scrub didn’t quite work as well as we might have hoped (we only made it through 2-3 bugs) (colindixon, 16:50:45)
    2. edwarnicke asks if IRC would be better (colindixon, 16:50:52)
    3. we’ll see what works for next week (colindixon, 16:51:06)

  6. review of controller release plan M2 deliverables (colindixon, 16:51:28)
    1. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Helium_Release_Plan edwarnicke walks through this to figure out what M2 deliverables are there (colindixon, 16:54:20)
    2. ACTION: edwarnicke will aggregate these results and present/note them later (colindixon, 16:56:10)


Meeting ended at 17:05:25 UTC (full logs).

Action items

  1. edwarnicke to start a thread on the mailing list about how to get your patches in (or delegate it)
  2. edwarnicke will aggregate these results and present/note them later


Action items, by person

  1. edwarnicke
    1. edwarnicke to start a thread on the mailing list about how to get your patches in (or delegate it)
    2. edwarnicke will aggregate these results and present/note them later


People present (lines said)

  1. colindixon (35)
  2. edwarnicke (5)
  3. flaviof (5)
  4. odl_meetbot (5)
  5. Madhu (3)
  6. devinavery (2)
  7. liemmn (2)
  8. dfarrell07 (2)
  9. readams (1)
  10. moizer (1)


Generated by MeetBot 0.1.4.