#opendaylight-meeting: Weekly TSC Meeting

Meeting started by phrobb at 16:57:41 UTC (full logs).

Meeting summary

  1. TSC Members Please #info in upon arrival (roll call) (phrobb, 16:58:09)
    1. dmm (dmm, 16:58:16)
    2. regXboi (IBM today) (regXboi, 16:58:22)
    3. Chris Wright (cdub, 17:00:52)
    4. https://wiki.opendaylight.org/view/TSC:Main (dmm, 17:02:00)
    5. the above is the agenda link for the minutes (regXboi, 17:02:05)
    6. Ed Warnicke (edwarnicke, 17:02:36)

  2. Agenda Bashing (phrobb, 17:06:02)
    1. https://wiki.opendaylight.org/view/TSC:Main <- Agenda on wiki (RobDolin, 17:06:23)

  3. Release Manager (phrobb, 17:07:24)
    1. Phil Robb reported that there are a couple of folks from Huawei who are interested in helping with Release Management (RobDolin, 17:08:05)
    2. planning a f2f on 6pm Tuesday at the OpenStack summit (regXboi, 17:08:19)
    3. phrobb will make information public when available (regXboi, 17:08:29)

  4. Helium Simultaneous Release Plan (regXboi, 17:08:44)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects (edwarnicke, 17:09:18)
    2. 4/30 deadline for new projects was yesterday - leading to a not-unexpected flurry of new projects (regXboi, 17:10:19)
    3. next milestone: 5/12 (M1) projects to have release plans and declare intent to participate (regXboi, 17:11:13)
    4. robdolin asked about the race condition of 5/12 for M1 vs 5/14 for project approval (regXboi, 17:11:43)
    5. edwarnicke answered that the TSC would exercise their discretion to make the race condition go away (regXboi, 17:12:08)
    6. Dave Lenrow asked about the race condition. (RobDolin, 17:12:13)
    7. AAA Service would like to be project reviewed on 5/15 TSC call. Will Email list. (lenrow, 17:13:41)
    8. note to TSC members to plan travel around 5/15 meeting as there will be creation reviews (regXboi, 17:15:56)
    9. because of it being the week of OpenStack (regXboi, 17:16:14)
    10. TSC members encourages project proposers to attend the TSC meeting when their project will be reviewed (RobDolin, 17:16:40)

  5. Lithium Release Plan/Venues (regXboi, 17:17:01)
    1. Kent Watsen (kwatsen, 17:17:32)
    2. Phil Robb - Ran into a conflict with June _2015_ date (RobDolin, 17:17:39)
    3. phrobb reports that the summit date is changing from 6/7/2015 to a new target of the week of 6/15/2015 (regXboi, 17:17:55)
    4. looking to lock down the Santa Clara Hyatt for that target week (regXboi, 17:18:23)

  6. Integration Projects containing distributions other than Release Vehicles (regXboi, 17:18:57)
    1. That is correct Abhijit. The 4/30 is for new projects to come forward for the two week period before their creation review (phrobb, 17:19:52)
    2. https://lists.opendaylight.org/pipermail/discuss/2014-April/002205.html - Discussion about integration keeping distributions other than Release Vehicles. (edwarnicke, 17:20:01)
    3. Chris Price joined (ChrsPriceAB, 17:24:47)
    4. regXboi suggests, that if we change release vehicles for Helium should we take the existing release editions for Hydrogen as a place for them (phrobb, 17:24:51)
    5. regXboi thinks that "hydrogen_release" might be even better (regXboi, 17:25:30)
    6. this discussion is probably best to go back to the list (regXboi, 17:28:39)
    7. discussion ensues on how best to manage distributions, release vehicles, and releases (New and stable/maintenance). (phrobb, 17:28:54)
    8. as there are mulitple ways to "skin the cat" (regXboi, 17:28:55)
    9. Madhu comments about release vehicles versus stable branches versus (regXboi, 17:30:12)
    10. edwarnicke drags the question back to the TSC issue (regXboi, 17:31:17)
    11. issues kicks and screams in response (edwarnicke, 17:31:41)
    12. which is that this is up to the integration project (regXboi, 17:31:52)
    13. dmm says we need to have more discussion (regXboi, 17:38:58)
    14. edwarnicke says that's around the minuta but not around the basic question (regXboi, 17:39:21)
    15. madhu is concerned about a particular user's request for a new distribution and who decides whether it gets in or not (regXboi, 17:39:56)
    16. dmm says let's move this to the TSC mailing list (regXboi, 17:41:02)
    17. propose: integration has leeway, we request integration to maintain clarity re: which are "blessed", tsc arbitrates release vehicles (latter part is what we already do afaik) (phrobb, 17:46:12)
    18. AGREED: on the proposal above (phrobb, 17:47:03)

  7. TSC charted text re:elections (regXboi, 17:47:39)
  8. TSC charter text re:elections (regXboi, 17:48:17)
    1. fixing the typo (regXboi, 17:48:25)
    2. https://lists.opendaylight.org/pipermail/tsc/2014-April/001089.html <- Phil Robb's email (RobDolin, 17:50:59)
    3. https://lists.opendaylight.org/pipermail/tsc/2014-April/001089.html (Phil's email) (dmm, 17:53:20)
    4. Ryan Moats (IBM) recommends "Option 1" with a proviso that Platinum member seats go away sometime in 2015 (RobDolin, 17:55:35)
    5. Please also note that the TSC does not have the power to rewrite this part of governance, but merely to send options to the board (edwarnicke, 17:57:26)
    6. phrobb notes that we don't have any core projects and therefore not a good way to build PTLs + developer representation on TSC, and unlikely to have significant change by apr 2015 (cdub, 18:02:05)
    7. dmm notes that he is conflicted on this issue. As a non-developer dmm would not be on TSC other than as a platinum designate (as the rules are currently written). (phrobb, 18:02:42)
    8. , dmm notes that the TSC has been asked to provide guidance on this topic. Suggests that option 1 (removal of the "if not otherwise represented" clause) has the most support currently (phrobb, 18:05:03)
    9. Project Technical Leaders (PTLs) for projects within OpenDaylight that are "Core" projects as defined by the Project Lifecycle [3] shall each have a seat on the TSC. Note that it does not matter what organization any of the PTLs come from. If the person is a PTL on a "Core" project, then they have a seat on the TSC regardless of company affiliation. There is only one PTL per project. (regXboi, 18:05:17)
    10. 1) So the first discussion/decision is to determine if there is a way to increase and improve the diversity of the technical community representation on the TSC, as is intended by the At-Large Committer positions, while preserving the strong leadership base already present within the existing TSC. (regXboi, 18:05:45)
    11. that's that correct option 1 (regXboi, 18:06:01)
    12. Option 1 -  Remove the "If Otherwise Not Represented" clause from the By-Laws and Charter document as it relates to Platinum Member designates to the TSC (phrobb, 18:06:33)
    13. suggestion made to trigger sunset of platinum designates on TSC - some number of Core projects in existence. (phrobb, 18:08:06)
    14. needs to step away for a few minutes (ChrsPriceAB, 18:09:36)
    15. back. (ChrsPriceAB, 18:13:11)
    16. proposal: take option 1 to board with the previso that platinum member seats be sunseted by a yet TBD trigger to allow the TSC to be more representative of the technical commnuity (regXboi, 18:15:32)
    17. vote results are 5 +1, 2 0, and 1 -1 : the vote carries (phrobb, 18:17:53)

  9. Creation Reviews: OpFlex (regXboi, 18:19:06)
    1. Corrected vote results: 5 yes (Dave, CP, Rob, Kent, CW), 1 no (Ryan), 1 abstain (Ed) (RobDolin, 18:19:08)
    2. https://wiki.opendaylight.org/view/Project_Proposals:OpFlex (dkehnx, 18:19:18)
    3. https://wiki.opendaylight.org/view/Project_Proposals:OpFlex (dmm, 18:19:37)

  10. Creation Review - OPFLEX (phrobb, 18:20:12)
    1. Q The policy agent written in C, why was it chosen?… A: because it may run in a switch or other types of devices (phrobb, 18:23:33)
    2. https://wiki.opendaylight.org/view/File:OpFlex_Policy_Agent_Proposal.png (abhijitkumbhare, 18:24:53)
    3. question: What are the observer & endpoint registry blocks in the diagram? (regXboi, 18:25:06)
    4. answer: these come from the ietf draft referred to in the proposal (regXboi, 18:25:32)
    5. ACTION: mestery to update scope from opflex protocol to opflext protocol library/impelmentation (regXboi, 18:28:26)
    6. AGREED: opflex to incubation (regXboi, 18:29:39)

  11. Hydrogen Stable Release (regXboi, 18:29:53)
    1. defense4all and snmp4sdn are not currently part of the hydrogen.1 release work - defense4all is not available, snmp4sdn is radio silent (regXboi, 18:31:10)
    2. projects are moving through the process, but there is a blocker in controller pom files that needs to be resolved so dependent projects can update version numbers (regXboi, 18:31:52)
    3. bgp-pcep has a patch dependency on controller (patch identified) and ovsdb has one as well (patch not identified) (regXboi, 18:32:23)
    4. conversation about release date went nowhere (i.e. no feedback) (regXboi, 18:32:50)
    5. target date looks to be out a week (regXboi, 18:32:59)
    6. we also have dependency issues from controller to yangtools and ofplugin to controller I believe (edwarnicke, 18:33:01)
    7. no time yet determined for when would be a good release date. cdub suggests we need at least a couple of weeks yet to get more consensus (phrobb, 18:33:05)
    8. open question for discussion on list: the current approach is to rev *all* artifacts, but an alternative approach is to rev only artifacts that changed (regXboi, 18:34:39)
    9. dmm asks since Hydrogen was a bit unique as the "first" release, how replicable is the stable release process/tooling for Helium and beyond? (phrobb, 18:35:08)
    10. dmm asks how replicatable is the hyrdogren approach - cdub says what's there is not applicable, especially if the root parent pom project is in use in helium (regXboi, 18:35:38)
    11. , cdub notes that this version of Stable branch creation is mostly a one-off (phrobb, 18:35:46)
    12. https://lists.opendaylight.org/pipermail/discuss/2014-April/002162.html <-- Hydrogen Stable Relase Date discussion (cdub, 18:37:54)


Meeting ended at 18:38:39 UTC (full logs).

Action items

  1. mestery to update scope from opflex protocol to opflext protocol library/impelmentation


Action items, by person

  1. mestery
    1. mestery to update scope from opflex protocol to opflext protocol library/impelmentation


People present (lines said)

  1. regXboi (65)
  2. phrobb (35)
  3. cdub (26)
  4. RobDolin (24)
  5. edwarnicke (20)
  6. alagalah (16)
  7. ChrsPriceAB (11)
  8. dmm (11)
  9. abhijitkumbhare (10)
  10. odl_meetbot (8)
  11. kwatsen (7)
  12. Madhu (5)
  13. rovarga (3)
  14. tbachman (3)
  15. readams (3)
  16. mlemay (2)
  17. lenrow (1)
  18. tnadeau (1)
  19. mrberner-mobile (1)
  20. dkehnx (1)
  21. mestery (1)


Generated by MeetBot 0.1.4.