#opendaylight-meeting: HoneyComb Overlay Layer and App Coexistence

Meeting started by edwarnicke at 14:03:53 UTC (full logs).

Meeting summary

  1. Waiting for folks to drift in... (edwarnicke, 14:04:01)
    1. gzhao (gzhao, 14:04:18)

  2. Rollcall - Please #info in (edwarnicke, 14:04:58)
    1. edwarnicke (edwarnicke, 14:05:02)
    2. colindixon (colindixon, 14:05:16)
    3. gzhao (gzhao, 14:05:16)

  3. Agenda Bashing (edwarnicke, 14:05:54)
    1. vina_ermagan (vina_ermagan, 14:05:58)
    2. Eric Multren, Yapeng Wu, Sam Hague, Sharad are on the phone. (gzhao, 14:06:37)
    3. perm, hemath (gzhao, 14:07:37)
    4. vishnoianil (vishnoianil, 14:09:42)

  4. Honeycomb (edwarnicke, 14:10:07)
    1. https://meetings.webex.com/collabs/meetings/join?uuid=MDHJCXR45WFFOUDWYX9FPOR0VK-9VIB (snackewm, 14:12:05)
    2. edwarnicke asks who is interested in doing concrete work on honeycomb related stuff (colindixon, 14:21:29)
    3. colindixon says there’s a difference between “interested” and “having cycles to do it" (colindixon, 14:21:40)
    4. edwarnicke says he’s been playing with how to tune down the memory usage of OpenDaylight (colindixon, 14:22:03)
    5. if you want to tweak the amount of RAM it’s located at target/assembly/bin/setenv (colindixon, 14:23:40)
    6. edwarnicke says his experience is that he was able to get things down to 256 MB of RAM without problems as far as he could tell (colindixon, 14:24:20)
    7. colindixon says that this is likley to affect peformance, Java tends to have worse performance and less predictable performance when running with limited memory largely due to more frequent and challenging garbage collections (colindixon, 14:25:11)
    8. https://wiki.opendaylight.org/view/Controller_Core_Functionality_Tutorials:Tutorials:Netconf_Mount#Testing_against_ODL_itself_.28MD-SAL_netconf_northbound_loopback_mount.29 (edwarnicke, 14:25:25)
    9. https://wiki.opendaylight.org/view/Controller_Core_Functionality_Tutorials:Application_Development_Tutorial (edwarnicke, 14:26:21)
    10. it sounds like sharad has done some real things on testing honeycomb (colindixon, 14:27:37)
    11. colindixon, vina_ermagan, and Anil (but not vishnoianil) say they’re interested, but may or may not have tons of cylces (colindixon, 14:27:52)

  5. overlay layer (colindixon, 14:30:23)
    1. colindixon, vina_ermagan, and Anil (but not vishnoianil) say they’re interested, but may or may not have tons of cylces (colindixon, 14:30:25)
    2. edwarnicke says if your overlay layer only handles tunnels, but doesn’t handle things like just delivering something out a port, it’s likely to make things less useful (colindixon, 14:31:13)
    3. this is something alagalah origially brought up (colindixon, 14:31:32)
    4. vina_ermagan asks if the overlay layer should include renderers or not? (colindixon, 14:32:12)
    5. edwarnicke says that it should be done so that it’s not “welded” to any given rednerer or southbound (colindixon, 14:32:28)
    6. florinc and prem both want to participate in the overlay layer as well (colindixon, 14:36:13)
    7. ACTION: colindixon and vina_ermagan will touch base offline with others that are interested to try to prepare for future discussoins (colindixon, 14:37:38)
    8. vishnoianil is also interested in overlay layer (edwarnicke, 14:37:49)

  6. App Coexistence (edwarnicke, 14:37:55)
    1. there’s a lot of discussion here, not all of it is caputued in IRC, ther will be a WebEx recording (colindixon, 14:43:10)
    2. edwarnicke talks about ways to do this, says that alagalah suggested the idea of using metadata to allow different apps to get their own namespace in each switch (colindixon, 14:43:46)
    3. colindixon says there are two things we want to talk about here: (1) how we will actually realize app compisition in switches and (2) how we will provide abstractiosn for app compisition to apps (colindixon, 14:44:25)
    4. in colindixon’s opinion, the metadata appraoch is one good idea for (1), but likely not (2) (colindixon, 14:44:42)
    5. colindixon also says their are implications of using metadata because OF only allows you to forward in table numbers, so you may only be able to be processed by one app per pass through a switch, which has implications (colindixon, 14:45:17)
    6. Pre asks some questions about this approach and other things, including what we mean by metadata (colindixon, 14:48:57)
    7. edwarnicke and colindixon say that we mean metadata in the OF spec sense as a 64-bit (I think) matchable and settalbe value that follows a packet, but isn’t in the packet itself (colindixon, 14:49:26)
    8. Prem asks what about targeting particular implementatsions of services, I think in the context of being OF specific (colindixon, 14:51:12)
    9. edwarnicke says we’ve tried to avoid being implementation specific (colindixon, 14:51:45)
    10. Andre asks how he things things like Neutron and OVSDB NetVirt fit into all of this (colindixon, 14:52:10)
    11. edwarnicke says he hasn’t thought about it very much, but asks shague if he has (colindixon, 14:52:27)
    12. shague says that he hasn’t been able to quite grok the current approach enough to be able to have good, well-informed opinions here (colindixon, 14:52:59)
    13. edwarnicke says he thinks that Neutron doesn’t map directly or compeltely onto an overlay layer, it’s just doing more than that (colindixon, 14:54:58)
    14. colindixon notes that he missed lots of notes here, but there was a comment that he and vina_ermagan had discussed maybe have one common sort of layer that spans overlay, policy, and sfc that migth be able to be arbitrarily composed (colindixon, 15:00:00)


Meeting ended at 15:06:38 UTC (full logs).

Action items

  1. colindixon and vina_ermagan will touch base offline with others that are interested to try to prepare for future discussoins


Action items, by person

  1. colindixon
    1. colindixon and vina_ermagan will touch base offline with others that are interested to try to prepare for future discussoins
  2. vina_ermagan
    1. colindixon and vina_ermagan will touch base offline with others that are interested to try to prepare for future discussoins


People present (lines said)

  1. colindixon (37)
  2. edwarnicke (14)
  3. odl_meetbot (6)
  4. gzhao (4)
  5. vishnoianil (4)
  6. alagalah (3)
  7. yapeng (1)
  8. vina_ermagan (1)
  9. snackewm (1)
  10. shague (0)


Generated by MeetBot 0.1.4.