#opendaylight-meeting: nic

Meeting started by phrobb at 16:03:33 UTC (full logs).

Meeting summary

  1. project startup logistics (alagalah, 16:05:39)
    1. https://wiki.opendaylight.org/view/GettingStarted:Project_Main#New_Project_Checklist (ShaunWackerly, 16:06:15)
    2. dlenrow discusses various approaches such as 1. RP Lithium - whats achievable 2. Potentially push to Be and focus on the architecture (alagalah, 16:11:14)
    3. dlenrow proposes 3 deliverables for Li (alagalah, 16:12:34)
    4. dlenrow asks "should the NIC project consider joining the Li release or should we wait until Beryllium? (phrobb, 16:13:47)
    5. dlenrow asks for someone to own process of shepherding on the ML and then to a google doc a draft release plan that people can review and comment on (like by Tuesday of next week) (phrobb, 16:16:05)
    6. ACTION: uchau duane Mentze volunteer to lead the creation of a strawman NIC release plan for Li by next Tuesday (2/3) (phrobb, 16:17:52)
    7. https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan <-- NIC release plan draft (tbachman, 16:19:17)
    8. mlemay asks "how can we ensure a reliable end product of code?.. this is bigger than the NIC project (phrobb, 16:22:09)
    9. dlenrow agrees that ensuring quality is an ODL-wide concern to be addressed (phrobb, 16:22:44)
    10. uchau suggests we start breaking out into milestones internal from the simultaneous release (alagalah, 16:23:14)
    11. dlenrow suggests creation of internal project plan (alagalah, 16:23:33)
    12. dlenrow notes that early on we need a program manager type to stay on top of project internal plans (phrobb, 16:24:25)
    13. dlenrow asks the group how we will "manage" the NIC project? (phrobb, 16:26:03)
    14. uchau recommends Devon Dawson to be the program mgr and the crowd goes wild (phrobb, 16:27:54)
    15. dlenrow asks if folks want to edit a UML model in the team meeting or do it offline ? (alagalah, 16:29:15)
    16. mlemay says he’d like to discuss the architecture before going into the UML (tbachman, 16:29:58)
    17. mlemay would do this discussion through various collaboration tools (google hangout, docs, etc.) (tbachman, 16:30:19)
    18. mlemay suggests discussing the overall architecture before putting too much into UML. (phrobb, 16:30:33)
    19. dbainbri asks what mlemay means by arch (tbachman, 16:30:38)
    20. ACTION: uchau to ask Devon to send email to nic-dev volunteering for PL role (tbachman, 16:30:58)
    21. ShaunWackerly says that once we figure what the APIs are, we can work on the implementation behind that interface (tbachman, 16:31:58)
    22. mlemay says that some folks at the intent summit talked about DSL or process ID or languages vs. API — something that’s more run-time processing language (“maple-ish”). There are different approaches on what the NBI should be (tbachman, 16:32:38)
    23. fschneider says that clarity on multiple levels of info modeling behind data is important before fixing functional blocks in between (tbachman, 16:33:03)
    24. dlenrow asks if there’s a middle ground on this (tbachman, 16:33:28)
    25. ShaunWackerly asks if the runtime language is in the gdoc that Cathy sent out (tbachman, 16:34:04)
    26. mlemay says he doesn’t know if that was captured, but he knows some folks talked about it (ESNet, et. al.). (tbachman, 16:34:23)
    27. dlenrow says the maple folks weren’t able to present at the Intent summit — maybe can invite them to speak at this meeting (tbachman, 16:34:47)
    28. mlemay says coming up with the proper primitives and how to provide a proper runtime set of functionality for these primitives (tbachman, 16:35:14)
    29. The primitives can be pushed down into a more formal model of a service request within the controller (tbachman, 16:35:34)
    30. mlemay says group can continue with UML model if they want (tbachman, 16:35:46)
    31. dlenrow asks mlemay to take a first whack at the straw-man/block-diagram (tbachman, 16:36:06)
    32. fschneider asks if we can agree on one meeting to drive this forward (ONF vs. this one) (tbachman, 16:37:04)
    33. dlenrow says another thought is that the ONF and similar organizations are good at use case documentation, and ODL is good at building stuff. Given that, what do folks think of take the info modeling work and use one of the ONF/NBI calls as an interactive session for the info model, and save this call for arch/implementation. (tbachman, 16:38:54)
    34. ShaunWackerly didn’t kown there was an ONF meeting on this subject; asks if dlenrow can forward the information for the ONF meeting (tbachman, 16:39:36)
    35. dlenrow says he’s chair of the NBI working group, which has several sub-groups, is working on making this accessible (tbachman, 16:40:23)
    36. uchau says as long as we have one forum where we’re pulling things in — we just want to make sure we have a place where we consolidate the arch with the implementation (tbachman, 16:41:45)
    37. uchau recommends using the ODL NIC meeting to pull it all together (tbachman, 16:41:56)
    38. colindixon asks if the purpose of the Li release plan is to identify a model that can be understood by other projects with other feature aspirational, is that the plan? (phrobb, 16:47:58)
    39. alagalah asks if there are any IPR rules with using the ONF as a forum to develop IP (alagalah, 16:49:01)
    40. dlenrow notes that the release plan does not require specific features. colindixon notes that the plan does need to call out features that could be leveraged by other projects and it will important to put those in the plan for Li (phrobb, 16:49:58)
    41. dlenrow suggests that we have Devon act as the project contact at least until a PTL is elected (phrobb, 16:51:41)
    42. colindixon notes that if we want to be an offset-2 project and "keep up", we may want to tease out what is a "must" for the release plan and get that down on release plan. Any additional items can be on the internal NIC action plan and not in the release plan. That way we minimize the tasks for the Li release plan (phrobb, 16:53:59)
    43. colindixon states that a goal maybe to provide functionality to other projects (alagalah, 16:54:42)
    44. ACTION: phrobb to work with Rick Bauer of ONF to discover any IPR topics that need to be addressed on the NIC work and it's relationship to ONF (phrobb, 17:02:33)


Meeting ended at 17:03:07 UTC (full logs).

Action items

  1. uchau duane Mentze volunteer to lead the creation of a strawman NIC release plan for Li by next Tuesday (2/3)
  2. uchau to ask Devon to send email to nic-dev volunteering for PL role
  3. phrobb to work with Rick Bauer of ONF to discover any IPR topics that need to be addressed on the NIC work and it's relationship to ONF


Action items, by person

  1. phrobb
    1. phrobb to work with Rick Bauer of ONF to discover any IPR topics that need to be addressed on the NIC work and it's relationship to ONF
  2. uchau
    1. uchau duane Mentze volunteer to lead the creation of a strawman NIC release plan for Li by next Tuesday (2/3)
    2. uchau to ask Devon to send email to nic-dev volunteering for PL role


People present (lines said)

  1. tbachman (37)
  2. phrobb (30)
  3. alagalah (13)
  4. ShaunWackerly (8)
  5. gzhao (6)
  6. odl_meetbot (6)
  7. dbainbri (4)
  8. uchau (3)
  9. dlenrow (2)
  10. colindixon (1)
  11. tykeal (1)


Generated by MeetBot 0.1.4.