#opendaylight-meeting: tsc

Meeting started by phrobb at 18:00:13 UTC (full logs).

Meeting summary

  1. Roll Call - TSC members please #info in (phrobb, 18:00:41)
    1. colindixon (colindixon, 18:00:48)
    2. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place (colindixon, 18:01:04)
    3. uchau - proxy for HP (uchau, 18:01:19)
    4. dfarrell07 for Red Hat/cdub (dfarrell07, 18:01:37)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-02-05-18.00.html minutes from last week for action items (colindixon, 18:01:56)
    6. LuisGomez (LuisGomez, 18:02:20)
    7. kwatsen (kwatsen, 18:02:24)
    8. regXboi (regXboi, 18:02:28)
    9. edwarnicke (edwarnicke, 18:02:39)
    10. rovarga as jmedved's proxy (rovarga_, 18:03:09)
    11. Youcef Laribi (Youcef, 18:03:14)
    12. mohnish anumala (mohnish, 18:04:37)
    13. ACTION: colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?) (colindixon, 18:05:29)
    14. ACTION: colindixon and TSC to elaborate on proper procedure for removal of committers from a project (colindixon, 18:05:36)
    15. ACTION: gzhao to work with phrobb to propose new Helium SR and the target dates (colindixon, 18:06:23)
    16. ACTION: colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags (colindixon, 18:06:47)
    17. ACTION: colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list (colindixon, 18:06:55)
    18. gzhao says that nobody depens on SNBI so they’re being behind schedule will not impact other projects (colindixon, 18:08:06)
    19. ACTION: gzhao to ask SNBI if and when the expect to be caught up, M3? (colindixon, 18:08:39)

  2. updates (colindixon, 18:09:10)
    1. the deadline for submisssions for the ODL summit is TOMORROW (colindixon, 18:09:26)
    2. CFP Summit deadline-deadline is tomorrow 2/13 (dfarrell07, 18:10:00)
    3. there’s an india forum which has a CFP that’s out (colindixon, 18:10:26)
    4. CFP for deadline India Summit is Feb 26th (dfarrell07, 18:10:52)
    5. the april hackfest is scheduled for April 15-16 (colindixon, 18:11:07)
    6. there’s a developer track on the monday of ONS and we’re looking to do tutorials the sunday before that (colindixon, 18:11:27)
    7. OpenStack Summit has many talks in from ODL community, design summit talk subs not open yet (dfarrell07, 18:11:40)
    8. ACTION: phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (colindixon, 18:13:09)
    9. finished tagging Helium-SR2 on Monday (so it took one week) (colindixon, 18:13:20)
    10. that’s the best we (really zxiiro) have done so far (colindixon, 18:13:31)
    11. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 Lithium status readout (colindixon, 18:17:39)
    12. two prjects are yellow: SNBI and VPN (colindixon, 18:17:41)
    13. OpFlex will have the M2 update by COB today... apologies for delay (alagalah, 18:18:20)
    14. Chris Price (wanders into IRC late) (ChrisPriceAB, 18:18:21)
    15. ACTION: gzhao to follow up with projects that haven’t yet reported, colindixon and/or phrobb can help (colindixon, 18:19:21)
    16. ACTION: alagalah to produce Core Tutorials M2 at same time as OpFlex (alagalah, 18:19:21)
    17. tests are back to normal after the SR2 tagging (colindixon, 18:19:57)
    18. Helium SR2 tagging effort was finished Monday, took one week (dfarrell07, 18:20:17)
    19. ACTION: phrobb will reach out to PCMM about joining Li release (dfarrell07, 18:20:18)
    20. ACTION: phrobb to reach out to Rob Sherwood about closing down net-virt-platform (colindixon, 18:22:58)
    21. zxiiro says as of today there are 37 project in JJB (tbachman, 18:23:12)
    22. zxiiro says 3 of the projects are of concern b/c they aren’t responding (tbachman, 18:23:41)
    23. Progress continues on ODL Forge, tykeal reports (dfarrell07, 18:24:45)
    24. ACTION: phrobb to reach out to plugin2oc, SDNi, and defense4all about JJB migration (tbachman, 18:24:49)
    25. tykeal says ODL forge is still in process (colindixon, 18:25:22)

  3. Neutron project proposal (colindixon, 18:25:27)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Neutron_Northbound Project proposal wiki (dfarrell07, 18:25:41)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-January/000251.html Proposed on 1/29/2015 (dfarrell07, 18:25:48)
    3. https://lists.opendaylight.org/pipermail/controller-dev/2015-January/008006.html thread 1 from controller-dev list (regXboi, 18:26:28)
    4. https://lists.opendaylight.org/pipermail/controller-dev/2015-January/008007.html thread 2 from controller-dev list on vote of committers (regXboi, 18:26:50)
    5. regXboi says that neutron, when first contributed, was made part of controller (tbachman, 18:27:45)
    6. regXboi says before it can be split from controller, the controller committer has to agree for it to be split off (tbachman, 18:27:59)
    7. regXboi has provided the responses frmo the controller committers in the links provided before (tbachman, 18:28:21)
    8. regXboi says one of the things we’d like to do is eventaully get to yang models (tbachman, 18:29:05)
    9. regXboi says this needs to be provider agnostic (tbachman, 18:29:19)
    10. regXboi says the initial committers list was drawn from those who had been active in neutron directories in the controller, and are still involved in ODL (tbachman, 18:30:13)
    11. regXboi says there’s no vendor-neutral issues, b/c it’s already part of ODL (tbachman, 18:30:53)
    12. tykeal asks if regXboi is planning on taking history from controller into the new project (tbachman, 18:31:14)
    13. regXboi says he’d like to (tbachman, 18:31:18)
    14. tykeal says it’s possible (tbachman, 18:31:27)
    15. regXboi would like to allow folks to maintain credit for their previous work (tbachman, 18:31:44)
    16. colindixon says if there are any commits that modified both the neutron stuff in the controller and the new project (tbachman, 18:31:58)
    17. tykeal says we’d need to take the commit history and remove anything that’s from controller (tbachman, 18:32:12)
    18. tykeal says this was done for TCPMD5 (tbachman, 18:32:27)
    19. it's pretty much git filter-branch, if I remember correctly (rovarga_, 18:32:56)
    20. RajeevK_ says the scope is focused on comms from ODL mechanism driver to the ODL neutron service, received by multiple ODL provider — what kind of information are you looking at (tbachman, 18:33:30)
    21. regXboi says it’s things qualified in the neutron API (tbachman, 18:33:38)
    22. RajeevK_ asks if this includes opaque objects being passed thru (tbachman, 18:33:54)
    23. regXboi says he considers this out of scope (tbachman, 18:33:59)
    24. RajeevK_ asks what’s the reasoning for this (tbachman, 18:34:08)
    25. regXboi asks why he’d want to be interested in this (tbachman, 18:34:24)
    26. RajeevK_ says he doesn’t want neutron to worry about dealing with the metadata, but ODL would want to deal with it (tbachman, 18:34:49)
    27. regXboi says you first need to pass it through neutron so that the neutron on openstack side won’t muck with it (tbachman, 18:35:08)
    28. regXboi says he doesn’t have a good feeling about putting that in scope (tbachman, 18:35:45)
    29. mohnish asks how this project interworks with other projects (tbachman, 18:35:58)
    30. regXboi says that today is through a whiteboard pattern, which still exists (tbachman, 18:36:11)
    31. regXboi says the plan of record is to come up with a yang model so that the neutron service can talk through the MD-SAL to whomever wants to listen (tbachman, 18:36:29)
    32. regXboi says there would be a 1 or 2 cycle deprecation of the whiteboard pattern (tbachman, 18:36:47)
    33. colindixon says technically you could deprecate in Lithium and remove in Beryllium (tbachman, 18:36:59)
    34. regXboi says technically yes, but we’d need the yang model first, and given where we are in the cycle, that would be a stretch (tbachman, 18:37:19)
    35. vina_ermagan asks if here are any plans to support openstack neutron extensions (port bindings, etc.) (tbachman, 18:37:58)
    36. regXboi says router extension is already supported (tbachman, 18:38:06)
    37. regXboi says there’s a patch to support the port bindings (tbachman, 18:38:12)
    38. regXboi says if there are other extensions needed, feel free to provide patches (tbachman, 18:38:22)
    39. alagalah asks if neutron has the capability to query versions of the API supported (tbachman, 18:39:14)
    40. regXboi says in openstack, the version is in the URI string (tbachman, 18:39:47)
    41. regXboi says that by using v2.0, you’re using v2.0 of the API (tbachman, 18:39:57)
    42. abhijitkumbhare says in the list of committers, it seems like a low number of committers (tbachman, 18:40:35)
    43. abhijitkumbhare asks if it makes sense to add more committers to the list (tbachman, 18:40:50)
    44. regXboi says the initial list based on the assumption that he was promoting people based on their contributions to the code (tbachman, 18:41:19)
    45. ChrisPriceAB voices the same concern, given the popularity of the interface (tbachman, 18:42:12)
    46. regXboi says he’d rather err on the side of caution — if you want to be a committer, provide code to demonstrate responsibility (as those currently on the list) in order to enjoy the rights and responsibility as a committer (tbachman, 18:43:19)
    47. ChrisPriceAB says the same thing was done on the openflowplugin (tbachman, 18:44:00)
    48. edwarnicke says the openflowplugin was different - it didn’t start from an existing code base (tbachman, 18:44:10)
    49. edwarnicke says if someone wants to be a committer, all they have to do is contribute (tbachman, 18:44:29)
    50. edwarnicke notes that there were a lot of people who expressed interest in being a committer to neutron who had no history with the project, and picking from that large group has the risk of becoming political (tbachman, 18:45:06)
    51. rovarga_ points out that for TCPMD5, the committer list was derived from the project it was spun out from; but agrees with regXboi’s thinking (tbachman, 18:46:06)
    52. dneary asks if the bar was expected to be lower for a new committer (tbachman, 18:46:20)
    53. regXboi says that will be up to the project lead that’s elected (tbachman, 18:46:39)
    54. dneary says the key point is that being a committer isn’t a pre-requisite to being a contributor (tbachman, 18:46:57)
    55. colindixon says his personal opinion is that we have by and large been overly generous with committers (tbachman, 18:47:13)
    56. correction on dneary’s earlier statement: "dneary says the key point is that being a committer isn’t a pre-requisite to being a contributor" vs "isn't seen to be a prerequisite" (tbachman, 18:48:42)
    57. regXboi says the list of potential committers was taken from those who have contributed to the two directories provided in the project proposal (tbachman, 18:50:02)
    58. Uri asks if the outcome of this is the ODL ML2 plugin and code on the ODL side, or is the ODL ML2 plugin considered here (tbachman, 18:50:54)
    59. regXboi says the ML2 code is part of openstack (tbachman, 18:51:02)
    60. regXboi says one of the goals of the APIs is to maintain the transparency of the APIs (tbachman, 18:52:07)
    61. regXboi says that when we do a YANG model, RESTCONF is made availlable; this allows others to write a proprietary driver if they want, but it’s not considered an interface (tbachman, 18:52:43)
    62. gzhao asks if this project is going to join the Lithium SR, and if so, is it an offset 2 project (tbachman, 18:53:03)
    63. regXboi says the reason for the creation review is to meet the M3 deadline requirement for spin-out from an existing project (tbachman, 18:53:28)
    64. regXboi doesn’t believe it will be an offset 2 project (tbachman, 18:53:49)
    65. colindixon says the M3 deadline is not until next week for offset 0 projects (tbachman, 18:54:03)
    66. VOTE: Voted on "Shall the TSC approve the Neutron Northbound project to Incubation?" Results are, +1: 10 (dfarrell07, 18:55:03)
    67. AGREED: The Neutron Northbound project is approved to Incubation (dfarrell07, 18:55:14)
    68. Thomas Kee here for PacketCable and anything else (xsited_, 18:55:35)

  4. ask.opendaylight.org (tbachman, 18:55:54)
    1. dfarrell07 points out that ask.opendaylight.org is a good place for folks to get q’s answered (tbachman, 18:56:10)
    2. https://ask.opendaylight.org/questions/ the fourm (colindixon, 18:56:19)
    3. dfarrell07 says we need more folks providing answers (tbachman, 18:56:21)
    4. dfarrell07 says having a broader audience answer questions would really help that portion of the community (tbachman, 18:56:43)
    5. dfarrell07 says it also depends on upvotes and accepting answers (tbachman, 18:56:59)
    6. dfarrell07 says this helps make it a good resource for others (tbachman, 18:57:10)

  5. PCMM joining lithium (colindixon, 18:58:40)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-February/002499.html Email requesting to join Li (colindixon, 18:58:45)
    2. dfarrell07 gets the credit for those previous two minutes ;) (tbachman, 18:59:11)
    3. Karthik Sundaresan says they’re ramping up resoruces — replacement for Thomas Kee and other dev resources (tbachman, 18:59:42)
    4. Karthik says they hope to maintain the plugin and add features, but main goal is to make sure nothing is broken and that it at least keeps the same functionality (tbachman, 19:00:19)
    5. regXboi asks if there’s a reason not to allow PCMM to Li (tbachman, 19:01:09)
    6. colindixon says no (tbachman, 19:01:12)
    7. VOTE: Voted on "Shall the TSC approve the PacketCable PCMM Plugin project to join the Lithium release?" Results are, +1: 10 (dfarrell07, 19:01:36)
    8. AGREED: The PacketCable PCMM Plugin project is approved to join the Lithium release (dfarrell07, 19:01:41)

  6. cookies (regXboi, 19:02:14)
    1. http://cdn.trendhunterstatic.com/thumbs/caffeinated-cookies-buzz-strong-real-coffee-cookies.jpeg caffeinated cookies just for tbachman (tykeal, 19:02:16)


Meeting ended at 19:02:30 UTC (full logs).

Action items

  1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
  2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
  3. gzhao to work with phrobb to propose new Helium SR and the target dates
  4. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
  5. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
  6. gzhao to ask SNBI if and when the expect to be caught up, M3?
  7. phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released
  8. gzhao to follow up with projects that haven’t yet reported, colindixon and/or phrobb can help
  9. alagalah to produce Core Tutorials M2 at same time as OpFlex
  10. phrobb will reach out to PCMM about joining Li release
  11. phrobb to reach out to Rob Sherwood about closing down net-virt-platform
  12. phrobb to reach out to plugin2oc, SDNi, and defense4all about JJB migration


Action items, by person

  1. alagalah
    1. alagalah to produce Core Tutorials M2 at same time as OpFlex
  2. colindixon
    1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
    2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
    3. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
    4. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
    5. gzhao to follow up with projects that haven’t yet reported, colindixon and/or phrobb can help
  3. gzhao
    1. gzhao to work with phrobb to propose new Helium SR and the target dates
    2. gzhao to ask SNBI if and when the expect to be caught up, M3?
    3. gzhao to follow up with projects that haven’t yet reported, colindixon and/or phrobb can help
  4. phrobb
    1. gzhao to work with phrobb to propose new Helium SR and the target dates
    2. phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released
    3. gzhao to follow up with projects that haven’t yet reported, colindixon and/or phrobb can help
    4. phrobb will reach out to PCMM about joining Li release
    5. phrobb to reach out to Rob Sherwood about closing down net-virt-platform
    6. phrobb to reach out to plugin2oc, SDNi, and defense4all about JJB migration
  5. zxiiro
    1. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags


People present (lines said)

  1. tbachman (118)
  2. colindixon (49)
  3. dfarrell07 (40)
  4. odl_meetbot (23)
  5. dneary (12)
  6. tykeal (11)
  7. ChrisPriceAB (10)
  8. phrobb (9)
  9. regXboi (9)
  10. snoble (9)
  11. alagalah (9)
  12. zxiiro (8)
  13. rovarga_ (6)
  14. edwarnicke (5)
  15. gzhao (5)
  16. kwatsen (3)
  17. uchau (3)
  18. Youcef (3)
  19. mohnish (3)
  20. LuisGomez (2)
  21. mlemay (2)
  22. RajeevK_ (2)
  23. xsited_ (1)
  24. cdub (1)
  25. abhijitkumbhare (1)
  26. Swami_ (1)


Generated by MeetBot 0.1.4.