#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:26 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:01:30)
    1. colindixon (colindixon, 17:01:30)
    2. Chris Price (ChrisPriceAB, 17:02:02)
    3. colindixon (colindixon, 17:03:54)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-07-23-17.00.html last week’s meeting minutes (colindixon, 17:04:14)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=34720#Agenda today’s agenda (colindixon, 17:04:21)
    6. LuisGomez (LuisGomez, 17:04:28)
    7. edwarnicke (edwarnicke, 17:04:40)
    8. ACTION: gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t (colindixon, 17:04:49)
    9. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1) (colindixon, 17:05:00)
    10. ACTION: ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and other things? (colindixon, 17:05:26)
    11. ACTION: phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours (colindixon, 17:05:37)
    12. mohnish anumala (mohnish, 17:05:47)
    13. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:05:47)
    14. dlenrow (dlenrow, 17:05:53)
    15. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:06:13)
    16. ACTION: tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting (colindixon, 17:06:31)
    17. dfarrell07 for cdub/Red Hat (dfarrell07, 17:06:54)
    18. edwarnicke says he’s working on getting jacoco reporting through sonoar if you use the MD-SAL IT parent pom, whcih would be awesome (colindixon, 17:08:42)
    19. dfarrell07, ChrisPriceAB, and others have good plans around using OPNFV resources to help with various testing (colindixon, 17:10:13)

  2. events (colindixon, 17:10:17)
    1. https://www.opendaylight.org/global-events (colindixon, 17:10:42)
    2. there will be a CFP for 1.5 days of content at the SDN & OpenFlow world congress in dusseldorf on 10/12-10/15 (colindixon, 17:11:34)
    3. https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress more info on that here (colindixon, 17:11:42)
    4. https://www.opendaylight.org/events/2015-08-16-000000/software-defined-networking-opendaylight-linuxcon-seattle SDN and with ODL at LinuxCon Seattle in two weeks on 8/16 (colindixon, 17:12:35)
    5. edwarnicke asks if we want to talk about when to do our hackfests (colindixon, 17:13:15)
    6. late agenda item: We don't have a NIC PTL for M1 due to recent resignation of D Bainbridge. Wish to join Be, but don't have PTL (dlenrow, 17:13:16)
    7. OPNFV summit in the bay area in November might be good colocate with (colindixon, 17:14:38)
    8. ACTION: edwarnicke and phrobb- to send out a mails for candidate dates for hackfest (colindixon, 17:15:01)
    9. http://events.linuxfoundation.org/events/opnfv-summit <-- opnfv summit link (gzhao, 17:15:13)

  3. beryllium (colindixon, 17:15:26)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Participating_Projects participating projects so far (colindixon, 17:16:12)
    2. ACTION: gzhao to put the link for the tracking spreadsheet here https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Project_Status (colindixon, 17:17:04)
    3. https://docs.google.com/spreadsheets/d/1o9L1q5OYl9T6ZwBEkAuPSoostFMIsjp4mh2FDawuk20/edit#gid=0 <-- Beryllium tracking (gzhao, 17:17:22)
    4. 6 offset 0 projects, 11 offset 1 projects and 15 offset 2 projects right now (gzhao, 17:18:19)
    5. it seem like the Beryllium release plan participating projects section is not yet up to date (colindixon, 17:18:30)
    6. there are 16 pending TSC approval projects (gzhao, 17:18:35)

  4. stable/lithium (colindixon, 17:19:00)
    1. the schedule says that SR1 is supposed to happen next week (colindixon, 17:20:06)
    2. ACTION: colindixon and gzhao to send a mail saying that we’re going to delay Lithium-SR1 by at least a week and seek feedback from projects, also set a cutoff for the build (colindixon, 17:21:31)

  5. system integration and test (colindixon, 17:22:08)
    1. LuisGomez says that integration is looking to split into two projects (colindixon, 17:22:44)
    2. they are planning and making sure that things are happening well (colindixon, 17:22:56)
    3. colindixon says that the review would be in two weeks, which is 8/20 (colindixon, 17:23:55)
    4. jamoluhrsen says that it’s actually 3 projects (colindixon, 17:24:54)

  6. infrastructure (colindixon, 17:24:57)
    1. tykeal scheduled updates for saturday (moring in the US), zxiiro will update the jobs (colindixon, 17:25:02)
    2. Integration is splitting into 3 projects in 2 weeks (corrections to last section) (dfarrell07, 17:25:09)
    3. there’s a meeting with rackspace about private cloud (colindixon, 17:25:19)
    4. edwarnicke asks about ODL forge (colindixon, 17:25:38)
    5. a few things put on the back burner: (1) infra issues with Lithium, (2) LF is moving to puppet 4 (colindixon, 17:26:38)
    6. tykeal says that it should come up soon, but he can’t give a date (colindixon, 17:26:59)
    7. tykeal says that moving into a rackspace private cloud will also help (colindixon, 17:27:19)
    8. phrobb- says that they’re looking to maybe hire another LF admin for ODL (colindixon, 17:29:14)
    9. dfarrell07 continues to advocate for hiring more LF admins. They are epic, but a bottleneck b/c numbers imho (dfarrell07, 17:30:59)
    10. tykeal we have a part time admin for us who is there only for escalations overnight (colindixon, 17:31:11)
    11. LuisGomez asks how to do that? (colindixon, 17:31:11)
    12. tykeal says that the biggest change will be that somebody will be watching the queues while zxiiro and tykeal sleep (colindixon, 17:31:46)
    13. phrobb- sent out escalation instructions to all PTLs which you can look for, but he’ll send them again (colindixon, 17:32:04)
    14. ACTION: phrobb- will send out escalation instructions again (colindixon, 17:32:14)

  7. FaaS creation review (round 2) (colindixon, 17:33:50)
    1. https://wiki.opendaylight.org/view/Project_Proposals:FaaS updated proposal (colindixon, 17:34:09)
    2. the scope has been updated (colindixon, 17:34:35)
    3. they say that they’re are only doing ACL policies, but relying on other projects for fancier things (colindixon, 17:34:51)
    4. also the scope is limited to L2/L3 network creations (colindixon, 17:35:03)
    5. in Beryllium the plan would be to support OpenFlow/OVSDB SB and GBP NB (colindixon, 17:35:24)
    6. mohnish asks if they talked about being a sub-project for GBP or NIC instead of a new project, xingjun says yes they talked about how to interact, but not about it being a sub-projecct (colindixon, 17:37:44)
    7. VOTE: Voted on "shall the FaaS project be moved into being an incubation project?" Results are, +1: 6 (colindixon, 17:40:42)
    8. AGREED: adding Uri’s +1 as well, we move FaaS to being an incubation project (colindixon, 17:41:15)

  8. YANG PUBSUB creation review (colindixon, 17:42:58)
    1. https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000349.html proposed on 7/16/2015 (colindixon, 17:44:07)
    2. https://wiki.opendaylight.org/view/Project_Proposals:YANG_PUBSUB (colindixon, 17:44:13)
    3. this is a project to help support a standards track set of work in the IETF as part of the I2RS working group (colindixon, 17:46:16)
    4. https://tools.ietf.org/html/draft-clemm-netconf-yang-push-01 IETF draft (colindixon, 17:48:00)
    5. shows a demo of pubsub working (colindixon, 17:48:43)
    6. it’s possible to do multiple subscriptions at once, which you can’t do with just YANG notifications (colindixon, 17:49:03)
    7. colindixon asks if this should be a separate project or just part of the NETCONF project? (colindixon, 17:50:45)
    8. the answer is that they might want support other transports, which means that they’d like to be a separate project (colindixon, 17:52:20)
    9. LuisGomez says it’s not clear to him that the scope spans beyond netconf, the response is that (colindixon, 17:55:09)
    10. colindixon, and many other TSC members say they’d like to see the discussion happen between the netconf project and this project (colindixon, 17:57:16)
    11. ACTION: YANG PUBSUB project will reach out to the netconf project and we’ll discuss more based on the outcome of that (colindixon, 17:57:56)
    12. colindixon notes that this seems like a really cool project and that he things ODL definitely needs the technology and support (colindixon, 17:58:19)
    13. edwarnicke asks if the project intends to participate in Beryllium (colindixon, 17:59:24)
    14. Eric answers yes, it does (colindixon, 17:59:30)

  9. Messaging4Transport creation review (colindixon, 18:01:49)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Messaging4Transport (colindixon, 18:03:03)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000338.html proposed on 7/8/2015 (colindixon, 18:03:15)
    3. https://wiki.opendaylight.org/images/9/90/Messaging4Transport.pdf (pradeeban, 18:03:57)
    4. https://wiki.opendaylight.org/images/9/90/Messaging4Transport.pdf (edwarnicke, 18:04:21)
    5. icbts says that the hopes that there is a Camel Component Integration for M4T (colindixon, 18:08:10)
    6. M4T is a binding for AMQP (and other message-oriented middleware) for the MD-SAL (colindixon, 18:11:32)
    7. this was presented at the design forum last week (colindixon, 18:12:31)
    8. http://opendaylightsummit2015.sched.org/event/19c5979c504fcfaa5035230635e718bf the presentation ad the design forum (colindixon, 18:13:53)
    9. Multiple controllers can be federated for messaging. (mohnish, 18:15:55)
    10. this can allow for controller federation through standardized message brokers where each controller can publish and subscribe to each other’s information (colindixon, 18:16:05)
    11. follow http://camel.apache.org/writing-components.html - once this is under camel we’ll have binding independance to all of Camel’s other endpoints (icbts, 18:16:48)
    12. based on feedback from the design forum, they made sure that it could be independent of partiuclar bindings (colindixon, 18:17:35)
    13. mohnish asks what the MD-SAL bindings in question are (colindixon, 18:18:08)
    14. the answer is “whatever can be passed through the RESTCONF interface, should also be exposed through this" (colindixon, 18:18:51)
    15. data tree, notifications, and RPCs (colindixon, 18:19:14)
    16. mohnish says he has other questions, but they’re mainly technical and so they could likely be deferred (colindixon, 18:20:29)
    17. colindixon asks if this will be protected by AAA? (colindixon, 18:21:25)
    18. Camel would provide authentication, etc for messaging http://camel.apache.org/camel-security.html (icbts, 18:21:36)
    19. http://code.google.com/p/kryo/ (pradeeban, 18:21:42)
    20. the answer is that it will protect itself in the same way RESTCONF does using AAA (colindixon, 18:22:39)
    21. the code is in progress and on github (colindixon, 18:22:51)
    22. tykeal says any incoming code will have to go through IPR, but that happens after we approve it (colindixon, 18:23:34)
    23. edwarnicke asks if the intent is to participate in Beryllium (colindixon, 18:24:02)
    24. pradeeban says no, but he hopes to participate in Boron (colindixon, 18:24:25)
    25. VOTE: Voted on "shall the TSC move the Messaging4Transport project to incubation?" Results are, +1: 6 (colindixon, 18:26:26)
    26. AGREED: the Messaging4Transport project is moved to incubation, note Uri_ and colindixon also voted +1 (colindixon, 18:27:04)

  10. controller shield (colindixon, 18:27:58)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Controller_Shield (colindixon, 18:28:46)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-June/000322.html proposed on 6/8/2015 (colindixon, 18:28:52)
    3. Colin notes that SDNi wrapper interaction with Controller shield may be out of scope. (mohnish, 18:52:36)
    4. TSC members are asking for clarification of scope. (mohnish, 18:53:32)
    5. Helen Chen notes the possible overlap with Unified Secure Channel goals. (mohnish, 18:57:39)
    6. dfarrell07 +1 (gzhao, 18:59:21)
    7. colidixon +1 (gzhao, 18:59:39)
    8. mohnish +1 (mohnish, 18:59:42)
    9. LuisGomez +1 (LuisGomez, 18:59:47)
    10. abhijitkumbhare +1 (abhijitkumbhare, 19:00:02)
    11. edwarnicke +1 (gzhao, 19:00:44)
    12. congratulations to controller shield project (gzhao, 19:01:21)


Meeting ended at 19:04:36 UTC (full logs).

Action items

  1. gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t
  2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
  3. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and other things?
  4. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
  5. phrobb to keep working on JIRA and let us know when we can use it
  6. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  7. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
  8. edwarnicke and phrobb- to send out a mails for candidate dates for hackfest
  9. gzhao to put the link for the tracking spreadsheet here https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Project_Status
  10. colindixon and gzhao to send a mail saying that we’re going to delay Lithium-SR1 by at least a week and seek feedback from projects, also set a cutoff for the build
  11. phrobb- will send out escalation instructions again
  12. YANG PUBSUB project will reach out to the netconf project and we’ll discuss more based on the outcome of that


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and other things?
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
    2. colindixon and gzhao to send a mail saying that we’re going to delay Lithium-SR1 by at least a week and seek feedback from projects, also set a cutoff for the build
  3. edwarnicke
    1. edwarnicke and phrobb- to send out a mails for candidate dates for hackfest
  4. gzhao
    1. gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t
    2. gzhao to put the link for the tracking spreadsheet here https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Project_Status
    3. colindixon and gzhao to send a mail saying that we’re going to delay Lithium-SR1 by at least a week and seek feedback from projects, also set a cutoff for the build
  5. UNASSIGNED
    1. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
    2. phrobb to keep working on JIRA and let us know when we can use it
    3. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
    4. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
    5. phrobb- will send out escalation instructions again
    6. YANG PUBSUB project will reach out to the netconf project and we’ll discuss more based on the outcome of that


People present (lines said)

  1. colindixon (125)
  2. edwarnicke (20)
  3. ChrisPriceAB (19)
  4. odl_meetbot (19)
  5. gzhao (17)
  6. mohnish (12)
  7. tykeal (9)
  8. dfarrell07 (8)
  9. pradeeban (8)
  10. Uri_ (5)
  11. dlenrow (5)
  12. LuisGomez (4)
  13. icbts (4)
  14. xingjun (3)
  15. abhijitkumbhare (3)
  16. alagalah (3)
  17. ebrjohn (1)
  18. kluehrs (1)
  19. einarnn (1)
  20. jamoluhrsen (1)


Generated by MeetBot 0.1.4.