#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:18 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:23)
    1. colindixon (colindixon, 17:00:25)
    2. dfarrell07 (dfarrell07, 17:00:25)
    3. mohnish anumala (mohnish_, 17:00:30)
    4. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=35733#Agenda the agenda for today (colindixon, 17:00:32)
    5. dlenrow (dlenrow, 17:00:38)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-20-17.00.html last week’s meeting minutes (colindixon, 17:00:43)
    7. ACTION: OF-CONFIG project will add ODL user IDs for the committers to the project proposal (colindixon, 17:02:05)
    8. ACTION: colindixon to see if anyone wants to write survival guides for M2 and M3 (colindixon, 17:02:14)
    9. LuisGomez (LuisGomez_, 17:02:26)
    10. ACTION: phrobb to start a discussion on the idea of moving from WebEx to something else (colindixon, 17:02:38)
    11. ACTION: dfarrell07 to work with odlcasey to get the gcal webex numbers fixed (colindixon, 17:02:51)
    12. edwarnicke (edwarnicke, 17:02:57)
    13. ACTION: tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting (colindixon, 17:03:03)
    14. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:03:46)
    15. abhijitkumbhare (abhijitkumbhare, 17:04:02)
    16. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:04:06)
    17. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (colindixon, 17:04:18)

  2. events (colindixon, 17:05:19)
    1. www.opendaylight.org/news/events/ events page (colindixon, 17:05:34)
    2. https://docs.google.com/forms/d/1p23KWqRIMf1utxr3z5YXho_DrlY8wur-ogFhuIDS5c4/viewform the CFP for dusseldorf closes at EoB tomororw (colindixon, 17:06:08)
    3. Phil asks people to do CFP quick to avoid last minute flush (gzhao, 17:06:27)
    4. https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress The OpenDaylight Mini-Summit will take place on Wednesday and Thursday, October 14 and 15, 2015. (colindixon, 17:06:49)
    5. uri asks who you should be representing, phrobb says hopefully OpenDaylight, but if you’re not a vendor or a telco, you need to be a sponsor to talk (colindixon, 17:07:53)
    6. ODL hackfest will be colocated with the OPFNV summit, 11/9-11/10 at the Hyatt Regency San Francisco Airport (colindixon, 17:08:41)
    7. dlenrow asks about slots at the duesseldorf layer123 thing, do the ODL slots count against company slots? phrobb says we have our own track with our own slots, but the rules about speaker eligibility stil apply. (colindixon, 17:11:12)
    8. openstack summit in Tokyo at the end of Ocotober, accept/reject for proposals should have gone out (colindixon, 17:11:50)
    9. dlenrow says he got one talking with “some people talking about some kind of policy intent sorta thing" (colindixon, 17:12:15)
    10. jmedved (jmedved, 17:13:05)

  3. new release manager (colindixon, 17:13:09)
    1. An Ho will be workign with gzhao and others on doing release management (colindixon, 17:13:47)
    2. kzhang (Katie Zhang) is also helping (colindixon, 17:14:13)
    3. An Ho == anipbu (colindixon, 17:14:35)

  4. beryllium (colindixon, 17:15:09)
    1. anipbu says things are mostly gpoing well, he’s reaching out to slow projects, we have 55 projects so far in Beryllium (colindixon, 17:16:28)
    2. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather (colindixon, 17:16:44)
    3. there are changes coming to two of the most important models in OpenDaylight during Beryllium (colindixon, 17:18:04)
    4. during Beryllium the plan is to deprecate the inventory model and move to using the topology model instead (colindixon, 17:18:28)
    5. the topology model is strictly richer version of inventory, for details ask (colindixon, 17:19:22)
    6. there is also a newer version of our topology models which breaks things apart into a network (which is closer to inventory) and topology (which adds links) (colindixon, 17:19:57)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-08-25-16.23.html some more information is here (colindixon, 17:20:29)
    8. https://wiki.opendaylight.org/view/Topology_Processing_Framework:Main the topology procesing framework has some nice thigns for working with topologies (colindixon, 17:21:12)
    9. https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call the September 8th, 2015 call here will be covering this topic if people want participate and/or find out more (colindixon, 17:23:13)

  5. stable/lithium (colindixon, 17:23:33)
    1. https://lists.opendaylight.org/pipermail/release/2015-August/003523.html newly proposed dates for Lithium SRs (colindixon, 17:24:01)
    2. abhijitkumbhare asks to move SR2 out from 10/1 to 10/8 (colindixon, 17:26:48)
    3. VOTE: Voted on "shall the TSC move the LIthium SR dates (at least tenatively) to the following SR2: 10/8, SR3: 11/12, SR4: 2/25?" Results are, +1: 7 (colindixon, 17:28:56)
    4. AGREED: the LIthium SR dates (at least tenatively) to the following SR2: 10/8, SR3: 11/12, SR4: 2/25 (colindixon, 17:29:06)
    5. ACTION: colindixon to discuss on the mailing list if we need to move LIhtium-SR3 again (colindixon, 17:30:49)

  6. system integration and test (colindixon, 17:31:22)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-August/003730.html integration split has new PTLs (colindixon, 17:32:09)
    2. jamoluhrsen will be doing system integration and test readouts (colindixon, 17:32:25)
    3. - integration/test: Jamo Luhrsen (colindixon, 17:32:38)
    4. - integration/distribution: Ed Warnicke (colindixon, 17:32:41)
    5. - integration/packaging: Daniel Farrell (colindixon, 17:32:43)
    6. Huge *thank you* to LuisGomez_ for running ODL Integration as the PTL for so long and doing such a good job! (dfarrell07, 17:33:31)
    7. +100 to that! (colindixon, 17:33:39)

  7. infrastructure (colindixon, 17:34:37)
    1. tykeal says thanks for all the new project buildouts, the six ones from the last two weeks are done (colindixon, 17:34:59)
    2. tykeal is workign with integration splitout (colindixon, 17:35:05)
    3. new versions of slaves and and ubuntu shoudl be coming (colindixon, 17:35:30)
    4. ubuntu thanks to some code from edwarnicke (colindixon, 17:35:48)
    5. almost getting our own private cloud at rackspace (colindixon, 17:36:01)
    6. as part of that, we will get better networking, we will get 10 Gbps backend and the control over what’s using the network, so we can do better controlled performance testing (colindixon, 17:37:08)
    7. we will also eventually be able to use OpenDaylight to control our network there if we choose to (yay dogfood) (colindixon, 17:37:37)

  8. committer promotion on FaaS (colindixon, 17:40:00)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-August/003735.html they asked to add an initial committer (colindixon, 17:40:12)
    2. in essence, they are asking for another initial committer, they have no code yet, so it seems like it might be a fine exception (colindixon, 17:41:14)
    3. VOTE: Voted on "shall the TSC make Alex Zhang as an initial committer on FaaS without setting precedent?" Results are, +1: 8 (colindixon, 17:42:38)
    4. AGREED: Alex Zhang is an initial committer on FaaS (colindixon, 17:42:51)

  9. moving projects to mature (colindixon, 17:43:04)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-July/003511.html colindixon started a thead on possible clarifications to becoming mature (colindixon, 17:44:00)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features stable feature definition (colindixon, 17:44:33)
    3. Ongoing conversation about results of being a stable feature. For example, edwarnicke highlighted extracting logic as maybe being more complex after being stable, colindixon clarifies that since it's new fn, would be okay (dfarrell07, 17:50:50)
    4. edwarnicke asks "what does 'feature was present in the previous release' mean in the context of refactoring for a 'more sane' set of features?... Answer from colindixon is that such refactoring of existing features should be recognized as being present in the previous release by the TSC (phrobb, 17:51:10)
    5. uri_ asks what the relationship is between mature projects and stable feature, colindixon says that stable features are the “mature” parts of mature projects, so that mature projects can still have experimental compoents (colindixon, 17:54:59)
    6. uri_ would like to explore creating a distribution of OpenDaylight that’s easy to use, deploy, etc. (colindixon, 17:56:39)
    7. edwarnicke says he’s going to try to get working on creating the stable distribution ASAP so we can start figuring out where this works and where it stops (colindixon, 17:57:12)
    8. mohnish_ asks how this will work if most (or maybe all) of our user facing applications are not mature/stable? (colindixon, 18:00:02)
    9. ACTION: colindixon to start a thread on starting mature/stable processes so we can collect information and discuss things (colindixon, 18:03:19)
    10. ACTION: edwarnicke will create a stable distribution and we can start to push people toward taht (colindixon, 18:03:31)

  10. cookies (colindixon, 18:04:48)


Meeting ended at 18:04:53 UTC (full logs).

Action items

  1. OF-CONFIG project will add ODL user IDs for the committers to the project proposal
  2. colindixon to see if anyone wants to write survival guides for M2 and M3
  3. phrobb to start a discussion on the idea of moving from WebEx to something else
  4. dfarrell07 to work with odlcasey to get the gcal webex numbers fixed
  5. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
  6. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  7. phrobb to keep working on JIRA and let us know when we can use it
  8. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  9. colindixon to discuss on the mailing list if we need to move LIhtium-SR3 again
  10. colindixon to start a thread on starting mature/stable processes so we can collect information and discuss things
  11. edwarnicke will create a stable distribution and we can start to push people toward taht


Action items, by person

  1. colindixon
    1. colindixon to see if anyone wants to write survival guides for M2 and M3
    2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
    3. colindixon to discuss on the mailing list if we need to move LIhtium-SR3 again
    4. colindixon to start a thread on starting mature/stable processes so we can collect information and discuss things
  2. dfarrell07
    1. dfarrell07 to work with odlcasey to get the gcal webex numbers fixed
  3. edwarnicke
    1. edwarnicke will create a stable distribution and we can start to push people toward taht
  4. phrobb
    1. phrobb to start a discussion on the idea of moving from WebEx to something else
    2. phrobb to keep working on JIRA and let us know when we can use it
  5. UNASSIGNED
    1. OF-CONFIG project will add ODL user IDs for the committers to the project proposal
    2. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
    3. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information


People present (lines said)

  1. colindixon (85)
  2. dfarrell07 (15)
  3. odl_meetbot (14)
  4. dlenrow (9)
  5. abhijitkumbhare (9)
  6. edwarnicke (8)
  7. tykeal (7)
  8. gzhao (6)
  9. mohnish_ (6)
  10. kzhang (5)
  11. uri_ (5)
  12. jmedved (4)
  13. dneary_ (4)
  14. phrobb (1)
  15. snoble (1)
  16. jamoluhrsen (1)
  17. anipbu (1)
  18. hideyuki_ (1)
  19. LuisGomez_ (1)


Generated by MeetBot 0.1.4.