#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:12 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:17)
    1. colindixon (colindixon, 17:00:19)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36179#Agenda the agenda in it’s usual place (colindixon, 17:00:33)
    3. dfarrell07 (dfarrell07, 17:00:42)
    4. Chris Price (ChrisPriceAB, 17:01:15)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-27-17.00.html last week’s meeting minutes (colindixon, 17:01:22)
    6. thanks to anipbu for writing M2/M3 survival guides (colindixon, 17:01:58)
    7. ACTION: phrobb to start a discussion on the idea of moving from WebEx to something else (colindixon, 17:02:21)
    8. LuisGomez (LuisGomez, 17:02:26)
    9. mohnish anumala (mohnish_, 17:02:34)
    10. ACTION: tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting (colindixon, 17:02:38)
    11. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:02:46)
    12. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:02:59)
    13. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (colindixon, 17:03:11)
    14. edwarnicke (edwarnicke, 17:03:59)

  2. events (colindixon, 17:05:06)
    1. https://www.opendaylight.org/global-events the events page in it’s usual place (colindixon, 17:05:24)
    2. CFP for dusseldorf (with 16 entries) closed on Friday (colindixon, 17:05:39)
    3. I submit a CFP to desseldorf for SFC (ebrjohn, 17:05:53)
    4. phrobb will try to get people notified of acceptances for dusseldorf by mid next week (colindixon, 17:06:09)
    5. phrobb says need to have a good exposure in Openstack for ODL (gzhao, 17:06:42)
    6. https://www.opendaylight.org/events/2015-10-27-000000-2015-10-30-000000/openstack-summit openstack summit didn’t get many ODL or OPNFV talks, we should figure out how to ahve a strong showing (colindixon, 17:06:46)
    7. ODL hackfest will be colocated with the OPFNV summit, 11/9-11/10 at the Hyatt Regency San Francisco Airport ( (colindixon, 17:07:22)

  3. OpenDaylight Summit feedback and planning (colindixon, 17:07:31)
    1. phrobb asks for feedback, notes attendance on Friday was light (colindixon, 17:07:51)
    2. dfarrell07 said he thought it was awesome, he really liked recording and posting talks—said it was better than everything else he’s been to including LinuxCon (colindixon, 17:08:16)
    3. edwarnicke said he liked the organization, he liked keeping the dev forum separate from the summit so that people weren’t overcommited, he wants to keep that (colindixon, 17:08:50)
    4. edwarnicke notes that he got a lot of positive feedback on the tutorials (colindixon, 17:09:34)
    5. dlenrow (dlenrow, 17:10:14)
    6. colindixon says 4 days would be better than 5, edwarnicke points out that’s true, but you need to figure out how that plays with the trade-offs of fitting everything in (colindixon, 17:10:17)
    7. abhijitkumbhare said most developers would like to be part in user tutorials as well. (gzhao, 17:10:43)
    8. abhijitkumbhare and dfarrell07 say that they would have liked to attend more of the tutorials, e.g., both developer and user (colindixon, 17:10:44)
    9. phrobb said he heard from some people would have liked to have heard higher-level, strategic content over deeper content (colindixon, 17:11:46)
    10. dfarrell07 said there was not enough coffee (colindixon, 17:13:12)
    11. ChrisPriceAB would have liked to see things more concetrated into less floorspace (colindixon, 17:13:44)
    12. I was not happy at all that I had to buy coffee several times (ebrjohn, 17:13:50)
    13. dlenrow says it would be good to fix the date as soon as possible (colindixon, 17:14:00)

  4. OpenDaylight summit 2016 planning (colindixon, 17:14:17)
    1. other feedback came back that doing it in the summer (in particular July/August) is a bad idea, especially for Europeans (colindixon, 17:14:43)
    2. phrobb says that the LF canvassed a bunch of loations to taget next fall (instead of summer) (colindixon, 17:15:10)
    3. in the bay area, there is nothing available in the Fall (colindixon, 17:15:35)
    4. they looked at doing something the last week of September in Bellevue, but the board gave feedback on doing things maybe a different time and staying in the Bay area if we can (colindixon, 17:16:55)
    5. the idea of the bay area in June was floated and is being looked at (colindixon, 17:17:12)
    6. phrobb says that assuming a normal 6 month cadence Boron release would be sometime around august 2016 (colindixon, 17:17:52)
    7. jmedved (jmedved, 17:20:38)
    8. thus if we did a june-ish date for the summit with a hackfest, we would move the dev forum to a different time after the boron release (colindixon, 17:20:55)
    9. phrobb asks how early June in the bay area would work for a summit for the technical community (colindixon, 17:21:56)
    10. ChrisPriceAB asks that we try avoid conflicting with others, e.g., the OPNFV summit in June in Europe (colindixon, 17:22:29)
    11. phrobb notes that the board worries about moving things from the bay area in terms of losing attendance (colindixon, 17:23:19)
    12. phrobb noes that the LF events staff says that as you move things around you tend to get local attendees (and retain some of them across years) (colindixon, 17:24:37)
    13. dfarrell07 +1s moving the Summit through various large cities, hoping to get the "pick up locals who now travel to Summit" benifit LF has seen (dfarrell07, 17:25:53)
    14. abhijitkumbhare says he’d prefer the september dates (colindixon, 17:26:16)
    15. dneary suggests a YANG network application developer tutorial something like what was done in the China bootcammp (colindixon, 17:27:29)
    16. phrobb says there’s an idea of a new format which might hit good trade-offs in terms of 4 days, developer forum, summit, tutorials, etc. (colindixon, 17:28:03)
    17. ACTION: phrobb to send an e-mail asking for any feedback about planning the ODL summit for 2016 (colindixon, 17:29:22)

  5. Beryllium (colindixon, 17:29:53)
    1. anipbu says that they’re addressing build issues with a cycle between aaa/netconf, patches are coming (colindixon, 17:30:26)
    2. https://git.opendaylight.org/gerrit/26205/ (zxiiro, 17:30:35)
    3. zxiiro has been looking at sonar coverage this week to give all projects sonar code coverage for unit tests (colindixon, 17:30:59)
    4. the above patch when merged should give sonar unti test coverage for all projects (colindixon, 17:32:55)
    5. ttkacik1 says that he figured out what the difference betwen jenkins code coverage and sonar code coverage reporting was, it was that sonar only counts UT in the same artifact (colindixon, 17:33:59)
    6. M2 offset 2 is today, send your things in (colindixon, 17:35:09)
    7. zxiiro says that once the odlparent patch goes in, he will be proposing patches to remove the (often incorrect) jacoco config from their pom files (colindixon, 17:35:42)
    8. zxiiro says that IT stuff has to be done in the IT pom, integration-parent might be a good choice (colindixon, 17:36:48)

  6. stable/lithium (colindixon, 17:36:59)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-September/003754.html thread on moving Lithium-SR3 (colindixon, 17:37:33)

  7. system integration and test (colindixon, 17:37:48)
    1. not too much this week, the split happened and the issues seem to have been resolve (colindixon, 17:38:08)
    2. colindixon notes that only distribution of the integration projects is formally participating in Beryllium, he asks if there are any problems with that (colindixon, 17:39:11)
    3. edwarnicke asks if packaging needs to participate, dfarrell07 says that there was a long thread on that and decided intentionally not to, they package after the release (colindixon, 17:39:58)
    4. dfarrell07 says that right now there is no continuous packaging delivery, but they’re moving that way (colindixon, 17:40:20)

  8. infastructure (colindixon, 17:41:42)
    1. yesterday they were having API issues with Rackspace, seems to have sorted itself out now (colindixon, 17:42:19)
    2. tykeal says that he now has a very, very basic Ubuntu image, but it’s yet to be tested in the sandbox (colindixon, 17:42:43)
    3. tykeal says now is the time for people to start submitting patches to the ubutu vagrant in releng to see if they work (colindixon, 17:43:53)
    4. tykeal says JIRA is next on his list and odlforge is somewhat further down on his list (colindixon, 17:44:53)

  9. mature projects/stable features (colindixon, 17:44:58)
    1. edwarnicke says there’s lots of stuff about stable feautres in the Beryllium release plan (colindixon, 17:45:44)
    2. edwarnicke notes that if we wait until the release review for the TSC to bless stable features, we will not get the results that we want (colindixon, 17:46:10)
    3. edwarnicke suggests instead (as PTL of distribution) that we start anipbu putting together a list of stable candiate feautres which could then be includied in a stable candidate distribution so we can start testing this stuff sooner (colindixon, 17:46:58)
    4. edwarnicke notes that this would not be an official stable release, but a candidate one, i.e., we wouldn’t need to enforce everything (colindixon, 17:49:58)
    5. ttkacik1 notes that you have to have two feaute repositories, e.g., one stable and one for everythign else (called extended) (colindixon, 17:52:50)
    6. https://lists.opendaylight.org/pipermail/tsc/2015-September/003763.html proposed clarifications to the graudation review for a projec to be mature (colindixon, 17:58:11)

  10. cookies (colindixon, 18:00:15)
    1. dlenrow says the first ODL user group is on Tuesday in Caimbridge, MA (colindixon, 18:00:33)
    2. https://www.opendaylight.org/events/2015-09-08-000000/odlug-northeast-usa-initial-f2f-meeting First NorthEast ODLUG Meeting (phrobb, 18:01:02)


Meeting ended at 18:01:18 UTC (full logs).

Action items

  1. phrobb to start a discussion on the idea of moving from WebEx to something else
  2. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
  3. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  4. phrobb to keep working on JIRA and let us know when we can use it
  5. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  6. phrobb to send an e-mail asking for any feedback about planning the ODL summit for 2016


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  2. phrobb
    1. phrobb to start a discussion on the idea of moving from WebEx to something else
    2. phrobb to keep working on JIRA and let us know when we can use it
    3. phrobb to send an e-mail asking for any feedback about planning the ODL summit for 2016
  3. zxiiro
    1. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information


People present (lines said)

  1. colindixon (87)
  2. dneary (8)
  3. dfarrell07 (7)
  4. edwarnicke (7)
  5. tykeal (7)
  6. ebrjohn (6)
  7. abhijitkumbhare (6)
  8. gzhao (5)
  9. odl_meetbot (5)
  10. anipbu2 (3)
  11. ttkacik1 (3)
  12. ChrisPriceAB (3)
  13. phrobb (2)
  14. rovarga_ (2)
  15. dlenrow (1)
  16. jmedved (1)
  17. LuisGomez (1)
  18. mohnish_ (1)
  19. zxiiro (1)
  20. jamoluhrsen (1)


Generated by MeetBot 0.1.4.