#opendaylight-meeting: tws

Meeting started by colindixon at 17:00:16 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:00:22)
    1. https://wiki.opendaylight.org/index.php?title=Tech_Work_Stream:Main&oldid=30240#Upcoming_Meeting_Agendas today’s meeting will be Sharon covering how to figure out who’s using what schema fragments in the MD-SAL (colindixon, 17:01:01)
    2. the agenda is open for future meetings (colindixon, 17:01:14)

  2. background (colindixon, 17:06:26)
    1. Sharon basically says XSQL is trying to provide an easier XSQL interface on top of the MD-SAL (colindixon, 17:06:48)
    2. he says that until a month ago, it was very buggy, but there’s been a lot of work in the last month to make it more real (colindixon, 17:08:28)
    3. it basically shows each MD-SAL schema level as an SQL table (colindixon, 17:08:58)
    4. shows “list vfields nodes/node/table/flow” which shosw shte proprties of a flow (colindixon, 17:09:34)
    5. shows “select * from nodes/node;” and gets the list of the nodes (colindixon, 17:10:25)
    6. shows a simple query builder where you can get control-space context-senseitive auto-completion for writing queries which is really pretty cool (colindixon, 17:11:36)
    7. dbainbri asks if there is a plan to turn this into a web-based tool and release it as part of the normal distribution (colindixon, 17:15:11)
    8. Sharon says that he couldn’t get it to work the web-based thing and the REST RPC call for some reason and so he fell back to making a Java/swing app (colindixon, 17:17:03)

  3. demo of working with Pentaho Report Designer (colindixon, 17:17:32)
    1. shows how to generate reports including PDF output (colindixon, 17:18:24)

  4. binding aware code (colindixon, 17:18:42)
    1. the big new feature is that you can do an XSQL query and then get back the BindingAware java objects directly (colindixon, 17:19:12)
    2. shows ToasterProviderModule in org.opendaylight.controller.config.yang.config.toaster_provider.impl (colindixon, 17:19:49)
    3. you should be able to produce an instance identifier from the results to be able to do get where it actually is in the backing store (colindixon, 17:23:22)
    4. dbainbri asks if you can also query TSDR, the answers is not right now, but it’s doable (colindixon, 17:25:25)
    5. currently when it gets the data, it does full table scans which is potentially slow (colindixon, 17:27:23)
    6. Sharon has been thinking about how to construct indices and make things faster, Sharon says he could use help here (colindixon, 17:28:10)
    7. https://lists.opendaylight.org/pipermail/controller-dev/2015-May/009214.html Sharon’s request for help (colindixon, 17:29:36)
    8. https://wiki.opendaylight.org/view/InternProjects:Main (colindixon, 17:31:40)

  5. forums to get help (colindixon, 17:32:26)
    1. colindixon points out that calls for help sent to controller-dev, which is somewhat of a black hole these days (colindixon, 17:36:52)
    2. figuring out how to bring topics up that have broad interest is hard and something we’re bad at as a community (colindixon, 17:39:10)
    3. the TSC call and TWS call are good for things that need to be a discussion (colindixon, 17:39:21)
    4. ACTION: colindixon says he’ll bring up the topic of XSQL help at the TSC meeting on Thursday (colindixon, 17:39:41)
    5. ACTION: dbainbri to bring a few slides around threading modules, load balancing, etc. for next week (colindixon, 17:40:02)

  6. can you query who uses a given grouping (the original question)? (colindixon, 17:40:25)
    1. the answer is not yet, but it shoudl be doable (colindixon, 17:40:33)

  7. security in ODL (colindixon, 17:44:05)
    1. Sharon asks about security in ODL and gets a bunch of pointers (colindixon, 17:44:22)


Meeting ended at 17:57:08 UTC (full logs).

Action items

  1. colindixon says he’ll bring up the topic of XSQL help at the TSC meeting on Thursday
  2. dbainbri to bring a few slides around threading modules, load balancing, etc. for next week


Action items, by person

  1. colindixon
    1. colindixon says he’ll bring up the topic of XSQL help at the TSC meeting on Thursday
  2. dbainbri
    1. dbainbri to bring a few slides around threading modules, load balancing, etc. for next week


People present (lines said)

  1. colindixon (42)
  2. odl_meetbot (4)
  3. dbainbri (4)
  4. hideyuki (1)
  5. phudgins (1)


Generated by MeetBot 0.1.4.