#opendaylight-meeting: UNI Manager

Meeting started by KLuehrs at 21:00:14 UTC (full logs).

Meeting summary

  1. Feasibility of using the OVS QoS 'MaxRate' parameter to implement UNI Speed attribute (KLuehrs, 21:00:39)
    1. Confirmed OVS support MaxRate, QoS has been added to OVS project and it has been merged. (KLuehrs, 21:06:34)
    2. ODL support for QoS - model has been updated. No code exists yet. (KLuehrs, 21:07:08)
    3. Gabriel will check with QoS developer to learn when code will be available. (KLuehrs, 21:08:27)
    4. When code is in OVSDB it should be fairly simple to translate MaxRate to UNI Manager speed attribute. (KLuehrs, 21:09:09)

  2. Unit Test Development techniques (KLuehrs, 21:09:46)
    1. We currently do not have resources available to develop unit tests. The project may be able to get a waiver. (KLuehrs, 21:11:51)
    2. Inocybe may be able to add some test classes and some example functions to the UNI Manager code, to make it easier for someone to follow. (KLuehrs, 21:12:26)

  3. OPNFV Brahamaputra release (KLuehrs, 21:13:35)
    1. OPNFV release team has asked about potential conflicts with ODL karaf, e.g., Is the UNI-mgr karaf feature able to run coexistent with the required karaf features used in OPNFV? (do they collide with net-virt or sfc for instance or are they able to run at the same time?) (KLuehrs, 21:44:43)
    2. Gabriel thinks the information they are looking for is (1) What URLs and JSON payload does LSO API use when calling ODL UNI Manager plug-in, and (2) is there, or is there potential for, a port conflict between ODL karaf (8080, 8181) and Tomcat as used by LSOAPI? (KLuehrs, 21:47:16)
    3. Currently our implementation of the OPNFV LSOAPI uses port 9090 so there should be no conflict. (KLuehrs, 21:47:43)
    4. ACTION: Gabriel will find out when ODL QoS implementation (code) will be done. (KLuehrs, 21:48:27)
    5. ACTION: Inocybe will create basic test framework for UNI Manager unit tests: test classes and one or two sample functions for reference. (KLuehrs, 21:49:19)
    6. AGREED: Next week's meeting (December 23) is cancelled due to holidays. The next UNI Manager project meeting will be held at the regularly scheduled time December 30. (KLuehrs, 21:51:24)


Meeting ended at 21:51:28 UTC (full logs).

Action items

  1. Gabriel will find out when ODL QoS implementation (code) will be done.
  2. Inocybe will create basic test framework for UNI Manager unit tests: test classes and one or two sample functions for reference.


People present (lines said)

  1. KLuehrs (18)
  2. odl_meetbot (4)


Generated by MeetBot 0.1.4.