#opendaylight-meeting: weekly irc sync

Meeting started by gzhao at 14:31:59 UTC (full logs).

Meeting summary

    1. tbachman for GBP (tbachman, 14:32:22)
    2. regXboi for neutron northbound (regXboi, 14:32:29)
    3. anipbu for usc (anipbu, 14:32:31)
    4. LuisGomez1 integration (LuisGomez1, 14:32:56)
    5. lori for lispflowmapping (lori, 14:33:08)
    6. Hideyuki for VTN (hideyuki, 14:33:20)
    7. gzhao for release USC (gzhao, 14:33:37)
    8. ttkacik for yangtools and controller (ttkacik, 14:33:53)
    9. odlcasey for ODL (odlcasey, 14:34:07)
    10. Thanh (zxiiro, 14:35:08)

  1. RC0 and branching, version bump (gzhao, 14:37:20)
    1. zxiiro says he's still trying to get an RC0 build going… he's on attempt #15 (phrobb1, 14:38:34)
    2. regXboi says Neutron Northbound s missing a couple of pieces of it's northbound connections to OpenStack (tbachman, 14:41:57)
    3. regXboi wonders how to handle this situation because its not precisely covered in the API waiver process (regXboi, 14:42:27)
    4. phrobb1 asks if there’s anything else blocking RC0/1? Is there anything this group can do to help? (tbachman, 14:42:34)
    5. gzhao says we need to get RC build successful, then all projects need to complete branch cutting and version bump (tbachman, 14:42:46)
    6. there still 6-7 projects haven't completed branching and version bump (gzhao, 14:43:44)

  2. Blocking bugs (gzhao, 14:44:28)
    1. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 < -- current blocking bugs (gzhao, 14:44:58)
    2. odlcasey asks if the Lithium Project Status spreadsheet is accurate (tbachman, 14:46:52)
    3. zxiiro says he’s been keeping it updated daily (tbachman, 14:47:14)
    4. regXboi notes that the bugs being filed don't necessarily contain enough useful information to triage (regXboi, 14:48:01)
    5. ACTION: regXboi to create template for NN bugs in NN wiki (regXboi, 14:52:03)
    6. https://wiki.opendaylight.org/view/Weather#Blocking_Bugs (edwarnicke, 14:52:37)
    7. Tony found the root cause of the bug 3344, and it was able to have unit test reproduce it. https://bugs.opendaylight.org/show_bug.cgi?id=3344 (hideyuki, 14:53:42)
    8. abhijitkumbhare OpenFlow plugin (abhijitkumbhare, 14:53:58)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=3344 blocker bug for VTN, which ttkacik recently found the source of and fixed (tbachman, 14:54:16)

  3. RC1 (gzhao, 14:56:21)
    1. RC1 is scheduled 6/4 tomorrow (gzhao, 14:57:51)
    2. edwarnicke asks if the purpose of RC# is to have images to test with... so the question becomes... can we really have an RC1 if we never built RC0... (tbachman, 15:00:53)
    3. edwarnicke notes that skipping RC0 materially means that we've cut off a third of our RC testing (tbachman, 15:01:43)
    4. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-lithium/15/ <--current RC0 build (gzhao, 15:02:12)
    5. zxiiro says there’s an RC0 build underway, and should be available in ~6 hours (tbachman, 15:02:58)
    6. edwarnicke asks about a blocking issue related to security groups in the stackforge networking_odl project — and how we can track dependencies against it (tbachman, 15:05:28)
    7. alagalah_ says the issue is that security group updates aren’t being sent (tbachman, 15:05:58)
    8. https://review.openstack.org/#/q/status:open+project:stackforge/networking-odl,n,z (alagalah_, 15:06:08)
    9. regXboi says that’s outside of scope (tbachman, 15:06:09)
    10. alagalah_ asks regXboi what’s in scope then? (tbachman, 15:07:36)
    11. regXboi says stackforge is openstack scope (tbachman, 15:07:45)
    12. gzhao asks if not all projects are on stable/lithium, will it cause tagging issues after RC build? (tbachman, 15:08:40)
    13. zxiiro says tagging no. but we should have stable/lithium in order to tag otherwise they won't have a lithium stream once tagging completes (tbachman, 15:08:56)
    14. regXboi says that these are bugs that need to be filed on openstack and the ODL ML2 driver (tbachman, 15:12:18)
    15. phrobb1 asks if the stackforge bug truly a blocker?… ie we wouldn't ship Li without it being fixed? (tbachman, 15:12:50)
    16. - I know this is a bit of a regression, but I'm not convinced that 3368 is a blocking bug (regXboi, 15:13:01)
    17. edwarnicke says its really a question of whether we are supporting basic neutron L2 or not (tbachman, 15:13:08)
    18. phrobb1 says that to him, it doesn't sound like a blocker but instead a severe bug that we document, then update with a version identifier on Kilo/driver/whatever if/when the issue is fixed in OpenStack (tbachman, 15:13:41)
    19. edwarnicke asks if we just say that we don't support L2 and SG then in our release notes? (tbachman, 15:15:30)
    20. regXboi says that all we can do is say we support SG as much as openstack does (regXboi, 15:16:03)
    21. edwarnicke notes that if I change a SG, I have to teardown and restand up *all* the VMs that impacts in order to reflect that (tbachman, 15:16:34)
    22. we don't support SG as much as OS does, but instead substantially less... entirely because of this bug in our OS driver (edwarnicke, 15:16:35)
    23. phrobb1 asks if regardless of the codebase where the bug resides, do we know who the logical people are to fix it?… ie is it someone from the ODL community who has been working in OpenStack?… or is there someone in OpenStack we need to work with to get it fixed? (tbachman, 15:17:11)
    24. edwarnicke notes that mestery has been giving it as much effort as he can, but he’s very busy; flaviof has also been looking at it (tbachman, 15:18:02)
    25. regXboi askes if edwarnicke is saying that without the SG patch to OS, then *we don't have a Lithium release, period* (regXboi, 15:18:26)
    26. regXboi notes that this feels like this is setitng both a bad precedent and is engaging in serious scope creep (regXboi, 15:19:08)
    27. edwarnicke says to him there are two choices: 1) Get this fixed, and make sure projects handle the fix correctly and claim OS support; : 2) Don't, and don't really have neutron support in Li (tbachman, 15:19:36)
    28. phrobb1 says ultimately, the TSC decides when the release is ready to ship. edwarnicke has a really good argument that the OpenStack bug is a blocker for ODL, particularly if we have the resources/ability to fix it regardless of code base. (tbachman, 15:19:57)
    29. ACTION: project: CCFT, D4A, DIDM, Doc, NIC, Persistence, Reservation, SNBI, SNMP4SDN need to complete stable/lithium branching and version bump ASAP (gzhao, 15:21:01)
    30. regXboi points out that the TSC doesn’t allocate resources (tbachman, 15:21:17)
    31. phrobb1 points out that the TSC does determine minimum functionality and robustness for release (tbachman, 15:22:27)
    32. edwarnicke asks flaviof if he knows whether there’s a bug filed on the OS side, and if not, where should it be filed over there? (tbachman, 15:24:55)
    33. https://bugs.launchpad.net/networking-odl odl ml2 bugs (flaviof, 15:25:43)
    34. https://bugs.launchpad.net/networking-odl/+bug/1444112 (flaviof, 15:26:12)
    35. https://bugs.launchpad.net/networking-odl/+bug/1450603 critical odl bug: fix ci (flaviof, 15:26:53)
    36. regXboi want to make the point that this is a change in scope (regXboi, 15:26:57)
    37. regXboi points out that we are now saying we are blocking on bugs that *ARE OUTSIDE ODL'S SCOPE* (regXboi, 15:27:26)
    38. : https://bugs.launchpad.net/networking-odl/+bug/1444112 bug against networking_odl security groups (in openstack) (tbachman, 15:27:28)
    39. regXboi says "and that's a *major* change" (regXboi, 15:27:50)
    40. https://wiki.opendaylight.org/view/Weather#Blocking_Bugs (edwarnicke, 15:33:11)
    41. edwarnicke has added the SG and SGR issue to blocking bugs list (edwarnicke, 15:33:46)
    42. ACTION: gzhao sends email to TSC for further SG/SGR discussions (gzhao, 15:34:34)

  4. cookies (gzhao, 15:34:37)


Meeting ended at 15:34:49 UTC (full logs).

Action items

  1. regXboi to create template for NN bugs in NN wiki
  2. project: CCFT, D4A, DIDM, Doc, NIC, Persistence, Reservation, SNBI, SNMP4SDN need to complete stable/lithium branching and version bump ASAP
  3. gzhao sends email to TSC for further SG/SGR discussions


Action items, by person

  1. gzhao
    1. gzhao sends email to TSC for further SG/SGR discussions
  2. regXboi
    1. regXboi to create template for NN bugs in NN wiki


People present (lines said)

  1. edwarnicke (70)
  2. tbachman (65)
  3. regXboi (61)
  4. gzhao (43)
  5. phrobb1 (24)
  6. zxiiro (13)
  7. alagalah_ (9)
  8. odl_meetbot (9)
  9. flaviof (6)
  10. hideyuki (5)
  11. odlcasey (4)
  12. ttkacik1 (4)
  13. tykeal (2)
  14. LuisGomez1 (2)
  15. abhijitkumbhare (2)
  16. ttkacik (1)
  17. anipbu (1)
  18. lori (1)


Generated by MeetBot 0.1.4.