#opendaylight-meeting: weekly_lithium_irc_sync

Meeting started by colindixon at 15:31:55 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 15:32:00)
    1. alagalah for GBP (alagalah, 15:32:04)
    2. dkutenic for bgpcep, tcpmd5 (dkutenic, 15:32:23)
    3. colindixon for docs,  ttp and the TSC (colindixon, 15:32:28)
    4. LuisGomez from integration (LuisGomez, 15:32:30)
    5. fabiel for Persistence Store Service (fabiel, 15:32:34)
    6. abhijitkumbhare for OpenFlow plugin (abhijitkumbhare, 15:32:37)
    7. Hideyuki for VTN (hideyuki, 15:32:40)
    8. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings the agenda for today and where to add things for future meetings (colindixon, 15:34:13)
    9. gzhao release (gzhao, 15:35:09)

  2. topics of general concern (colindixon, 15:36:43)
    1. alagalah asks what was going on with builds failing last night because of what looked like git clone issues (colindixon, 15:37:11)
    2. https://lists.opendaylight.org/pipermail/release/2015-March/001523.html Email fom sdean778 on M3 requirements (tbachman, 15:37:30)
    3. https://lists.opendaylight.org/pipermail/release/2015-March/001524.html Response from gzhao to sdean778’s M3 requirements email (tbachman, 15:38:10)
    4. tykeal: rackspace rebooted all of the Xen hosts last night. They did it over ~8 hours so the entire environment would have been very unstable (alagalah, 15:38:25)
    5. the gist of gzhao’s response to sdean778 is that you should report where you are and for things that aren’t on track what the new ETA is (colindixon, 15:38:53)
    6. tykeal says that things appear to be back to normal (colindixon, 15:39:01)
    7. Steve Dean for DIDM and SNMP PLugin (sdean778, 15:39:10)
    8. https://lists.opendaylight.org/pipermail/release/2015-February/001489.html we still need lots of people to update their single feature test and note that it’s been fixed in the spreadsheet (colindixon, 15:40:06)
    9. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 the sheet to report when you’ve updated your single feature test (also linked from the above mail) (colindixon, 15:41:35)
    10. https://lists.opendaylight.org/pipermail/release/2015-February/001506.html (colindixon, 15:42:53)
    11. https://lists.opendaylight.org/pipermail/release/2015-February/001506.html this shows how colindixon produced the list of offending projects and a more recent (but not curent) list (colindixon, 15:43:20)

  3. questions about M3 deliverables (colindixon, 15:45:04)
    1. LuisGomez notes that he has gotten nearly no features patches to integration despite the M3 offiset 1 deadline for that being tomorrow (colindixon, 15:52:40)
    2. LuisGomez says that there are only 5 projects that are offset 1 and new to Lithium: persistence, SXP, SNMP and topology processing (colindixon, 15:52:56)
    3. only topoprocessing has gotten their features in, but this is less worrying since it’s just three projects that haven’t done it yet (colindixon, 15:53:35)
    4. fabiel notes that persistence is working on it as we speak (colindixon, 15:53:56)

  4. questions from one project to another (colindixon, 15:54:45)
  5. announcements of changes that might affect other projects (colindixon, 15:56:12)
    1. announce: TWS call in 2 weeks (Mon March 16th) we will explain Robot Framework (LuisGomez, 15:56:18)
    2. ACTION: all projects to check and/or fix their single feature test using the link above in the minutes (colindixon, 15:56:54)
    3. with robot examples, best practices, etc… (LuisGomez, 15:57:12)
    4. ACTION: at least SXP, persistence, Neutron, and SNMP to get their features into integration. Other offset 1 projects may need to update their features definitions. (colindixon, 15:57:42)
    5. ttkacik says that yangtools and controller will be pushing patches to move completely to normalized node from composite node starting on monday (colindixon, 15:59:45)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-03-03-16.59.html more info on the move from composite to normalized nodes is here (only affects controller and ttp as far as ttkacik knows) (colindixon, 16:00:38)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings post any topics for next week here (colindixon, 16:01:09)


Meeting ended at 16:01:13 UTC (full logs).

Action items

  1. all projects to check and/or fix their single feature test using the link above in the minutes
  2. at least SXP, persistence, Neutron, and SNMP to get their features into integration. Other offset 1 projects may need to update their features definitions.


People present (lines said)

  1. colindixon (69)
  2. tbachman (38)
  3. alagalah (23)
  4. tykeal (11)
  5. LuisGomez (10)
  6. gzhao (5)
  7. odl_meetbot (5)
  8. ttkacik (3)
  9. abhijitkumbhare (3)
  10. fabiel (2)
  11. sdean778 (2)
  12. hideyuki (2)
  13. dkutenic (1)
  14. phrobb- (0)


Generated by MeetBot 0.1.4.