#opendaylight-meeting: weekly lithium irc sync

Meeting started by colindixon at 14:30:36 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 14:30:41)
    1. Prem for VPNService (Prem, 14:30:45)
    2. regXboi for NN (regXboi, 14:30:58)
    3. colindixon for TTP, TSC and docs (colindixon, 14:31:05)
    4. gzhao for release, USC (gzhao, 14:31:19)
    5. lori for lispflowmapping (lori, 14:31:28)
    6. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings the (out-of-date) agenda in it’s usual place (colindixon, 14:31:36)
    7. Thanh (zxiiro, 14:31:56)
    8. odl-casey (odl-casey, 14:32:43)
    9. LuisGomez1 for integration (LuisGomez1, 14:32:54)
    10. Hideyuki for VTN (hideyuki, 14:32:57)
    11. jburns for iotdm (jburns, 14:33:41)
    12. abhijitkumbhare OpenFlow plugin (abhijitkumbhare, 14:35:41)

  2. M5 milestone (colindixon, 14:37:21)
    1. the M5 status is due *tomorrow* for offset 2 projects and that will mean the whole project is code frozen with only bug fixes (colindixon, 14:37:42)
    2. as part of that you should cut a stable/lithium branch for your bug fixes, zxiiro has instructions on how to do that (colindixon, 14:38:11)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Cutting_Stability_Branches the instructions are here (colindixon, 14:38:22)
    4. after you’ve cut your branch, you’ll bump versions on the master branch to keep the two from interfering with each other (colindixon, 14:38:53)
    5. snmp4sdn and snbi M5 status are two weeks overdue (gzhao, 14:39:07)
    6. after you’ve bumped versions on the master branch you can do whatever development you want on master (colindixon, 14:42:12)
    7. bug fixes should go to stable/lithium (and in 99% of the cases also be cherry-picked to master) (colindixon, 14:42:46)

  3. coretutorials (colindixon, 14:43:01)
    1. tonytkacik asks if coretutorials will be able to add new tutorials after code freeze (colindixon, 14:43:15)
    2. there’s some discussion on whether they should be in the release, and leaving might make that easier since the rules wouldn’t apply, but LuisGomez1 says they ahve one feature used in integration for a DS benchmark (colindixon, 14:43:48)
    3. ACTION: colindixon to try to add some stuff to beryllium for docs-like projects (colindixon, 14:44:33)
    4. ACTION: colindixon, gzhao, and phrobb to work with core tuorials to figure out what needs to happen (colindixon, 14:45:03)
    5. ACTION: tonytkacik to send mail to the list (or phrobb and colindixon) about different docs in Beryllium (colindixon, 14:46:34)

  4. bugs in key projects (colindixon, 14:46:53)
    1. at the MD-SAL weekly interest call we tried to find simple bugs during the bug scrub (colindixon, 14:47:12)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-05-12-16.07.html easy bugs for controller and yangtools are listed here undr “4. bug scrub” (colindixon, 14:47:30)
    3. if anyone wants to help fix bugs deep in ODL infrastructure for everyone in Lithium, this is the time and place (colindixon, 14:47:53)
    4. tonytkacik has volunteered to mentor help, so it’s a great opportunity to get involved (colindixon, 14:48:18)

  5. branch cutting/version bumping (colindixon, 14:48:32)
    1. there is discussion about cutting the openflowplugin branch and a dependency on an IPv6 fix to bump versions (colindixon, 14:52:23)
    2. ACTION: ttkacik, abhijitkumbhare, michal_rehak, and zxiiro to work on getting openflowplugin unstuck (colindixon, 14:52:57)
    3. it seems like master for projects dependent on openflowplugin is going to be blocked for a while while the IPv6 fix is worked out (the IPv6 issues may affect OVSDB and GBP) (colindixon, 14:59:28)
    4. colindixon notes that in beryllium we should try to avoid this issue (changes happening in upstream projects before you cut your branch making your version bump impossible), possibly by cutting branches all the same time (colindixon, 15:01:18)
    5. https://lists.opendaylight.org/pipermail/controller-dev/2015-April/009149.html (ttkacik, 15:01:28)
    6. https://lists.opendaylight.org/pipermail/controller-dev/2015-April/009149.html the IPv6 issue at hand :-/ (colindixon, 15:01:44)
    7. ACTION: colindixon to add a discussion of how to avoid branch cutting delay in Beryllium (colindixon, 15:04:50)

  6. deependency tracking (colindixon, 15:05:07)
    1. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-daily-master/lastFailedBuild/artifact/dependencies.log zxiiro wrote a script to track dependencies (colindixon, 15:05:20)
    2. https://git.opendaylight.org/gerrit/gitweb?p=releng/autorelease.git;a=blob;f=scripts/list-project-dependencies.sh;h=4faaa9860bf5459a06ce00a34571d3fe3914f0cc;hb=HEAD the script is here (colindixon, 15:05:33)

  7. cookies (colindixon, 15:08:01)


Meeting ended at 15:08:07 UTC (full logs).

Action items

  1. colindixon to try to add some stuff to beryllium for docs-like projects
  2. colindixon, gzhao, and phrobb to work with core tuorials to figure out what needs to happen
  3. tonytkacik to send mail to the list (or phrobb and colindixon) about different docs in Beryllium
  4. ttkacik, abhijitkumbhare, michal_rehak, and zxiiro to work on getting openflowplugin unstuck
  5. colindixon to add a discussion of how to avoid branch cutting delay in Beryllium


Action items, by person

  1. abhijitkumbhare
    1. ttkacik, abhijitkumbhare, michal_rehak, and zxiiro to work on getting openflowplugin unstuck
  2. colindixon
    1. colindixon to try to add some stuff to beryllium for docs-like projects
    2. colindixon, gzhao, and phrobb to work with core tuorials to figure out what needs to happen
    3. tonytkacik to send mail to the list (or phrobb and colindixon) about different docs in Beryllium
    4. colindixon to add a discussion of how to avoid branch cutting delay in Beryllium
  3. gzhao
    1. colindixon, gzhao, and phrobb to work with core tuorials to figure out what needs to happen
  4. tonytkacik
    1. tonytkacik to send mail to the list (or phrobb and colindixon) about different docs in Beryllium
  5. ttkacik
    1. ttkacik, abhijitkumbhare, michal_rehak, and zxiiro to work on getting openflowplugin unstuck
  6. zxiiro
    1. ttkacik, abhijitkumbhare, michal_rehak, and zxiiro to work on getting openflowplugin unstuck


People present (lines said)

  1. colindixon (76)
  2. ttkacik (16)
  3. abhijitkumbhare (14)
  4. zxiiro (12)
  5. gzhao (10)
  6. tonytkacik (8)
  7. LuisGomez1 (6)
  8. hideyuki (5)
  9. Prem (3)
  10. regXboi (3)
  11. odl_meetbot (3)
  12. lori (3)
  13. jburns (1)
  14. odl-casey (1)
  15. phrobb1 (1)


Generated by MeetBot 0.1.4.