#opendaylight-meeting: weekly lithium irc sync

Meeting started by colindixon at 14:30:50 UTC (full logs).

Meeting summary

  1. agenda items and roll call (colindixon, 14:30:51)
    1. colindixon for TSC, docs and TTP (colindixon, 14:31:00)
    2. Prem for VPNService (Prem, 14:31:08)
    3. Thanh releng (zxiiro, 14:31:10)
    4. LuisGomez integration (LuisGomez, 14:31:25)
    5. here (alagalah, 14:31:45)
    6. Hideyuki for VTN (hideyuki, 14:32:09)
    7. anipbu for usc (anipbu, 14:32:18)
    8. alagalah for GBP (alagalah, 14:32:24)

  2. neutron northbound breakage (colindixon, 14:33:03)
    1. late yesterday afternoon saw issues with CDS borks when writing to OVSDB.... (alagalah, 14:34:00)
    2. https://lists.opendaylight.org/pipermail/controller-dev/2015-May/009400.html Email to lists, reporting breakage (tbachman, 14:34:04)
    3. Backed out yangtools to May15 (pre 5 patches on the same bug) and was able to continue (alagalah, 14:34:20)
    4. later that night, was testing a patch for "fixedIPs" in neutron stable/ lithium, and was able to test, prove patch, but then found next fault (approx 9pm) and emailed Ed (alagalah, 14:34:50)
    5. at midnight, Ed had another patch for me to fix next fixedIPs issue and it was at that time I saw "Activator" problems (ie couldn't load feature) (alagalah, 14:35:15)
    6. I discovered that -DskipTests can sometimes be evil, and that NEutron was borking on various UTs (alagalah, 14:35:40)
    7. at same time yangtools/controller were also fixing issues, so it was a matter of "do I wait?" "try this?" but results in 5-6 hours of playing fetch me a rock with yangtools, controller, neutron and my m2 (alagalah, 14:36:19)
    8. https://lists.opendaylight.org/pipermail/controller-dev/2015-May/009401.html email from rovarga, asking edwarnicke if the problem was a commit he made (tbachman, 14:36:36)
    9. Last status is I sent my SureFire reports to controller-dev, yangtool-dev, neutron-dev and... (alagalah, 14:36:39)
    10. rovarga has replied with "something got taken out of neutron around Activator" (alagalah, 14:37:00)
    11. vishnoianil_ (vishnoianil_, 14:37:02)
    12. ACTION: colindixon to find flaviof or edwarnicke in Vancover and see if he can get them to look at NN for a bit (colindixon, 14:39:17)

  3. cutting RC0 (colindixon, 14:40:32)
    1. zxiiro says we are still waiting on openflowplugin to cut branches to start the lithium auto-release (colindixon, 14:41:48)
    2. ACTION: zxiiro to create a bug to track the inability of openflowplugin to cut stable/lithium and put it on the blocking bugs list (colindixon, 14:47:36)
    3. it sounds like it make be the case that openflow plugin could cut stable/lithium it’s just that it would block master after that because you would *have* to immediately version bump, but that might be better than being unable to cut RC0 (colindixon, 14:48:13)
    4. ACTION: colindixon to try to lay out the current problem with openflowplugin and paths forward on the release/TSC mailing list (colindixon, 14:53:08)

  4. cookies (colindixon, 14:55:19)


Meeting ended at 14:55:24 UTC (full logs).

Action items

  1. colindixon to find flaviof or edwarnicke in Vancover and see if he can get them to look at NN for a bit
  2. zxiiro to create a bug to track the inability of openflowplugin to cut stable/lithium and put it on the blocking bugs list
  3. colindixon to try to lay out the current problem with openflowplugin and paths forward on the release/TSC mailing list


Action items, by person

  1. colindixon
    1. colindixon to find flaviof or edwarnicke in Vancover and see if he can get them to look at NN for a bit
    2. colindixon to try to lay out the current problem with openflowplugin and paths forward on the release/TSC mailing list
  2. edwarnicke
    1. colindixon to find flaviof or edwarnicke in Vancover and see if he can get them to look at NN for a bit
  3. zxiiro
    1. zxiiro to create a bug to track the inability of openflowplugin to cut stable/lithium and put it on the blocking bugs list


People present (lines said)

  1. colindixon (55)
  2. alagalah (26)
  3. zxiiro (9)
  4. tbachman (8)
  5. ttkacik1 (6)
  6. odl_meetbot (6)
  7. vishnoianil_ (4)
  8. LuisGomez (2)
  9. ttkacik (2)
  10. phrobb1 (2)
  11. Prem (1)
  12. hideyuki (1)
  13. anipbu (1)
  14. gzhao (0)
  15. phrobb (0)
  16. edwarnicke (0)
  17. dfarrell07 (0)


Generated by MeetBot 0.1.4.