#opendaylight-meeting: weekly lithium IRC sync

Meeting started by colindixon at 14:29:25 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 14:29:35)
    1. colindixon for TSC, TTPs and docs (colindixon, 14:29:52)
    2. Prem for VPNService (Prem, 14:30:58)
    3. ttkacik for controller and yangtoools (ttkacik, 14:31:08)
    4. Hideyuki for VTN (hideyuki, 14:31:15)
    5. Casey Cain for ODL (odl-casey, 14:31:17)
    6. tbachman for Group Based Policy (tbachman, 14:31:44)
    7. abhijitkumbhare for OpenFlow Plugin (abhijitkumbhare, 14:31:52)
    8. LuisGomez1 integration (LuisGomez1, 14:32:43)

  2. RC0 and branch cutting (colindixon, 14:34:39)
    1. abhijitkumbhare says that openflow plugin cut their stable/lithium branch yesterday (colindixon, 14:35:02)
    2. that means we can start to try to cut RC0 today (colindixon, 14:35:13)
    3. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2015-May/003170.html email from michal_rehak on branch cut (tbachman, 14:35:53)
    4. abhijitkumbhare says openflow plugin points to the version of yangtools without the IPv6 prefix change (abhijitkumbhare, 14:35:55)
    5. zxiiro said he was going to work on cuttong RC0 today (colindixon, 14:36:06)
    6. https://www.timeanddate.com/countdown/generic?iso=20150528T235959&p0=1440&msg=Lithium+RC0+Build+Start (colindixon, 14:36:48)

  3. blocking bugs (colindixon, 14:38:15)
    1. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 the blocking bugs spreadsheet (colindixon, 14:38:58)
    2. please add any blocking bugs here and we’ll try to track it (colindixon, 14:39:14)
    3. ACTION: abhijitkumbhare to update the entries fro openflowplugin in the blocking bug sheet, I think we have patches for 3305 and 3341, it’s unclear about 3306 since they’re still using the Lithium versions of yangtools (colindixon, 14:42:41)
    4. I plan to add bug 3344 as a blocking bug to the spreadsheet. https://bugs.opendaylight.org/show_bug.cgi?id=3344 (hideyuki, 14:43:07)
    5. the remainting bugs are against iotdm for blocking autorelease, and neutron/ovsdb for issues blockg GBP (colindixon, 14:43:27)
    6. Due to the Bug 3344, VTN Manager does not work correctly. ttkacik (Tony) is working on that. (hideyuki, 14:44:17)

  4. 3rd party sources (colindixon, 14:45:00)
    1. odl-casey has been trying round up the source code for our 3rd party dependenceis (colindixon, 14:45:16)
    2. https://docs.google.com/spreadsheets/d/1q_vxUjo4gIxpyAGq43Yiu77o1GHdLaSlxVMysd6G5bQ/edit?usp=sharing (odl-casey, 14:45:28)
    3. https://docs.google.com/spreadsheets/d/1q_vxUjo4gIxpyAGq43Yiu77o1GHdLaSlxVMysd6G5bQ/edit?usp=sharing this is the list of 3rd-party dependenceis which we’re still looking for source jars for (colindixon, 14:47:09)

  5. version bumps on master for Beryllium development (colindixon, 14:48:28)
    1. hideyuki asks if we have a way we’re tracking who has bumped their versions on master (colindixon, 14:49:12)
    2. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1592977660 it is supposedly tracked in column F of this sreadhseet tab based on the M5 readout (colindixon, 14:49:53)
    3. based on what abhijitkumbhare said, it might still be dangerous for projects using openflowplugin to do a version bump becuase I think openflowplugin is still using the lithium versions of yangtools, so a normal version bump will result in a skew between the versions of yangtools that are used (colindixon, 14:50:56)
    4. ACTION: zxiiro and abhijitkumbhare to touch base to figure out if it’s safe for projects downstream of openflowplugin to bump their versions, for now, I’d recommend not (colindixon, 14:52:04)
    5. hideyuki asks if there’s an ETA for a version bump in openflowplugin, abhijitkumbhare says not yet (colindixon, 14:53:31)

  6. bug fixing in yangtools and controller (colindixon, 14:53:52)
    1. if there are broader community members interested in getting involved in fixing bugs in the key parts of ODL, please come to the MD-SAL weekly interest calls where we’ve been doing bug scrubbing and finding bugs which are “easy” with mentoring to fix them (colindixon, 14:54:28)
    2. https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call more information on when the meetings are and old minutes here (colindixon, 14:54:44)

  7. cookies (colindixon, 14:56:37)


Meeting ended at 14:56:40 UTC (full logs).

Action items

  1. abhijitkumbhare to update the entries fro openflowplugin in the blocking bug sheet, I think we have patches for 3305 and 3341, it’s unclear about 3306 since they’re still using the Lithium versions of yangtools
  2. zxiiro and abhijitkumbhare to touch base to figure out if it’s safe for projects downstream of openflowplugin to bump their versions, for now, I’d recommend not


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to update the entries fro openflowplugin in the blocking bug sheet, I think we have patches for 3305 and 3341, it’s unclear about 3306 since they’re still using the Lithium versions of yangtools
    2. zxiiro and abhijitkumbhare to touch base to figure out if it’s safe for projects downstream of openflowplugin to bump their versions, for now, I’d recommend not


People present (lines said)

  1. colindixon (53)
  2. hideyuki (14)
  3. abhijitkumbhare (12)
  4. tbachman (11)
  5. ttkacik (5)
  6. odl_meetbot (4)
  7. Prem (3)
  8. odl-casey (3)
  9. LuisGomez1 (2)
  10. gzhao (0)
  11. phrobb (0)


Generated by MeetBot 0.1.4.