#opendaylight-meeting: weekly lithium irc sync

Meeting started by gzhao at 14:30:24 UTC (full logs).

Meeting summary

  1. roll call and agenda (gzhao, 14:31:07)
    1. gzhao release USC (gzhao, 14:32:35)
    2. Hideyuki for VTN (hideyuki, 14:32:40)
    3. Prem for VPNService (Prem, 14:32:57)
    4. colindixon for TTP, docs, and TSC (colindixon, 14:33:36)
    5. LuisGomez1 (LuisGomez1, 14:33:47)
    6. Casey Cain (odl-casey, 14:35:25)

  2. blocking issues (gzhao, 14:35:33)
    1. abhijitkumbhare OpenFlow plugin (abhijitkumbhare, 14:35:58)
    2. tbachman for GBP (tbachman, 14:36:08)

  3. blocking bugs (colindixon, 14:36:38)
    1. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 <--- blocking issues (colindixon, 14:36:44)
    2. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1360517736 <-- RC0 issues (gzhao, 14:37:54)
    3. according to Ryan, 3368 need to be fixed externally (gzhao, 14:40:36)
    4. colindixon notes that very few projects have responeded to the RC0 call for reports (colindixon, 14:41:57)
    5. VTN project is testing RC0, and have not detected any new critical issues in it so far. (hideyuki, 14:42:07)
    6. alagalah GBP (alagalah, 14:42:20)
    7. https://lists.opendaylight.org/pipermail/release/2015-June/002575.html if you haven’t sent in a report, it would help a lot if you could reply to Luis’s mail here (colindixon, 14:42:48)
    8. GBP has done some testing on RC0, but was waiting to finish testing before updating the spreadsheet (tbachman, 14:42:57)
    9. alagalah asks if we will delay release because we missed RC0 for a week, colindixon says not right now, the current plan is to do RC0, RC1, RC2 and then release (skipping an RC3) to try to release on time (colindixon, 14:44:27)
    10. LuisGomez1 said all projects should feed https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1072617634 (gzhao, 14:45:16)

  4. sonar reports (colindixon, 14:47:30)
    1. tbachman says “btw — folks sonar reports may look a little worse than usual for today (patch submitted to yangtools master to fix this)” (colindixon, 14:47:41)

  5. RCs and reports (colindixon, 14:47:52)
    1. as stated above the plan is to have only 3 RCs (called RC0, RC1, and RC2, but on the original dates slated for RC1, RC2, and RC3) and release on time (colindixon, 14:48:27)
    2. Projects please respond email https://lists.opendaylight.org/pipermail/release/2015-June/002575.html for RC0 reports. (gzhao, 14:48:28)
    3. there is an e-mail asking for RC0 reports based on testing, please fill that out (colindixon, 14:48:48)
    4. ACTION: gzhao to update the release plan to make the dates correc (colindixon, 14:49:58)

  6. documentation (colindixon, 14:50:02)
    1. https://lists.opendaylight.org/pipermail/release/2015-June/002618.html this shows the state of documentation as of Monday (colindixon, 14:50:11)
    2. I’m updating the tracking spreadsheet pretty regularly and recording the last update at the top (colindixon, 14:50:39)
    3. ACTION: zxiiro will try to get autorelease-daily jobs to produce staging repos as well so people can check if their bugs are fixed more than once a week (colindixon, 14:51:13)
    4. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit?pli=1#gid=613128231 here’s the docs tracking spreadsheet (colindixon, 14:51:27)

  7. release reviews (colindixon, 14:51:31)
    1. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=743945554 the signup sheet for release reviews (colindixon, 14:53:04)
    2. gzhao asks projects to please sign up for slots to have a release review (colindixon, 14:53:18)
    3. to have a release review, you need to bring release notes and the release review templates filled in (colindixon, 14:53:49)
    4. https://wiki.opendaylight.org/view/Sample_Release_Notes sample release notes template that you can use (colindixon, 14:54:02)
    5. https://wiki.opendaylight.org/view/Sample_Release_Review sample release review template tha tyou can use (colindixon, 14:54:10)
    6. gzhao notes that hes left next week blank because of ONS, but we might need to change that to get everything done (colindixon, 14:54:39)
    7. ACTION: gzhao to send mail to the rlease list for people to sign up (colindixon, 14:55:01)
    8. colindixon notest that the docs group would like to get the release notes *also* into AsciiDoc, but we’ll sort that out later (colindixon, 14:55:36)
    9. abhijitkumbhare asks how we can do release reviews while we’re still fixing bugs since the releast notes might change to reflect blocking bugs (colindixon, 14:58:31)
    10. colindixon notes that the bugs listed should really only be bugs fixed since the last release, but if there are blocking bugs we’ll add them to the release notes as needed even after a release review (colindixon, 14:59:20)
    11. ACTION: gzhao to open slots for release reviews for next week as well to try to get through things (colindixon, 14:59:40)
    12. colindixon notes that the TSC doesn’t *need* to attend them, but is merely encouraged to do so, so sscheduling should be easier (colindixon, 15:00:03)
    13. ACTION: at some point gzhao to start scheduling projects into slots and telling them when the slot is and asking them to object if we get to the point that we might not finish (colindixon, 15:00:33)

  8. cookies (colindixon, 15:01:27)


Meeting ended at 15:01:29 UTC (full logs).

Action items

  1. gzhao to update the release plan to make the dates correc
  2. zxiiro will try to get autorelease-daily jobs to produce staging repos as well so people can check if their bugs are fixed more than once a week
  3. gzhao to send mail to the rlease list for people to sign up
  4. gzhao to open slots for release reviews for next week as well to try to get through things
  5. at some point gzhao to start scheduling projects into slots and telling them when the slot is and asking them to object if we get to the point that we might not finish


Action items, by person

  1. gzhao
    1. gzhao to update the release plan to make the dates correc
    2. gzhao to send mail to the rlease list for people to sign up
    3. gzhao to open slots for release reviews for next week as well to try to get through things
    4. at some point gzhao to start scheduling projects into slots and telling them when the slot is and asking them to object if we get to the point that we might not finish
  2. zxiiro
    1. zxiiro will try to get autorelease-daily jobs to produce staging repos as well so people can check if their bugs are fixed more than once a week


People present (lines said)

  1. colindixon (68)
  2. gzhao (29)
  3. tbachman (13)
  4. odl_meetbot (12)
  5. abhijitkumbhare (9)
  6. LuisGomez1 (6)
  7. hideyuki (4)
  8. alagalah (3)
  9. zxiiro (2)
  10. Prem (1)
  11. phrobb1 (1)
  12. odl-casey (1)


Generated by MeetBot 0.1.4.