#opendaylight-meeting: beryllium release review

Meeting started by anipbu at 15:28:23 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 15:28:30)
    1. PTL and TSC members please #info in (anipbu, 15:28:42)
    2. anipbu (anipbu, 15:28:48)
    3. yamahata for neutron northbound (yamahata, 15:30:45)
    4. colindixon for TTP, docs, and TSC (colindixon, 15:31:04)

  2. NEUTRON (Neutron Northbound) (anipbu, 15:32:14)
    1. https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium:Release_Notes <-- Release Notes (anipbu, 15:32:19)
    2. https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium:Release_Review <-- Release Review (anipbu, 15:32:24)
    3. Isaku Yamahata is representing NEUTON (anipbu, 15:32:28)
    4. https://lists.opendaylight.org/pipermail/release/2016-February/005456.html (colindixon, 15:33:53)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=4527 (colindixon, 15:34:08)
    6. https://git.opendaylight.org/gerrit/#/c/33957/ (yamahata, 15:35:46)
    7. https://git.opendaylight.org/gerrit/#/c/33932/ (yamahata, 15:35:51)
    8. https://review.openstack.org/#/c/271012/ (yamahata, 15:41:56)
    9. https://review.openstack.org/#/c/278839/ (yamahata, 15:42:28)
    10. ACTION: yamahata to update the EoL/Deprecated/Removed list in the release notes to specify which ones are deprecated vs. removed (colindixon, 15:43:13)
    11. yamahata notes that migration to Be from any previous release ins't supported (colindixon, 15:43:31)
    12. update external testing once it is done (anipbu, 15:44:15)

  3. SDNINTERFACEAPP (anipbu, 15:44:23)
    1. https://wiki.opendaylight.org/view/ODL-SDNi:Beryllium_Release_Notes <-- Release Notes (anipbu, 15:44:34)
    2. https://wiki.opendaylight.org/view/ODL-SDNi:Beryllium_Release_Review <-- Release Review (anipbu, 15:44:46)
    3. Shahid Shaik is representing SDNINTERFACEAPP (anipbu, 15:45:03)
    4. ACTION: Shahid_Shaik to add the changes since previous releases sections to the release notes fro SDNi (colindixon, 15:49:13)
    5. https://wiki.opendaylight.org/view/Sample_Release_Notes (colindixon, 15:49:29)
    6. sdni has not system test, no test plan. Shahid_Shaik says sdni don't have any user facing features, it was unit and integration testing (anipbu, 15:50:10)
    7. Shahid_Shaik says they have against RC2 artifacts and no blockers (anipbu, 15:51:57)
    8. ACTION: Shahid_Shaik to focus on migration/compatibility from/with previous releases and anyting that was deprecated or removed (it sounds like no compatibility or migration) (colindixon, 15:52:08)
    9. ACTION: anipbu to start an email follow up thread with relevant people about SDNi (colindixon, 15:55:56)

  4. SNMP (anipbu, 15:56:11)
    1. Vaishali Mithbaokar is representing SNMP (anipbu, 15:56:29)
    2. ACTION: SNMP to create release notes and release plan template (anipbu, 15:59:03)
    3. ACTION: Vaishali to create pages for SNMP's release review and release notes for Beryllium based on the templates here: https://wiki.opendaylight.org/view/Sample_Release_Notes https://wiki.opendaylight.org/view/Sample_Release_Review (colindixon, 15:59:07)
    4. ACTION: anipbu to follow up with SNMP (anipbu, 15:59:52)

  5. SXP (anipbu, 16:00:29)
    1. https://wiki.opendaylight.org/view/SXP:Beryllium:Release_Review <-- Release Review (anipbu, 16:00:33)
    2. https://wiki.opendaylight.org/view/ODL-SDNi:Beryllium_Release_Notes <-- Release Notes (anipbu, 16:00:46)
    3. Matthew Robertson is representing SXP (anipbu, 16:01:11)
    4. mamihale is representing SXP on behalf of Matthew Robertson (anipbu, 16:01:52)
    5. ACTION: mamihale needs to add the section on Changes Since Previous Releases from the sample release notes template for SXP (colindixon, 16:01:57)
    6. SXP has tested against RC2 with no blockers (anipbu, 16:03:21)
    7. ACTION: colindixon to add a list of experimental features, a list of user-facing features, and a link to system test results or waiver to the sample release review template (colindixon, 16:03:37)
    8. mamihale says no experiemental features (anipbu, 16:03:38)
    9. https://git.opendaylight.org/gerrit/gitweb?p=integration/distribution.git;a=blob;f=features-test/src/main/resources/features.xml;h=d735ec0d24d868defc6d57d1f2c733768b9f8ea3;hb=refs/heads/stable/beryllium (LuisGomez, 16:07:34)
    10. ACTION: mamihale to update the list of user-facing features based on the definition here: https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features (colindixon, 16:09:59)
    11. ACTION: mamihale to re-enable feature testing in integration for SXP (colindixon, 16:10:28)
    12. mamihale to add the "Changes Since Previous Releases" section filled out to release notes from here: https://wiki.opendaylight.org/view/Sample_Release_Notes (anipbu, 16:10:40)

  6. TCPMD5 (anipbu, 16:11:33)
    1. https://wiki.opendaylight.org/view/TCPMD5:Beryllium_Release_Notes <-- Release Notes (anipbu, 16:11:37)
    2. https://wiki.opendaylight.org/view/TCPMD5:Beryllium_Release_Review <-- Release Review (anipbu, 16:11:41)
    3. Milos Fabian is representing TCPMD5 (anipbu, 16:11:55)
    4. Vina Ermagan for lispflowmapping (vina_ermagan, 16:13:22)
    5. https://git.opendaylight.org/gerrit/#/q/project:tcpmd5+status:merged there were no commits of substance (other than version bumps and tracking upstream changes etc.) in Beryllium for TCPMD5 (colindixon, 16:14:44)
    6. Milos_ says TCP MD5 is tested with BGPCEP - all those system tests are passing. No blockers in RC2 (anipbu, 16:14:45)

  7. YANGPUSH (anipbu, 16:17:04)
    1. https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_Release_Notes <-- Release Notes (anipbu, 16:17:09)
    2. https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_Release_Review <-- Release Review (anipbu, 16:17:14)
    3. Ambika Prasad Tripathy is representing YANGPUSH (anipbu, 16:17:25)
    4. ACTION: qwebirc791144 it would be great if you could add the expansion of the bug and what it means to users instead of just the link to the URL in the known issues for yang push (colindixon, 16:18:58)
    5. no CSIT for yangpush (jamoluhrsen, 16:18:59)
    6. qwebirc791144 says yangpush features are experimental (anipbu, 16:20:46)
    7. LuisGomez notes that he doesn't have issues with the testing or lack thereof it it's an experimental feature (colindixon, 16:22:33)
    8. link https://wiki.opendaylight.org/view/YANG_PUBSUB:_Beryllium_System_Test <-- System Test Plan Manual (anipbu, 16:23:21)
    9. ACTION: qwebirc791144 to update the documentation as soon as is possible (colindixon, 16:28:29)
    10. no blockers in yangpush after RC2 manual testing (anipbu, 16:28:55)

  8. ALTO (anipbu, 16:30:50)
    1. https://wiki.opendaylight.org/view/ALTO:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:30:55)
    2. https://wiki.opendaylight.org/view/ALTO:Beryllium:Release_Review <-- Release Review (anipbu, 16:31:00)
    3. Kai Gao or Jensen Zhang is representing ALTO (anipbu, 16:31:14)
    4. ACTION: jensen_zhang to note that migration isn't possible in the release notes (colindixon, 16:32:26)
    5. no CSIT for ALTO (jamoluhrsen, 16:33:05)
    6. ACTION: jensen_zhang to add to the release notes that it requires java 8 or java 7 not just java 7 (colindixon, 16:33:43)
    7. https://git.opendaylight.org/gerrit/#/c/32581/ (colindixon, 16:34:15)
    8. jensen_zhang notes ALTO's features are experimental in Beryllium (colindixon, 16:37:47)

  9. DIDM (phrobb, 16:39:48)
    1. https://wiki.opendaylight.org/view/DIDM:_Beryllium_Release_Review <--- release review (colindixon, 16:40:29)
    2. https://wiki.opendaylight.org/view/DIDM:_Beryllium_Release_Notes <--- release notes (colindixon, 16:40:38)
    3. basic system test is there, but broken. needs fixing. (jamoluhrsen, 16:42:05)
    4. ACTION: anandhi_ to add a filled out "Changes Since Previous Releases" section for the release notes borrowing it from here: https://wiki.opendaylight.org/view/Sample_Release_Notes (colindixon, 16:42:53)
    5. it sounds like there are no compatibility issues, migration should work, and nothing was deprecated or removed, but that should be noted in the release notes (colindixon, 16:43:32)
    6. ACTION: anandhi_ to update create asciidoc documentation as well as the wiki docs. Instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements (colindixon, 16:45:26)
    7. ACTION: anandhi_ to follow up with tracking sonar reporting, zxiiro can probably help (doesn't need to be before the release I don't think though) (colindixon, 16:48:07)
    8. Hideyuki for VTN (hideyuki, 16:51:04)

  10. VTN (anipbu2, 16:51:13)
    1. https://wiki.opendaylight.org/view/VTN:Beryllium:Release_Review <-- Release Review (anipbu2, 16:51:18)
    2. https://wiki.opendaylight.org/view/VTN:Beryllium:Release_Notes <-- Release Notes (anipbu2, 16:51:22)
    3. Hideyuki Tai is representing VTN (anipbu2, 16:51:27)
    4. https://git.opendaylight.org/gerrit/#/c/33787/ asciidoc commit for Be docs (colindixon, 16:56:11)
    5. ACTION: hideyuki to provide a link to asciidoc commit https://git.opendaylight.org/gerrit/#/c/33787/ that from the release review (colindixon, 16:56:39)
    6. hideyuki says no experimental features (anipbu2, 16:58:27)
    7. ACTION: hideyuki to provide anipbu2 a list of user-facing features (colindixon, 16:58:35)
    8. ACTION: anipbu to track user-facing on spreadsheet (anipbu, 17:01:13)

  11. DLUX (anipbu, 17:01:56)
    1. https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Beryllium:Release_Notes <-- Release Notes (anipbu, 17:02:05)
    2. https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Beryllium_Release_Review <-- Release Review (anipbu, 17:02:15)
    3. Maxime Millette Coulombe is representing DLUX (anipbu, 17:02:32)
    4. no CSIT as of yet. (jamoluhrsen, 17:04:26)
    5. ACTION: mmcoulombe to add the latest version of chrome/firefox/safari to the target execution environment (colindixon, 17:04:41)
    6. ACTION: mmcoulombe to not that it works with Java 8 as well as Java 7 (colindixon, 17:05:01)
    7. DLUX CSIT pending patch https://git.opendaylight.org/gerrit/#/c/29612/ (anipbu, 17:05:54)
    8. ACTION: mmcoulombe to work on updating the AsciiDoc versions of developer/user guides for beryllium, instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements (colindixon, 17:08:28)
    9. ACTION: mmcoulombe to download RC artifacts and test if DLUX works (anipbu, 17:09:25)
    10. ACTION: jamoluhrsen and LuisGomez to work to get the system test patch reviewed and merged (colindixon, 17:10:02)

  12. FAAS (anipbu, 17:13:08)
    1. https://wiki.opendaylight.org/view/FaaS:Beryllium_Release_Notes <-- Release Notes (anipbu, 17:13:12)
    2. https://wiki.opendaylight.org/view/FaaS:Beryllium_Release_Review <-- Release Review (anipbu, 17:13:27)
    3. Xingjun Chu is representing FAAS (anipbu, 17:13:44)
    4. ACTION: xingjun_ to note that Java 7 and Java 8 work rather than saying Java 8 is required in the FaaS release notes (colindixon, 17:15:16)
    5. ACTION: xingjun_ it would be great if we could add links to the bugs in the known issues of the release notes for FaaS (colindixon, 17:15:52)
    6. https://git.opendaylight.org/gerrit/gitweb?p=integration/distribution.git;a=blob;f=features-test/src/main/resources/features.xml;h=d735ec0d24d868defc6d57d1f2c733768b9f8ea3;hb=refs/heads/stable/beryllium (LuisGomez, 17:16:03)
    7. https://git.opendaylight.org/gerrit/#/c/31228/ link to asciidocs for FaaS in beryllium (colindixon, 17:16:52)
    8. ACTION: xingjun_ to add a link to https://git.opendaylight.org/gerrit/#/c/31228/ in the non-code section of the FaaS release review (colindixon, 17:16:57)
    9. ACTION: faas to work on CSIT (anipbu, 17:17:31)
    10. ACTION: xingjun_ to add faas features to distribution test (LuisGomez, 17:17:35)
    11. https://wiki.opendaylight.org/view/FaaS:SystemTestPlan (anipbu, 17:17:47)
    12. https://wiki.opendaylight.org/view/FaaS:SystemTestPlan <-- FaaS System Test Plan (anipbu, 17:18:00)
    13. ACTION: xingjun_ should link to bugs listed in the bugzilla section of the FaaS release review rather than just listing them as text (colindixon, 17:18:06)
    14. ACTION: faas to link system test plan to https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report (anipbu, 17:18:27)
    15. https://wiki.opendaylight.org/view/FaaS:User_Guide (xingjun_, 17:19:46)
    16. user-facing features of fass: odl-faas-all (anipbu, 17:21:10)
    17. fass has no experimental features (anipbu, 17:23:15)
    18. faas test RC2 this morning. no blockers (anipbu, 17:23:48)

  13. LISPFLOWMAPPING (anipbu, 17:26:04)
    1. Vina Ermagan is representing LISPFLOWMAPPING (anipbu, 17:26:25)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Review (vina_ermagan, 17:26:26)
    3. https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Notes (vina_ermagan, 17:26:38)
    4. https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Review <-- Release Review (anipbu, 17:27:18)
    5. https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Beryllium_Release_Notes <-- Release Notes (anipbu, 17:27:28)
    6. ACTION: vina_ermagan it would be good to call out the major feature in Beryllium for LFM in the release notes (colindixon, 17:28:16)
    7. neutron is marked as experimental (anipbu, 17:29:34)
    8. lspflowmapping is tested in RC2.1 and no blockers (anipbu, 17:29:51)
    9. ACTION: vina_ermagan to make sure the EOLing sections on the release notes and release review match (colindixon, 17:31:20)
    10. ACTION: vina_ermagan to update the migration section of release notes (anipbu, 17:34:28)

  14. cookies (anipbu, 17:38:17)


Meeting ended at 17:39:02 UTC (full logs).

Action items

  1. yamahata to update the EoL/Deprecated/Removed list in the release notes to specify which ones are deprecated vs. removed
  2. Shahid_Shaik to add the changes since previous releases sections to the release notes fro SDNi
  3. Shahid_Shaik to focus on migration/compatibility from/with previous releases and anyting that was deprecated or removed (it sounds like no compatibility or migration)
  4. anipbu to start an email follow up thread with relevant people about SDNi
  5. SNMP to create release notes and release plan template
  6. Vaishali to create pages for SNMP's release review and release notes for Beryllium based on the templates here: https://wiki.opendaylight.org/view/Sample_Release_Notes https://wiki.opendaylight.org/view/Sample_Release_Review
  7. anipbu to follow up with SNMP
  8. mamihale needs to add the section on Changes Since Previous Releases from the sample release notes template for SXP
  9. colindixon to add a list of experimental features, a list of user-facing features, and a link to system test results or waiver to the sample release review template
  10. mamihale to update the list of user-facing features based on the definition here: https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features
  11. mamihale to re-enable feature testing in integration for SXP
  12. qwebirc791144 it would be great if you could add the expansion of the bug and what it means to users instead of just the link to the URL in the known issues for yang push
  13. qwebirc791144 to update the documentation as soon as is possible
  14. jensen_zhang to note that migration isn't possible in the release notes
  15. jensen_zhang to add to the release notes that it requires java 8 or java 7 not just java 7
  16. anandhi_ to add a filled out "Changes Since Previous Releases" section for the release notes borrowing it from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
  17. anandhi_ to update create asciidoc documentation as well as the wiki docs. Instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements
  18. anandhi_ to follow up with tracking sonar reporting, zxiiro can probably help (doesn't need to be before the release I don't think though)
  19. hideyuki to provide a link to asciidoc commit https://git.opendaylight.org/gerrit/#/c/33787/ that from the release review
  20. hideyuki to provide anipbu2 a list of user-facing features
  21. anipbu to track user-facing on spreadsheet
  22. mmcoulombe to add the latest version of chrome/firefox/safari to the target execution environment
  23. mmcoulombe to not that it works with Java 8 as well as Java 7
  24. mmcoulombe to work on updating the AsciiDoc versions of developer/user guides for beryllium, instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements
  25. mmcoulombe to download RC artifacts and test if DLUX works
  26. jamoluhrsen and LuisGomez to work to get the system test patch reviewed and merged
  27. xingjun_ to note that Java 7 and Java 8 work rather than saying Java 8 is required in the FaaS release notes
  28. xingjun_ it would be great if we could add links to the bugs in the known issues of the release notes for FaaS
  29. xingjun_ to add a link to https://git.opendaylight.org/gerrit/#/c/31228/ in the non-code section of the FaaS release review
  30. faas to work on CSIT
  31. xingjun_ to add faas features to distribution test
  32. xingjun_ should link to bugs listed in the bugzilla section of the FaaS release review rather than just listing them as text
  33. faas to link system test plan to https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
  34. vina_ermagan it would be good to call out the major feature in Beryllium for LFM in the release notes
  35. vina_ermagan to make sure the EOLing sections on the release notes and release review match
  36. vina_ermagan to update the migration section of release notes


Action items, by person

  1. anandhi_
    1. anandhi_ to add a filled out "Changes Since Previous Releases" section for the release notes borrowing it from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
    2. anandhi_ to update create asciidoc documentation as well as the wiki docs. Instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements
    3. anandhi_ to follow up with tracking sonar reporting, zxiiro can probably help (doesn't need to be before the release I don't think though)
  2. anipbu
    1. anipbu to start an email follow up thread with relevant people about SDNi
    2. anipbu to follow up with SNMP
    3. anipbu to track user-facing on spreadsheet
  3. anipbu2
    1. hideyuki to provide anipbu2 a list of user-facing features
  4. colindixon
    1. colindixon to add a list of experimental features, a list of user-facing features, and a link to system test results or waiver to the sample release review template
  5. hideyuki
    1. hideyuki to provide a link to asciidoc commit https://git.opendaylight.org/gerrit/#/c/33787/ that from the release review
    2. hideyuki to provide anipbu2 a list of user-facing features
  6. jamoluhrsen
    1. jamoluhrsen and LuisGomez to work to get the system test patch reviewed and merged
  7. jensen_zhang
    1. jensen_zhang to note that migration isn't possible in the release notes
    2. jensen_zhang to add to the release notes that it requires java 8 or java 7 not just java 7
  8. LuisGomez
    1. jamoluhrsen and LuisGomez to work to get the system test patch reviewed and merged
  9. mamihale
    1. mamihale needs to add the section on Changes Since Previous Releases from the sample release notes template for SXP
    2. mamihale to update the list of user-facing features based on the definition here: https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features
    3. mamihale to re-enable feature testing in integration for SXP
  10. mmcoulombe
    1. mmcoulombe to add the latest version of chrome/firefox/safari to the target execution environment
    2. mmcoulombe to not that it works with Java 8 as well as Java 7
    3. mmcoulombe to work on updating the AsciiDoc versions of developer/user guides for beryllium, instructions are here: https://wiki.opendaylight.org/view/Documentation/Beryllium/Project_Documentation_Requirements
    4. mmcoulombe to download RC artifacts and test if DLUX works
  11. qwebirc791144
    1. qwebirc791144 it would be great if you could add the expansion of the bug and what it means to users instead of just the link to the URL in the known issues for yang push
    2. qwebirc791144 to update the documentation as soon as is possible
  12. Shahid_Shaik
    1. Shahid_Shaik to add the changes since previous releases sections to the release notes fro SDNi
    2. Shahid_Shaik to focus on migration/compatibility from/with previous releases and anyting that was deprecated or removed (it sounds like no compatibility or migration)
  13. Vaishali
    1. Vaishali to create pages for SNMP's release review and release notes for Beryllium based on the templates here: https://wiki.opendaylight.org/view/Sample_Release_Notes https://wiki.opendaylight.org/view/Sample_Release_Review
  14. vina_ermagan
    1. vina_ermagan it would be good to call out the major feature in Beryllium for LFM in the release notes
    2. vina_ermagan to make sure the EOLing sections on the release notes and release review match
    3. vina_ermagan to update the migration section of release notes
  15. xingjun_
    1. xingjun_ to note that Java 7 and Java 8 work rather than saying Java 8 is required in the FaaS release notes
    2. xingjun_ it would be great if we could add links to the bugs in the known issues of the release notes for FaaS
    3. xingjun_ to add a link to https://git.opendaylight.org/gerrit/#/c/31228/ in the non-code section of the FaaS release review
    4. xingjun_ to add faas features to distribution test
    5. xingjun_ should link to bugs listed in the bugzilla section of the FaaS release review rather than just listing them as text
  16. yamahata
    1. yamahata to update the EoL/Deprecated/Removed list in the release notes to specify which ones are deprecated vs. removed
  17. UNASSIGNED
    1. SNMP to create release notes and release plan template
    2. faas to work on CSIT
    3. faas to link system test plan to https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report


People present (lines said)

  1. anipbu (166)
  2. colindixon (147)
  3. LuisGomez (40)
  4. jamoluhrsen (38)
  5. yamahata (26)
  6. xingjun_ (21)
  7. phrobb (20)
  8. anandhi_ (18)
  9. anipbu2 (16)
  10. vina_ermagan (14)
  11. Shahid_Shaik (13)
  12. qwebirc791144 (12)
  13. hideyuki (12)
  14. Vaishali (11)
  15. mmcoulombe (9)
  16. odl_meetbot (8)
  17. mamihale (8)
  18. jensen_zhang (6)
  19. yuling (2)
  20. Milos_ (2)


Generated by MeetBot 0.1.4.