#opendaylight-meeting: beryllium release review

Meeting started by anipbu at 15:30:14 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 15:30:18)
    1. PTL and TSC members please #info in (anipbu, 15:30:25)
    2. colindixon for TTP, docs, and TSC (colindixon, 15:30:25)
    3. anipbu (anipbu, 15:30:32)
    4. vjanandr for SNBI (vjanandr, 15:31:07)

  2. SNBI (anipbu, 15:31:36)
    1. https://wiki.opendaylight.org/view/SNBI_Berrylium_Release_Notes <-- Release Notes (anipbu, 15:31:43)
    2. https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:BerylliumReleaseReview <-- Release Review (anipbu, 15:31:48)
    3. Vijay Anand R is representing SNBI (anipbu, 15:32:05)
    4. https://git.opendaylight.org/gerrit/#/c/34063/ asciidoc (vjanandr, 15:32:06)
    5. SNBI would be an experimental release for Beryllium (anipbu, 15:33:43)
    6. ACTION: vjanandr to not that "It is expected to finish the forwarding element coding and then interoperate with the controller in Beryllium release." was actually done in the release notes (colindixon, 15:33:50)
    7. aleckey for NetIDE (aleckey, 15:33:56)
    8. ACTION: vjanandr to verify against RC (anipbu, 15:34:28)
    9. https://git.opendaylight.org/gerrit/#/c/34063/ patch for docs for Beryllium (colindixon, 15:35:05)
    10. user facing features: SNBI registrar (anipbu, 15:35:25)
    11. kalai for LACP (kalai, 15:36:02)
    12. ACTION: vjanandr to note that the Be release of SNBI is not compatible with and does not support migration from the Li release on the release notes (colindixon, 15:36:34)
    13. ACTION: vjanandr to copy EoL and deprecated things from the release notes to the release review for SNBI (colindixon, 15:36:52)
    14. LuisGomez1 (LuisGomez1, 15:37:10)
    15. ACTION: vjanandr to complete CSIT for SNBI (anipbu, 15:39:22)
    16. https://wiki.opendaylight.org/view/SNBI_Berrylium_Test_plan (vjanandr, 15:43:50)
    17. https://wiki.opendaylight.org/view/SNBI_Berrylium_Test_plan <-- SNBI System test plan (anipbu, 15:44:11)

  3. IOTDM (IoT Data Management) (anipbu, 15:47:38)
    1. https://wiki.opendaylight.org/view/Iotdm:Beryllium_Release_Notes <-- Release Notes (anipbu, 15:47:43)
    2. https://wiki.opendaylight.org/view/Iotdm:_Beryllium_Release_Review <-- Release Review (anipbu, 15:47:48)
    3. Lionel Florit will be representing IOTDM (anipbu, 15:47:53)
    4. ACTION: lflorit to complete the subsections under "Changes Since Previous Releases" from here: https://wiki.opendaylight.org/view/Sample_Release_Notes (colindixon, 15:49:39)
    5. IOTDM has test against RC and no blocking issues (anipbu, 15:49:46)
    6. iotdm features can be used in production (anipbu, 15:53:30)
    7. https://jenkins.opendaylight.org/releng/view/iotdm/job/iotdm-csit-1node-basic-only-beryllium/ (LuisGomez1, 15:54:55)
    8. ACTION: lflorit to provide system test plan template for iotdm https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template (anipbu, 15:55:57)
    9. user facing features of iotdm: the oneM2M API (anipbu, 15:56:10)
    10. lflorit says that the docs haven't changed from Li, but that was intentional (colindixon, 15:57:41)
    11. ACTION: lflorit to get back to why most csit are failing (anipbu, 15:58:07)
    12. https://jenkins.opendaylight.org/releng/view/iotdm/job/iotdm-csit-1node-basic-only-beryllium/ <-- lflorit to get back to why most csit are failing (anipbu, 15:58:22)
    13. ACTION: lflorit to follow up with anipbu and LuisGomez1 about why csit tests are faiing for IoTDM (colindixon, 15:58:56)

  4. LACP (anipbu, 16:01:16)
    1. https://wiki.opendaylight.org/view/LACP:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:01:35)
    2. https://wiki.opendaylight.org/view/LACP:Beryllium:Release_Review <-- Release Review (anipbu, 16:01:40)
    3. Badrinath Viswanatha will be representing LACP (anipbu, 16:01:44)
    4. ACTION: lflorit: to fix the csit and to get back to LuisGomez1 regarding fix (anipbu, 16:02:33)
    5. no experimental features in lacp (anipbu, 16:04:44)
    6. odl-lacp-ui odl-lacp-rest, odl-lacp-plugin are user facing features in LACP (anipbu, 16:05:23)
    7. LACP has tested against RC with no blockers (anipbu, 16:06:12)
    8. https://jenkins.opendaylight.org/sandbox/job/lacp-csit-1node-lacp-all-stable-lithium/ (kalai, 16:07:03)
    9. ACTION: kalai to follow up with int/test team to fix test in releng (anipbu, 16:09:20)
    10. no migration issues in LACP (anipbu, 16:10:30)

  5. NETIDE (anipbu, 16:11:14)
    1. https://wiki.opendaylight.org/view/NetIDE:Release_Notes <-- Release Notes (anipbu, 16:11:19)
    2. https://wiki.opendaylight.org/view/NetIDE:Release_Review <-- Release Review (anipbu, 16:11:28)
    3. Alec Leckey will be representing NETIDE (anipbu, 16:11:40)
    4. NETIDE has tested against RC and found one minot bug (logged and fixed) (anipbu, 16:12:30)
    5. NETIDE has no blocking issues from testing (anipbu, 16:12:55)
    6. netide has no experimental features (anipbu, 16:13:14)
    7. odl-netide-rest is user facing features of netide (anipbu, 16:14:07)
    8. https://jenkins.opendaylight.org/releng/view/netide/job/netide-csit-1node-basic-only-beryllium/ (LuisGomez1, 16:14:42)
    9. this is netide first release, so no migration issues (anipbu, 16:15:21)
    10. https://git.opendaylight.org/gerrit/#/c/30562/ <-- pending docs patch (anipbu, 16:15:43)
    11. ACTION: colindixon to review/merge docs patch(es) for NetIDE (phrobb, 16:16:09)
    12. the manual system test will be converted to ROBOT as soon as possibel (anipbu, 16:19:47)

  6. NIC (anipbu, 16:20:10)
    1. https://wiki.opendaylight.org/view/Network_Intent_Composition:Release_Notes <-- Release Notes (anipbu, 16:20:16)
    2. https://wiki.opendaylight.org/view/Network_Intent_Composition:Beryllium_Release_Review <-- Release Review (anipbu, 16:20:25)
    3. Raphael Amorim is representing NIC (anipbu, 16:20:38)
    4. NIC tested on RC and no blockers (anipbu, 16:22:49)
    5. ACTION: raphaelamorim: get information on wiki into adoc so that we can put it in the proper PDF guides (anipbu, 16:23:57)
    6. ACTION: raphaelamorim and NIC team to get all docs on wiki into adoc prior to Be Release (phrobb, 16:23:58)
    7. user facing features for nic: odl-nic-console odl-nic-core-service-mdsal odl-nic-core-service-hazelcast (anipbu, 16:28:37)
    8. all NIC features are considered experimental (NIC is still an experimental project) (anipbu, 16:30:11)
    9. ACTION: raphaelamorim to update the sections on migration concerns/issues (anipbu, 16:30:54)

  7. PACKETCABLE (PacketCable PCMM/COPS) (anipbu, 16:31:47)
    1. https://wiki.opendaylight.org/view/PacketCablePCMM:BerylliumReleaseReview <-- Release Review (anipbu, 16:31:51)
    2. https://wiki.opendaylight.org/view/PacketCablePCMM:BerylliumReleaseNotes <-- Release Notes (anipbu, 16:31:56)
    3. Kevin Kershaw is representing PACKETCABLE (anipbu, 16:32:00)
    4. packetcable tested against RC and no blockers found (anipbu, 16:34:45)
    5. have one user-facing feature: odl-packetcable-policy-server (anipbu, 16:35:11)
    6. packetcable has no experimental features. ready for production. (anipbu, 16:36:15)
    7. ACTION: kkershaw to get wiki docs into Adoc for the Be release (anipbu, 16:39:16)
    8. https://jenkins.opendaylight.org/releng/view/packetcable/job/packetcable-csit-1node-pcmm-all-beryllium/ (anipbu, 16:42:43)
    9. https://jenkins.opendaylight.org/releng/view/packetcable/job/packetcable-csit-1node-pcmm-all-beryllium/ (kkershaw, 16:42:48)

  8. VPNSERVICE (anipbu, 16:44:26)
    1. https://wiki.opendaylight.org/view/Vpnservice:Beryllium_Release_Notes <-- Release Notes (anipbu, 16:44:30)
    2. https://wiki.opendaylight.org/view/Vpnservice:Beryllium_Release_Review <-- Release Review (anipbu, 16:44:35)
    3. Prem Sankar will be representing VPNSERVICE (anipbu, 16:44:40)
    4. spnservice has tested against RC and no blockers found (anipbu, 16:48:04)
    5. ELAN is experimental features (anipbu, 16:48:32)
    6. https://jenkins.opendaylight.org/vpnservice/job/vpnservice-csit-1node-vpnservice-only-beryllium/ (LuisGomez1, 16:49:27)
    7. ACTION: Prem_ to review/update the Release Notes "Known Isusues", "Migration", and "Capatibilitiy" (phrobb, 16:51:00)
    8. no blockers in VPNSERVICE (anipbu, 16:51:31)
    9. vpnservice has pending docs https://git.opendaylight.org/gerrit/#/c/30978/ (anipbu, 16:53:27)
    10. ACTION: Prem_ to address CSIT failures (anipbu, 16:55:30)
    11. VPNSERVICE have just raised another patch with new set of test cases (anipbu, 16:56:07)
    12. Pradeeban for Messaging4Transport. (pradeeban1, 16:57:01)
    13. ACTION: anipbu and Wei Meng will reschedule for OFCONFIG (anipbu, 16:57:51)

  9. MESSAGING4TRANSPORT (anipbu, 16:57:57)
    1. https://wiki.opendaylight.org/view/Messaging4Transport:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:58:02)
    2. https://wiki.opendaylight.org/view/Messaging4Transport:Beryllium:Release_Review <-- Release Review (anipbu, 16:58:06)
    3. Pradeeban Kathiravelu is representing MESSAGING4TRANSPORT (anipbu, 16:58:10)
    4. Messaging4Transport tested against RC and found no blockers (anipbu, 17:00:33)
    5. all Messaging4Transport features are considered experimental (anipbu, 17:00:51)
    6. user facing features in Messaging4Transport: odl-messaging4transport (anipbu, 17:01:14)
    7. https://git.opendaylight.org/gerrit/#/c/30724/ (pradeeban1, 17:02:18)
    8. pending docs patches https://git.opendaylight.org/gerrit/#/c/30724/ (anipbu, 17:03:29)
    9. M4T has all end-user relevant docs in adoc: in 2 docs - user guide and developer guide (anipbu, 17:05:35)
    10. ACTION: pradeeban1 to update release notes to include support for Java 8 as well as 7 (phrobb, 17:07:52)

  10. OPENFLOWPLUGIN (anipbu, 17:08:42)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Beryllium_Release_Notes <-- Release Notes (anipbu, 17:08:47)
    2. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Beryllium_Release_Review <-- Release Review (anipbu, 17:08:51)
    3. Abhijit Kumbhare is representing OPENFLOWPLUGIN (anipbu, 17:08:55)
    4. OPENFLOWPLUGIN tested against RC and no blockers found (anipbu, 17:12:27)
    5. OPENFLOWPLUGIN has no experimental features (anipbu, 17:12:39)
    6. ACTION: abhijitkumbhare to update release notes and remove the info about the 2 designs (anipbu, 17:17:35)
    7. ACTION: abhijitkumbhare to update bug list to helium design (anipbu, 17:18:11)
    8. openflowpugin has functional, perf/scal, longevity and cluster csit tests in place (anipbu, 17:18:36)

  11. OPFLEX (anipbu, 17:20:43)
    1. https://wiki.opendaylight.org/view/OpFlex:Beryllium_Release_Notes <-- Release Notes (anipbu, 17:20:45)
    2. https://wiki.opendaylight.org/view/OpFlex:Beryllium_Release_Review <-- Release Review (anipbu, 17:20:51)
    3. Rob Adams is representing OPFLEX (anipbu, 17:20:56)
    4. Tested externally against OpenStack and ACI plus unit tests in ODL build (readams, 17:21:00)
    5. no experimental features (readams, 17:21:04)
    6. no Karaf features at all (readams, 17:21:09)
    7. opflex has been tested against external RC artifacts of OpFlex. No blockers found. There are no experimental features in opflex. There are no user-facing features in opflex. (anipbu, 17:23:00)
    8. Tested externally against OpenStack and ACI plus unit tests in ODL build. opflex system test plan https://wiki.opendaylight.org/view/OpFlex:Beryllium_Feature_Integration_System_Test (anipbu, 17:24:37)
    9. opflex RC artifacts are located in latest Be merge task (anipbu, 17:25:08)
    10. ACTION: readams to work with anipbu and zxiiro to upload the final release artifacts for opflex into some public location, such as nexus, etc. (anipbu, 17:33:44)

  12. cookies (anipbu, 17:38:01)


Meeting ended at 17:38:18 UTC (full logs).

Action items

  1. vjanandr to not that "It is expected to finish the forwarding element coding and then interoperate with the controller in Beryllium release." was actually done in the release notes
  2. vjanandr to verify against RC
  3. vjanandr to note that the Be release of SNBI is not compatible with and does not support migration from the Li release on the release notes
  4. vjanandr to copy EoL and deprecated things from the release notes to the release review for SNBI
  5. vjanandr to complete CSIT for SNBI
  6. lflorit to complete the subsections under "Changes Since Previous Releases" from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
  7. lflorit to provide system test plan template for iotdm https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template
  8. lflorit to get back to why most csit are failing
  9. lflorit to follow up with anipbu and LuisGomez1 about why csit tests are faiing for IoTDM
  10. lflorit: to fix the csit and to get back to LuisGomez1 regarding fix
  11. kalai to follow up with int/test team to fix test in releng
  12. colindixon to review/merge docs patch(es) for NetIDE
  13. raphaelamorim: get information on wiki into adoc so that we can put it in the proper PDF guides
  14. raphaelamorim and NIC team to get all docs on wiki into adoc prior to Be Release
  15. raphaelamorim to update the sections on migration concerns/issues
  16. kkershaw to get wiki docs into Adoc for the Be release
  17. Prem_ to review/update the Release Notes "Known Isusues", "Migration", and "Capatibilitiy"
  18. Prem_ to address CSIT failures
  19. anipbu and Wei Meng will reschedule for OFCONFIG
  20. pradeeban1 to update release notes to include support for Java 8 as well as 7
  21. abhijitkumbhare to update release notes and remove the info about the 2 designs
  22. abhijitkumbhare to update bug list to helium design
  23. readams to work with anipbu and zxiiro to upload the final release artifacts for opflex into some public location, such as nexus, etc.


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to update release notes and remove the info about the 2 designs
    2. abhijitkumbhare to update bug list to helium design
  2. anipbu
    1. lflorit to follow up with anipbu and LuisGomez1 about why csit tests are faiing for IoTDM
    2. anipbu and Wei Meng will reschedule for OFCONFIG
    3. readams to work with anipbu and zxiiro to upload the final release artifacts for opflex into some public location, such as nexus, etc.
  3. colindixon
    1. colindixon to review/merge docs patch(es) for NetIDE
  4. kalai
    1. kalai to follow up with int/test team to fix test in releng
  5. kkershaw
    1. kkershaw to get wiki docs into Adoc for the Be release
  6. lflorit
    1. lflorit to complete the subsections under "Changes Since Previous Releases" from here: https://wiki.opendaylight.org/view/Sample_Release_Notes
    2. lflorit to provide system test plan template for iotdm https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template
    3. lflorit to get back to why most csit are failing
    4. lflorit to follow up with anipbu and LuisGomez1 about why csit tests are faiing for IoTDM
    5. lflorit: to fix the csit and to get back to LuisGomez1 regarding fix
  7. LuisGomez1
    1. lflorit to follow up with anipbu and LuisGomez1 about why csit tests are faiing for IoTDM
    2. lflorit: to fix the csit and to get back to LuisGomez1 regarding fix
  8. pradeeban1
    1. pradeeban1 to update release notes to include support for Java 8 as well as 7
  9. Prem_
    1. Prem_ to review/update the Release Notes "Known Isusues", "Migration", and "Capatibilitiy"
    2. Prem_ to address CSIT failures
  10. raphaelamorim
    1. raphaelamorim: get information on wiki into adoc so that we can put it in the proper PDF guides
    2. raphaelamorim and NIC team to get all docs on wiki into adoc prior to Be Release
    3. raphaelamorim to update the sections on migration concerns/issues
  11. readams
    1. readams to work with anipbu and zxiiro to upload the final release artifacts for opflex into some public location, such as nexus, etc.
  12. vjanandr
    1. vjanandr to not that "It is expected to finish the forwarding element coding and then interoperate with the controller in Beryllium release." was actually done in the release notes
    2. vjanandr to verify against RC
    3. vjanandr to note that the Be release of SNBI is not compatible with and does not support migration from the Li release on the release notes
    4. vjanandr to copy EoL and deprecated things from the release notes to the release review for SNBI
    5. vjanandr to complete CSIT for SNBI


People present (lines said)

  1. anipbu (219)
  2. phrobb (57)
  3. LuisGomez1 (51)
  4. vjanandr (30)
  5. colindixon (27)
  6. Prem_ (25)
  7. lflorit (22)
  8. abhijitkumbhare (22)
  9. raphaelamorim (20)
  10. kalai (20)
  11. readams (17)
  12. pradeeban1 (16)
  13. kkershaw (15)
  14. aleckey (11)
  15. odl_meetbot (9)
  16. rvail (1)
  17. Badri (1)
  18. anipbu2 (0)


Generated by MeetBot 0.1.4.